Difference between revisions of "Std Base"

From FreeCAD Documentation
Jump to: navigation, search
({{TOCright}} template to move the table of contents)
(Commands from the structure toolbar)
Line 5: Line 5:
 
[[Image:freecad16.svg|64px]]
 
[[Image:freecad16.svg|64px]]
 
<translate>
 
<translate>
 
== Introduction ==
 
 
The [[Std_Base|Std_Base]] or [[Standard Menu|Standard Menu]] is not a real workbench, but is a page where all commands from the base system are collected.
 
 
The standard menu allows access to functions which are used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.).
 
  
 
{{TOCright}}
 
{{TOCright}}
  
== File menu ==
+
== Introduction ==
 
 
The [[Std_File_Menu|File]] option provides functions related to input and output, such as Open, Print, Export, etc.
 
 
 
== Edit menu ==
 
 
 
The [[Std_Edit_Menu|Edit]] option provides functions related to changing the model, such as Copy, Paste, etc.
 
 
 
== View menu ==
 
 
 
The [[Std_View Menu|View]] option provides functions related to the display of the model, such as which panels to show, Zoom, etc.
 
 
 
* [[Std Workbench|Std Workbench]]: switches to the indicated [[Workbenches|Workbench]].
 
 
 
== Tools menu ==
 
 
 
The [[Std_Tools Menu|Tools]] option provides functions for debugging models and customizing FreeCAD's behaviour.
 
 
 
== Macro menu ==
 
  
The [[Std_Macro_Menu|Macro]] option provides functions related to the recording and execution of groups of FreeCAD commands.
+
The [[Std_Base|Std Base]] is not a real workbench. This page just collects all commands from the base system which do not belong to a specific workbench, but which may be used in all of them.
  
== Workbench ==
+
== Tools ==
  
The [[Std Workbench Menu|Workbench]] option provides functions related to the [[Workbenches|workbench]] in use.  It contains functions specific to the current workbench.
+
Most of the commands in this page can be accessed from menus, toolbars, and context menus.
  
== Windows menu ==
+
=== Standard menu ===
  
The [[Std_Windows Menu|Windows]] option allows for switching between and arranging open FreeCAD windows.
+
The [[Standard_Menu|Standard Menu]] is composed of seven sub-menus.
 +
* [[Std_File_Menu|File menu]]
 +
* [[Std_Edit_Menu|Edit menu]]
 +
* [[Std_View_Menu|View menu]]
 +
* [[Std_Tools_Menu|Tools menu]]
 +
* [[Std_Macro_Menu|Macro menu]]
 +
* [[Std_Windows_Menu|Windows menu]]
 +
* [[Std_Help_Menu|Help menu]]
  
== Help menu ==
+
=== Structure toolbar ===
  
The [[Std_Help Menu|Help]] option provides access to the FreeCAD help system and provides information about your FreeCAD installation.
+
* [[File:Std_Part.svg|32px]] [[Std_Part|Std Part]]
 +
* [[File:Std_Group.svg|32px]] [[Std_Group|Std Group]]
 +
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]]
 +
* [[File:Std_LinkActions.svg|32px]] [[Std_LinkActions|Std LinkActions]]
  
 
{{Userdocnavi}}
 
{{Userdocnavi}}
 
</translate>
 
</translate>

Revision as of 20:19, 20 October 2019

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Freecad16.svg

Introduction

The Std Base is not a real workbench. This page just collects all commands from the base system which do not belong to a specific workbench, but which may be used in all of them.

Tools

Most of the commands in this page can be accessed from menus, toolbars, and context menus.

Standard menu

The Standard Menu is composed of seven sub-menus.

Structure toolbar