Difference between revisions of "Standard Menu/en"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
(Updating to match new version of source page)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 
__NOTOC__
 
__NOTOC__
{{docnav|Robot Workbench|Macros}}
+
{{docnav
 +
|[[Robot Workbench|Robot Workbench]]
 +
|[[Macros|Macros]]
 +
}}
  
<!-- ==The Standard Menu== -->
+
==Introduction==
  
{{StdMenu| File &nbsp;&nbsp;&nbsp;  Edit &nbsp;&nbsp;&nbsp;  View &nbsp;&nbsp;&nbsp;  Tools &nbsp;&nbsp;&nbsp;  Macro &nbsp;&nbsp;&nbsp;  Workbench &nbsp;&nbsp;&nbsp;  Measure &nbsp;&nbsp;&nbsp; Windows &nbsp;&nbsp;&nbsp;  Help }}
+
The standard menu allows access to functions which are used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.).
  
===Overview===
+
Different workbenches can also add menus depending on how they decide to structure their own tools.
The standard FreeCAD menu allows access to functions which are used in all workbenches.  Your menu may look slightly different depending on your desktop environment (KDE, Gnome, Windows, OS X, etc).  
 
  
===File===
+
{{StdMenu| File &nbsp;&nbsp;&nbsp;  Edit &nbsp;&nbsp;&nbsp;  View &nbsp;&nbsp;&nbsp;  Tools &nbsp;&nbsp;&nbsp;  Macro &nbsp;&nbsp;&nbsp;  Windows &nbsp;&nbsp;&nbsp;  Help }}
The [[Std_File_Menu|File]] option provides functions related to input and output, such as Open, Print, Export, etc.
 
  
===Edit===
+
==File menu==
The [[Std_Edit_Menu|Edit]] option provides functions related to changing the model, such as Copy, Paste, etc.
 
  
===View===
+
The [[Std_File_Menu|File]] menu provides functions related to file input and output, such as Open, Print, Export, etc.
The [[Std_View Menu|View]] option provides functions related to the display of the model, such as which panels to show, Zoom, etc.
 
  
===Tools===
+
==Edit menu==
The [[Std_Tools Menu|Tools]] option provides functions for debugging models and customizing FreeCAD's behaviour.
 
  
===Macro===
+
The [[Std_Edit_Menu|Edit]] menu provides functions related to changing the model, such as Copy, Paste, etc.
The [[Std_Macro_Menu|Macro]] option provides functions related to the recording and execution of groups of FreeCAD commands.
 
  
===Workbench===
+
==View menu==
The [[Std Workbench Menu|Workbench]] option provides functions related to the [[Workbenches|workbench]] in use.  It contains functions specific to the current workbench.
 
  
===Measure===
+
The [[Std_View_Menu|View]] menu provides functions related to the display of the [[3D view|3D view]], as well as choosing which components of the main window and panels to show.
The [[Std_Measure_Menu|Measure]] option provides functions related to the Delta and/or 3D distances. This menu appears only in the Part Workbench.
 
  
===Windows===
+
==Tools menu==
The [[Std_Windows Menu|Windows]] option allows for switching between and arranging open FreeCAD windows.
 
  
===Help===
+
The [[Std_Tools_Menu|Tools]] menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the [[Std_ExportGraphviz|dependency graph]].
The [[Std_Help Menu|Help]] option provides access to the FreeCAD help system and provides information about your FreeCAD installation.
 
  
 +
==Macro menu==
  
{{docnav|Robot Workbench|Macros}}
+
The [[Std_Macro_Menu|Macro]] menu provides functions related to the recording and execution of [[macros|macros]].
  
 +
==Windows menu==
 +
 +
The [[Std_Windows_Menu|Windows]] menu allows switching and arranging open windows of the application.
 +
 +
==Help menu==
 +
 +
The [[Std_Help_Menu|Help]] menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.
 +
 +
{{docnav
 +
|[[Robot Workbench|Robot Workbench]]
 +
|[[Macros|Macros]]
 +
}}
 +
 +
{{Std Base}}
 
{{Userdocnavi}}
 
{{Userdocnavi}}
 
[[Category:Documentation]]
 
[[Category:Command_Reference]]
 

Revision as of 13:02, 21 October 2019

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська
Arrow-left.svg Previous: Robot Workbench
Next: Macros Arrow-right.svg

Introduction

The standard menu allows access to functions which are used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.).

Different workbenches can also add menus depending on how they decide to structure their own tools.

File     Edit     View     Tools     Macro     Windows     Help

File menu

The File menu provides functions related to file input and output, such as Open, Print, Export, etc.

Edit menu

The Edit menu provides functions related to changing the model, such as Copy, Paste, etc.

View menu

The View menu provides functions related to the display of the 3D view, as well as choosing which components of the main window and panels to show.

Tools menu

The Tools menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the dependency graph.

Macro menu

The Macro menu provides functions related to the recording and execution of macros.

Windows menu

The Windows menu allows switching and arranging open windows of the application.

Help menu

The Help menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.

Arrow-left.svg Previous: Robot Workbench
Next: Macros Arrow-right.svg