Difference between revisions of "Standard Menu/en"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
(Updating to match new version of source page)
 
(2 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 
__NOTOC__
 
__NOTOC__
{{docnav
+
{{Docnav
 
|[[Robot Workbench|Robot Workbench]]
 
|[[Robot Workbench|Robot Workbench]]
 
|[[Macros|Macros]]
 
|[[Macros|Macros]]
Line 16: Line 16:
 
==File menu==
 
==File menu==
  
The [[Std_File_Menu|File]] menu provides functions related to file input and output, such as Open, Print, Export, etc.
+
The {{StdMenu|[[Std_File_Menu|File]]}} menu provides functions related to file input and output, such as Open, Print, Export, etc.
  
 
==Edit menu==
 
==Edit menu==
  
The [[Std_Edit_Menu|Edit]] menu provides functions related to changing the model, such as Copy, Paste, etc.
+
The {{StdMenu|[[Std_Edit_Menu|Edit]]}} menu provides functions related to changing the model, such as Copy, Paste, etc.
  
 
==View menu==
 
==View menu==
  
The [[Std_View_Menu|View]] menu provides functions related to the display of the [[3D view|3D view]], as well as choosing which components of the main window and panels to show.
+
The {{StdMenu|[[Std_View_Menu|View]]}} menu provides functions related to the display of the [[3D view|3D view]], as well as choosing which components of the main window and panels to show.
  
 
==Tools menu==
 
==Tools menu==
  
The [[Std_Tools_Menu|Tools]] menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the [[Std_ExportGraphviz|dependency graph]].
+
The {{StdMenu|[[Std_Tools_Menu|Tools]]}} menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the [[Std_ExportGraphviz|dependency graph]].
  
 
==Macro menu==
 
==Macro menu==
  
The [[Std_Macro_Menu|Macro]] menu provides functions related to the recording and execution of [[macros|macros]].
+
The {{StdMenu|[[Std_Macro_Menu|Macro]]}} menu provides functions related to the recording and execution of [[macros|macros]].
  
 
==Windows menu==
 
==Windows menu==
  
The [[Std_Windows_Menu|Windows]] menu allows switching and arranging open windows of the application.
+
The {{StdMenu|[[Std_Windows_Menu|Windows]]}} menu allows switching and arranging open windows of the application.
  
 
==Help menu==
 
==Help menu==
  
The [[Std_Help_Menu|Help]] menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.
+
The {{StdMenu|[[Std_Help_Menu|Help]]}} menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.
  
{{docnav
+
{{Docnav
 
|[[Robot Workbench|Robot Workbench]]
 
|[[Robot Workbench|Robot Workbench]]
 
|[[Macros|Macros]]
 
|[[Macros|Macros]]
 
}}
 
}}
  
{{Std Base}}
+
 
{{Userdocnavi}}
+
{{Std Base navi{{#translation:}}}}
 +
 
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 06:50, 19 February 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська
Arrow-left.svg Previous: Robot Workbench
Next: Macros Arrow-right.svg

Introduction

The standard menu allows access to functions which are used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.).

Different workbenches can also add menus depending on how they decide to structure their own tools.

File     Edit     View     Tools     Macro     Windows     Help

File menu

The File menu provides functions related to file input and output, such as Open, Print, Export, etc.

Edit menu

The Edit menu provides functions related to changing the model, such as Copy, Paste, etc.

View menu

The View menu provides functions related to the display of the 3D view, as well as choosing which components of the main window and panels to show.

Tools menu

The Tools menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the dependency graph.

Macro menu

The Macro menu provides functions related to the recording and execution of macros.

Windows menu

The Windows menu allows switching and arranging open windows of the application.

Help menu

The Help menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.

Arrow-left.svg Previous: Robot Workbench
Next: Macros Arrow-right.svg


Template:Std Base navi/en

Template:Userdocnavi/en