Réglage des préférences

From FreeCAD Documentation
Revision as of 12:37, 10 November 2019 by Mario52 (talk | contribs)
Jump to: navigation, search
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Le réglage des préférences de FreeCAD est accessible par le menu Édition → Préférences....

Les fonctionnalités de FreeCAD sont séparées en différents modules, chaque module étant responsable du fonctionnement d'un atelier spécifique. FreeCAD utilise aussi un concept nommé late loading (chargement tardif), qui veut dire que les composants ne sont chargés que lorsqu'ils sont nécessaires. Vous avez peut-être remarqué que quand vous sélectionnez un atelier dans la barre d'outil de FreeCAD, l'atelier et tout ses composants se chargent à ce moment. Ceci inclut ses réglages de préférences.

Sans aucun module chargé, vous aurez accès à deux sections de configuration, responsables des réglages de préférences générales et des réglages d'affichage. Lorsque vous vous trouvez dans un certain atelier, les préférences de cet atelier apparaissent en tant que nouvelle section et les formats de fichier pris en charge par l'atelier apparaissent en tant que nouvel onglet dans la section Importer-Exporter.

Cliquez sur le bouton Réinitialiser situé dans le coin inférieur gauche de la fenêtre des préférences définit les valeurs par défaut de toutes les préférences de FreeCAD.

Préférences générales

Cette section de préférences a 6 onglets : Général, Document, Éditeur, Fenêtre de sortie, Macro, et Unités.

Général

Dans l'onglet Général, vous pouvez spécifier les éléments suivants:

Nom Description
Changer la langue Sélectionnez la langue de l'interface utilisateur de FreeCAD
Taille de la liste des fichiers récents Spécification du nombre de fichiers à répertorier dans la liste des fichiers récents
Activer l'arrière-plan en mosaïque Si cette case est cochée, l’arrière-plan de la fenêtre principale de FreeCAD sera par défaut constitué de mosaïques de cette image: Background.png

Cette option n’a un effet que si Feuille de style/Aucune feuille de style est sélectionné.

L'image peut être modifiée en ajoutant les dossiers Gui/Images dans le dossier

%APPDATA%/FreeCAD (sous Windows),

$HOME/.FreeCAD (sur Linux) ou

$HOME/Library/Preferences/FreeCAD (sous MacOS).

Placez-y un fichier nommé background.png et cochez/décocher cette option pour voir le fichier modifié.

Feuille de style Sélection d'une feuille de style. Les feuilles de style définissent l'apparence de l'interface utilisateur de FreeCAD.
Taille des icônes de la barre d'outils Sélection de la taille des icônes de la barre d’outils
Module chargé automatiquement après le démarrage Sélection de l'atelier à utiliser directement après le démarrage de FreeCAD
Activer l'écran de démarrage au démarrage Si cette case est cochée, l'écran de démarrage de FreeCAD apparaît au démarrage.

L'image de l'écran de démarrage peut être modifiée en ajoutant les dossiers Gui/Images dans le dossier %APPDATA%/FreeCAD (où %APPDATA% est le dossier d’installation spécifique à l’utilisateur de FreeCAD de votre système d’exploitation). Mettez-y un fichier nommé splash_image.png et redémarrez FreeCAD pour voir l'écran de démarrage modifié.

Activer le retour à la ligne Les mots seront enveloppés lorsqu'ils dépasseront l'espace horizontal disponible dans la console Python. Cette console s’affiche à l’aide du menu View → Panels → Console Python.
Preference General Tab 01 fr.png

Document

Dans l'onglet Document, vous pouvez spécifier les éléments suivants :

Nom Description
Créer un nouveau document au démarrage Si coché, FreeCAD créera un nouveau document au démarrage
Niveau de compression du document Spécification du niveau de compression pour les fichiers FCStd. Les fichiers FCStd sont des fichiers compressés au format ZIP. Par conséquent, vous pouvez renommer leur suffixe .FCStd en .zip et les ouvrir avec un programme d’archive ZIP.
Utiliser Annuler / Rétablir sur les documents Si coché, toutes les modifications dans les documents sont stockées de manière à pouvoir être annulées / rétablies
Nombre maximum d'actions Annuler / Rétablir Spécification du nombre d'actions Annuler / Rétablir à mémoriser
Lancer AutoRecovery au démarrage Si un fichier de récupération est disponible, FreeCAD lancera automatiquement une récupération de fichier au démarrage. De cette façon, les fichiers peuvent être restaurés en cas de blocage.
Enregistrer l'information AutoRecovery chaque Spécification de la fréquence d'écriture d'un fichier de récupération.
Enregistrer la vignette dans le fichier projet lors de la sauvegarde du document Si cette case est cochée, une vignette sera également enregistrée lors de la sauvegarde du document. La vignette sera par exemple affichée dans la liste des fichiers récents dans l'atelier Start.
Ajouter le logo du programme à la vignette générée Si cette case est cochée, le logo du programme FreeCAD FreeCAD-logo.svg sera ajouté à la vignette. Cette option n'a d'effet que si Enregistrer la vignette dans le fichier projet lors de la sauvegarde du document est utilisé.
Nombre maximal de fichiers de sauvegarde à conserver lors de la sauvegarde du document Si cette case est cochée, les fichiers de sauvegarde seront conservés lors de la sauvegarde du document. Vous pouvez spécifier combien de fichiers de sauvegarde seront conservés. Ils contiennent la version précédemment enregistrée du document. Le premier fichier de sauvegarde porte le suffixe .FCStd1, le second .FCStd2, etc.
Autoriser la duplication des étiquettes dans un document Si coché, les objets peuvent avoir le même label/nom. Par exemple, différentes parties ou caractéristiques peuvent alors porter le même nom dans le même document.
Nom de l'auteur Tous les documents qui seront créés auront le nom d’auteur spécifié. Laissez le champ auteur vide pour un auteur anonyme. Si l'option Set on save est cochée, le champ Dernière modification par sera défini sur l'auteur spécifié lors de l'enregistrement du fichier. Ce champ peut être visualisé par le menu Fichier → Informations sur le projet.
Société Tous les documents qui seront créés auront le nom de société spécifié
Licence par défaut Sélection d'une licence par défaut pour les nouveaux documents. Pour une licence prédéfinie, URL de licence sera automatiquement défini en conséquence. Sélectionnez « Autre » pour une licence propre ou spéciale.
URL de licence Spécification de l'URL décrivant la licence sélectionnée dans Licence par défaut

Preference General Tab 02 fr.png

Éditeur

Les paramètres de préférences de l'éditeur affectent le comportement de l'éditeur de macro. L'éditeur peut être ouvert à l’aide du menu Macro → Macros ... → Éditer/Créer.

Les paramètres de couleur et de police affectent également la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Dans l'onglet Éditeur, vous pouvez spécifier les éléments suivants :

Nom Description
Éléments d'affichage Sélection du type de code. Les paramètres de couleur et de police seront appliqués au type sélectionné. Le résultat est visible dans le champ Aperçu.
Police Spécification de la famille de polices à utiliser pour le type de code sélectionné
Taille Spécification de la taille de la police à utiliser pour le type de code sélectionné
Activer la numérotation des lignes Si coché, les lignes de code seront numérotées
Taille des tabulations Spécification du raster de tabulation (combien d'espaces). Si, par exemple, il est réglé sur "6", une pression sur Tab permet de passer au caractère 7, 13, 19, etc., en fonction de la position actuelle du curseur. Ce paramètre est utilisé uniquement si Garder les tabulations est activé.
Taille de retrait Spécification du nombre d'espaces insérés lors de la pression de Tab. Ce paramètre est utilisé uniquement si Insérer des espaces est sélectionné.
Garder les tabulations Si cette option est sélectionnée, une pression sur Tab insérera une tabulation avec le raster défini par Taille des tabulations.
Insérer des espaces Si cette option est sélectionnée, une pression sur Tab insérera le nombre d'espaces définis par Taille de retrait.

Preference General Tab 03 fr.png

Fenêtre de sortie

Les préférences de sortie affectent le comportement de la vue Rapport.

Dans l'onglet Fenêtre de Sortie, vous pouvez spécifier les éléments suivants :

Nom Description
Enregistrer les messages du journal Si coché, les messages de journalisation seront également enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Journal des messages. Ce panneau s’affiche à l’aide du menu Affichage → Panneaux → Vue rapport.
Enregistrer les avertissements Si coché, les avertissements seront enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Avertissements.
Enregistrer les messages d'erreur Si coché, les messages d'erreur seront enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Erreurs.
Messages normaux Spécification de la couleur de la police pour les messages normaux dans le panneau d'affichage Rapport.
Journal des messages Spécification de la couleur de police pour les messages de journal dans le panneau d'affichage Rapport.
Avertissements Spécification de la couleur de police pour les messages d'avertissement dans le panneau d'affichage Rapport.
Erreurs Spécification de la couleur de la police pour les messages d'erreur dans le panneau d'affichage Rapport.
Rediriger les messages internes Python vers la Vue rapport Si cette case est cochée, la sortie interne Python sera redirigée de la console Python vers le panneau d'affichage Rapport. La console Python s’affiche à l’aide du menu Affichage → Panneaux → Console Python.
Rediriger les erreurs internes Python vers la Vue rapport Si cette case est cochée, les messages d'erreur interne Python seront redirigés de la console Python vers le panneau d'affichage Rapport.

Preference General Tab 04 fr.png

Macro

Ces options contrôlent certains aspects de l'exécution des macros.

Dans l'onglet Macro, vous pouvez spécifier les éléments suivants :

Nom Description
Exécuter les macros dans l'environnement local Si coché, les variables définies par les macros sont créées en tant que variables locales, sinon en tant que variables globales Python
Chemin de la macro Spécification d'un chemin d'accès aux fichiers de macros
Enregistrement des commandes de l'interface graphique Si coché, les macros enregistrées contiendront également les commandes d'interface utilisateur.
Enregistrer comme un commentaire Si coché, les Macros enregistrées contiendront également des commandes d'interface utilisateur, mais sous forme de commentaires. Ceci est utile si vous ne souhaitez pas exécuter d'actions visibles lors de l'exécution de la macro mais voir ce qui peut être fait de manière visible.
Afficher les commandes de script dans la console Python Si cette case est cochée, les commandes exécutées par les scripts de macro sont affichées dans la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Preference General Tab 05 fr.png

Unités

Cet onglet configure la manière dont les Unités sont affichées.

Dans l'onglet Unités, vous pouvez spécifier les éléments suivants :

Nom Description
Système de l'utilisateur Sélection d'un système d'unités devant être utilisé pour toutes les parties de FreeCAD
Nombre de décimales Nombre de décimales à afficher pour les nombres et les dimensions dans FreeCAD
Fraction minimale en pouce La fraction minimale en pouce qui doit être affichée. Ce paramètre est uniquement disponible si le système d’unités Construction US (ft-en/sqft/pi3) est utilisé.

Preference General Tab 06 fr.png

Préférences d'affichage

Cette section de préférences comporte deux onglets généraux, 3D View et Colors, et d'autres onglets en fonction des ateliers utilisés.

Vue 3D

Cet onglet est toujours disponible, et contrôle certaines caractéristiques de 3D view.

Dans l'onglet Vue 3D, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher le système de coordonnées dans le coin Si coché, le système de coordonnées principal sera toujours affiché en bas à droite dans les fichiers ouverts.
Afficher le compteur d'images par seconde Si cette case est cochée, le temps nécessaire à la dernière opération et la fréquence d'images seront toujours indiqués en bas à gauche des fichiers ouverts.
Afficher le cube de navigation Si cette case est cochée, le cube de navigation sera toujours affiché sur le Coin sélectionné des fichiers ouverts.
Utiliser OpenGL Vertex Buffer Object Si cette case est cochée, Vertex Buffer Objects (VBO) sera utilisé. Un VBO est une fonctionnalité OpenGL qui fournit des méthodes pour télécharger des données de vertex (position, vecteur normal, couleur, etc.) sur la carte graphique. Les VBO offrent des gains de performances substantiels car les données résident dans la mémoire de la carte graphique plutôt que dans la mémoire système et peuvent donc être restituées directement par le GPU. Pour plus d'informations, voir cette page web.
Cache de rendu introduced in version 0.19 "Cache de rendu" ou "Accélération de rendu" sont expliqués plus en détail dans

Link#render-caching. Il y a 3 options:

  • Auto (par défaut), laissez Coin3D décider où mettre en cache.
  • Distributed, active manuellement le cache pour tous les nœuds racine du fournisseur de vue.
  • Centralized, désactive manuellement le cache sur tous les nœuds de tous les fournisseurs de vues et uniquement sur le nœud racine du graphe de la scène. Ceci offre une vitesse de rendu plus rapide mais une réponse plus lente à tout changement de scène.
Permettre l'animation Si coché, les rotations peuvent être animées. Si, par exemple, Navigation 3D est défini sur CAD et que la souris est déplacée alors que la molette de défilement et le bouton droit de la souris sont enfoncés, les pièces sont pivotées. Si vous maintenez la souris en mouvement tout en lâchant, par exemple le bouton droit de la souris, la rotation se poursuivra sous forme d'animation. Pour terminer l'animation, cliquez avec le bouton gauche de la souris.
Navigation 3D Sélection d'un ensemble de paramètres de navigation. Pour voir ce que chaque ensemble définit, sélectionnez un ensemble et appuyez sur le bouton Souris....
Style d'orbite Sélection du style d'orbite de rotation. Lorsque vous visualisez une pièce dans le plan XY et que vous vous trouvez en mode de rotation de la navigation 3D, la différence est la suivante: Si Trackball est sélectionné, déplacez la souris horizontalement pour faire pivoter la pièce autour de l'axe des Y, si Platine est sélectionné, la pièce sera pivotée autour de l'axe des Z.
Anticrénelage Sélection si et quel type d'anticrénelage multi-échantillons est utilisé.
Nouvelle orientation de la caméra du document Sélection de l'orientation de la caméra pour les nouveaux documents.
Nouvelle échelle de document affecte le "niveau de zoom" initial de la caméra pour les nouveaux documents. La valeur que vous définissez est le diamètre d'une sphère qui convient à la vue 3D. La valeur par défaut est 100 mm, ce qui est pratique pour les objets tels que les boîtes pour Arduino. Il définit également la taille initiale des entités d'origine (plans de base dans un nouveau corps PartDesign).
Zoom sur le curseur Si cette case est cochée, les opérations de zoom seront effectuées à la position du pointeur de la souris. Sinon, les opérations de zoom seront effectuées au centre de la vue actuelle. Le pas de Zoom définit l'amplitude du zoom. Un pas de zoom de '1' signifie un facteur de 7,5 pour chaque pas de zoom.
Inverser le zoom Si coché, le sens des opérations de zoom sera inversé.
Désactiver l'inclinaison par geste de l'écran tactile Si cette case est cochée, le geste d’inclinaison sera désactivé pour le zoom par pincement (zoom à deux doigts). Ceci n'affecte que le Navigation 3D défini sur Gesture.
Glisser au curseur Si cette case est cochée, les rotations en 3D utiliseront la position actuelle du curseur comme centre de la rotation. Sinon, le centre de l'écran sera toujours utilisé.
Taille du marqueur Sélection de la taille des sommets (points) dans Sketcher. La zone cliquable des points peut également être agrandie en augmentant le rayon de sélection (onglet Couleurs).
Distance entre les yeux pour les modes stéréo Spécification de la distance œil-à-œil utilisée pour les projections stéréoscopiques. La valeur spécifiée est un facteur qui sera multiplié par la taille bounding box de l'objet 3D actuellement affiché.
Activer la couleur de rétroéclairage Si coché, le rétroéclairage est activé avec la couleur définie. Le rétroéclairage est utilisé pour le rendu des côtés arrières des faces (en général, vous ne les voyez pas dans les solides, sauf si vous en coupez une avec un plan de découpe ou si les faces ne sont pas orientées correctement). Il n'est actif que pour les objets dont la propriété Lighting (onglet View) est définie sur "One side". Si cette option est désactivée, le verso des faces des objets en mode d'éclairage "One side" sera noir.
Intensité du rétro-éclairage Spécification de l'intensité du rétro-éclairage. Ce paramètre est activé uniquement si Activer la couleur de rétroéclairage est coché.
Type de caméra Sélection du type de projection de la caméra.
  • Rendu en perspective, les objets apparaîtront en perspective.
  • Rendu orthogonal, les objets seront projetés en mode orthogonal.

Preference Display Tab 01 fr.png

Couleurs

Cet onglet est toujours disponible.

Dans l'onglet Couleurs, vous pouvez spécifier les éléments suivants :

Nom Description
Activer la surbrillance de présélection Si cette case est cochée, la présélection est activée et sera mise en évidence par la couleur spécifiée. La présélection signifie que, par exemple, des arêtes dans certaines parties seront mises en surbrillance lorsque vous les survolez avec la souris pour indiquer qu'elles peuvent être sélectionnées.
Activer la surbrillance de sélection Si cette case est cochée, la surbrillance de la sélection est activée et la couleur spécifiée sera utilisée pour cela.
Sélectionner le rayon Définit la zone de sélection des éléments en vue 3D. Une valeur plus grande facilite la tâche, mais rend impossible la sélection de petits éléments.
Couleur simple Si sélectionné, l’arrière-plan des pièces aura la couleur sélectionnée.
Dégradé de couleurs Si sélectionné, l’arrière-plan des pièces aura le dégradé de couleur sélectionné.
Couleur intermédiaire N'est activé que si Dégradé de couleurs est sélectionné. Si cette case est cochée, le dégradé de couleur aura la couleur sélectionnée en tant que couleur intermédiaire.
Objet en cours d'édition Sélection de la couleur d'arrière-plan pour les objets de la vue arborescente en cours d'édition.
Conteneur actif Sélection de la couleur d'arrière-plan des conteneurs actifs dans l'arborescence. Par exemple, s'il y a plusieurs parties dans la vue arborescente et qu'une partie est basculée en tant que corps actif, la couleur d'arrière-plan sélectionnée apparaît dans la vue arborescente.

Preference Display Tab 02 fr.png

Couleurs des pièces

Cet onglet n'apparaît que si vous vous trouvez dans les ateliers Part ou PartDesign ou si vous avez déjà travaillé dans ces ateliers avant.

Dans l'onglet Couleurs de la pièce, vous pouvez spécifier les éléments suivants :

Nom Description
Couleur des formes par défaut Sélection de la couleur par défaut pour les nouvelles formes. Si l'option Couleur des formes aléatoire est activée, une couleur aléatoire est utilisée.
Couleur de ligne par défaut Sélection de la couleur de ligne par défaut pour les nouvelles formes.
Épaisseur de trait par défaut Spécification de l'épaisseur de trait par défaut pour les nouvelles formes.
Couleur de sommet par défaut Sélection de la couleur par défaut pour les nouveaux vertices.
Taille de sommet par défaut Spécification de la taille par défaut pour les nouveaux vertices.
Couleur de la boite englobante Sélection de la couleur de Bounding box dans la vue 3D.
Couleur de texte par défaut Sélection de la couleur de texte par défaut pour les annotations de document. Il n'y a actuellement aucune boîte de dialogue permettant d'ajouter des annotations aux documents. Des annotations peuvent être ajoutées seulement depuis la console Python avec cette commande :

obj=App.ActiveDocument.addObject("App::Annotation", "Label")

Cette console est affichée à l'aide du menu Affichage → Panneaux → Console Python.

Preference Display Tab 03 fr.png

Vue maillage

Cet onglet ne s'affiche que si vous êtes dans l'atelier Mesh ou si vous avez déjà été dans cet atelier.

Dans l'onglet Vue Maillage, vous pouvez spécifier les éléments suivants :

Nom Description
Couleur de maillage par défaut Sélection de la couleur par défaut pour les nouveaux maillages
Couleur de ligne par défaut Sélection de la couleur de ligne par défaut pour les nouveaux maillages
Transparence du maillage Spécification de la transparence par défaut pour les nouveaux maillages
Transparence de ligne Spécification de la transparence de ligne par défaut pour les nouveaux maillages
Rendu bi-faces Si coché, le rendu de la face inférieure de la surface sera identique à celui de la face supérieure. Si non coché, cela dépendra de l'option Activer la couleur de rétroéclairage (voir la section Vue 3D). La couleur de rétroéclairage sera utilisée ou noire.
Afficher le cadre de sélection pour les maillages mis en surbrillance ou sélectionnés Si coché, un cadre de sélection jaune s'affiche pour les maillages sélectionnés ou en surbrillance.
Définissez la valeur normale par sommet Si coché, l'ombrage progressif sera utilisé, sinon l'ombrage est uniforme. L'ombrage définit l'apparence des surfaces. Avec un ombrage uniforme, les normales de surface ne sont pas définies par sommet, ce qui donne un aspect irréel aux surfaces courbes, tandis que l'utilisation de l'ombrage progressif permet d'obtenir un aspect plus lisse.
Angle de courbure L'angle de courbure est un angle de seuil entre deux faces. Il ne peut être défini que si l'option Définir la normale par sommet est utilisée.
Si angle entre faces ≥ angle de froissage, l’ombrage des facettes est utilisé
Si angle entre faces < angle de froissage, l’ombrage est uniforme

Mesh View Preferences.png

Options d'Import-Export

Les paramètres d'import-export affectent la manière dont les fichiers sont importés et exportés vers et depuis FreeCAD. Ils sont décrits dans la page Préférences d’import-export.

Préférences d'ateliers

Les préférences d'ateliers les plus courantes sont définies ci-dessous. Certains ateliers n'ont pas de préférences. D'autres ateliers optionnels peuvent ne pas être listés.

Ateliers externes