Difference between revisions of "Mouse Model/it"

From FreeCAD Documentation
Jump to: navigation, search
Line 136: Line 136:
  
 
Nella navigazione Maya-Gesture, traslazione, zoom e rotazione della vista richiedono il tasto {{KEY|Alt}} insieme al pulsante del mouse; pertanto, è richiesto un mouse a tre pulsanti. È anche possibile usare i gesti poiché questa modalità è stata sviluppata sulla modalità [[Mouse Model/it#Navigazione Gesture|Navigazione gestuale]].
 
Nella navigazione Maya-Gesture, traslazione, zoom e rotazione della vista richiedono il tasto {{KEY|Alt}} insieme al pulsante del mouse; pertanto, è richiesto un mouse a tre pulsanti. È anche possibile usare i gesti poiché questa modalità è stata sviluppata sulla modalità [[Mouse Model/it#Navigazione Gesture|Navigazione gestuale]].
{{MayaGesture Navigation/it
+
{{MayaGesture Navigation
 
|Select_name=Selezione
 
|Select_name=Selezione
 
|Pan_name=Traslazione
 
|Pan_name=Traslazione

Revision as of 07:45, 12 April 2019

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

La funzione Navigazione 3D - Tipo di mouse di FreeCAD comprende i comandi utilizzati per navigare visivamente lo spazio 3D e per interagire con gli oggetti visualizzati. Attualmente FreeCAD offre diversi stili di navigazione con il mouse. Lo stile di navigazione predefinito, denominato "Navigazione CAD​​", è molto semplice e pratico, ma si può anche usare uno stile alternativo, secondo le proprie preferenze.

Navigazione

I gesti del mouse utilizzati per la manipolazione dell'oggetto variano in base allo stile di navigazione selezionato; lo stile attivo, attualmente selezionato, viene utilizzato in tutti gli ambienti.

Ci sono due modi per modificare lo stile di navigazione:

  • In Preferenze, Modifica → Preferenze → Visualizzazione → Vista 3D → Navigazione 3D.
  • Cliccare col tasto destro nello spazio vuoto dell'area di visualizzazione 3D, quindi selezionare Stile di navigazione →... nel menu contestuale.

Navigazione CAD

Questo è lo stile di navigazione predefinito. Permette all'utente un semplice controllo della vista. Richiede l'uso della tastiera solo per eseguire multi-selezioni.

Selezione Traslazione Zoom Rotazione vista
Primo metodo
Rotazione vista
Metodo alternativo
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare.

Tenendo premuto Ctrl consente la selezione di più oggetti.

Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore. Usare la rotellina del mouse per zoommare avanti e indietro.

Facendo clic sul pulsante centrale del mouse, la vista viene nuovamente centrata sulla posizione del cursore.

Tenere premuto il pulsante centrale del mouse, quindi premere e tenere premuto il pulsante sinistro del mouse, quindi spostare il puntatore.

La posizione del cursore quando viene premuto il pulsante centrale del mouse determina il centro di rotazione. La rotazione funziona come una palla che ruota attorno al suo centro. Se i pulsanti vengono rilasciati prima di interrompere il movimento del mouse, la visualizzazione continua la rotazione, se l'azione è abilitata.

Un doppio clic con il pulsante centrale del mouse imposta un nuovo centro di rotazione.

Tenere premuto il pulsante centrale del mouse, e tenere premuto il pulsante destro del mouse, quindi spostare il puntatore.

Con questo metodo il pulsante centrale del mouse può essere rilasciato dopo aver tenuto premuto il pulsante destro del mouse.

Gli utenti che utilizzano il mouse con la mano destra potrebbero trovare questo metodo più semplice del primo metodo.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Modalità Traslazione: tenere premuto il tasto Ctrl, preme il tasto destro del mouse una volta, quindi muovere il puntatore. Disponibile dalla versione 0.17 Modalità zoom: tenere premuti i tasti Ctrl e Shift, premere il pulsante destro del mouse una volta, quindi spostare il puntatore. Disponibile dalla versione 0.17 Modalità rotazione: tenere premuto il tasto Shift, premere il tasto destro del mouse una volta, quindi spostare il puntatore. Disponibile dalla versione 0.17


Navigazione OpenInventor

La Navigazione OpenInventor (formalmente Inventor), si basa sul modello Open Inventor. Per selezionare gli oggetti, è necessario tenere premuto il tasto Ctrl.

Questa modalità non è basata su Autodesk Inventor.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Tenere premuto Ctrl, quindi premere il tasto sinistro del mouse sopra un oggetto che si desidera selezionare. Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore. Usare la rotellina del mouse per zoommare avanti e indietro.

In alternativa, tenere premuto il pulsante centrale del mouse, quindi premere e tenere premuto il pulsante sinistro del mouse, quindi spostare il puntatore.

Tenere premuto il pulsante sinistro del mouse, quindi spostare il puntatore.


Navigazione Blender

Lo stile di navigazione Blender segue il modello di Blender. In precedenza non c'era la traslazione con il solo mouse, ed era richiesto l'uso del tasto Shift per spostare la vista. Questo è cambiato nel 2016 con l'introduzione di una funzione aggiuntiva. Per eseguire una panoramica della vista, ora è possibile premere i pulsanti sinistro e destro del mouse per spostare la vista.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto Shift e il pulsante centrale del mouse, quindi spostare il puntatore.

In alternativa, tenere premuti i pulsanti sinistro e destro del mouse, quindi spostare il puntatore.

Usare la rotellina del mouse per zoommare avanti e indietro. Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore.


Navigazione Touchpad

Nella navigazione Touchpad, traslazione, zoom e rotazione della vista richiedono un tasto modificatore insieme al touchpad.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PagSù, PagGiù Alt+Touchpad.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Hold Shift, quindi spostare il puntatore. Use PagSù e PagGiù per ingrandire e ridurre. Tenere premuto Alt, quindi spostare il puntatore.
Shift+Ctrl+Touchpad.svg Shift+Touchpad LB hold.svg
In alternativa, tenere premuto Shift e Ctrl, quindi spostare il puntatore. In alternativa, tenere premuto Shift e il pulsante sinistro, quindi spostare il puntatore.


Navigazione Gesture

Questo stile di navigazione è stato introdotto nella versione 0.16, è fatto su misura per essere usato con il touchscreen o con la penna, ma è usabile anche con il mouse.

Selezione Traslazione Zoom Rotazione vista Inclinazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto il tasto destro del mouse, quindi spostare il puntatore. Usare la rotellina del mouse per zoommare avanti e indietro. Tenere premuto il pulsante sinistro del mouse, quindi spostare il puntatore.

In Sketcher e altre modalità di modifica, questo comportamento è disabilitato. Tenere premuto Alt quando si preme il pulsante del mouse per accedere alla modalità di rotazione.

Per impostare il punto di messa a fuoco della fotocamera per la rotazione, fare clic su un punto con il pulsante centrale del mouse. In alternativa, puntare il cursore su un punto e premere H sulla tastiera.

Tenere premuti i pulsanti sinistro e destro del mouse, quindi spostare il puntatore di lato.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Toccare per selezionare. Trascinare con due dita.

In alternativa, toccare e tenere premuto, quindi trascinare. Questo simula la traslazione con il tasto destro del mouse.

Trascinare due dita (pizzicare) più vicino o più lontano. Trascinare con un dito per ruotare.

Tenere premuto Alt quando ci si trova in Sketcher.

Ruota la linea immaginaria formata da due punti di contatto.

In v0.18 questo metodo è disabilitato per impostazione predefinita. Per abilitarlo, andare in Modifica → Preferenze → Visualizzazione e deselezionare la casella di controllo "Disabilita l'inclinazione touchscreen".


Navigazione Maya-Gesture

Nella navigazione Maya-Gesture, traslazione, zoom e rotazione della vista richiedono il tasto Alt insieme al pulsante del mouse; pertanto, è richiesto un mouse a tre pulsanti. È anche possibile usare i gesti poiché questa modalità è stata sviluppata sulla modalità Navigazione gestuale.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto Alt e il pulsante centrale del mouse, quindi spostare il puntatore. Tenere premuto Alt e il tasto destro del mouse, quindi spostare il puntatore.

In alternativa, utilizzare la rotellina del mouse per ingrandire e ridurre.

Tenere premuto Alt e il tasto sinistro del mouse, quindi spostare il puntatore.


Navigazione Revit

Questo stile è stato introdotto nella versione 0.18.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore.

In alternativa, tenere premuti i pulsanti sinistro e destro del mouse, quindi spostare il puntatore.

Usa la rotellina del mouse per zoommare avanti e indietro. Tenere premuto Shift e il pulsante centrale del mouse, quindi spostare il puntatore.

In alternativa, tenere premuto il pulsante centrale del mouse, e tenere premuto il pulsante destro del mouse, quindi spostare il puntatore.


OpenCascade

Questo stile è stato introdotto nella versione 0.18.

Selezione Traslazione Zoom Rotazione vista
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore. Usare la rotellina del mouse per zoommare avanti e indietro.

In alternativa, tenere premuto Ctrl e il tasto sinistro del mouse, quindi spostare il puntatore.

Tenere premuto Ctrl e il tasto destro del mouse, quindi spostare il puntatore.


La selezione degli oggetti

Selezione semplice

Gli oggetti si possono selezionare con un click del tasto sinistro del mouse o facendo clic sull'oggetto nella vista 3D o selezionandoli nella vista ad albero.

Preselezione

Passando con il mouse sugli oggetti, una funzione di Preselezione li evidenzia e visualizza le relative informazioni prima della loro selezione. Se questo comportamento non è gradito o si dispone di una macchina lenta, è possibile disattivare la funzione nel dialogo delle preferenze.

La manipolazione degli oggetti

FreeCAD offre strumenti Manipolatori utilizzabili per modificare un oggetto o il suo aspetto visivo.

Un esempio semplice è dato dal Piano di taglio attivabile con il menu Visualizza → Piano di taglio.

Supporto Hardware

FreeCAD supporta anche i dispositivi di input 3D.

Problemi con Mac OS X

Recentemente abbiamo ricevuto segnalazioni nel forum da utenti Mac che questi pulsanti del mouse e le combinazioni di tasti non funzionano come previsto. Purtroppo, nessuno degli sviluppatori possiede un Mac e neppure gli altri collaboratori regolari. Abbiamo bisogno del vostro aiuto per determinare quali pulsanti del mouse e quali combinazioni di tasti funzionano e poter aggiornare questo wiki.

Arrow-left.svg Per iniziare Pagina precedente:
Pagina successiva: Cubo di navigazione Arrow-right.svg