Difference between revisions of "Mouse Model/fr"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
m
 
(4 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
<div class="mw-translate-fuzzy">
+
{{docnav/fr
{{docnav/fr|[[Getting started/fr|Premiers pas]]|[[Navigation Cube/fr|Cube de navigation]]}}
+
|[[Getting started/fr|Premiers pas]]
</div>
+
|[[Navigation Cube/fr|Cube de navigation]]
 +
}}
  
 
La '''navigation par la souris''' dans FreeCAD décrit les commandes utilisées pour naviguer visuellement dans l'espace 3D et interagir avec les objets affichés. FreeCAD prend en charge plusieurs styles de navigation à la souris. Le style de navigation par défaut est appelé "CAD Navigation" et est très simple et pratique, mais FreeCAD fournit également des styles de navigation alternatifs que vous pouvez choisir en fonction de vos préférences.
 
La '''navigation par la souris''' dans FreeCAD décrit les commandes utilisées pour naviguer visuellement dans l'espace 3D et interagir avec les objets affichés. FreeCAD prend en charge plusieurs styles de navigation à la souris. Le style de navigation par défaut est appelé "CAD Navigation" et est très simple et pratique, mais FreeCAD fournit également des styles de navigation alternatifs que vous pouvez choisir en fonction de vos préférences.
Line 11: Line 12:
 
Il y a deux façons de changer le style de navigation :
 
Il y a deux façons de changer le style de navigation :
  
<div class="mw-translate-fuzzy">
 
 
* Dans les [[Preferences Editor/fr|Préférences]], menu {{MenuCommand|Édition → Préférences → Affichage → Vue 3D → Navigation 3D}}.
 
* Dans les [[Preferences Editor/fr|Préférences]], menu {{MenuCommand|Édition → Préférences → Affichage → Vue 3D → Navigation 3D}}.
 
* En cliquant avec le bouton droit de la souris dans une zone vide de la vue 3D, puis en sélectionnant {{MenuCommand|Style de navigation → ...}} dans le menu contextuel.
 
* En cliquant avec le bouton droit de la souris dans une zone vide de la vue 3D, puis en sélectionnant {{MenuCommand|Style de navigation → ...}} dans le menu contextuel.
</div>
 
  
 
===Mode CAD (par défaut)===
 
===Mode CAD (par défaut)===
Line 38: Line 37:
 
|Rotate_view_text=Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton gauche de la souris, puis déplacez le pointeur.
 
|Rotate_view_text=Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton gauche de la souris, puis déplacez le pointeur.
  
<div class="mw-translate-fuzzy">
 
 
Lorsque le bouton central de la souris est enfoncé l'emplacement du curseur détermine le centre de rotation. La rotation fonctionne comme une balle qui tourne autour de son centre. Si les boutons sont relâchés avant d'arrêter le mouvement de la souris, la vue continue [[spinning/fr|sa rotation]], si cette option est activée.
 
Lorsque le bouton central de la souris est enfoncé l'emplacement du curseur détermine le centre de rotation. La rotation fonctionne comme une balle qui tourne autour de son centre. Si les boutons sont relâchés avant d'arrêter le mouvement de la souris, la vue continue [[spinning/fr|sa rotation]], si cette option est activée.
</div>
 
  
 
Double cliquer avec le bouton central de la souris définit un nouveau centre de rotation.
 
Double cliquer avec le bouton central de la souris définit un nouveau centre de rotation.
Line 210: Line 207:
 
== Support matériel==
 
== Support matériel==
  
<div class="mw-translate-fuzzy">
 
 
FreeCAD supporte aussi quelques [[3D input devices/fr|périphériques d'entrée 3D]].
 
FreeCAD supporte aussi quelques [[3D input devices/fr|périphériques d'entrée 3D]].
</div>
 
  
 
== Mac OS X ==
 
== Mac OS X ==
Line 218: Line 213:
 
Récemment nous avons créé un [http://forum.freecadweb.org/viewtopic.php?f=3&t=3592&start=0 post sur le forum] des utilisateurs Mac pour qui ces combinaisons de touches et boutons de souris ne fonctionneraient pas comme prévu. Malheureusement, aucun des développeurs n'est possesseur d'un Mac, pas plus que les autres contributeurs réguliers. Nous avons besoin de votre aide pour déterminer les combinaisons de touches et boutons de souris fonctionnelles afin que nous puissions les renseigner sur ce wiki.
 
Récemment nous avons créé un [http://forum.freecadweb.org/viewtopic.php?f=3&t=3592&start=0 post sur le forum] des utilisateurs Mac pour qui ces combinaisons de touches et boutons de souris ne fonctionneraient pas comme prévu. Malheureusement, aucun des développeurs n'est possesseur d'un Mac, pas plus que les autres contributeurs réguliers. Nous avons besoin de votre aide pour déterminer les combinaisons de touches et boutons de souris fonctionnelles afin que nous puissions les renseigner sur ce wiki.
  
<div class="mw-translate-fuzzy">
+
{{docnav/fr
{{docnav/fr|[[Getting started/fr|Premiers pas]]|[[Navigation Cube/fr|Cube de navigation]]}}
+
|[[Getting started/fr|Premiers pas]]
</div>
+
|[[Navigation Cube/fr|Cube de navigation]]
 +
}}
  
 
{{Userdocnavi/fr}}
 
{{Userdocnavi/fr}}
  
 
[[Category:User Documentation/fr]]
 
[[Category:User Documentation/fr]]

Latest revision as of 10:14, 4 November 2019

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎
Arrow-left.svg Page précédente: Premiers pas
Page suivante: Cube de navigation Arrow-right.svg

La navigation par la souris dans FreeCAD décrit les commandes utilisées pour naviguer visuellement dans l'espace 3D et interagir avec les objets affichés. FreeCAD prend en charge plusieurs styles de navigation à la souris. Le style de navigation par défaut est appelé "CAD Navigation" et est très simple et pratique, mais FreeCAD fournit également des styles de navigation alternatifs que vous pouvez choisir en fonction de vos préférences.

Navigation

La gestuelle de la souris utilisée pour la manipulation d'objets varie en fonction du style de navigation sélectionné ; le style choisi est utilisé pour tous les ateliers.

Il y a deux façons de changer le style de navigation :

  • Dans les Préférences, menu Édition → Préférences → Affichage → Vue 3D → Navigation 3D.
  • En cliquant avec le bouton droit de la souris dans une zone vide de la vue 3D, puis en sélectionnant Style de navigation → ... dans le menu contextuel.

Mode CAD (par défaut)

C'est le style de navigation par défaut. Il permet à l'utilisateur un contrôle simple de la vue et ne nécessite pas l'utilisation de touches du clavier, sauf pour effectuer des sélections multiples.

Sélection Mouvement panoramique Zoom Rotation
1ère méthode
Rotation
2è méthode
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner.

Maintenez la touche Ctrl enfoncée pour sélectionner plusieurs objets.

Maintenez le bouton central de la souris enfoncé et déplacez le pointeur pour déplacer l'objet. Utilisez la molette de la souris pour zoomer et dézoomer.

En cliquant sur le bouton central de la souris, la vue est recentrée sur l'emplacement du curseur.

Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton gauche de la souris, puis déplacez le pointeur.

Lorsque le bouton central de la souris est enfoncé l'emplacement du curseur détermine le centre de rotation. La rotation fonctionne comme une balle qui tourne autour de son centre. Si les boutons sont relâchés avant d'arrêter le mouvement de la souris, la vue continue sa rotation, si cette option est activée.

Double cliquer avec le bouton central de la souris définit un nouveau centre de rotation.

Maintenez le bouton central de la souris enfoncé, appuyez ensuite sur le bouton droit de la souris, puis déplacez le pointeur.

Avec cette méthode, le bouton central de la souris peut être relâché si vous maintenez le bouton droit de la souris enfoncé.

Les utilisateurs qui utilisent la souris avec leur main droite peuvent trouver cette méthode plus facile que la première.

Ctrl+Mouse RMB.svg Ctrl+Maj+Mouse RMB.svg Maj+Mouse RMB.svg
Pan mode: maintenez la touche Ctrl enfoncée, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur. Disponible dans la version 0.17 Mode zoom: maintenez les touches Ctrl et Maj enfoncées, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur. Disponible dans la version 0.17 Mode rotation: maintenez la touche Maj enfoncée, appuyez simultanément sur le bouton droit de la souris, puis déplacez le pointeur. Disponible dans la version 0.17


Mode OpenInventor

Le mode de navigation OpenInventor (anciennement Inventor) s'inspire de Open Inventor. Pour sélectionner des objets, vous devez maintenir la touche Ctrl enfoncée.

Ce mode n'est pas basé sur Autodesk Inventor.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Maintenez la touche Ctrl enfoncée, cliquez ensuite avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer.

Alternativement : Maintenez le bouton central de la souris enfoncé, pressez ensuite le bouton gauche de la souris, puis déplacez le pointeur.

Appuyez sur le bouton gauche de la souris, puis déplacez le pointeur.


Mode Blender

Le style de navigation Blender a été modélisé d'après Blender. Auparavant, il n'y avait pas de panoramique uniquement à la souris ; il fallait toujours maintenir appuyé la touche Maj. Cela a changé en 2016, maintenant vous pouvez maintenir les boutons gauche et droit de la souris enfoncés.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Maj+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez la touche Maj enfoncée, appuyez ensuite sur le bouton central de la souris, et déplacez le pointeur.

Vous pouvez également maintenir enfoncé les boutons gauche et droit de la souris, et déplacer le pointeur.

Utilisez la molette de la souris pour zoomer et dézoomer. Appuyez sur le bouton central de la souris, et déplacez le pointeur.


Mode Touchpad

En mode Touchpad, le mouvement panoramique, le zoom et la rotation de vue nécessitent une touche modificatrice en plus du pavé tactile.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Maj+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
Cliquez avec le bouton gauche sur l'objet que vous souhaitez sélectionner. Maintenez la touche Maj enfoncée, et déplacez le pointeur. Utiliser les touches PageUp et PageDown pour zoomer et dézoomer. Maintenez la touche Alt enfoncée, puis déplacez le pointeur.
Maj+Ctrl+Touchpad.svg Maj+Touchpad LB hold.svg
Alternativement : Maintenez les touches Maj et Ctrl enfoncées, puis déplacez le pointeur. Alternativement : Maintenez la touche Maj enfoncée ainsi que le bouton gauche, puis déplacez le pointeur.


Mode Gestuel

Ce style de navigation a été adapté pour faciliter l'utilisation avec un écran tactile et un stylet. Néanmoins il peut aussi être utilisé avec la souris.

Sélection Mouvement panoramique Zoom Rotation de la vue Basculement de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez le bouton droit de la souris enfoncé et déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer. Maintenez le bouton gauche de la souris enfoncé et déplacez le pointeur.

Dans l'atelier Sketcher et d'autres modes d'édition, ce comportement est désactivé. Maintenez la touche Alt enfoncée tout en appuyant sur le bouton de la souris pour passer en mode de rotation.

Pour fixer le point de focus pour la rotation de la caméra, cliquez sur ce point avec le bouton central de la souris. Sinon, pointez le curseur sur ce point et appuyez sur la touche H du clavier.

Maintenez les boutons gauche et droit de la souris enfoncés, et déplacer le pointeur latéralement.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Cliquez pour sélectionner. Glisser avec deux doigts.

Vous pouvez également cliquer et maintenir, puis glisser. Cela simule le panoramique avec le bouton droit de la souris.

Pincez ou écartez avec deux doigts. Glissez avec un doigt pour tourner.

Maintnez la touche Alt enfoncée si vous êtes dans Sketcher.

Faites pivoter la ligne imaginaire formée par deux points de contact.

Dans la v0.18 ce mode est désactivé par défaut. Pour l'activer, allez dans Édition → Préférences → Affichage, et décochez la case "Désactiver gestuelle de basculement écran tactile".


Mode Gestuelle-Maya

Dans le mode Gestuelle-Maya, le panoramique, le zoom et la rotation de la vue nécessitent la touche Alt et un bouton de la souris, par conséquent, une souris à trois boutons est requise. Il est également possible d'utiliser des gestes car ce mode a été développé par rapport au mode de navigation par gestes.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Maintenez la touche Alt et le bouton central de la souris enfoncés, puis déplacez le pointeur. Maintenez la touche Alt et le bouton droit de la souris enfoncés, puis déplacez le pointeur.

Vous pouvez également utilisez la molette de la souris pour zoomer et dézoomer.

Maintenez la touche Alt et le bouton gauche de la souris enfoncés, puis déplacez le pointeur.


Mode Revit

Ce style est introduit dans la version 0.18.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Maj+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur.

Vous pouvez également maintenir enfoncé les boutons gauche et droit de la souris, et déplacer le pointeur.

Utilisez la molette de la souris pour zoomer et dézoomer. Maintenez la touche Maj et le bouton central de la souris enfoncés, puis déplacez le pointeur.

Vous pouvez également maintenir enfoncé le bouton central de la souris, puis aussi le bouton droit, et déplacer le pointeur.


Mode OpenCascade

Ce style est introduit dans la version 0.18.

Sélection Mouvement panoramique Zoom Rotation de la vue
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Cliquez avec le bouton gauche de la souris sur l'objet que vous souhaitez sélectionner. Appuyez sur le bouton central de la souris, puis déplacez le pointeur. Utilisez la molette de la souris pour zoomer et dézoomer.

Vous pouvez également maintenir la touche Ctrl et le bouton gauche de la souris enfoncés, puis déplacer le pointeur.

Maintenez la touche Ctrl et le bouton droit de la souris enfoncés, puis déplacer le pointeur.


Sélectionner des objets

Sélection simple

Les objets peuvent être sélectionnés en cliquant avec le bouton gauche de la souris sur l'objet, soit dans la vue 3D, soit dans la vue arborescente.

Présélection

Un mécanisme de présélection permet de mettre les objets en surbrillance et d'afficher des informations à leur sujet lorsque le curseur de la souris les survole. Si vous n'aimez pas ce comportement, ou si vous avez un PC modeste, vous pouvez désactiver la présélection dans les préférences.

Manipulation d'objets

FreeCAD propose des manipulateurs qui sont des poignées pouvant être utilisés pour modifier l'apparence, la forme ou d'autres paramètres d'un objet.

Le plan de coupe est un exemple d'objet avec des manipulateurs. Un plan de coupe peut être activé avec le menu Affichage → Plan de coupe.

Support matériel

FreeCAD supporte aussi quelques périphériques d'entrée 3D.

Mac OS X

Récemment nous avons créé un post sur le forum des utilisateurs Mac pour qui ces combinaisons de touches et boutons de souris ne fonctionneraient pas comme prévu. Malheureusement, aucun des développeurs n'est possesseur d'un Mac, pas plus que les autres contributeurs réguliers. Nous avons besoin de votre aide pour déterminer les combinaisons de touches et boutons de souris fonctionnelles afin que nous puissions les renseigner sur ce wiki.

Arrow-left.svg Page précédente: Premiers pas
Page suivante: Cube de navigation Arrow-right.svg