Difference between revisions of "Mouse Model/en"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
 
(25 intermediate revisions by 4 users not shown)
Line 1: Line 1:
"Модела за работа с Мишката" в се състои от командите които се използват за да се навгира в 3D пространството и да се работи с обектите в него. FreeCAD подържа няколко стила на навигация с мишка. Стилът по-поразбиране се нарича "CAD Навигация," и е доста прост и практичен. FreeCAD също предлага алтернативни стилове (модели) за навигация, които може да изберете спрямо вашите предпочитания.
+
<languages/>
 +
{{docnav|Getting started|Navigation Cube}}
  
== Навигация ==
+
The FreeCAD '''mouse model''' consists of the commands used to visually navigate the 3D space and interact with the objects displayed. FreeCAD supports multiple mouse model navigation styles. The default navigation style is referred to as "CAD Navigation," and is very simple and practical, but FreeCAD also provides alternative navigation styles which you can choose according to your preferences.
Стилът на навигацията и работа с обектите е един и същ във всички работни плотове. Следните жестове на мишката могат да се използват за да ес контролира позицията на обекта и изгледа към обекта (в зависимост от кой стил на навигация е избран).
+
 
 +
== Navigation ==
 +
The mouse gestures used for object manipulation vary depending on the Navigation style selected; the currently selected style is used for all workbenches.
  
 
There are two ways to change the navigation style:
 
There are two ways to change the navigation style:
  
* In the [[Preferences Editor]], Display section, ''3D View'' tab;
+
* In the [[Preferences Editor]], {{MenuCommand|Edit → Preferences → Display 3D View → 3D Navigation}}.
* By right-clicking in empty space in the 3D view area, then selecting ''Navigation style'' in the contextual menu.
+
* By right-clicking in empty space in the 3D view, then selecting {{MenuCommand|Navigation style →...}} in the contextual menu.
 +
 
 +
=== CAD Navigation ===
 +
This is the default navigation style. It allows the user a simple control of the view, and does not require the use of keyboard keys except to make multi-selections.
 +
 
 +
{{CAD Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view<br>First method
 +
|Rotate_view_alt_name=Rotate view<br>Alternate method
 +
|Ctrl={{KEY|Ctrl}}
 +
|Shift={{KEY|Shift}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
 
 +
Holding down {{KEY|Ctrl}} allows the selection of multiple objects.
 +
|Pan_text=Hold the middle mouse button, then move the pointer.
 +
|Pan_mode_text=Pan mode: hold the {{KEY|Ctrl}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
 
 +
Clicking the middle mouse button re-centers the view on the location of the cursor.
 +
|Zoom_mode_text=Zoom mode: hold the {{KEY|Ctrl}} and {{KEY|Shift}} keys, press the right mouse button once, then move the pointer. {{Version|0.17}}
 +
|Rotate_view_text=Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.
  
 +
The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues [[spinning]], if this is enabled.
  
=== CAD Navigation (default) ===
+
A double click with the middle mouse button sets a new center of rotation.
This is the default navigation style and allows the user a simple control of the view, and does not require the use of keyboard keys except to make multi-selections.
+
|Rotate_view_mode_text=Rotate mode: hold the {{KEY|Shift}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
{{CAD Navigation}}
+
|Rotate_view_alt_text=Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.
  
 +
With this method the middle mouse button may be released after the right mouse button is held pressed.
  
=== Inventor Navigation ===
+
Users who use the mouse with their right hand may find this method easier than the first method.
In Inventor Navigation, modeled after [http://en.wikipedia.org/wiki/Open_Inventor Open Inventor] (not to be confused with Autodesk Inventor), there is no mouse-only selection. In order to select objects, you must hold down the {{KEY|CTRL}} key.
+
}}
{{Inventor Navigation}}
 
  
 +
=== OpenInventor Navigation ===
 +
OpenInventor navigation (formerly Inventor) was modeled after [http://en.wikipedia.org/wiki/Open_Inventor Open Inventor]. In order to select objects, you must hold down the {{KEY|Ctrl}} key.
 +
 +
This mode is not based on Autodesk Inventor.
 +
 +
{{OpenInventor Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Ctrl={{KEY|Ctrl}}
 +
|Select_text=Hold {{KEY|Ctrl}}, then press the left mouse button over an object you want to select.
 +
|Pan_text=Hold the middle mouse button, then move the pointer.
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
 +
Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.
 +
|Rotate_view_text=Hold the left mouse button, then move the pointer.
 +
}}
  
 
=== Blender Navigation ===
 
=== Blender Navigation ===
  
In Blender Navigation, modeled after [http://www.blender.org Blender], there is no mouse-only panning. In order to pan the view, you must hold down the {{KEY|SHIFT}} key.
+
The Blender navigation style was modeled after [http://www.blender.org Blender]. Previously there was no mouse-only panning; it always required holding the {{KEY|Shift}} key. This changed in 2016, now you can hold both left and right mouse buttons to pan.
{{Blender Navigation}}
+
{{Blender Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Shift={{KEY|Shift}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Pan_text=Hold {{KEY|Shift}} and the middle mouse button, then move the pointer.
  
 +
Alternatively, hold both left and right mouse buttons, and then move the pointer.
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
|Rotate_view_text=Hold the middle mouse button, then move the pointer.
 +
}}
  
 
=== Touchpad Navigation ===
 
=== Touchpad Navigation ===
  
In Touchpad Navigation, neither panning, nor zooming, nor rotating the view, are mouse-only (or touchpad-only) operations.
+
In Touchpad Navigation, panning, zooming, and rotating the view require a modifier key together with the touchpad.
{{Touchpad Navigation}}
+
{{Touchpad Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Shift={{KEY|Shift}}
 +
|Ctrl={{KEY|Ctrl}}
 +
|Alt={{KEY|Alt}}
 +
|PageUp={{KEY|PageUp}}
 +
|PageDown={{KEY|PageDown}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Pan_text=Hold {{KEY|Shift}}, then move the pointer.
 +
|Zoom_text=Use {{KEY|PageUp}} and {{KEY|PageDown}} to zoom in and out.
 +
|Zoom_alt_text=Alternatively, hold {{KEY|Shift}} and {{KEY|Ctrl}}, then move the pointer.
 +
|Rotate_view_text=Hold {{KEY|Alt}}, then move the pointer.
 +
|Rotate_view_alt_text=Alternatively, hold {{KEY|Shift}} and the left button, then move the pointer.
 +
}}
  
=== Gesture Navigation (v0.16) ===
+
=== Gesture Navigation ===
  
This navigation style was tailored for usability with touchscreen and pen, but is very usable with mouse too.
+
This style was introduced in version 0.16, and was tailored for use with a touchscreen and pen. Nevertheless, it can also be used with a mouse.
{{Gesture Navigation}}
+
{{Gesture Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Tilt_view_name=Tilt view
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Select_gesture_text=Tap to select.
 +
|Pan_text=Hold the right mouse button, then move the pointer.
 +
|Pan_gesture_text=Drag with two fingers.
  
 +
Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button.
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
|Zoom_gesture_text=Drag two fingers (pinch) closer or farther apart.
 +
|Rotate_view_text=Hold the left mouse button, then move the pointer.
 +
In [[Sketcher Workbench|Sketcher]] and other edit modes, this behavior is disabled. Hold {{KEY|Alt}} when pressing the mouse button to enter rotation mode.
 +
 +
To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press {{KEY|H}} on the keyboard.
 +
|Rotate_view_gesture_text=Drag with one finger to rotate.
 +
 +
Hold {{KEY|Alt}} when in the [[Sketcher Workbench|Sketcher]].
 +
|Tilt_view_text=Hold both left and right mouse buttons, then move the pointer sideways.
 +
|Tilt_view_gesture_text=Rotate the imaginary line formed by two touch points.
 +
 +
On v0.18 this method is disabled by default. To enable, go to {{MenuCommand|Edit → Preferences → Display}}, and untick "Disable touchscreen tilt gesture" checkbox.
 +
}}
  
 
=== Maya-Gesture Navigation ===
 
=== Maya-Gesture Navigation ===
  
In Maya-Gesture Navigation, all view movements are archived pressing {{KEY|ALT}} and a mouse button, so that it will be needed to have a 3 button mouse in order to correctly use this navigation mode. Alternately it's possible to use gestures as this mode was been developed over the normal Gesture Navigation mode.
+
In Maya-Gesture Navigation, panning, zooming, and rotating the view require the {{KEY|Alt}} key together with a mouse button; therefore, a three-button mouse is required. It's also possible to use gestures as this mode was developed over the [[Mouse Model#Gesture Navigation|Gesture Navigation]] mode.
{{MayaGesture Navigation}}
+
{{MayaGesture Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Alt={{KEY|Alt}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Pan_text=Hold {{KEY|Alt}} and the middle mouse button, then move the pointer.
 +
|Zoom_text=Hold {{KEY|Alt}} and the right mouse button, then move the pointer.
 +
 
 +
Alternatively, use the mouse wheel to zoom in and out.
 +
|Rotate_view_text=Hold {{KEY|Alt}} and the left mouse button, then move the pointer.
 +
}}
 +
 
 +
 
 +
=== Revit Navigation ===
 +
 
 +
This style was introduced in version 0.18.
 +
 
 +
{{Revit Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Shift={{KEY|Shift}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Pan_text=Hold the middle mouse button, then move the pointer.
 +
 
 +
Alternatively, hold both left and right mouse buttons, then move the pointer.
 +
 
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
|Rotate_view_text=Hold {{KEY|Shift}} and the middle mouse button, then move the pointer.
 +
 
 +
Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.
 +
}}
 +
 
 +
=== OpenCascade ===
 +
 
 +
This style was introduced in version 0.18.
 +
 
 +
{{OpenCascade Navigation
 +
|Select_name=Select
 +
|Pan_name=Pan
 +
|Zoom_name=Zoom
 +
|Rotate_view_name=Rotate view
 +
|Ctrl={{KEY|Ctrl}}
 +
|Select_text=Press the left mouse button over an object you want to select.
 +
|Pan_text=Hold the middle mouse button, then move the pointer.
 +
|Zoom_text=Use the mouse wheel to zoom in and out.
 +
 
 +
Alternatively, hold {{KEY|Ctrl}} and the left mouse button, then move the pointer.
 +
|Rotate_view_text=Hold {{KEY|Ctrl}} and the right mouse button, then move the pointer.
 +
}}
  
 
== Selecting objects ==
 
== Selecting objects ==
Line 49: Line 196:
 
=== Preselection ===
 
=== Preselection ===
 
There is also a ''Preselection'' mechanism that highlights objects and displays information before selection by just hovering the mouse over the objects. If you don't like this behaviour or you have a slow machine, you can switch preselection off in the preferences.
 
There is also a ''Preselection'' mechanism that highlights objects and displays information before selection by just hovering the mouse over the objects. If you don't like this behaviour or you have a slow machine, you can switch preselection off in the preferences.
 
  
 
== Manipulating Objects ==
 
== Manipulating Objects ==
 
FreeCAD offers [[Manipulator|''manipulators'']] that are handles that can be used to modify an object's appearance, shape, or other parameters.
 
FreeCAD offers [[Manipulator|''manipulators'']] that are handles that can be used to modify an object's appearance, shape, or other parameters.
  
.
+
The [[Std ClippingPlane|clipping plane]] is an example of an object with manipulators. A [[Std ClippingPlane|clipping plane]] can be activated with the menu {{MenuCommand|View → Clipping Plane}}.
 
 
{{Note|''Obsolete''|The [[Std ClippingPlane|clipping plane]] is a good example of an object with manipulators. A [[Std ClippingPlane|clipping plane]] can be activated with the ''View→Clipping Plane'' menu. After activation the clipping plane object appears and shows seven obvious manipulators as little boxes: One on each end of its three coordinate axes and one on the center of the plane normal axis. There are four more that are not as obvious: The plane itself and the thin part of the three axis objects.
 
;Scaling: To scale the object click with the left mouse button on the box manipulators at the end of the axes and pull them back and forth. Depending on the object the manipulators work independently or synchronously.
 
;Out of plane shifting: To shift the object along its normal vector, pull the long box on the center of an axis with the left mouse button. For the clipping plane there is only one manipulator along the normal vector.
 
;In plane shifting: To move the center of the clipping plane, click on the plane object and pull it to the desired location.
 
;Rotation: Clicking on the thin part of the axes puts the manipulator in rotation mode.
 
}}
 
  
 
== Hardware support ==
 
== Hardware support ==
Line 71: Line 210:
 
Recently we got reports [http://forum.freecadweb.org/viewtopic.php?f=3&t=3592&start=0 on the forum] from Mac users that those mouse button and key combination do not work as expected. Unfortunately, none of the developers owns a Mac, neither do the other regular contributors. We need your help to determine which mouse buttons and key combination work so we can update this wiki.
 
Recently we got reports [http://forum.freecadweb.org/viewtopic.php?f=3&t=3592&start=0 on the forum] from Mac users that those mouse button and key combination do not work as expected. Unfortunately, none of the developers owns a Mac, neither do the other regular contributors. We need your help to determine which mouse buttons and key combination work so we can update this wiki.
  
{{docnav|Getting started|Document structure}}
+
{{docnav|Getting started|Navigation Cube}}
 +
 
 +
{{Userdocnavi}}
  
[[Category:User Documentation/en]]
+
[[Category:User Documentation]]
<languages/>
 

Latest revision as of 18:34, 11 April 2019

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

The FreeCAD mouse model consists of the commands used to visually navigate the 3D space and interact with the objects displayed. FreeCAD supports multiple mouse model navigation styles. The default navigation style is referred to as "CAD Navigation," and is very simple and practical, but FreeCAD also provides alternative navigation styles which you can choose according to your preferences.

Navigation

The mouse gestures used for object manipulation vary depending on the Navigation style selected; the currently selected style is used for all workbenches.

There are two ways to change the navigation style:

  • In the Preferences Editor, Edit → Preferences → Display → 3D View → 3D Navigation.
  • By right-clicking in empty space in the 3D view, then selecting Navigation style →... in the contextual menu.

CAD Navigation

This is the default navigation style. It allows the user a simple control of the view, and does not require the use of keyboard keys except to make multi-selections.

Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Press the left mouse button over an object you want to select.

Holding down Ctrl allows the selection of multiple objects.

Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Clicking the middle mouse button re-centers the view on the location of the cursor.

Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues spinning, if this is enabled.

A double click with the middle mouse button sets a new center of rotation.

Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.

With this method the middle mouse button may be released after the right mouse button is held pressed.

Users who use the mouse with their right hand may find this method easier than the first method.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: hold the Ctrl key, press the right mouse button once, then move the pointer. introduced in version 0.17 Zoom mode: hold the Ctrl and Shift keys, press the right mouse button once, then move the pointer. introduced in version 0.17 Rotate mode: hold the Shift key, press the right mouse button once, then move the pointer. introduced in version 0.17


OpenInventor Navigation

OpenInventor navigation (formerly Inventor) was modeled after Open Inventor. In order to select objects, you must hold down the Ctrl key.

This mode is not based on Autodesk Inventor.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Hold Ctrl, then press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

Hold the left mouse button, then move the pointer.


Blender Navigation

The Blender navigation style was modeled after Blender. Previously there was no mouse-only panning; it always required holding the Shift key. This changed in 2016, now you can hold both left and right mouse buttons to pan.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Press the left mouse button over an object you want to select. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, and then move the pointer.

Use the mouse wheel to zoom in and out. Hold the middle mouse button, then move the pointer.


Touchpad Navigation

In Touchpad Navigation, panning, zooming, and rotating the view require a modifier key together with the touchpad.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
Press the left mouse button over an object you want to select. Hold Shift, then move the pointer. Use PageUp and PageDown to zoom in and out. Hold Alt, then move the pointer.
Shift+Ctrl+Touchpad.svg Shift+Touchpad LB hold.svg
Alternatively, hold Shift and Ctrl, then move the pointer. Alternatively, hold Shift and the left button, then move the pointer.


Gesture Navigation

This style was introduced in version 0.16, and was tailored for use with a touchscreen and pen. Nevertheless, it can also be used with a mouse.

Select Pan Zoom Rotate view Tilt view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Press the left mouse button over an object you want to select. Hold the right mouse button, then move the pointer. Use the mouse wheel to zoom in and out. Hold the left mouse button, then move the pointer.

In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard.

Hold both left and right mouse buttons, then move the pointer sideways.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Tap to select. Drag with two fingers.

Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button.

Drag two fingers (pinch) closer or farther apart. Drag with one finger to rotate.

Hold Alt when in the Sketcher.

Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox.


Maya-Gesture Navigation

In Maya-Gesture Navigation, panning, zooming, and rotating the view require the Alt key together with a mouse button; therefore, a three-button mouse is required. It's also possible to use gestures as this mode was developed over the Gesture Navigation mode.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Press the left mouse button over an object you want to select. Hold Alt and the middle mouse button, then move the pointer. Hold Alt and the right mouse button, then move the pointer.

Alternatively, use the mouse wheel to zoom in and out.

Hold Alt and the left mouse button, then move the pointer.


Revit Navigation

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, then move the pointer.

Use the mouse wheel to zoom in and out. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.


OpenCascade

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold Ctrl and the left mouse button, then move the pointer.

Hold Ctrl and the right mouse button, then move the pointer.


Selecting objects

Simple selection

Objects can be selected by a click with the left mouse button either by clicking on the object in the 3D-view or by selecting it in the tree view.

Preselection

There is also a Preselection mechanism that highlights objects and displays information before selection by just hovering the mouse over the objects. If you don't like this behaviour or you have a slow machine, you can switch preselection off in the preferences.

Manipulating Objects

FreeCAD offers manipulators that are handles that can be used to modify an object's appearance, shape, or other parameters.

The clipping plane is an example of an object with manipulators. A clipping plane can be activated with the menu View → Clipping Plane.

Hardware support

FreeCAD also supports some 3D input devices.

Mac OS X Issues

Recently we got reports on the forum from Mac users that those mouse button and key combination do not work as expected. Unfortunately, none of the developers owns a Mac, neither do the other regular contributors. We need your help to determine which mouse buttons and key combination work so we can update this wiki.