Difference between revisions of "Interface Customization/pl"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
(3 intermediate revisions by the same user not shown)
Line 58: Line 58:
 
}}
 
}}
  
<div class="mw-translate-fuzzy">
+
{{Std Base navi}}
{{Std Base}}
+
{{Interface/pl}}
{{Interface}}
+
{{Userdocnavi/pl}}
{{Userdocnavi}}
 
</div>
 

Revision as of 17:28, 16 January 2020

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Ponieważ interfejs FreeCAD oparty jest na nowoczesnym zestawie narzędzi Qt, posiada on najbardziej efektywną organizację.
Widżety, menu, paski narzędzi i inne narzędzia mogą być modyfikowane, przenoszone, współdzielone pomiędzy warsztatami, skróty klawiaturowe mogą być ustawiane, modyfikowane, a makra mogą być nagrywane i odtwarzane. Okno dostosowywania jest dostępne z menu Narzędzia → Dostosuj:

Screenshot-customize.jpg

Zakładka dostosowywania wyglądu

Zakładka Polecenia umożliwia przeglądanie wszystkich dostępnych poleceń FreeCAD, uporządkowanych według kategorii.

W polu Keyboard możesz zobaczyć skróty klawiaturowe związane z każdym poleceniem FreeCAD. Jeśli chcesz, możesz zmodyfikować lub przypisać nowy skrót do dowolnego polecenia. Jest to miejsce, do którego należy się udać, jeśli często używasz konkretnego Środowiska pracy i chciałbyś przyspieszyć jego używanie za pomocą klawiatury.

Karty Paski narzędzi umożliwiają modyfikację istniejących pasków narzędzi lub utworzenie niestandardowych pasków narzędzi.

Zakładka Środowiska zawiera Środowiska pracy dostępne w programie FreeCAD. Po lewej stronie - obecnie wyłączone, a po prawej - aktualnie dostępne. Status można zmienić za pomocą poziomych strzałek.

File:UserdefSymbstrip.jpg

Po lewej stronie zakładki Paski narzędzi znajdują się te same kategorie poleceń, co przy karcie Polecenia.
Po kliknięciu w kategorię pojawiają się odpowiednie polecenia, które można skopiować na prawą stronę. Zanim to zrobisz, wybierz aktywny obszar roboczy, do którego chcesz dodać indywidualny pasek narzędzi. Zanim do niego skopiujesz wybrane polecenia, najpierw wybierz nazwę dla tego paska narzędzi za pomocą przycisku Nowy. Gdy ten obszar roboczy zostanie wywołany później, pasek ten musi zostać aktywowany: Widok → Paski narzędzi.

Uwaga: Jeśli po prawej stronie okienka zostanie wybrana opcja Globalne (zamiast obszaru roboczego), dodany pasek narzędzi będzie aktywny w każdym Środowisku pracy.


Menu Makro pozwala zarządzać zapisanymi Makrodefinicjami.

Utwórz paski narzędzi dla swojego makra Dostosuj paski narzędzi.

Od wersji FreeCAD 0.16 dostępne jest nowe narzędzie, które pozwala na zarządzanie Środowiskiem pracy.

CustomizeWorkbenches.png

Przykład

Na przykład zakładamy, że chcemy, aby narzędzie Pomiar odległości pojawiło się również na pasku narzędzi w Środowisku pracy Draft.

  • w FreeCAD wybierz Narzędzia → Dostosuj z menu głównego,
  • wybierz zakładkę Paski narzędzi,
  • po lewej stronie w menu rozwijanym wybierz Część,
  • po lewej stronie w dolnym oknie przewiń w dół do pozycji Pomiar odległości i wybierz ją,
  • po prawej stronie wybierz "Szkic" w menu rozwijanym,
  • kliknij na Nowy..., aby utworzyć nowy pasek narzędzi i wybrać jego nazwę,
  • teraz wybierz pasek narzędzi miejsca docelowego w prawym dolnym oknie (wymagane tylko wtedy, gdy masz więcej niż jeden pasek narzędzi),
  • klikając na niebieską Strzałkę w prawo (górna ikona w środkowym rzędzie) dodasz wybrany wpis do wybranego paska narzędzi.

Gdy zaznaczysz opcję Global w rozwijanym menu po prawej stronie, utworzysz pasek narzędzi, który będzie widoczny na wszystkich stołach warsztatowych.

Aby dodać zainstalowane makro do paska narzędzi, należy:

  • wybrać zakładkę Makra w rozwijanym menu po lewej stronie,
  • mają przypisaną etykietę wyświetlaną w menu, ikonę (Pixmapę) itd. za pomocą menu Narzędzia → Dostosuj → Makra.