Difference between revisions of "Interface Customization/fr"

From FreeCAD Documentation
Jump to: navigation, search
m
(Created page with "Sous l'onglet '''Ateliers''' ('''Workbenches'''), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le...")
Line 16: Line 16:
 
Les onglets '''Barre d'outils''' et '''Barre de boîte d'outils''' vous permet de modifier des barres d'outils existantes, ou de créer vos propres barres d'outils personnalisées.
 
Les onglets '''Barre d'outils''' et '''Barre de boîte d'outils''' vous permet de modifier des barres d'outils existantes, ou de créer vos propres barres d'outils personnalisées.
  
Under the tab '''Worksbenches''' ('''Workbenches''') the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.
+
Sous l'onglet '''Ateliers''' ('''Workbenches'''), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le statut peut être changé avec les flèches horizontales.
  
 
[[Image:UserdefSymbstrip.jpg]]
 
[[Image:UserdefSymbstrip.jpg]]

Revision as of 18:19, 24 November 2019

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Puisque l'interface de FreeCAD est basée sur le très moderne toolkit Qt, elle dispose d'une organisation de pointe. Les widgets, menus, barres d'outils et autres outils peuvent être modifiés, déplacés, partagés entre ateliers ; des raccourcis-clavier peuvent être créés et modifiés, et des macros peuvent être enregistrées et jouées. La fenêtre de personnalisation est accessible depuis le menu Outils → Personnaliser

La fenêtre Personnaliser...

Onglets de personnalisation

L'onglet Commandes permet de naviguer à travers les commandes disponibles de FreeCAD, classées par leur catégorie.

L'onglet Clavier affiche les raccourcis associés avec chaque commande de FreeCAD, et vous permet de modifier ou d'assigner un nouveau raccourci à n'importe quelle commande. Ceci peut être utile si vous utiliser couramment un atelier en particulier : vous pouvez augmenter votre rapidité en utilisant le clavier.

Les onglets Barre d'outils et Barre de boîte d'outils vous permet de modifier des barres d'outils existantes, ou de créer vos propres barres d'outils personnalisées.

Sous l'onglet Ateliers (Workbenches), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le statut peut être changé avec les flèches horizontales.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


L'onglet Macros permet de gérer vos Macros enregistrées.

Tutoriel pour créer vos Barres d'Outils pour vos macro Customize Toolbars

Depuis FreeCAD 0.16, un nouvel outil est disponible pour vous permettre de gérer vos ateliers.

CustomizeWorkbenches.png

Exemple

Par exemple lors d’une session de travail, supposons que nous voulions que l’outil "Mesure de longueur" apparaisse également dans une barre d'outils personnalisée dans l’atelier Draft.

  • dans FreeCAD choisissez Outils → Personnaliser... dans le menu tout en haut
  • sélectionnez l’onglet "Barre d'outils"
  • sur le côté gauche, choisissez "Pièce" dans le menu déroulant
  • sur le côté gauche de la fenêtre inférieure, descendez jusqu’à l’entrée "Mesure de longueur" et sélectionnez-la
  • sur le côté droit, choisissez "Draft" dans le menu déroulant
  • cliquez sur "Nouveau ..." pour créer une nouvelle barre d’outils et choisissez un nom pour celle-ci
  • sélectionnez maintenant votre barre d’outils de destination dans la fenêtre inférieure droite (uniquement nécessaire si vous avez plus d’une barre d’outils)
  • en cliquant sur la "Flèche vers la droite" bleue (icône du haut de la rangée du milieu), vous ajouterez l’entrée sélectionnée à la barre d’outils sélectionnée

Remarques:

Lorsque vous sélectionnez "Global" dans le menu déroulant sur le côté droit, vous allez créer une barre d’outils qui sera visible dans tous les ateliers

Pour ajouter une macro déjà enregistrée à une barre d’outils, vous devez

  • sélectionnez "Macros" dans le menu déroulant sur le côté gauche en haut
  • sinon au préalable il faut avoir une macro correctement définie en ayant utilisé l’onglet Outils → Personnaliser → Macros et qu’elle soit présente dans la fenêtre "Installer des macros personnalisées"