Difference between revisions of "Interface Customization/de"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
Line 49: Line 49:
 
</div>
 
</div>
  
<div class="mw-translate-fuzzy">
+
{{Std Base/de}}
[[Category:User Documentation/de]]
+
{{Interface/de}}
</div>
+
{{Userdocnavi/de}}

Revision as of 20:07, 10 November 2019

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Status: FreeCAD-Version 0.16

Die FreeCAD-Oberfläche ist mit Hilfe der modernen Qt-Software gestaltet und lässt sich vom Benutzer verändern: Bildschirm-Fenster, Menüs, Werkzeugleisten, Aufruf-Tastaturkürzel u.a. Die Einstellmöglichkeiten über das Werkzeuge → Benutzerdefiniert-Menü erreicht werden.

BenutzerdefBefehle.jpg

Unter der Registerkarte Befehle (Commands) sind alle in FreeCAD vorkommenden Befehle aufgeführt. Sie sind nach verschiedenen Kriterien (Punkte im Hauptmenü, Arbeitsbereiche u.a.) zusammen gefasst. Diese Karte dient nur der Übersicht, Veränderungen erfolgen nach Aufruf der nächsten Karten.

Unter der Registerkarte Tastatur (Keybord) sind die zum Aufruf eines Befehls verwendeten Tastenkombinationen eingetragen oder können eingetragen und/oder geändert werden.

Unter der Registerkarte Arbeitsbereiche (Workbenches) sind die in FreeCAD existierenden Arbeitsbereiche aufgeführt, links die z.Zt. passiven, rechts die z.Zt. aktiven Bereiche. Der Status-Wechsel erfolgt mit den horizontalen Pfeilen.

BenutzerdefSymbLeisten.jpg

Unter der Registerkarte Symbolleisten (Toolbars) stehen links die gleichen Befehls-Kategorien wie unter der Karte Befehle. Nach Anklicken einer Kategorie erscheinen die dazugehörenden Befehle, die auf die rechte Seite hinüber kopiert werden können. Vorher wählt man dort einen aktiven Arbeitsbereich, dem man eine individuelle Symbolleiste zufügen möchte. Für diese Leiste ist zuerst mit Neu (New...) ein Name zu wählen, bevor man in sie Befehle herüber kopiert. Beim späteren Aufruf dieses Arbeitsbereichs ist diese Leiste zu aktivieren: Ansicht -> Symbolleisten.

Anmerkung: Wenn rechts "Global" (anstatt eines Arbeitsbereiches) gewählt wird, kann die zugefügte Symbolleiste in jedem Arbeitsbereich aktiviert werden.

Unter der Registerkarte Makros (Macros) werden den von extern beschafften Programmteilen (Makros) Worte und Icons zugefügt, die für ihren Aufruf als Makro-Werkzeuge erforderlich sind.

Siehe auch dieses Tutorial

Seit FreeCAD v0.16 ist ein neues Werkzeug verfügbar, mit dem die Arbeitsbereiche verwaltet werden können.

.

.

.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu