Difference between revisions of "How to install macros/de"

From FreeCAD Documentation
Jump to: navigation, search
(Created page with "Du musst einen Dekompressor verwenden, um die internen Dateien zu erhalten. * Für Windows kannst Du ein Programm wie [http://www.7-zip.org/ 7-zip] oder [http://www.kanmandet....")
(Created page with "center {{Caption|align=center|Vom Makro erzeugtes Objekt}}")
 
(16 intermediate revisions by the same user not shown)
Line 223: Line 223:
 
}}
 
}}
  
2. Download the compressed archive with the macro code to a local folder.
+
2. Lade das komprimierte Archiv mit dem Makrocode in einen lokalen Ordner herunter.
  
 
[[Image:Macro Install HowTo 01.png|center]]  
 
[[Image:Macro Install HowTo 01.png|center]]  
{{Caption|align=center|Downloading the compressed archive to a local directory}}
+
{{Caption|align=center|Herunterladen des komprimierten Archivs in ein lokales Verzeichnis}}
  
3. Decompress the file in the folder.
+
3. Entpacke die Datei in dem Ordner.
  
 
[[Image:Macro Install HowTo 02.png|center]]  
 
[[Image:Macro Install HowTo 02.png|center]]  
{{Caption|align=center|Decompressing the file in the folder}}
+
{{Caption|align=center|Entpacken der Datei im Ordner}}
  
4. The decompressor creates a new directory with the unpacked files.
+
4. Der Entpacker erstellt ein neues Verzeichnis mit den entpackten Dateien.
  
 
[[Image:Macro Install HowTo 03.png|center]]  
 
[[Image:Macro Install HowTo 03.png|center]]  
{{Caption|align=center|New directory created after unpacking the archive}}
+
{{Caption|align=center|Neues Verzeichnis nach dem Entpacken des Archivs erstellt}}
  
5. Go inside the new directory, and copy or cut the macro file.
+
5. Gehe  in das neue Verzeichnis und kopiere oder schneide die Makrodatei aus.
  
 
[[Image:Macro Install HowTo 04.png|center]]  
 
[[Image:Macro Install HowTo 04.png|center]]  
{{Caption|align=center|Entering the newly created directory with the decompressed macro file}}
+
{{Caption|align=center|Eingeben des neu erstellten Verzeichnisses mit der entpackten Makrodatei}}
  
6. Go to the macro directory and paste the file there.
+
6. Gehe in das Makroverzeichnis und füge die Datei dort ein.
  
 
[[Image:Macro Install HowTo 05.png|center]]  
 
[[Image:Macro Install HowTo 05.png|center]]  
{{Caption|align=center|Placing the macro file in the macro directory}}
+
{{Caption|align=center|Platzieren der Makrodatei im Makroverzeichnis}}
  
7. In FreeCAD, open the menu {{MenuCommand|Macro → [[Image:Std DlgMacroExecuteDirect.svg|16px]] [[Std_DlgMacroExecuteDirect|Macros]]}} to open the [[Std_DlgMacroExecuteDirect|Execute macro dialog]].
+
7. Öffne in FreeCAD das Menü {{MenuCommand/de|Makro → [[Image:Std DlgMacroExecuteDirect.svg|16px]] [[Std_DlgMacroExecuteDirect/de|Makros]]}}, um den [[Std_DlgMacroExecuteDirect/de|Makro Dialog ausführen]].
  
 
[[Image:Macro Install HowTo 06.png|center]]
 
[[Image:Macro Install HowTo 06.png|center]]
{{Caption|align=center|Opening the execute macro dialog}}
+
{{Caption|align=center|Öffnen des Makroausführungsdialogs}}
  
8. Select the new macro and press {{Button|Execute}}.
+
8. Wähle das neue Makro aus und drücke  {{Button|Ausführen}}.
  
 
[[Image:Macro Install HowTo 07.png|center]]
 
[[Image:Macro Install HowTo 07.png|center]]
{{Caption|align=center|Selecting the macro to run it}}
+
{{Caption|align=center|Auswählen des Makros zur Ausführung}}
  
9. The macro now runs. Select the desired options, and click the {{Button|Create}} button.
+
9. Das Makro läuft jetzt. Wähle die gewünschten Optionen aus und klicke auf die Schaltfläche {{Button|Erstellen}}.
  
 
[[Image:Macro Install HowTo 08.png|center|640px]]
 
[[Image:Macro Install HowTo 08.png|center|640px]]
{{Caption|align=center|The macro in action; select the desired options, and press Create when ready}}
+
{{Caption|align=center|Das Makro in Aktion; wähle die gewünschten Optionen und drücke Erstellen, wenn du bereit bist.}}
  
 
[[Image:Macro Install HowTo 30.png|center]]
 
[[Image:Macro Install HowTo 30.png|center]]
{{Caption|align=center|Object created by the macro}}
+
{{Caption|align=center|Vom Makro erzeugtes Objekt}}
  
 
</div>
 
</div>

Latest revision as of 16:48, 6 January 2020

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский • ‎svenska

Base ExampleCommandModel.png Tutorial

Thema
Programmierung
Niveau
durchschnittliche Programmierer
Zeit zum Abschluss
Not provided
Autor
Mario52
FreeCAD version
Alle
Beispieldatei(en)
None


Beschreibung

Diese Seite zeigt dir, wie du FreeCAD Makros installieren und benutzen kannst.

Makros sind Befehlssequenzen, die zur Ausführung einer komplexen Zeichenoperation verwendet werden. Makros sind Python Skripte, d.h. sie sind Textdateien, die mit einem Texteditor geschrieben und bearbeitet werden können.

Während Python Skripte normalerweise die Erweiterung .py haben, sollten FreeCAD Makros die Erweiterung .FCMacro haben. Eine Sammlung von Makros, die von erfahrenen Anwendern geschrieben wurden, findest Du auf der Seite Makrozepte.

Siehe Einführung in Python, um mehr über die Programmiersprache Python zu erfahren, und dann Python Skript Tutorium und FreeCAD Skript Grundlagen, um das Schreiben von Makros zu erlernen.

Hier ist ein Video über Installieren von FreeCAD Makros in Ubuntu.

Das Makro Menü und die Werkzeugleiste

Werkzeugleiste

Menü

Neben den Werkzeugen in der Werkzeugleiste sind auch die folgenden Funktionen im Menü Makro verfügbar.

Makros Verzeichnis

Makros werden in einem bestimmten Ordner unter dem FreeCAD Benutzerverzeichnis erstellt. Dieses Verzeichnis kann im Makrodialog ausführen, oder im Einstellungseditor, über das Menü Bearbeiten → Einstellungen → Allgemein → Makro → Makro Aufnahme Einstellungen.

Heruntergeladene Makros sollten ebenfalls in diesem Verzeichnis abgelegt werden.

Standardverzeichnis

Makros können einfach kopiert werden in

$ROOT_DIR/

wobei $ROOT_DIR ein Verzeichnis der obersten Ebene ist, das von FreeCAD beim Start durchsucht wird.

Der $ROOT_DIR könnte ein systemweites Verzeichnis sein, in diesem Fall wird das Makro für alle Benutzer installiert.

  • Unter Linux ist es normalerweise /usr/share/freecad/
  • Unter Windows ist es normalerweise C:\Program Files\FreeCAD\
  • Unter Mac OSX ist es normalerweise /Applications/FreeCAD/

Der $ROOT_DIR könnte das Verzeichnis eines bestimmten Benutzers sein.

  • Unter Linux ist es normalerweise /home/username/.FreeCAD/
  • Unter Windows ist es normalerweise C:\Benutzername\Benutzername\Anwendungsdaten\FreeCAD\
  • Unter Mac OSX ist es normalerweise /Benutzer/Benutzername/Bibliothek/Einstellungen/FreeCAD/

Konfigurieren des Benutzerverzeichnisses

1. Öffne das Menü Makro → Std DlgMacroExecuteDirect.svg Makros, um den Makrodialog ausführen.

Dxf Importer Install 01.png

Opening the macro dialog


2. Setze den entsprechenden Nutzer Makros Standort.

  • Linux: normalerweise /home/username/.FreeCAD/
  • Windows: normalerweise C:\Users\username\AppData\Roaming\FreeCAD\
  • MacOS: normalerweise /Users/username/Library/Preferences/FreeCAD/
Dxf Importer Install 02.png

Setting of the macros directory


3. Navigiere zu diesem Verzeichnis auf deinem Computer.

  • Linux: Füge die Adresse in deinen Dateimanager ein, "Nautilus" oder andere. Eventuell musst du Ctrl+H drücken, um das versteckte Verzeichnis .FreeCAD/ sichtbar zu machen.
  • Windows: Füge die Adresse in dein "Datei Suchprogramm" ein und bestätige.
  • MacOS: Suche den Ordner im "Finder" oder füge die Adresse in ein "Datei Suchprogramm" ein; merke dir das file:/// Vorsatzzeichen im "Datei Suchprogramm" für eine Datei auf der Festplatte.
Dxf Importer Install 03.png

Accessing the macros directory in the operating system


4. Füge diesem Verzeichnis Makrodateien hinzu.

  • Linux: Lasse den Dateimanager geöffnet und setze ein Lesezeichen für den schnelleren Zugriff.
  • Windows: Lasse das Datei Suchprogramm geöffnet.
  • MacOS: Lasse entweder ein "Finder"-Fenster geöffnet, oder setze ein Lesezeichen für den Speicherort in deinem "Datei Suchprogramm", oder richte einen "Alias" ein, um darauf zu zeigen, oder ziehe den Ordner in die " Seitenleiste" des "Finders", so dass er von anderen Programmen, wie z.B. Texteditoren, verwendet werden kann.
Dxf Importer Install 04.png

Macros directory


Makros installieren

Automatische Methode

Ab FreeCAD 0.17 verwende den Zusatzmanager in Werkzeuge → Zusatzmanager, um ein Makro zu installieren, das in das FreeCAD-macros Repositorium aufgenommen wurde.

In früheren Versionen von FreeCAD konntest du zwei automatisierte Wege nutzen, um Makros und andere Addons zu installieren:

  • addons_installer.FCMacro: selbst ein Makro, dies war der Vorläufer des Zusatzmanagers, und wird im FreeCAD-addons Repositorium beherbergt. Bei Neuinstallationen von FreeCAD muss dieses Tool nicht verwendet werden.
  • freecad-pluginloader: ebenfalls ein Makro, es kann verwendet werden, um neue Komponenten in FreeCAD zu installieren. Es wird nicht mehr weiterentwickelt.

Der empfohlene Weg, Zusätze, d.h. externe Arbeitsbereiche und Makros zu installieren, ist der Zusatzmanager. Du kannst jedoch immer noch Makros mit den in den folgenden Abschnitten beschriebenen manuellen Methoden zu deinem System hinzufügen; dies ist nützlich, wenn du deinen eigenen Code entwickelst und testest.

Manuelle Methode 1. Kopiere den Code in den Makro Editor=

Für Makros, die relativ klein sind, 300 Zeilen oder weniger, kann der Code kopiert und direkt in den FreeCAD Makro-Editor eingefügt werden.

Wir werden Part Prism Apothem.svg Macro Apothem Based Prism GUI als ein Beispiel verwenden.

1. Gehe auf die Makro Wiki Seite, die unter Makro Rezepte aufgelistet sein sollte.

Wenn es ein benutzerdefiniertes Symbol gibt, lade es herunter; klicke mit der rechten Maustaste darauf und wähle Bild speichern unter...; platziere das Symbol im Makroverzeichnis. Dieses Symbol kann als Tastaturkürzel für das Makro in einer benutzerdefinierten Werkzeugleiste verwendet werden. Das Standardsymbol ist Text-x-python.png.

Macro Install HowTo 28.png

Downloading the icon from the macro page


2. Wähle auf der Makroseite den Code innerhalb der Abschnitte Skript oder Makro aus und kopiere ihn.

3. Öffne in FreeCad das Menü Makro → Std DlgMacroExecuteDirect.svg Makros, um den Makro Dialog ausführen.

Dxf Importer Install 01.png

Opening the execute macro dialog


4. Klicke Erstelle.

Macro Install HowTo 17.png

Creating a new macro


5. Gib den Makronamen ein, hier Macro_Apothem_Based_Prism_GUI, und drücke OK.

Macro Install HowTo 18.png

Entering the macro name


6. Der Makro Editor öffnet sich und zeigt den vollständigen Pfad des neuen Makros an.

Macro Install HowTo 19.png

The macro editor


7. Füge den Code in das Editorfenster ein und klicke dann auf das Kreuz auf der Registerkarte, um das Fenster zu schließen.

Macro Install HowTo 20.png

Closing the macro editor


8. Ein Fenster erscheint, das nach Bestätigung zum Speichern des Codes fragt; klicke auf Ja. Du kannst auch Ctrl+S verwenden, um die Datei zu speichern.

Starte FreeCAD neu, um das neue Makro korrekt zu registrieren.

Macro Install HowTo 27.png

Asking for confirmation to save the code


9. Öffne dann das Menü erneut, Makro → Std DlgMacroExecuteDirect.svg Makros, wähle das neue Makro aus und drücke Ausführen.

Macro Install HowTo 21.png

Selecting the macro to run it


10. Das Makro läuft jetzt. Fülle die Felder mit deinen Werten aus und klicke auf die Schaltfläche OK.

Macro Install HowTo 22.png

The macro in action; fill in the information and press OK when ready


11. Dieses Makro sollte einen Fehler zurückgeben, wenn kein Dokument aktiv ist; andere Makros öffnen ein neues Dokument, wenn keines existiert.

Erstelle ein neues Dokument mit Datei → Document-new.svg Neu, und wiederhole dann die vorherigen Schritte, um das Makro auszuführen.

Macro Install HowTo 23.png

Das Makro gibt einen Fehler zurück, wenn kein Dokument aktiv ist


12. Sobald ein aktives Dokument verfügbar ist, wird das Makro ausgeführt und ein Objekt erstellt.

Macro Install HowTo 24.png

Vom Makro erzeugtes Objekt


13. Du kannst das Makro erneut im Editor öffnen, um es auszuführen oder zu modifizieren. Gehe zu Makro → Std DlgMacroExecuteDirect.svg Makros, wähle das Makro aus und drücke Edit.

Macro Install HowTo 25.png

Öffnen des Makros im Editor


14. Das Makro kann nun mit Makro → Macro-execute.svg Makro ausführen, oder durch Klicken auf die Macro-execute.svg Ausführen Taste in der Werkzeugleiste.

Macro Install HowTo 26.png

Ausführen des im Editor geladenen Makros


Manuelle Methode 2. Hinzufügen einer Makrodatei aus einer komprimierten .zip-Datei

Einige Makros sind zu groß, als dass es unbequem ist, sie zu kopieren und in den Makro Editor einzufügen, oder sie können nicht im Wiki beherbergt werden. In diesem Fall kann der Code irgendwo anders beherbergt werden, in einem Github Repositorium oder im FreeCAD Forum. Der Code kann auch in eine .zip Datei, einen Tarball .tar.xz oder eine andere Art von Archiv komprimiert werden, wenn es mehrere Dateien enthält. Wenn der Code auf diese Weise verteilt wird, sollte das Archiv extrahiert und die Dateien im Makro Verzeichnis abgelegt werden.

Wir werden Text-x-python.png Makro Schrauben Ersteller als ein Beispiel.

1. Lade den komprimierten Code aus dem Forum herunter, Screw Maker.

Du musst einen Dekompressor verwenden, um die internen Dateien zu erhalten.

  • Für Windows kannst Du ein Programm wie 7-zip oder L-Zarc oder quickzip verwenden.
  • Für Linux kannst Du einen Befehl vom Terminal aus verwenden
unzip your_file.zip -d your_directory

2. Lade das komprimierte Archiv mit dem Makrocode in einen lokalen Ordner herunter.

Macro Install HowTo 01.png

Herunterladen des komprimierten Archivs in ein lokales Verzeichnis


3. Entpacke die Datei in dem Ordner.

Macro Install HowTo 02.png

Entpacken der Datei im Ordner


4. Der Entpacker erstellt ein neues Verzeichnis mit den entpackten Dateien.

Macro Install HowTo 03.png

Neues Verzeichnis nach dem Entpacken des Archivs erstellt


5. Gehe in das neue Verzeichnis und kopiere oder schneide die Makrodatei aus.

Macro Install HowTo 04.png

Eingeben des neu erstellten Verzeichnisses mit der entpackten Makrodatei


6. Gehe in das Makroverzeichnis und füge die Datei dort ein.

Macro Install HowTo 05.png

Platzieren der Makrodatei im Makroverzeichnis


7. Öffne in FreeCAD das Menü Makro → Std DlgMacroExecuteDirect.svg Makros, um den Makro Dialog ausführen.

Macro Install HowTo 06.png

Öffnen des Makroausführungsdialogs


8. Wähle das neue Makro aus und drücke Ausführen.

Macro Install HowTo 07.png

Auswählen des Makros zur Ausführung


9. Das Makro läuft jetzt. Wähle die gewünschten Optionen aus und klicke auf die Schaltfläche Erstellen.

Macro Install HowTo 08.png

Das Makro in Aktion; wähle die gewünschten Optionen und drücke Erstellen, wenn du bereit bist.


Macro Install HowTo 30.png

Vom Makro erzeugtes Objekt


Ausführen eines Makros in der Kommandozeile

Kommandozeile ein Makro ausführen (.FCMacro oder .py)

unter Windows

"C:\Program Files\FreeCAD\bin\FreeCAD.exe" "C:\Users\userName\AppData\Roaming\FreeCAD\Mod\WorkFeature\start_WF.FCMacro"

unter Linux

todo

Fehler in Makros

Einrückungsfehler

Der weiße Raum am Anfang der Zeilen (Einrückung) ist in der Programmiersprache Python sehr wichtig und ein integraler Bestandteil des Codes. Ein ungeeignetes Leerzeichen kann dazu führen, dass der Code nicht läuft oder Fehler aufweist.

Dieser Abschnitt beschreibt einige Fehler, die beim Kopieren und Einfügen sowie beim Schreiben von Makrocode auftreten können.

Ein typischer Einrückungsfehler sieht wie folgt aus:

<unknown exception traceback><type 'exceptions.IndentationError'>: ('expected an indented block', ('C:/Users/d/AppData/Roaming/FreeCAD/Macro_Apothem_Based_Prism_GUI.FCMacro', 21, 3, 'def priSm(self):\n'))

Beispiel 1

Wenn der Code keine Einrückung aufweist, wird der Code nicht funktionieren. Klassen (class) und Funktionsdefinitionen (def()), sowie Kontrollstrukturen (if, while, for) sollten von einem Block eingerückten Codes gefolgt werden.

Dieser Fehler ist möglich, wenn der Benutzer den Code nicht korrekt kopiert und alle Leerzeichen versehentlich entfernt wurden.

Macro Install HowTo 09.png

Python Code, der keine Einrückung hat; er wird einen Fehler verursachen, wenn er ausgeführt wird


Einrückungsproblem behoben.

Macro Install HowTo 10.png

Python Code mit der richtigen Einrückung


Wenn der Code ausgewählt ist, sollten alle Zeilen bis zum linken Rand hervorgehoben werden, um anzuzeigen, dass die Zeilen ausgerichtet sind.

Macro Install HowTo 11.png

Python Code hervorgehoben, was zeigt, dass alle Zeilen am linken Rand beginnen


Beispiel 2

Wenn ein zusätzliches Leerzeichen am Anfang aller Zeilen eingefügt, wird der Python Interpreter versagen und sich über unnötige Einrückungen beschweren. In diesem Fall muss in alle Zeilen das anfangs Leerzeichen entfernt werden.

Macro Install HowTo 12.png

Python Code mit zusätzlichem Leerzeichen in jeder Zeile


Beispiel 3

Hier wurde der Code aus einem Foren Thema durch Verwendung Alles auswählen Schaltfläche kopiert. Anscheinend ist die Auswahl gut.

Macro Install HowTo 14.png

Python Code kopiert aus einem Forum


Wenn die Auswahl jedoch in den Makro Editor eingefügt wird, scheint es zu einer unerwünschten Einrückung zu kommen.

Macro Install HowTo 15.png

Python Code aus einem Forum in den Makro Editor kopiert; unnötige Einrückung wird hinzugefügt


In this case, the initial spaces need to be removed. This can be done with a specialized text editor to quickly decrease the indentation of the lines.

Unter Windows Notepad++ kann die Auswahl ausgeführt mit Alt + Maus ziehen und dann verwenden Bearbeiten → Einrücken → Verringere die Einrückung.

Macro Install HowTo 16.png

Python Code mit der korrekten Einrückung


Beispiel 4

Hier wählt die Auswahl auch die Zeilennummern im Codebeispiel aus. Wenn diese Auswahl in den Makro Editor eingefügt wird, funktioniert sie nicht. Es müssen alle Zeilennummern entfernt und die Leerzeichen so angepasst werden, dass der Python Code die richtige Einrückung hat.

Macro Install HowTo 29.png

Auswahl, die auch die Zeilennummern auswählt; wenn dieser Code in den Makro Editor eingefügt wird, wird es nicht funktionieren


Guter Code

Macro Install HowTo 13.png

Python Code mit der richtigen Einrückung


Keine Textausgabe aus Makros

Makros können Informationen in der Berichtsansicht ausgeben, um zu zeigen, was der Code während der Ausführung tut.

Wenn keine Information angezeigt wird, stelle sicher, dass die Reportansicht und die Python Konsole sichtbar sind und dass die Ausgabe auf die Berichtsansicht gerichtet ist.

Druckinformationen

FreeCAD Makros haben zwei Methoden, um Informationen in die Berichtsansicht zu drucken.

Die FreeCAD Funktionen

FreeCAD.Console.PrintMessage("Hello World! \n")
FreeCAD.Console.PrintError("Hello World! \n")
FreeCAD.Console.PrintWarning("Hello World! \n")

Die einfache Python Funktion

print("Hello World!")

Aktivieren der Berichtsansicht

Um die in der Konsole angezeigten Informationen zu sehen, solltest Du:

1. Gehe zum Menü Ansicht → Paneele.

Macro Install HowTo 31.png
Macro Install HowTo 32.png

Sichtbarmachung der Panels im Menü Ansicht → Paneele


2. Aktiviere die Berichtansicht und die Python Konsole.

Macro Install HowTo 33.png

Aktivieren der Berichtsansicht und der Python Konsole


3. Die Bedienfelder sind jetzt sichtbar, und Befehle wie FreeCAD.Console.PrintMessage() geben jetzt Informationen aus, die in der Berichtansicht angezeigt werden.

Macro Install HowTo 34.png

FreeCAD Hauptfenster mit der Berichtsansicht und der Python Konsole


= Aktivieren des Befehls print()

FreeCAD muss möglicherweise so konfiguriert werden, dass die Funktion print() von Python seine Ausgabe korrekt in die Berichtsansicht umleitet.

1. Gehe in den Einstellungs Editor mit dem Menü Bearbeiten → Einstellungen.

Macro Install HowTo 35.png

In den Einstellungen Editor gehen


2. Gehe zum Abschnitt Allgemein, und dann Ausgabefenster → Python Interpreter.

Macro Install HowTo 36.png

Ausgabefenster Einstellungen


3. Beide Kästchen ankreuzen:

  • Case a cocher O.png Interne Python Ausgabe in die Berichtsansicht umleiten
  • Case a cocher O.png Umleiten interner Python Fehler in die Berichtsansicht

und drücke dann die {OK Taste.

Macro Install HowTo 37.png

Umleitung der Python-Ausgabe in die Berichtsansicht.


Macro Install HowTo 38.png

Python Befehle zum Drucken von Informationen in die Berichtsansicht.