Difference between revisions of "FAQ/de"

From FreeCAD Documentation
Jump to: navigation, search
(Updating to match new version of source page)
m
 
(30 intermediate revisions by 3 users not shown)
Line 17: Line 17:
 
==== Multithreading ====
 
==== Multithreading ====
  
<div class="mw-translate-fuzzy">
+
Der FreeCAD zugrunde liegende geometrische Modellierungskern, die Drittanbieterbibliothek [http://en.wikipedia.org/wiki/Open_Cascade_Technology OpenCASCADE Technologie] (OCCT),[https://forum.freecadweb.org/viewtopic.php?f=4&t=17501&p=173095&hilit=Multithread#p173095 unterstützt derzeit nur teilweise Multithreading]. Weitere Informationen finden Sie auf der Seite [[multithreading/de|Multithreading]].
Der FreeCAD zugrundeliegende "geometric modeling kernel" [https://de.wikipedia.org/wiki/Open_CASCADE_Technology Open CASCADE Technology] (kurz OCC) eines Drittanbieters <s>unterstützt zur Zeit kein multithreading</s>.
 
[https://forum.freecadweb.org/viewtopic.php?f=4&t=17501&p=173095&hilit=Multithread#p173095 bietet zur Zeit partielle Mulitithreading].
 
</div>
 
  
==== Für MAC-Nutzer ====
+
==== Für MAC Nutzer ====
  
Es wird nur die Mac-/Intel-Architektur unterstützt, für PowerPC sind keine Versionen verfügbar.
+
Es wird nur die MacIntel Architektur unterstützt. Für die PowerPC Architektur sind keine Builds verfügbar.
  
=== Ich möchte FreeCAD selbst kompilieren ===
+
=== Was, wenn ich FreeCAD selbst kompilieren möchte? ===
  
Der Sourcecode von FreeCAD ist im entsprechenden Repository des Projektes verfügbar. Das eigene Kompilieren ermöglicht die Nutzung der neuesten Funktionen, erfordert aber ein paar Computerkenntnisse. Das Verfahren ist ziemlich einfach. Der Zugang zum Sourcecode ist erklärt [[CompileOnUnix#Getting_the_source|here]] und es existieren genaue Anleitungen zum Kompilieren für [[CompileOnWindows|Windows]], [[CompileOnUnix|Linux]] und [[compileOnMac|Mac OSX]].
+
Der Quellcode von FreeCAD ist immer im Projekt Quellcode Repository verfügbar. Wenn du FreeCAD selbst kompilierst, kannst du die neuesten Funktionen verwenden, die gerade entwickelt werden, erfordert aber ein wenig Computerkenntnisse, obwohl das Verfahren ziemlich einfach ist. Der Zugriff auf den Quellcode wird erklärt [[Compile on Linux/Unix#Getting_the_source|here]], und wir haben detaillierte Anweisungen zum Kompilieren auf [[Compile_on_Windows/de|Windows]], [[Compile_on_Linux/de/Unix|Linux]] und [[Compile_on_MacOS/de|MacOS]].
  
 
=== FreeCAD meldet, dass einige Module oder Anwendungen fehlen ===
 
=== FreeCAD meldet, dass einige Module oder Anwendungen fehlen ===
Line 83: Line 80:
 
Nach dem Start von FreeCAD erscheint die GUI fast augenblicklich, aber sie ist eingefroren und die CPU-Auslastung bei ungefähr 99%. Das kann auf dem KDE-Desktop passieren, wenn man das Oxygen-Theme benutzt. Das ist ein Bug im Oxygen-Theme und die Nutzung eines anderen Themes sollte das Problem lösen.
 
Nach dem Start von FreeCAD erscheint die GUI fast augenblicklich, aber sie ist eingefroren und die CPU-Auslastung bei ungefähr 99%. Das kann auf dem KDE-Desktop passieren, wenn man das Oxygen-Theme benutzt. Das ist ein Bug im Oxygen-Theme und die Nutzung eines anderen Themes sollte das Problem lösen.
  
=== FreeCAD stürzt beim Anlegen eines neuen oder Öffnen eines vorhandenen Dokuments ab ===
+
=== FreeCAD stürzt beim Anlegen eines neuen Dokuments oder Öffnen einer vorhandenen Datei ab ===
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Falls FreeCAD beim Anlegen einer neuen 3D-Ansicht abstürzt, versuch FreeCAD von einem Terminal aus zu starten. Falls eine Fehlermeldung beim Absturz erscheint, in der "Assertion failed"  und ein Komponentenname beginnend mit "So" (SoBase, SoFieldContainer, etc) erwähnt wird, dann ist die Chance sehr hoch, gerade wenn Du auf Linux bist, dass FreeCAD versucht, zwei verschiedene Versionen der coin-Library zu verwenden, was den Absturz verursacht.
+
Wenn FreeCAD abstürzt, wenn es eine neue 3D-Ansicht erstellt, versuche, FreeCAD von einem Terminal aus zu starten. Wenn ein Meldungsfehler auftritt, wenn der Absturz auftritt und {{SystemOutput|Assertion Failed}} erwähnt wird, und ein Komponentenname, der mit "So" ({{SystemOutput|SoBase}}}, {{SystemOutput|SoFieldContainer}}, usw.) beginnt, sind die Chancen sehr hoch, insbesondere wenn Sie auf Linux sind, dass FreeCAD versucht, zwei verschiedene Versionen der Coin Library zu verwenden, was den Absturz verursacht.
Um zu prüfen, dass das tatsächlich das Problem ist, versuch das Folgende:
+
Um zu überprüfen, ob dies tatsächlich das Problem ist, versuche Folgendes:
* Finde das FreeCAD-Binary (normalerweise in /usr/lib/FreeCAD/bin)
+
* Suche die ausführbare FreeCAD-Datei (normalerweise in {{FileName|/usr/lib/FreeCAD/bin}}).
* Führe den Befehl 'ldd FreeCAD' in einem Terminal aus
+
* Führe den Befehl {{SystemInput|ldd FreeCAD}} von einem Terminal aus.
* Merke Dir die Version der libCoin-Library, die FreeCAD benutzt (z.B. libCoin.so.60)
+
* Notiere die Version der Bibliothek {{FileName|libCoin.so}}, die FreeCAD verwendet (z.B. {{FileName|libCoin.so.60}}).
* Finde die linSoQt.so-Library (normalerweise in /usr/lib)
+
* Suche die Bibliothek {{FileName|libSoQt.so}} (normalerweise in {{FileName|/usr/lib}}}).
* Führe 'ldd libSoQt.so' aus und prüfe, ob dort die gleiche Version wie bei FreeCAD benutzt wird
+
* Führe {{SystemInput|ldd libSoQt.so}} aus und prüfe, ob es auf die gleiche Coin-Version wie FreeCAD verweist.
Wenn es einen Unterschied gibt, dann muss entweder FreeCAD oder SoQt erneut kompiliert werden (es ist besser, das Programm mit der älteren Coin-Version erneut zu kompilieren). Das normale Verhalten ist, die Personen zu kontaktieren, die für das Paketieren von FreeCAD oder Coin zuständig sind und sie freundlich zu bitten, über ein erneutes Kompilieren nachzudenken.  
+
Wenn es einen Unterschied gibt, muss entweder FreeCAD oder SoQt neu kompiliert werden (besser diejenige, die die älteste Coin-Version verwendet). Das normale Verhalten ist es, die für die Verpackung von SoQt oder FreeCAD verantwortlichen Personen zu kontaktieren und sie zu bitten, eine Neukompilierung in Betracht zu ziehen.
Wenn Du diesen Schritt selbst durchführen willst und es nicht möglich ist, SoQt erneut zu kompilieren, weil dann andere Anwendungen auf Deinem System nicht funktionieren, dann kannst Du FreeCAD mit './configure --with-coin=DIR' zwingen, die benötigte Coin-Version beim Kompilieren zu benutzen. Du solltest vorher sicherstellen, dass das passende devel-Paket zu dieser Coin-Version installiert ist.
+
Wenn Du diesen Schritt selbst durchführen willst und es nicht möglich ist, SoQt neu zu kompilieren, weil es andere Anwendungen auf Deinem System zerstört, kannst Du FreeCAD zwingen, mit {{SystemInput|<nowiki>./configure --with-coin=DIR</nowiki>}} mit der erforderlichen Coin-Version zu kompilieren. Du musst jedoch sicherstellen, dass das richtige Entwicklungspaket dieser Coin-Version installiert ist.
 
</div>
 
</div>
  
 
=== FreeCAD stürzt nach Bearbeiten → Ausrichtung ab ===
 
=== FreeCAD stürzt nach Bearbeiten → Ausrichtung ab ===
  
<div class="mw-translate-fuzzy">
+
Ein Segmentierungsfehler tritt bei {{SystemOutput|vbo_save_playback_vertex_list()}} auf. Das bedeutet, dass die Implementierung von VBO im Grafiktreiber schlecht ist. Um das Caching von OpenGL-Aufrufen zu vermeiden, kannst Du versuchen, die Umgebungsvariable {{SystemInput|<nowiki>IV_SEPARATOR_MAX_CACHES=0</nowiki>}} einzustellen und FreeCAD neu zu starten.
Ein Segmentation fault tritt in vbo_save_playback_vertex_list() auf. Dies bedeutet, dass die Implementierung von VBO im Grafiktreiber schlecht ist. Um zu vermeiden, dass für OpenGL-Aufrufe Caching benutzt wird, kannst Du versuchen, die Umgebungsvariable IV_SEPARATOR_MAX_CACHES=0 zu setzen und FreeCAD neu zu starten.
 
</div>
 
  
 
=== Ich habe Schwierigkeiten bei der Ausführung von FreeCAD auf Mac OSX ===
 
=== Ich habe Schwierigkeiten bei der Ausführung von FreeCAD auf Mac OSX ===
Line 125: Line 120:
  
  
Es ist ein [[Macro findConfigFiles]] verfügbar, um bei der Suche nach Deinen Konfigurationsdateien zu helfen. Es kann mit Hilfe des Addon-Manager im Werkzeuge-Menü installiert werden ({{MenuCommand|Werkzeuge → Addon Manager → Macros → findConfigFiles}}). Das Makro findet Dein Konfigurationsdateienverzeichnis, kopiert den Namen in die Zwischenablage und öffnet (bzw. versucht es) das Verzeichnis mit Deinem Standard-Datei-Explorer. Es macht keine Änderungen an Deinen Dateien oder Einstellungen.
+
Es gibt ein [[Makro findConfigFiles/de|Macro findConfigFiles]], das dir beim Auffinden deiner Konfigurationsdateien hilft. Es kann über den Addon Manager im Menü Extras installiert werden{{MenuCommand/de|Werkzeuge → Addon Manager → Makros → findConfigFiles}}. Das Makro findet den Ordner deiner Konfigurationsdatei, kopiert ihn in die Zwischenablage und versucht, diesen Ort mit deinem Standard-Dateibrowser zu öffnen. Es werden keine Änderungen an Ihren Dateien oder Einstellungen vorgenommen.
  
 
== FreeCAD benutzen ==
 
== FreeCAD benutzen ==
Line 135: Line 130:
 
=== Wie drehe ich die 3D-Ansicht? ===
 
=== Wie drehe ich die 3D-Ansicht? ===
  
<div class="mw-translate-fuzzy">
 
 
<center>
 
<center>
 
<gallery widths="300" heights="200">
 
<gallery widths="300" heights="200">
Image:Style_of_navigation.png|Mit der {{KEY|rechte Taste}} Maus
+
Image:Style_of_navigation.png|Von der {{KEY|right button}} Maus
Image:Style of navigation menu.png|Vom Menü Bearbeiten  Einstellungen 
+
Image:Style of navigation menu.png|Vom Menü {{MenuCommand|Edit Preferences }}
 
</gallery>
 
</gallery>
 
</center>
 
</center>
{{clear}}
 
FreeCAD hat mehrere verschiedene [[Mouse Model/de|Navigationsmodi]], die im Einstellungsdialog oder durch Rechtsklicken in der 3D-Ansicht geändert werden können. Mehr Einzelheiten über die Modi findest Du auf der [[Mouse Model/de|Maus-Modell]]-Seite. Für den Standard-Modus ("CAD-Navigation") sind die Befehle wie folgt
 
 
{{clear}}
 
{{clear}}
{{CAD Navigation
 
|Select_name=Select
 
|Pan_name=Pan
 
|Zoom_name=Zoom
 
|Rotate_view_name=Rotate view<br>First method
 
|Rotate_view_alt_name=Rotate view<br>Alternate method
 
|Ctrl={{KEY|Ctrl}}
 
|Shift={{KEY|Shift}}
 
|Select_text=Press the left mouse button over an object you want to select.
 
 
Holding down {{KEY|Ctrl}} allows the selection of multiple objects.
 
|Pan_text=Hold the middle mouse button, then move the pointer.
 
|Pan_mode_text=Pan mode: hold the {{KEY|Ctrl}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
 
|Zoom_text=Use the mouse wheel to zoom in and out.
 
 
Clicking the middle mouse button re-centers the view on the location of the cursor.
 
|Zoom_mode_text=Zoom mode: hold the {{KEY|Ctrl}} and {{KEY|Shift}} keys, press the right mouse button once, then move the pointer. {{Version|0.17}}
 
|Rotate_view_text=Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.
 
 
The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues [[spinning]], if this is enabled.
 
 
A double click with the middle mouse button sets a new center of rotation.
 
|Rotate_view_mode_text=Rotate mode: hold the {{KEY|Shift}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
 
|Rotate_view_alt_text=Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.
 
 
With this method the middle mouse button may be released after the right mouse button is held pressed.
 
 
Users who use the mouse with their right hand may find this method easier than the first method.
 
}}
 
</div>
 
  
FreeCAD has several different [[Mouse Model|navigation modes]] available, that can be set in the preferences settings dialog or changed by right-clicking in the 3D view. For full details about the modes, see the [[Mouse Model|Mouse Model]] pageFor the default mode ("CAD Navigation"), the commands are as follows,
+
FreeCAD verfügt über mehrere verschiedene [[Mouse Model/de|Navigationsmodi]], die man im Einstellungsdialog einstellen oder durch einen Rechtsklick in der 3D Ansicht ändern kann. Ausführliche Informationen zu den Modi finden sich auf der Seite [[Mouse Model/de|Mausmodell]].  Für den Standardmodus ("CAD-Navigation") lauten die Befehle wie folgt,
 
{{clear}}
 
{{clear}}
  
Line 187: Line 149:
 
|Ctrl={{KEY|Ctrl}}
 
|Ctrl={{KEY|Ctrl}}
 
|Shift={{KEY|Shift}}
 
|Shift={{KEY|Shift}}
|Select_text=Press the left mouse button over an object you want to select.
+
|Select_text=Drücke die linke Maustaste über einem Objekt, das Du auswählen möchtest.
  
Holding down {{KEY|Ctrl}} allows the selection of multiple objects.
+
Wenn man die Taste {{KEY|Ctrl}} gedrückt hält, kann man mehrere Objekte auswählen.
|Pan_text=Hold the middle mouse button, then move the pointer.
+
|Pan_text=Halte die mittlere Maustaste gedrückt und bewege den Mauszeiger.
|Pan_mode_text=Pan mode: hold the {{KEY|Ctrl}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
+
|Pan_mode_text=Pan mode: Halte die Taste {{KEY|Ctrl}} gedrückt, drücke einmal die rechte Maustaste und bewege den Mauszeiger. {{Version/de|0.17}} |Zoom_text=Verwende das Mausrad, um heran- und herauszuzoomen.
|Zoom_text=Use the mouse wheel to zoom in and out.
 
  
Clicking the middle mouse button re-centers the view on the location of the cursor.
+
Klicken der mittleren Maustaste zentriert die Ansicht neu auf die Position des Cursors.
|Zoom_mode_text=Zoom mode: hold the {{KEY|Ctrl}} and {{KEY|Shift}} keys, press the right mouse button once, then move the pointer. {{Version|0.17}}
+
|Zoom_mode_text=Zoom Modus: Halte die Tasten {{KEY|Ctrl}} und {{KEY|Shift}} gedrückt, drücke einmal die rechte Maustaste und bewege dann den Zeiger. {{Version/de|0.17}}
|Rotate_view_text=Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.
+
|Rotate_view_text=Halte die mittlere Maustaste gedrückt, halte dann die linke Maustaste gedrückt und bewege den Mauszeiger.
  
The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues [[spinning|spinning]], if this is enabled.
+
Die Cursorposition beim Drücken der mittleren Maustaste bestimmt den Drehpunkt. Rotation funktioniert wie das Drehen einer Kugel, die sich um ihr Zentrum dreht. Wenn die Tasten losgelassen werden, bevor Sie die Mausbewegung stoppen, wird die Ansicht [[spinning/de|Drehen]] fortgesetzt, sofern dies aktiviert ist.
  
A double click with the middle mouse button sets a new center of rotation.
+
Ein Doppelklick mit der mittleren Maustaste setzt einen neuen Drehpunkt.
|Rotate_view_mode_text=Rotate mode: hold the {{KEY|Shift}} key, press the right mouse button once, then move the pointer. {{Version|0.17}}
+
|Rotate_view_mode_text=Rotate mode: Halte die Taste {{KEY|Shift}} gedrückt, drücke einmal die rechte Maustaste und bewege den Mauszeiger. {{Version/de|0.17}}
|Rotate_view_alt_text=Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.
+
|Rotate_view_alt_text=Halte die mittlere Maustaste gedrückt, halte dann die rechte Maustaste gedrückt und bewege den Mauszeiger.
  
With this method the middle mouse button may be released after the right mouse button is held pressed.
+
Mit dieser Methode kann die mittlere Maustaste losgelassen werden, wenn die rechte Maustaste gedrückt gehalten wird.
  
Users who use the mouse with their right hand may find this method easier than the first method.
+
Anwender, die die Maus mit der rechten Hand benutzen, können diese Methode leichter finden als die erste Methode.
 
}}
 
}}
  
Line 229: Line 190:
  
 
Es gibt viele Möglichkeiten, wie Du ein falsches Ergebnis bekommst. Der beste Weg ist sicherzugehen, was in dem zu extrudierenden Objekt steckt. Der Inhalt von Objekten kann einfach mit Python untersucht werden. Nimm beispielsweise an, dass Du ein Objekt namens "Wire" hast. Du kannst dann in der Python-Konsole folgendes eintippen:
 
Es gibt viele Möglichkeiten, wie Du ein falsches Ergebnis bekommst. Der beste Weg ist sicherzugehen, was in dem zu extrudierenden Objekt steckt. Der Inhalt von Objekten kann einfach mit Python untersucht werden. Nimm beispielsweise an, dass Du ein Objekt namens "Wire" hast. Du kannst dann in der Python-Konsole folgendes eintippen:
 +
 
{{code|code=
 
{{code|code=
 
obj = FreeCAD.ActiveDocument.Wire
 
obj = FreeCAD.ActiveDocument.Wire
Line 273: Line 235:
 
=== Nimmt FreeCAD am "Google Summer of Code" teil? ===
 
=== Nimmt FreeCAD am "Google Summer of Code" teil? ===
  
<div class="mw-translate-fuzzy">
+
Ja. FreeCAD nimmt ab 2016 am Google Summer of Code teil. Siehe [[Google Summer of Code/de|Google Summer of Code]] für Informationen zu früheren Ausgaben und [http://forum.freecadweb.org/viewtopic.php?f=8&t=13838 Google Summer Of Code 2016] im Forum für die ursprüngliche Ankündigung.
Ja. Beginnend mit 2016 nimmt FreeCAD am "Google Summer of Code" teil. Im Forum findest Du dieses  [http://forum.freecadweb.org/viewtopic.php?f=8&t=13838 Thema] und [[http://www.freecadweb.org/wiki/index.php?title=Google_Summer_of_Code diese Wiki-Seite]].
 
</div>
 
  
 
=== Ich möchte beginnen, das Wiki in meine Sprache zu übersetzen. Was muss ich tun? ===
 
=== Ich möchte beginnen, das Wiki in meine Sprache zu übersetzen. Was muss ich tun? ===
Line 287: Line 247:
 
=== Muss ich etwas bezahlen, um FreeCAD nutzen zu können? ===
 
=== Muss ich etwas bezahlen, um FreeCAD nutzen zu können? ===
  
<div class="mw-translate-fuzzy">
+
Nein. FreeCAD ist völlig kostenlos zu verwenden, herunterzuladen, weiterzugeben oder zu modifizieren. Es ist [http://en.wikipedia.org/wiki/Open_source open-source software], veröffentlicht unter den Bedingungen der [http://en.wikipedia.org/wiki/GNU_Lesser_General_Public_License GNU Lesser General Public License 2.1], die Dir diese Freiheiten garantiert und, was noch wichtiger ist, Dir garantiert, dass Dir diese Freiheiten nie genommen werden.
Nein. FreeCAD ist total kostenlos und frei zu nutzen, herunterzuladen, weiter zu verteilen oder zu ändern. Es ist [https://de.wikipedia.org/wiki/Open_Source Open-Source-Software] unter den Bestimmungnen von zwei frei Software-Lizenzen ([https://de.wikipedia.org/wiki/GNU_General_Public_License GPL] und [https://de.wikipedia.org/wiki/GNU_Lesser_General_Public_License LGPL]), was Dir diese Freiheiten garantiert, und, noch wichtiger, garantiert, dass Dir keine diese Freiheiten nehmen kann.
 
</div>
 
  
 
=== Kann ich einen beliebigen Teil der FreeCAD-Illustrationen oder Teile der Webseite wiederverwenden? ===
 
=== Kann ich einen beliebigen Teil der FreeCAD-Illustrationen oder Teile der Webseite wiederverwenden? ===
  
<div class="mw-translate-fuzzy">
+
Sicher. Alle Vorlagen (Icons, Banner, usw.) von FreeCAD sind LGPL lizenziert, ebenso wie der FreeCAD-Code. Bediene dich auf der Seite [[Artwork/de|Artwork]]. Die Website ist eine Standard-MediaWiki-Site, alle grafischen Elemente können frei wiederverwendet werden, und wenn Du neugierig bist, wie wir die MediaWiki-Software optimiert haben, suche nach den speziellen Common css- und js-Seiten.
Sicher. Die gesamten Illustrationen (Icons, Banner, etc....) von FreeCAD sind LGPL, das Gleiche gilt für den FreeCAD-Code. Bedien' Dich auf der [[Artwork/de|Artwork]]-Seite. Die Webseite ist eine Standard-Mediawiki-Site, alle grafischen Elemente können frei/kostenlos (freely) wiederverwendet werden, und falls Du Dich fragst, wie man die Mediawiki-Software so verändern kann, wie wir es tun, dann schau' nach den speziellen allgemeinen css- und js-Seiten.
 
</div>
 
  
 
=== Kann ich Teile von FreeCAD in anderen Anwendungen wiederverwenden? ===
 
=== Kann ich Teile von FreeCAD in anderen Anwendungen wiederverwenden? ===
  
<div class="mw-translate-fuzzy">
+
Ja, du kannst die Kernteile von FreeCAD in anderen Anwendungen verwenden, solange du die Bedingungen der LGPL einhältst. Bibliotheken von Drittanbietern, [[external workbenches/de|externe Arbeitsbereiche]] und [[macros/de|Makros]] können ihren eigenen Lizenzbedingungen unterliegen, also wende dich bitte an ihre Autoren. Weitere Informationen findest Du auf der Seite [[Licence/de|Lizenz]].
Ja, mit ein wenig Rücksichtnahme (considerations), weil einige Teil des Codes LGPL und andere GPL unterstehen, und der Tatsache, dass die von FreeCAD genutzte Software dritter Parteien möglicherweise anderen Bedingungen untersteht. Mehr Einzelheiten findest Du auf der [[Licence/de|Lizenz]]-Seite.
 
</div>
 
  
 
{{Userdocnavi/de}}
 
{{Userdocnavi/de}}
  
 
[[Category:Documentation/de]]
 
[[Category:Documentation/de]]

Latest revision as of 16:38, 6 December 2019

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎suomi • ‎français • ‎italiano • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎中文(中国大陆)‎

Diese Seite versucht, die am häufigsten im Forum gestellten Fragen zu beantworten. Wenn Du ein Problem oder eine Frage bezüglich FreeCAD hast, sieh bitte zuerst hier nach. Erst wenn Du hier keine Antwort auf Deine Frage findest, wende dich an das Forum FreeCAD forum!

Contents

Installation

Was ist der einfachste Weg, FreeCAD auf meinem Rechner zu installieren ?

Wenn Du mit Windows oder Mac OS arbeitest ist es am einfachsten, sich die fertigen Installationspakete von der Download-Seite herunterzuladen. Arbeitest Du mit Debian, Fedora, Ubuntu (und noch einigen weiteren Distributionen), dann ist FreeCAD bereits in den Standard-Repositories enthalten und kann mit dem entsprechenden Softwaremanager einfach installiert werden. Für Ubuntu pflegt das FreeCAD-Team sogar ein eigenes PPA repositories. Für weitere Einzelheiten zur Installation wird auf die FreeCAD installieren-Seite verwiesen.

Was sind die Voraussetzungen um FreeCAD auszuführen

Im Gegensatz zu den meisten 3D-CAD-Programmen läuft FreeCAD problemlos auf den meisten (auch einfachen) Rechnern, so auch auf Pentium 4 und IntelCore2 solo CPUs. Wenn auf Ihrem Rechner ein aktuelles Betriebssystem seinen Dienst verrichtet, stehen die Chanchen gut für FreeCAD. Die einzige Voraussetzung ist eine Grafikkarte, deren Chipsatz [1] in der Version 2.0 und höher unterstützt. Im Problemfall lesen Sie im Abschnitt (Fehlerbeseitigung ) dieser FAQ nach.

Multithreading

Der FreeCAD zugrunde liegende geometrische Modellierungskern, die Drittanbieterbibliothek OpenCASCADE Technologie (OCCT),unterstützt derzeit nur teilweise Multithreading. Weitere Informationen finden Sie auf der Seite Multithreading.

Für MAC Nutzer

Es wird nur die MacIntel Architektur unterstützt. Für die PowerPC Architektur sind keine Builds verfügbar.

Was, wenn ich FreeCAD selbst kompilieren möchte?

Der Quellcode von FreeCAD ist immer im Projekt Quellcode Repository verfügbar. Wenn du FreeCAD selbst kompilierst, kannst du die neuesten Funktionen verwenden, die gerade entwickelt werden, erfordert aber ein wenig Computerkenntnisse, obwohl das Verfahren ziemlich einfach ist. Der Zugriff auf den Quellcode wird erklärt here, und wir haben detaillierte Anweisungen zum Kompilieren auf Windows, Linux und MacOS.

FreeCAD meldet, dass einige Module oder Anwendungen fehlen

FreeCAD benötigt eine Reihe von Komponenten, um seine volle Funktionalität zu gewährleisten, die wichtigsten sind in den Installationspaketen vorhanden oder werden durch den Paketmanager geliefert. Wenn Sie FreeCAD allerdings aus einer nichtoffiziellen Quelle installieren oder selbst kompilieren, können einige Teile fehlen. Das ist unkritisch für FreeCAD, kann aber einen eingeschränkten Funktionsumfang zur Folge haben. Einige spezielle Dateiformate (wie Collada oder DWG) benötigen auch zusätzliche Komponenten, die nicht in FreeCAD integriert werden können. Diese müssen von Dir separat installiert werden.

Diese Komponenten und das empfohlende Vorgehen zur Installation sind auf dieser Seite aufgeführt: Extra Python-Module.

Fehlersuche

FreeCAD startet überhaupt nicht

Dafür kann es eine Menge Gründe geben, am wahrscheinlichsten fehlen einige Bibliotheken. Versuche FreeCAD von einem Terminal zu starten (schreibe freecad in der Eingabeaufforderung, FreeCAD auf einigen Systemen), um hier evtl. Fehlermeldungen zu erhalten. Lies außerdem den Rest der FAQs, um weitere Tips zur Lösung dieses Problems zu erhalten. Wenn nichts hilft, berichte darüber im Forum, hier kann Dir bestimmt jemand helfen.

Auf einigen älteren XP-Rechnern erhältst Du u.U. folgende oder eine ähnliche Fehlermeldung: Die Anwendung kann nicht gestarten werden, da die "side-by-side Konfiguration fehlerhaft ist. Die erneute Installation der Anwendung kann das Problem evtl. beheben. Die Ursache für das Problem sind entweder fehlende CRT-Laufzeitbliotheken oder dass die installierte Version zu alt ist, weil FreeCAD gegen eine neuere Version gelinked wurde. Installiere in diesem Fall das Microsoft Visual C++ Redistributable Package, das im Download-Bereich von Microsoft verfügbar ist; siehe auch: forum message.

FreeCAD startet normal, aber nicht alle Icons werden angezeigt. Einige werden durch ein schwarzes 'X' ersetzt.

Einige Teile von FreeCAD sind von dem externen Pythonmodul "Pivy" abhängig. Unter Windows ist "Pivy" Bestandteil des Installationspaketes. Auf Debian/Ubuntu-Systemen ist das python-pivy-Paket Bestandteil der Standard-Repositories. Auf anderen Systemen muss pivy derzeit selbst kompiliert werden. Ohne pivy sind einige Werkzeuge nicht verfügbar, der "Rest" von FreeCAD funktioniert normal.

Ich habe Anzeigeprobleme, die 3D-Ansicht verhält sich nicht korrekt, es gibt "Müll", wenn ich die Ansicht bewege/drehe, etc.

FreeCAD ist abhängig von OpenGL bei der Anzeige von 3D-Inhalten und erfordert daher eine funktionierende OpenGL-Umgebung. Auf einigen Systemen ist OpenGL als Standardeinstellung nicht aktiviert und Du musst ggf. die Grafiktreiber installieren oder aktualisieren. Diese Probleme treten meistens auf Linux- oder virtuellen Systemen auf. Wenn Du ein Linux-basiertes System hast, versuche die folgenden Schritte:

  • überprüfe, dass Dein Computer eine 3D-fähige Grafikkarte hat
  • tippe glxinfo in einem Terminal-Fenster ein und prüfe in der Ausgabe, dass 'Direct Rendering' auf "yes" steht und dass OpenGL-Hersteller/Renderer/Version zu Deiner Grafikkarte passen
  • installiere weitere OpenGL-basierte Software (beispielsweise [Blender]) und prüfe, ob sie läuft und fehlerfrei anzeigt

FreeCAD stürzt beim Start ab

Ein Absturz könnte eine ernsthafteren Fehler andeuten oder ein Problem in Deiner Konfiguration. Die meisten Abstürze treten aus einem der beiden folgenden Gründe auf:

Die OpenGL-Treiber sind nicht installiert oder funktionieren nicht ordnungsgemäß

Es gibt einen einfachen Grund für dieses Problem. Die Symtome sind, dass FreeCAD während des Startvorgangs abstürzt bzw. wenn Du eine 3D-Ansicht öffnest (z.B. beim Anlegen eines neuen Dokuments). Versuche den Typ Deines Grafik-Chips herauszufinden und suche z.B. auf [2], ob er unterstützt wird (das ist bei den meisten der Fall), dann finde den richtigen Treiber und installiere ihn. Eine gute Methode zur Überprüfung von OpenGL ist, eine andere OpenGL-Anwendung wie z.B. blender zu testen.

Als generellen Hinweis zur Ermittlung von weiteren Informationen über Abstürze kannst du FreeCAD mit der Option --write-log starten. Dies wird die Datei FreeCAD.log in $HOME/.FreeCAD auf Linux und Mac OS X oder %APPDATA\FreeCAD% auf Windows-Systemen.

In einigen seltenen Fällen hast Du vielleicht einen Grafiktreiber installiert, der nicht zu Deiner Grafikkarte passt. Wir hatten einen Fall, wo im Laptop des Benutzer eine Intel on-board-Grafik verbaut war, aber ATI-Treiber installiert waren ([3]). Nach dem Entfernen der Dateien und Installation der richtigen Treiber startete FreeCAD ohne Fehler.

Eine von FreeCAD benötigte Bibliothek ist nicht auf Deinem System vorhanden oder wurde nicht von FreeCAD gefunden

Es gibt zwei mögliche Erklärungen für dieses Problem: Entweder diese Bibliothek fehlt ganz einfach, so dass FreeCAD den Start verweigert, oder die Bibliothek ist vorhanden, aber in einer älteren Version als der von FreeCAD erwarteten, so dass ein Absturz beim Zugriff auf eine fehlende Funktion in der Bibliothek erfolgt. Ein übliches Beispiel ist, wenn Du Qt3 und Qt4 auf Deinem System installiert hast, dann könnte FreeCAD Qt4 erkennen, aber falls Deine Konfiguration fehlerhaft ist, könnten einige Teile von Qt3 noch benutzt werden, aber zu Abstürzen führen.

Bitte überprüfe die FreeCAD installieren-Anleitung, stelle sicher, dass Du alle benötigten Bibliotheken installiert hast (auf den meisten Linux-Systemen passiert das automatisch) und überprüfe die minimale Versionsnummer für jede der Komponenten.

Wenn alles richtig aussieht, beschreibe das Problen im Forum oder Tracker. Wenn Du auf einem Linux-System bist, ist es einfach, ein Debug-Backtrace zu erstellen, der für die Entwickler sehr wichtige Informationen über den Absturz liefert:

  • Tippe in einem Terminal gdb freecad (vorausgesetzt, das gdb-Paket ist installiert)
  • In gdb, tippe run
  • Nach dem Absturz tippe bt, um den Backtrace zu erhalten, so dass Du ihn an den Bug-Report anfügen kannst.

FreeCAD friert nach dem Start ein

Nach dem Start von FreeCAD erscheint die GUI fast augenblicklich, aber sie ist eingefroren und die CPU-Auslastung bei ungefähr 99%. Das kann auf dem KDE-Desktop passieren, wenn man das Oxygen-Theme benutzt. Das ist ein Bug im Oxygen-Theme und die Nutzung eines anderen Themes sollte das Problem lösen.

FreeCAD stürzt beim Anlegen eines neuen Dokuments oder Öffnen einer vorhandenen Datei ab

Wenn FreeCAD abstürzt, wenn es eine neue 3D-Ansicht erstellt, versuche, FreeCAD von einem Terminal aus zu starten. Wenn ein Meldungsfehler auftritt, wenn der Absturz auftritt und Assertion Failed erwähnt wird, und ein Komponentenname, der mit "So" (SoBase}, SoFieldContainer, usw.) beginnt, sind die Chancen sehr hoch, insbesondere wenn Sie auf Linux sind, dass FreeCAD versucht, zwei verschiedene Versionen der Coin Library zu verwenden, was den Absturz verursacht. Um zu überprüfen, ob dies tatsächlich das Problem ist, versuche Folgendes:

  • Suche die ausführbare FreeCAD-Datei (normalerweise in /usr/lib/FreeCAD/bin).
  • Führe den Befehl ldd FreeCAD von einem Terminal aus.
  • Notiere die Version der Bibliothek libCoin.so, die FreeCAD verwendet (z.B. libCoin.so.60).
  • Suche die Bibliothek libSoQt.so (normalerweise in /usr/lib}).
  • Führe ldd libSoQt.so aus und prüfe, ob es auf die gleiche Coin-Version wie FreeCAD verweist.

Wenn es einen Unterschied gibt, muss entweder FreeCAD oder SoQt neu kompiliert werden (besser diejenige, die die älteste Coin-Version verwendet). Das normale Verhalten ist es, die für die Verpackung von SoQt oder FreeCAD verantwortlichen Personen zu kontaktieren und sie zu bitten, eine Neukompilierung in Betracht zu ziehen. Wenn Du diesen Schritt selbst durchführen willst und es nicht möglich ist, SoQt neu zu kompilieren, weil es andere Anwendungen auf Deinem System zerstört, kannst Du FreeCAD zwingen, mit ./configure --with-coin=DIR mit der erforderlichen Coin-Version zu kompilieren. Du musst jedoch sicherstellen, dass das richtige Entwicklungspaket dieser Coin-Version installiert ist.

FreeCAD stürzt nach Bearbeiten → Ausrichtung ab

Ein Segmentierungsfehler tritt bei vbo_save_playback_vertex_list() auf. Das bedeutet, dass die Implementierung von VBO im Grafiktreiber schlecht ist. Um das Caching von OpenGL-Aufrufen zu vermeiden, kannst Du versuchen, die Umgebungsvariable IV_SEPARATOR_MAX_CACHES=0 einzustellen und FreeCAD neu zu starten.

Ich habe Schwierigkeiten bei der Ausführung von FreeCAD auf Mac OSX

Die Mac-Plattform ist weniger einfach zu unterstützen als Windows oder Linux, weil keiner der Core-Entwickler einen besitzt. Die OSX-Pakete werden von bereitwilligen FreeCAD-Benutzern kompiliert und teilweise können sie auf Deiner Maschine nicht richtig funktionieren, abhängig von Deinem System. Die beste Möglichkeit ist wahrscheinlich, im Forum nach Mac OSX-verwandten Threads zu suchen und Dein Problem darzustellen oder zu sehen, ob jemand anders eine Lösung gefunden hat.

Ich kann keine numerischen Werte in den Eigenschaften-Panels von FreeCAD eingeben

language options

Du hast höchstwahrscheinlich eine fehlerhafte Windows-Lokalisierungseinstellung. Prüfe bitte, ob Du das gleiche Zeichen für den Dezimaltrenner und die Tausendertrennung in Deinen Lokalisierungseinstellungen hast. Falls das so ist, dann passe Deine Systemeinstellungen an und verwende für Dezimal- und Tausendertrennung unterschiedliche Zeichen. Beachte, dass es nicht nötig ist, einen Punkt als Dezimaltrenner zu haben. Es ist nötig, unterschiedliche Zeichen für diese Einstellungen zu haben.


FreeCAD lief normal, aber plötzlich startet es nicht mehr

Dies kann auch passieren, wenn Du von einer älteren auf eine neuere Version aktualisiert hast. Während dieses Vorgangs könnten die Konfigurationsdateien aus irgendeinem Grund beschädigt worden sein, so dass FreeCAD sie nicht mehr lesen und deshalb nicht mehr starten kann. Die Lösung ist, diese Konfigurationsdateien zu löschen, damit FreeCAD sie beim nächsten Start wieder erzeugen kann.

  • Auf Windows: Öffne den Datei-Explorer und schreibe %APPDATA%\FreeCAD als Dateipfad. Lösche dort die Dateien user.cfg und system.cfg
  • Auf Linux: Navigiere zu /home/USERNAME/.FreeCAD und lösche dort die Dateien user.cfg und system.cfg
  • Auf Mac: Navigiere zu /Users/USERNAME/Library/Preferences/FreeCAD und lösche dort die Dateien user.cfg und system.cfg

FreeCAD sollte nun wieder normal starten mit den Standardeinstellungen.


Es gibt ein Macro findConfigFiles, das dir beim Auffinden deiner Konfigurationsdateien hilft. Es kann über den Addon Manager im Menü Extras installiert werden. Werkzeuge → Addon Manager → Makros → findConfigFiles. Das Makro findet den Ordner deiner Konfigurationsdatei, kopiert ihn in die Zwischenablage und versucht, diesen Ort mit deinem Standard-Dateibrowser zu öffnen. Es werden keine Änderungen an Ihren Dateien oder Einstellungen vorgenommen.

FreeCAD benutzen

Ist FreeCAD wirklich kostenlos/frei (free)? Sogar für kommerzielle Nutzung?

FreeCAD ist Open-Source-Software und sowohl kostenlos als auch frei, sowohl für Dich selbst als auch für kommerzielle Nutzung. Das gilt auch für die Weitergabe, Änderung oder sogar die Nutzung in einer Closed-Source-Anwendung. Du bist frei, (nahezu) alles damit zu machen, was Du willst. Auf der Lizenz-Seite findest Du Einzelheiten.

Wie drehe ich die 3D-Ansicht?


FreeCAD verfügt über mehrere verschiedene Navigationsmodi, die man im Einstellungsdialog einstellen oder durch einen Rechtsklick in der 3D Ansicht ändern kann. Ausführliche Informationen zu den Modi finden sich auf der Seite Mausmodell. Für den Standardmodus ("CAD-Navigation") lauten die Befehle wie folgt,


Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Drücke die linke Maustaste über einem Objekt, das Du auswählen möchtest.

Wenn man die Taste Ctrl gedrückt hält, kann man mehrere Objekte auswählen.

Halte die mittlere Maustaste gedrückt und bewege den Mauszeiger. Verwende das Mausrad, um heran- und herauszuzoomen.

Klicken der mittleren Maustaste zentriert die Ansicht neu auf die Position des Cursors.

Halte die mittlere Maustaste gedrückt, halte dann die linke Maustaste gedrückt und bewege den Mauszeiger.

Die Cursorposition beim Drücken der mittleren Maustaste bestimmt den Drehpunkt. Rotation funktioniert wie das Drehen einer Kugel, die sich um ihr Zentrum dreht. Wenn die Tasten losgelassen werden, bevor Sie die Mausbewegung stoppen, wird die Ansicht Drehen fortgesetzt, sofern dies aktiviert ist.

Ein Doppelklick mit der mittleren Maustaste setzt einen neuen Drehpunkt.

Halte die mittlere Maustaste gedrückt, halte dann die rechte Maustaste gedrückt und bewege den Mauszeiger.

Mit dieser Methode kann die mittlere Maustaste losgelassen werden, wenn die rechte Maustaste gedrückt gehalten wird.

Anwender, die die Maus mit der rechten Hand benutzen, können diese Methode leichter finden als die erste Methode.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: Halte die Taste Ctrl gedrückt, drücke einmal die rechte Maustaste und bewege den Mauszeiger. verfügbar in Version 0.17 Zoom Modus: Halte die Tasten Ctrl und Shift gedrückt, drücke einmal die rechte Maustaste und bewege dann den Zeiger. verfügbar in Version 0.17 Rotate mode: Halte die Taste Shift gedrückt, drücke einmal die rechte Maustaste und bewege den Mauszeiger. verfügbar in Version 0.17


Was kann ich mit FreeCAD tun? Wo soll ich anfangen?

Geh auf die Erste Schritte-Seite für eine kurze Beschreibung der Werkzeuge, die Du benutzen kannst. Es gibt auch einen neuen Tutorien-Abschnitt, der ein paar Hilfsquellen enthält. Der Hinweise für Einsteiger-Abschnitt enthält detailliertere Informationen zu den verschiedenen Arbeitsbereichen von FreeCAD. Beachte, dass FreeCAD relativ neu ist, so dass das Benutzer-Interface noch relativ nackt ist und noch nicht viele Werkzeuge bietet. Aber sehr viel fortgeschrittene Funktionalitäten stehen Dir mit der Übersicht für erfahrene Anwender zur Verfügung.

Gibt es Dokumentation für Neueinsteiger? Wie kann ich die Benutzung von FreeCAD lernen?

Im Moment gibt es unglücklicherweise noch recht wenig Dokumentation für Anfänger, aber der Tutorien-Abschnitt enthält einige Seiten, die Dir beim Einstieg helfen.

Ich möchte Daten im XYZ-Format nach/von FreeCAD im-/exportieren. Wie mache ich das?

Bitte nutze die Seite FreeCAD Howto Import Export. Vielleicht werden Deine Fragen dort bereits beantwortet.

Arbeiten mit Part-Geometrie

Wie extrudiere ich Dinge in Volumenkörper ? Ich bekomme nicht das richtige Ergebnis

Die Theorie ist einfach: Linien (oder Linienzüge) werden zu Flächen (wenn sie extrudiert werden). Flächen werden beim Extrudieren zu Volumenkörpern. Wenn Du etwas extrudierst und das Ergebnis kein Volumenkörper ist, dann war das Ausgangsobjekt keine Fläche. Wenn Du Linien hast und daraus einen Volumenkörper extrudieren willst, musst Du zuerst Linien auswählen, die eine geschlossene Fläche bilden (wähle mehrere Objekte mit gedrückter Strg-Taste), füge sie zu einem Linienzug zusammen (Hochstufen-Werkzeug) und erzeuge dann (wieder mit dem Hochstufen-Werkzeug) eine Fläche aus diesem Linienzug. Wenn alles glatt geht, dann kannst Du nun daraus einen Volumenkörper extrudieren.

Es gibt viele Möglichkeiten, wie Du ein falsches Ergebnis bekommst. Der beste Weg ist sicherzugehen, was in dem zu extrudierenden Objekt steckt. Der Inhalt von Objekten kann einfach mit Python untersucht werden. Nimm beispielsweise an, dass Du ein Objekt namens "Wire" hast. Du kannst dann in der Python-Konsole folgendes eintippen:

obj = FreeCAD.ActiveDocument.Wire
shp = obj.Shape
print shp.Faces
print shp.Wires
if shp.Wires:
    for w in shp.Wires:
        print w.isClosed()

Der obige Code holt die Form aus einem Objekt, zeigt die Flächen und Linienzüge Deines Objekts (falls vorhanden), und wenn es Linienzüge gibt, dann wird ausgegeben, ob sie geschlossen sind. Wenn Du keine Fläche hast, dann wirst Du keinen Volumenkörper bekommen. Wenn es keinen geschlossenen Linienzug gibt, dann kann daraus keine Fläche werden. Wenn Du interessiert bist, dann gibt es auf der part scripting-Seite mehr Informationen darüber, was Du mit Python überprüfen kannst. Wenn Du nicht verschiedene Linien zu einem Linienzug zusammenfügen kannst, ist die wahrscheinlichste Ursache dafür, dass sich ihre Endpunkte nicht treffen, weil kleine Lücken zwischen (einigen von) ihnen existieren. Der schnellste Weg aus meiner Erfahrung ist es, einen neuen Linienzug darüber zu zeichnen.

Meine booleschen Operationen schlagen fehl oder liefern merkwürdige Ergebnisse

Der in FreeCAD für Part-Geometrien verwendete Open CASCADE-Geometrie-Modellierungs-Kernel, obwohl er möglicherweise der beste verfügbar Open-Source-Geometrie-Kernel ist, hat seine Schwachpunkte und Einschränkungen. Die booleschen Operationen (Vereinigung, Subtraktion, Schnitt) sind in der Tat nicht die besten Merkmale und liefern oftmals merkwürdige Ergebnisse. Dies ist eine aktuelle Einschränkung, die wir nicht lösen können, so dass der beste Weg diese Problem zu umgehen darin besteht, das gewünschte Ergebnis auf eine andere Art zu modellieren. Beispielsweise können Probleme mit Körpern wie Zylindern oftmals mit einem extrudierten Kreis gelöst werden. In der gleichen Ebene liegende Flächen zwischen Teilen können Probleme verursachen, genau wie Oberflächenberührungen. Als generelle Regel: Wenn eine Form nicht funktioniert, dann versuch es auf eine andere Weise zu remodellieren. In 99% aller Fälle wirst Du das gewünschte Ergebnis erhalten.

Wenn ich mein Modell exportiere (oder ansehe), werden die Löcher ausgefüllt =

Benutze nicht Strg + A (alles auswählen), um alles im Hierarchiebaum auszuwählen. Wenn das Modell aus einem einzelnen Gegenstand (item) besteht, versuch' nur den aktuellsten (normalerweise den letzten) Gegenstand im Hierarchiebaum auszuwählen.

Wenn wir ein Modell im PartDesign-Arbeitsbereich erstellen, übernimmt jedes Merkmal die Form des letzten und fügt etwas hinzu oder entfernt etwas, erstellt lineare Abhängigkeiten von Merkmal zu Merkmal, während das Modell erstellt wird. Deswegen ist ein "Ausschneiden"-Merkmal nicht einfach das Loch selbst, sondern das gesamte Teil mit dem Ausschnitt. Deshalb sollte der Benutzer eigentlich nur den neuesten Gegenstand (das Merkmal) im Modellbaum sehen, denn anderenfalls überlagern die Phasen des Modells sich selbst und Löcher werden durch frühere Merkmale des Modells gefüllt.

Um die Sichtbarkeit eines Objekts umzuschalten, wähle es im Hierarchiebaum und drücke die Leertaste. Normalerweise sollte alles außer dem letzten Gegenstand ausgegraut werden und deshalb in der 3D-Ansicht nicht sichtbar sein.

Zu FreeCAD beitragen

FreeCAD ist so ein tolles Programm! Wie kann ich helfen?

Es gibt eine Menge verschiedener Wege, um zu helfen, selbst wenn Du kein Programmierer bist. Hier sind eine Reihe von Dingen, die Du tun kannst:

  • Gib den FreeCAD-Entwicklern Feedback: Es ist immer nützlich zu wissen, was die Leute denken, was sie gut finden, was sie vermisen, etc. Schreib eine Nachricht im Forum, um Deine Meinung darzustellen, oder stell' eine Anfrage im issue tracker!
  • Hilf beim Schreiben von Dokumentation: Die Dokumentation, die wir auf dieser Site haben, ist sehr eingeschränkt. Wenn Du etwas gefunden hast, das nicht gut dokumentiert ist, dann trage Dein Wissen bei!
  • Hilf anderen Neulingen: Sei im Forum und hilf neuen Leuten bei der Lösung von grundsätzlichen Fragen, wie etwa der Installation, wie für ich einen Würfel hinzu, etc.
  • Übersetzen der Dokumentation in Deine eigene Sprache
  • Schreibe Tutorien oder erstelle Video-Tutorien: Tutorien sind ein sehr einfacher Weg für Neulinge, eine neue Software kennenzulernen. Falls Du etwas Tolles gemacht hast, kannst Du es doch anderen Leuten zeigen!
  • Trage Beispiele bei: Wir brauchen noch gute Beispieldateien in FreeCAD. Wenn Du etwas Gutes erstellt hast, lass uns teilhaben!
  • Tracker: Es ist sehr wichtig, dass alle Fehler korrigiert werden. Wenn Du einen findest, beschreib' ihn so klar wie möglich, so dass wir genau verstehen, was passiert.
  • Versuch' ein bisschen Python-Programmierung: Du vorher noch nie programmiert, möchtest es aber versuchen? Python is einfach. Lies unsere Einführung in Python... Aber sei vorsichtig, Du könntest schnell süchtig werden!
  • Schau auf der Mitwirken-Seite für weitere Einzelheiten, wie Du beitragen kannst.

Wie kann ich Berechtigungen zum Editieren im Wiki bekommen?

Der "Dokumentieren"-Abschnitt auf der Mitwirken-Seite zeigt mehr Informationen dazu.

Nimmt FreeCAD am "Google Summer of Code" teil?

Ja. FreeCAD nimmt ab 2016 am Google Summer of Code teil. Siehe Google Summer of Code für Informationen zu früheren Ausgaben und Google Summer Of Code 2016 im Forum für die ursprüngliche Ankündigung.

Ich möchte beginnen, das Wiki in meine Sprache zu übersetzen. Was muss ich tun?

Dieses Wiki enthält eine Menge von Inhalten. Das aktuellste und interessanteste Material ist im Handbuch zusammengestellt.

Im "Übersetzung für FreeCAD"-Abschnitt der Mitwirken-Seite finden sind mehr Informationen, wie das Wiki übersetzen werden kann.

Lizenzierung, kopieren und Wiederverwendung

Muss ich etwas bezahlen, um FreeCAD nutzen zu können?

Nein. FreeCAD ist völlig kostenlos zu verwenden, herunterzuladen, weiterzugeben oder zu modifizieren. Es ist open-source software, veröffentlicht unter den Bedingungen der GNU Lesser General Public License 2.1, die Dir diese Freiheiten garantiert und, was noch wichtiger ist, Dir garantiert, dass Dir diese Freiheiten nie genommen werden.

Kann ich einen beliebigen Teil der FreeCAD-Illustrationen oder Teile der Webseite wiederverwenden?

Sicher. Alle Vorlagen (Icons, Banner, usw.) von FreeCAD sind LGPL lizenziert, ebenso wie der FreeCAD-Code. Bediene dich auf der Seite Artwork. Die Website ist eine Standard-MediaWiki-Site, alle grafischen Elemente können frei wiederverwendet werden, und wenn Du neugierig bist, wie wir die MediaWiki-Software optimiert haben, suche nach den speziellen Common css- und js-Seiten.

Kann ich Teile von FreeCAD in anderen Anwendungen wiederverwenden?

Ja, du kannst die Kernteile von FreeCAD in anderen Anwendungen verwenden, solange du die Bedingungen der LGPL einhältst. Bibliotheken von Drittanbietern, externe Arbeitsbereiche und Makros können ihren eigenen Lizenzbedingungen unterliegen, also wende dich bitte an ihre Autoren. Weitere Informationen findest Du auf der Seite Lizenz.