Difference between revisions of "Extra python modules"

From FreeCAD Documentation
Jump to: navigation, search
m (Add Japanese to languages)
Line 1: Line 1:
The python interpreter inside FreeCAD can easily be extended by adding new modules to your system's python installation. Those modules will be automatically detected and used by FreeCAD.
+
This page lists several additional python modules or other pieces of software that can be downloaded freely from the internet, and add functionality to your FreeCAD installation.
  
All python modules can be used from within FreeCAD, but several of them, listed below, have a special importance because they allow python programs complete access to core functionality of FreeCAD. Examples of use of those modules can also be found on the [[Code snippets]] page.
+
== PyQt4 ==
  
'''Notes''':  
+
* homepage: [http://www.riverbankcomputing.co.uk/pyqt http://www.riverbankcomputing.co.uk/pyqt]
 +
* license: GPL 2 & 3
 +
* optional, but needed by several modules: Draft, Arch, Ship, Plot, OpenSCAD, Spreadsheet
  
* Of the following modules, Pivy is now fully integrated into any FreeCAD installation package, and PyQt4 is also integrated in the Windows installation package.
+
PyQt is required by several modules of FreeCAD to access FreeCAD's Qt interface. It is already bundled in the windows verison of FreeCAD, and is usually installed automatically by FreeCAD on Linux, when installing from official repositories. If those modules (Draft, Arch, etc) are enabled after FreeCAD is installed, it means PyQt is already there, and you don't need to do anything more.
* PyQt4 will be progressively obsoleted in FreeCAD after version 0.13, in favour of [http://qt-project.org/wiki/PySide PySide], which does exactly the same job but has a license (LGPL) more compatible with FreeCAD.
 
  
==PyQt4==
+
'''Note:'''
  
homepage: [http://www.riverbankcomputing.co.uk/pyqt http://www.riverbankcomputing.co.uk/pyqt]
+
PyQt4 will be progressively obsoleted in FreeCAD after version 0.13, in favour of [http://qt-project.org/wiki/PySide PySide], which does exactly the same job but has a license (LGPL) more compatible with FreeCAD.
  
PyQt (version 4) is a python bindings library which allow programs to access, create or modify [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] interfaces. Since the FreeCAD interface is built with Qt, installing PyQt4 on your system allow python programs inside FreeCAD to access all the interface, modify its parts, create new widgets or gather info from interface parts.
+
=== Installation ===
  
PyQt is released under a multiple licensing system, same system as [http://trolltech.com/products/qt used by Qt]. To resume, there is a commercial version and a free GPL version. If you want to use it to make commercial (closed source) programs, you need to purchase the commercial license, otherwise you can simply install and use freely the GPL version.
+
==== Linux ====
  
===Installation===
+
The simplest way to install PyQt4 is through your distribution's package manager. On Debian/Ubuntu systems, the package name is generally ''python-qt4'', while on RPM-based systems it is named ''pyqt4''. The necessary dependencies (Qt and SIP) will be taken care of automatically.
  
Before installing PyQt4, you obviously need a python environment installed and working.
+
==== Windows ====
  
'''Linux'''
+
The program can be downloaded from http://www.riverbankcomputing.co.uk/pyqt/download.php . You'll need to install the Qt and SIP libraries before installing pyqt4 (to be documented).
  
The simplest way to install PyQt4 is through your distribution's package manager. On Debian/Ubuntu systems, the package name is generally ''python-qt4'', while on RPM-based systems it is named ''pyqt4''. The necessary dependencies (Qt and SIP) will be taken care of automatically.
+
==== MacOSX ====
  
'''Windows'''
+
PyQt on Mac can be installed via homebrew or port. See [[CompileOnMac#Install_Dependencies]] for more information.
  
The program can be downloaded from [http://www.riverbankcomputing.co.uk/pyqt/download.php here]. You'll need to install the Qt and SIP libraries before installing pyqt4 (to be documented).
+
=== Usage ===
 
 
===Usage===
 
  
 
Once it is installed, you can check that everything is working by typing in FreeCAD python console:
 
Once it is installed, you can check that everything is working by typing in FreeCAD python console:
Line 44: Line 43:
 
  FreeCADWindow.addDockWidget(QtCore.Qt.RghtDockWidgetArea,my_custom_widget)
 
  FreeCADWindow.addDockWidget(QtCore.Qt.RghtDockWidgetArea,my_custom_widget)
  
===Documentation===
+
=== Additional documentation ===
  
 
More pyQt4 tutorials (including how to build interfaces with Qt Designer to use with python):
 
More pyQt4 tutorials (including how to build interfaces with Qt Designer to use with python):
  
http://www.riverbankcomputing.co.uk/static/Docs/PyQt4/html/classes.html - the official PyQt4 API Reference
+
* http://www.riverbankcomputing.co.uk/static/Docs/PyQt4/html/classes.html - the official PyQt4 API Reference
 
+
* http://www.rkblog.rk.edu.pl/w/p/introduction-pyqt4/ - a simple introduction
http://www.rkblog.rk.edu.pl/w/p/introduction-pyqt4/ - a simple introduction
+
* http://www.zetcode.com/tutorials/pyqt4/ - very complete in-depth tutorial
 
 
http://www.zetcode.com/tutorials/pyqt4/ - very complete in-depth tutorial
 
 
 
==Pivy==
 
  
homepage: [http://pivy.coin3d.org/ http://pivy.coin3d.org/]
+
== Pivy ==
  
Pivy is a [http://www.coin3d.org coin] bindings library for python, officially supported by coin. Coin itself is a toolkit for building 3D applications in OpenGL. It is the toolkit that FreeCAD uses to draw its 3d Scene on the screen. Installing Pivy on your system will allow python programs to access the FreeCAD scenegraph, draw new objects on the scene and use the wide range of available Coin tools for drawing operations. Coin is based on the open Inventor scene description language. Pivy is used by the 2D drafting module of FreeCAD (and also by the complete module), so it is needed if you want to use any tool of those modules.
+
* homepage: [http://pivy.coin3d.org/ http://pivy.coin3d.org/]
 +
* license: BSD
 +
* optional, but needed by several modules of FreeCAD: Draft, Arch
  
It is important to know that FreeCAD only uses coin for representation of objects on the screen, which is separated from the definition of objects. This means that pivy won't be able to modify existing objects, neither to create valid FreeCAD objects. But it can be used to draw all kind of temporary things on screen, such as axis, grids, manipulators, construction geometry, etc...
+
Pivy is a needed by several modules to access the 3D view of FreeCAD. On windows, Pivy is already bundled inside the FreeCAD installer, and on Linux it is usually automatically installed when you install FreeCAD from an official repository. On MacOSX, unfortunately, you will need to compile pivy yourself.
  
Pivy, as well as Coin, is released under a GPL license.
+
=== Installation ===
  
===Installation===
+
==== Prerequisites ====
 
 
====Prerequisites====
 
  
 
I believe before compiling Pivy you will want to have Coin and SoQt installed.
 
I believe before compiling Pivy you will want to have Coin and SoQt installed.
Line 76: Line 71:
 
SoQt compiled from [http://www.coin3d.org/lib/soqt/releases/1.5.0 source] fine on Mac and Linux.
 
SoQt compiled from [http://www.coin3d.org/lib/soqt/releases/1.5.0 source] fine on Mac and Linux.
  
====Debian & Ubuntu====
+
==== Debian & Ubuntu ====
  
 
Starting with Debian Squeeze and Ubuntu Lucid, pivy will be available directly from the official repositories, saving us a lot of hassle. In the meantime, you can either download one of the packages we made (for debian and ubuntu karmic) availables on the [[Download]] pages, or compile it yourself.
 
Starting with Debian Squeeze and Ubuntu Lucid, pivy will be available directly from the official repositories, saving us a lot of hassle. In the meantime, you can either download one of the packages we made (for debian and ubuntu karmic) availables on the [[Download]] pages, or compile it yourself.
Line 86: Line 81:
 
to have pivy properly built into an official installable package. Then, just install the package with gdebi.
 
to have pivy properly built into an official installable package. Then, just install the package with gdebi.
  
====Other linux distributions====
+
==== Other linux distributions ====
  
 
First get the latest sources from the [http://pivy.coin3d.org/mercurial/ project's repository]:
 
First get the latest sources from the [http://pivy.coin3d.org/mercurial/ project's repository]:
Line 110: Line 105:
 
That's it, pivy is installed.
 
That's it, pivy is installed.
  
====Mac OS====
+
==== Mac OS ====
 +
 
 
These instructions may not be complete.  Something close to this worked for OS 10.7 as of March 2012.  I use MacPorts for repositories, but other options should also work.
 
These instructions may not be complete.  Something close to this worked for OS 10.7 as of March 2012.  I use MacPorts for repositories, but other options should also work.
  
Line 130: Line 126:
 
  sudo python setup.py install
 
  sudo python setup.py install
  
====Windows====
+
==== Windows ====
  
 
Assuming you are using Visual Studio 2005 or later you should open a command prompt with 'Visual Studio 2005 Command prompt' from the Tools menu.
 
Assuming you are using Visual Studio 2005 or later you should open a command prompt with 'Visual Studio 2005 Command prompt' from the Tools menu.
Line 181: Line 177:
 
After that copy the generated pivy directory to a place where the python interpreter in FreeCAD can find it.
 
After that copy the generated pivy directory to a place where the python interpreter in FreeCAD can find it.
  
===Usage===
+
=== Usage ===
 +
 
 +
To check if Pivy is correctly installed:
 +
 
 +
import pivy
  
 
To have Pivy access the FreeCAD scenegraph do the following:  
 
To have Pivy access the FreeCAD scenegraph do the following:  
Line 193: Line 193:
 
You can now explore the FCSceneGraph with the dir() command.
 
You can now explore the FCSceneGraph with the dir() command.
  
===Documentation===
+
=== Additonal Documentation ===
  
 
Unfortunately documentation about pivy is still almost inexistant on the net. But you might find Coin documentation useful, since pivy simply translate Coin functions, nodes and methods in python, everything keeps the same name and properties, keeping in mind the difference of syntax between C and python:
 
Unfortunately documentation about pivy is still almost inexistant on the net. But you might find Coin documentation useful, since pivy simply translate Coin functions, nodes and methods in python, everything keeps the same name and properties, keeping in mind the difference of syntax between C and python:
  
http://doc.coin3d.org/Coin/classes.html - Coin3D API Reference
+
* http://doc.coin3d.org/Coin/classes.html - Coin3D API Reference
 +
* http://www-evasion.imag.fr/~Francois.Faure/doc/inventorMentor/sgi_html/index.html - The Inventor Mentor - The "bible" of Inventor scene description language.
  
http://www-evasion.imag.fr/~Francois.Faure/doc/inventorMentor/sgi_html/index.html - The Inventor Mentor - The "bible" of Inventor scene description language.
+
You can also look at the Draft.py file in the FreeCAD Mod/Draft folder, since it makes big use of pivy.
  
You can also look at the Draft.py file in the FreeCAD Mod/Draft folder, since it makes big use of pivy.
+
== pyCollada ==
  
==pyCollada==
+
* homepage: http://pycollada.github.com
 +
* license: BSD
 +
* optional, needed to enable import and export of Collada (.DAE) files
  
[http://pycollada.github.com pyCollada] is a python library that allow programs to read and write [http://en.wikipedia.org/wiki/COLLADA Collada (*.DAE)] files. When pyCollada is installed on your system, FreeCAD ({{version|0.13}}) will detect it and add import and export options to handle opening and saving in the Collada file format.
+
pyCollada is a python library that allow programs to read and write [http://en.wikipedia.org/wiki/COLLADA Collada (*.DAE)] files. When pyCollada is installed on your system, FreeCAD will be able to handle importing and exporting in the Collada file format.
  
===Installation===
+
=== Installation ===
  
 
Pycollada is usually not yet available in linux distributions repositories, but since it is made only of python files, it doesn't require compilation, and is easy to install. You have 2 ways, or directly from the official pycollada git repository, or with the easy_install tool.
 
Pycollada is usually not yet available in linux distributions repositories, but since it is made only of python files, it doesn't require compilation, and is easy to install. You have 2 ways, or directly from the official pycollada git repository, or with the easy_install tool.
  
====Linux====
+
==== Linux ====
  
 
In either case, you'll need the following packages already installed on your system:
 
In either case, you'll need the following packages already installed on your system:
Line 219: Line 222:
 
  python-dateutil
 
  python-dateutil
  
=====From the git repository=====
+
===== From the git repository =====
  
 
  git clone git://github.com/pycollada/pycollada.git pycollada
 
  git clone git://github.com/pycollada/pycollada.git pycollada
Line 225: Line 228:
 
  sudo python setup.py install
 
  sudo python setup.py install
  
=====With easy_install=====
+
===== With easy_install =====
  
 
Assuming you have a complete python installation already, the easy_install utility should be present already:
 
Assuming you have a complete python installation already, the easy_install utility should be present already:
Line 237: Line 240:
 
If it returns nothing (no error message), then all is OK
 
If it returns nothing (no error message), then all is OK
  
====Windows====
+
==== Windows ====
 +
 
 +
To Be Documented
 +
 
 +
==== Mac OS ====
  
 
To Be Documented
 
To Be Documented
  
==IfcOpenShell==
+
== IfcOpenShell ==
  
IFCOpenShell is a library currently in development, that allows to import (and soon export) [http://en.wikipedia.org/wiki/Industry_Foundation_Classes Industry foundation Classes (*.IFC)] files. IFC is an extension to the STEP format, and is becoming the standard in [http://en.wikipedia.org/wiki/Building_information_modeling BIM] workflows. When ifcopenshell is correctly installed on your system, the FreeCAD [[Arch Module]] will detect it and use it to import IFC files. Since ifcopenshell is based on OpenCasCade, like FreeCAD, the quality of the import is very high, producing high-quality solid geometry.
+
* homepage: http://www.ifcopenshell.org
 +
* license: LGPL
 +
* optional, needed to extend import abilities of IFC files
  
Homepage: http://www.ifcopenshell.org
+
IFCOpenShell is a library currently in development, that allows to import (and soon export) [http://en.wikipedia.org/wiki/Industry_Foundation_Classes Industry foundation Classes (*.IFC)] files. IFC is an extension to the STEP format, and is becoming the standard in [http://en.wikipedia.org/wiki/Building_information_modeling BIM] workflows. When ifcopenshell is correctly installed on your system, the FreeCAD [[Arch Module]] will detect it and use it to import IFC files, instead of its built-in rudimentary importer. Since ifcopenshell is based on OpenCasCade, like FreeCAD, the quality of the import is very high, producing high-quality solid geometry.
  
===Installation===
+
=== Installation ===
  
 
Since ifcopenshell is pretty new, you'll likely need to compile it yourself.
 
Since ifcopenshell is pretty new, you'll likely need to compile it yourself.
  
====Linux====
+
==== Linux ====
  
 
You will need a couple of development packages installed on your system in order to compile ifcopenshell:
 
You will need a couple of development packages installed on your system in order to compile ifcopenshell:
Line 290: Line 299:
 
If it returns nothing (no error message), then all is OK
 
If it returns nothing (no error message), then all is OK
  
====Windows====
+
==== Windows ====
  
 
''Copied from the IfcOpenShell README file''
 
''Copied from the IfcOpenShell README file''
Line 297: Line 306:
  
 
For building the IfcPython wrapper, SWIG needs to be installed. Please download the latest swigwin version from http://www.swig.org/download.html . After extracting the .zip file, please add the extracted folder to the PATH environment variable. Python needs to be installed, please provide the include and library paths to Visual Studio.
 
For building the IfcPython wrapper, SWIG needs to be installed. Please download the latest swigwin version from http://www.swig.org/download.html . After extracting the .zip file, please add the extracted folder to the PATH environment variable. Python needs to be installed, please provide the include and library paths to Visual Studio.
 +
 +
== Teigha Converter ==
 +
 +
* homepage: http://www.opendesign.com/guestfiles/TeighaFileConverter
 +
* license: freeware
 +
* optional, used to enable import and export of DWG files
 +
 +
The Teigha Converter is a small freely available utility that allows to convert between several versions of DWG and DXF files. FreeCAD can use it to offer DWG import and export, by converting DWG files to the DXF format under the hood,then using its standard DXF importer to import the file contents. The restrictions of the [[Draft_DXF|DXF importer]] apply.
 +
 +
=== Installation ===
 +
 +
On all platforms, only by installing the appropriate package from http://www.opendesign.com/guestfiles/TeighaFileConverter . After installation, if the utility is not found automatically by FreeCAD, you might need to set the path to the converter executable manually, in the menu Edit -> Preferences -> Draft -> Import/Export options.
  
 
{{docnav|Localisation|Source documentation}}
 
{{docnav|Localisation|Source documentation}}

Revision as of 21:00, 29 August 2013

This page lists several additional python modules or other pieces of software that can be downloaded freely from the internet, and add functionality to your FreeCAD installation.

PyQt4

PyQt is required by several modules of FreeCAD to access FreeCAD's Qt interface. It is already bundled in the windows verison of FreeCAD, and is usually installed automatically by FreeCAD on Linux, when installing from official repositories. If those modules (Draft, Arch, etc) are enabled after FreeCAD is installed, it means PyQt is already there, and you don't need to do anything more.

Note:

PyQt4 will be progressively obsoleted in FreeCAD after version 0.13, in favour of PySide, which does exactly the same job but has a license (LGPL) more compatible with FreeCAD.

Installation

Linux

The simplest way to install PyQt4 is through your distribution's package manager. On Debian/Ubuntu systems, the package name is generally python-qt4, while on RPM-based systems it is named pyqt4. The necessary dependencies (Qt and SIP) will be taken care of automatically.

Windows

The program can be downloaded from http://www.riverbankcomputing.co.uk/pyqt/download.php . You'll need to install the Qt and SIP libraries before installing pyqt4 (to be documented).

MacOSX

PyQt on Mac can be installed via homebrew or port. See CompileOnMac#Install_Dependencies for more information.

Usage

Once it is installed, you can check that everything is working by typing in FreeCAD python console:

import PyQt4

To access the FreeCAD interface, type:

from PyQt4 import QtCore,QtGui
app = QtGui.qApp
FreeCADWindow = app.activeWindow()

Now you can start to explore the interface with the dir() command. You can add new elements, like a custom widget, with commands like:

FreeCADWindow.addDockWidget(QtCore.Qt.RghtDockWidgetArea,my_custom_widget)

Additional documentation

More pyQt4 tutorials (including how to build interfaces with Qt Designer to use with python):

Pivy

Pivy is a needed by several modules to access the 3D view of FreeCAD. On windows, Pivy is already bundled inside the FreeCAD installer, and on Linux it is usually automatically installed when you install FreeCAD from an official repository. On MacOSX, unfortunately, you will need to compile pivy yourself.

Installation

Prerequisites

I believe before compiling Pivy you will want to have Coin and SoQt installed.

I found for building on Mac it was sufficient to install the Coin3 binary package. Attempting to install coin from MacPorts was problematic: tried to add a lot of X Windows packages and ultimately crashed with a script error.

For Fedora I found an RPM with Coin3.

SoQt compiled from source fine on Mac and Linux.

Debian & Ubuntu

Starting with Debian Squeeze and Ubuntu Lucid, pivy will be available directly from the official repositories, saving us a lot of hassle. In the meantime, you can either download one of the packages we made (for debian and ubuntu karmic) availables on the Download pages, or compile it yourself.

The best way to compile pivy easily is to grab the debian source package for pivy and make a package with debuild. It is the same source code from the official pivy site, but the debian people made several bug-fixing additions. It also compiles fine on ubuntu karmic: http://packages.debian.org/squeeze/python-pivy (download the .orig.gz and the .diff.gz file, then unzip both, then apply the .diff to the source: go to the unzipped pivy source folder, and apply the .diff patch:

patch -p1 < ../pivy_0.5.0~svn765-2.diff

then

debuild

to have pivy properly built into an official installable package. Then, just install the package with gdebi.

Other linux distributions

First get the latest sources from the project's repository:

hg clone http://hg.sim.no/Pivy/default Pivy 

As of March 2012, the latest version is Pivy-0.5.

Then you need a tool called SWIG to generate the C++ code for the Python bindings. Pivy-0.5 reports that it has only been tested with SWIG 1.3.31, 1.3.33, 1.3.35, and 1.3.40. So you can download a source tarball for one of these old versions from http://www.swig.org. Then unpack it and from a command line do (as root):

./configure
make
make install (or checkinstall if you use it)

It takes just a few seconds to build.

Alternatively, you can try building with a more recent SWIG. As of March 2012, a typical repository version is 2.0.4. Pivy has a minor compile problem with SWIG 2.0.4 on Mac OS (see below) but seems to build fine on Fedora Core 15.

After that go to the pivy sources and call

python setup.py build 

which creates the source files. Note that build can produce thousands of warnings, but hopefully there will be no errors.

This is probably obsolete, but you may run into a compiler error where a 'const char*' cannot be converted in a 'char*'. To fix that you just need to write a 'const' before in the appropriate lines. There are six lines to fix.

After that, install by issuing (as root):

python setup.py install (or checkinstall python setup.py install)

That's it, pivy is installed.

Mac OS

These instructions may not be complete. Something close to this worked for OS 10.7 as of March 2012. I use MacPorts for repositories, but other options should also work.

As for linux, get the latest source:

hg clone http://hg.sim.no/Pivy/default Pivy 

If you don't have hg, you can get it from MacPorts:

port install mercurial

Then, as above you need SWIG. It should be a matter of:

port install swig

I found I needed also:

port install swig-python

As of March 2012, MacPorts SWIG is version 2.0.4. As noted above for linux, you might be better off downloading an older version. SWIG 2.0.4 seems to have a bug that stops Pivy building. See first message in this digest: https://sourceforge.net/mailarchive/message.php?msg_id=28114815

This can be corrected by editing the 2 source locations to add dereferences: *arg4, *arg5 in place of arg4, arg5. Now Pivy should build:

python setup.py build
sudo python setup.py install

Windows

Assuming you are using Visual Studio 2005 or later you should open a command prompt with 'Visual Studio 2005 Command prompt' from the Tools menu. If the Python interpreter is not yet in the system path do

set PATH=path_to_python_2.5;%PATH%

To get pivy working you should get the latest sources from the project's repository:

svn co https://svn.coin3d.org/repos/Pivy/trunk Pivy 

Then you need a tool called SWIG to generate the C++ code for the Python bindings. It is recommended to use version 1.3.25 of SWIG, not the latest version, because at the moment pivy will only function correctly with 1.3.25. Download the binaries for 1.3.25 from http://www.swig.org. Then unpack it and from the command line add it to the system path

set PATH=path_to_swig_1.3.25;%PATH%

and set COINDIR to the appropriate path

set COINDIR=path_to_coin

On Windows the pivy config file expects SoWin instead of SoQt as default. I didn't find an obvious way to build with SoQt, so I modified the file setup.py directly. In line 200 just remove the part 'sowin' : ('gui._sowin', 'sowin-config', 'pivy.gui.') (do not remove the closing parenthesis).

After that go to the pivy sources and call

python setup.py build 

which creates the source files. You may run into a compiler error several header files couldn't be found. In this case adjust the INCLUDE variable

set INCLUDE=%INCLUDE%;path_to_coin_include_dir

and if the SoQt headers are not in the same place as the Coin headers also

set INCLUDE=%INCLUDE%;path_to_soqt_include_dir

and finally the Qt headers

set INCLUDE=%INCLUDE%;path_to_qt4\include\Qt

If you are using the Express Edition of Visual Studio you may get a python keyerror exception. In this case you have to modify a few things in msvccompiler.py located in your python installation.

Go to line 122 and replace the line

vsbase = r"Software\Microsoft\VisualStudio\%0.1f" % version

with

vsbase = r"Software\Microsoft\VCExpress\%0.1f" % version

Then retry again. If you get a second error like

error: Python was built with Visual Studio 2003;...

you must also replace line 128

self.set_macro("FrameworkSDKDir", net, "sdkinstallrootv1.1")

with

self.set_macro("FrameworkSDKDir", net, "sdkinstallrootv2.0")

Retry once again. If you get again an error like

error: Python was built with Visual Studio version 8.0, and extensions need to be built with the same version of the compiler, but it isn't installed.

then you should check the environment variables DISTUTILS_USE_SDK and MSSDK with

echo %DISTUTILS_USE_SDK%
echo %MSSDK%

If not yet set then just set it e.g. to 1

set DISTUTILS_USE_SDK=1
set MSSDK=1

Now, you may run into a compiler error where a 'const char*' cannot be converted in a 'char*'. To fix that you just need to write a 'const' before in the appropriate lines. There are six lines to fix. After that copy the generated pivy directory to a place where the python interpreter in FreeCAD can find it.

Usage

To check if Pivy is correctly installed:

import pivy

To have Pivy access the FreeCAD scenegraph do the following:

from pivy import coin
App.newDocument() # Open a document and a view 
view = Gui.ActiveDocument.ActiveView 
FCSceneGraph = view.getSceneGraph() # returns a pivy Python object that holds a SoSeparator, the main "container" of the Coin scenegraph
FCSceneGraph.addChild(coin.SoCube()) # add a box to scene 

You can now explore the FCSceneGraph with the dir() command.

Additonal Documentation

Unfortunately documentation about pivy is still almost inexistant on the net. But you might find Coin documentation useful, since pivy simply translate Coin functions, nodes and methods in python, everything keeps the same name and properties, keeping in mind the difference of syntax between C and python:

You can also look at the Draft.py file in the FreeCAD Mod/Draft folder, since it makes big use of pivy.

pyCollada

pyCollada is a python library that allow programs to read and write Collada (*.DAE) files. When pyCollada is installed on your system, FreeCAD will be able to handle importing and exporting in the Collada file format.

Installation

Pycollada is usually not yet available in linux distributions repositories, but since it is made only of python files, it doesn't require compilation, and is easy to install. You have 2 ways, or directly from the official pycollada git repository, or with the easy_install tool.

Linux

In either case, you'll need the following packages already installed on your system:

python-lxml 
python-numpy
python-dateutil
From the git repository
git clone git://github.com/pycollada/pycollada.git pycollada
cd pycollada
sudo python setup.py install
With easy_install

Assuming you have a complete python installation already, the easy_install utility should be present already:

easy_install pycollada

You can check if pycollada was correctly installed by issuing in a python console:

import collada

If it returns nothing (no error message), then all is OK

Windows

To Be Documented

Mac OS

To Be Documented

IfcOpenShell

IFCOpenShell is a library currently in development, that allows to import (and soon export) Industry foundation Classes (*.IFC) files. IFC is an extension to the STEP format, and is becoming the standard in BIM workflows. When ifcopenshell is correctly installed on your system, the FreeCAD Arch Module will detect it and use it to import IFC files, instead of its built-in rudimentary importer. Since ifcopenshell is based on OpenCasCade, like FreeCAD, the quality of the import is very high, producing high-quality solid geometry.

Installation

Since ifcopenshell is pretty new, you'll likely need to compile it yourself.

Linux

You will need a couple of development packages installed on your system in order to compile ifcopenshell:

liboce-*-dev
python-dev
swig

but since FreeCAD requires all of them too, if you can compile FreeCAD, you won't need any extra dependency to compile IfcOpenShell.

Grab the latest source code from here:

svn co https://ifcopenshell.svn.sourceforge.net/svnroot/ifcopenshell ifcopenshell

The build process is very easy:

mkdir ifcopenshell-build
cd ifcopenshell-build
cmake ../ifcopenshell/cmake

or, if you are using oce instead of opencascade:

cmake -DOCC_INCLUDE_DIR=/usr/include/oce ../ifcopenshell/cmake 

Since ifcopenshell is made primarily for Blender, it uses python3 by default. To use it inside FreeCAD, you need to compile it against the same version of python that is used by FreeCAD. So you might need to force the python version with additional cmake parameters (adjust the python version to yours):

cmake -DOCC_INCLUDE_DIR=/usr/include/oce -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 -DPYTHON_LIBRARY=/usr/lib/python2.7.so ../ifcopenshell/cmake

Then:

make
sudo make install

You can check that ifcopenshell was correctly installed by issuing in a python console:

import IfcImport

If it returns nothing (no error message), then all is OK

Windows

Copied from the IfcOpenShell README file

Users are advised to use the Visual Studio .sln file in the win/ folder. For Windows users a prebuilt Open CASCADE version is available from the http://opencascade.org website. Download and install this version and provide the paths to the Open CASCADE header and library files to MS Visual Studio C++.

For building the IfcPython wrapper, SWIG needs to be installed. Please download the latest swigwin version from http://www.swig.org/download.html . After extracting the .zip file, please add the extracted folder to the PATH environment variable. Python needs to be installed, please provide the include and library paths to Visual Studio.

Teigha Converter

The Teigha Converter is a small freely available utility that allows to convert between several versions of DWG and DXF files. FreeCAD can use it to offer DWG import and export, by converting DWG files to the DXF format under the hood,then using its standard DXF importer to import the file contents. The restrictions of the DXF importer apply.

Installation

On all platforms, only by installing the appropriate package from http://www.opendesign.com/guestfiles/TeighaFileConverter . After installation, if the utility is not found automatically by FreeCAD, you might need to set the path to the converter executable manually, in the menu Edit -> Preferences -> Draft -> Import/Export options.

Available translations of this page: Flag-es.jpg Flag-fr.jpg Flag-it.jpg Flag-jp.jpg Flag-ru.jpg Template:Se