Draft DXF

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft DXF and the translation is 100% complete.

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe

Draft DXF

Menu location
File → Export → Autodesk DXF 2D (*.dxf)
Workbenches
Draft
Default shortcut
Ctrl+E
Introduced in version
-
See also
FreeCAD and DXF Import, FreeCAD and DWG Import


Description

Voir aussi: FreeCAD et import DXF et FreeCAD et import DWG.

Cette fonction ouvre un fichier DXF, n'importe quelle version de 12 à 2007, dans un nouveau document.

Screenshot qcad.jpg

Qcad plan exporté en DXF qui est ensuite ouvert dans FreeCAD


Ouverture

Les types d'objets .DXF suivants sont actuellement supportés:

  • lignes
  • polylignes et lwpolylignes
  • cercles
  • arcs
  • calques (les calques contenant des objets sont convertis en groupes dans FreeCAD)
  • textes and Mtextes (textes multi-lignes)
  • dimensions
  • blocs (géométrie seulement. Les textes, dimensions et attributs à l'intérieur des blocs seront ignorés)
  • points introduced in version 0.13
  • repères (flêchés) introduced in version 0.13

Les autres entités DXF ne sont actuellement pas importées car il n'y a pas d'objet FreeCAD correspondant. Au fur et à mesure que de nouvelles fonctionnalités seront implémentées, il sera possible d'importer davantage de types d'entités.

Installation

Note: pour des raisons de licence, les bibliothèques DXF import/export ne font plus partie du code source FreeCAD. Pour cette raison, ils doivent être installés par vous, l'utilisateur, après avoir installé FreeCAD. Il y a une manière automatique de le faire avec FreeCAD ou vous pouvez le faire manuellement.

Automatiquement

Depuis la version 0.15, vous avez seulement besoin de marquer dans Edition → Préférences → Import/Export → DXF/DWG → "Autoriser FreeCAD à télécharger automatiquement les bibliothèques DXF" pour que FreeCAD prenne automatiquement soin de télécharger et d'installer ces bibliothèques. Pour les anciennes versions, vous devrez le faire manuellement.

Manuellement

L'ensemble doit être téléchargé sur https://github.com/yorikvanhavre/Draft-dxf-importer

Ici un tutoriel vous explique pas à pas la procédure complète à suivre.

Importation

Cela fonctionne de la même manière que pour l'ouverture d'un fichier, mais le contenu du fichier DXF sera ajouté au document actif, au lieu de créer un nouveau document.

Tutorial: Dxf Importer Install

Exportation

Le fichier .DXF exporté est compatible avec la version Autocad 2012 et plus, il devrait donc s'ouvrir dans n'importe quelle application qui supporte le format .DXF. Actuellement, les objets suivants sont exportés par FreeCAD :

  • lignes et fils (polylignes)
  • arcs et cercles
  • textes
  • les couleurs sont mappées à partir des objets, aux couleurs RVB, indice de couleur (ACI) d'Autocad. Le noir sera toujours la couleur "de la couche (layer)".
  • les couches (layers) sont mappées à partir des noms de groupe. Lorsque des groupes sont imbriqués, le plus profond du groupe donne le nom au calque (layer).
  • les dimensions, sont exportées avec le style "Standard" dimstyle

Préférences

Les paramètres suivants peuvent être spécifiés dans les Préférences depuis le menu Édition → Préférences → Import-Export.

  • Le style d'importation : Cela vous permet de choisir la manière dont les objets du fichier dxf seront établis dans FreeCAD.
  • Vous pouvez choisir entre :
    • Aucun : c'est le moyen plus rapide, il n'y a pas de conversion, tous les objets seront de couleur noire avec une largeur de 2 pixels (par défaut FreeCAD).
    • Utiliser la couleur par défaut, et, la largeur de ligne : Tous les objets dxf importés auront la largeur/couleur de ligne en cours dans la barre de commande projet.
    • Couleurs d'origine, et, largeur de ligne : les objets garderont la couleur, et, la largeur de la ligne (si spécifié) tels qu'ils sont dans le fichier DXF.
    • Couleurs mappées à la largeur de la ligne : Si cette option est sélectionnée, l'option fichier de mapping ci-dessous est utilisé.
  • Fichier de mapping Couleur : Cela vous permet de spécifier un fichier de mapping à être utilisé pour traduire les couleurs dxf à la couleur, et, la largeur de la ligne, de la même manière qu'un style de tracé fonctionnant dans Autocad. Le fichier de mapping doit être un fichier texte séparé par des tabulations. Il existe un sympathique utilitaire gratuit appelé Plot style viewer qui peut convertir les fichiers Autocad CTB (styles de tracé de couleur) ou STB (styles de tracé nommé) en fichiers séparés par des tabulations cartographiques utilisables dans FreeCAD. Sinon, nous avons une paire de fichiers made FreeCAD cartographiques Disponibles.
  • Textes d'importation : Cela vous permet de spécifier si vous voulez importer les textes, et, les dimensions contenues dans le fichier dxf ou non. Beaucoup de textes pourraient rendre votre travail dans FreeCAD très lourd, de sorte que vous pouvez utiliser cette option quand bon vous semble.
  • Les modèles importés : Activez cette fonction si vous voulez importer l'objet de l'espace papier. Ils seront fusionnés dans le même document que les objets de l'espace objet.

Script

Voir aussi: Draft API et FreeCAD Scripts de base.

Vous pouvez exporter des éléments vers un fichier DXF en utilisant la fonction suivante:

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)

Exemple:

import Draft, importDXF

Polygon1 = Draft.makePolygon(3, radius=500)
Polygon2 = Draft.makePolygon(5, radius=1500)

objects = [Polygon1, Polygon2]

importDXF.export(objects, "/home/user/Pictures/myfile.dxf")