Difference between revisions of "Customize Toolbars/de"

From FreeCAD Documentation
Jump to: navigation, search
(Created page with "900px|center|Right mouse click {{clear}}")
(Updating to match new version of source page)
 
(44 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{TutorialInfo/de|Thema=SampleClass|Level=Beginner|Time=5 minutes|Author=[[User:Mario52|Mario52]]|FCVersion=All}}
+
<languages/>
 +
{{TutorialInfo/de|Thema=SampleTopic|Level=Anfänger|Time=5 Minuten|Author=[[User:Mario52|Mario52]]|FCVersion=Alle}}
  
 
<small>Status: FreeCAD-Version 0.16</small>
 
<small>Status: FreeCAD-Version 0.16</small>
  
 
==Zusammenfassung==
 
==Zusammenfassung==
Dieses Tutorial behandelt die Anpassung der Werkzeugleisten durch den Benutzer. Ein Werkzeug (inklusive ein Makro-Werkzeug) kann außer aus seiner angestammten, einem Arbeitsbereich zugeordneten Leiste auch aus anderen Werkzeugleisten heraus aufgerufen werden. Zuerst werden beispielsweise dem Makro "Camera" die zum Aufruf als  Werkzeug benötigten Worte und ein Icon zugefügt. Anschließend wird eine zusätzliche Werkzeugleiste im Arbeitsbereich Körper (Part) erstellt und in sie das  vervollständigte Makro-Werkzeug "Camera" eingetragen.
+
Dieses Tutorial behandelt die Anpassung von Werkzeugleisten. Werkzeuge (inklusive Makro-Werkzeugen) können in verschiedenen Arbeitsbereichen verwendet werden. In einem Beispiel wird durch Erzeugung eines '''Menütextes''', eines '''Tooltips''' und eines '''Icons''' aus einem Makro ein Makro-Werkzeug. Anschließend wird dieses Makro-Werkzeug Teil einer zusätzlichen Werkzeugleiste in einem Arbeitsbereich.
  
 
==Vorgehen==
 
==Vorgehen==
Line 10: Line 11:
 
<u>'''1.''' Aufruf des Anpassungs-Menüs "Benutzerdefiniert"</u>
 
<u>'''1.''' Aufruf des Anpassungs-Menüs "Benutzerdefiniert"</u>
  
*Klicke {{MenuCommand|Haupt-Menü → Werkzeuge → Benutzerdefiniert...}},
+
*Klicke {{MenuCommand|Haupt-Menü → Werkzeuge → Benutzerdefiniert...}},
  
[[File:Customize1.jpg |900px|center|Customize]]
+
[[File:CustomizeToolBar 01.png|640px|center|Benutzerdefiniert...]]
 
{{clear}}
 
{{clear}}
  
* oder mache einen Rechts-Klick (rechte Maustaste) in irgend eine Werkzeugleiste und klicke dort in "Benurtzerdefiniert".
+
* oder mache einen Rechts-Klick (rechte Maustaste) in irgendeine Werkzeugleiste.
  
[[File:Customize2.jpg|900px|center|Right mouse click]]
+
[[File:CustomizeToolBar 02.png|640px|center|Rechter Mausklick]]
 
{{clear}}
 
{{clear}}
  
 
*Das Menü (Fenster) "Benutzerdefiniert" öffnet sich.
 
*Das Menü (Fenster) "Benutzerdefiniert" öffnet sich.
  
[[File:Customize3de.jpg|900px|center|Right mouse click]]
+
[[File:CustomizeToolBar 03.png|640px|center|Das Fenster 'Benutzerdefiniert' erscheint]]
 
{{clear}}
 
{{clear}}
  
<u>'''2.''' Erzeugen eines Makro-Werkzeuges für eine bestimmte, in den PC geladene Programm-Ergänzung (Makro-Text)</u>
+
<u>'''2.''' Erzeugen eines Makro-Werkzeugs aus einem Makro</u>
  
*Klicke auf den Reiter "Makros".
+
*Klicke auf den Reiter "Makros"
  
*Für das Zufügen eines Icons für das vorgesehene Makro-Werkzeug klicke auf das Symbol &nbsp; {{KEY|... }}.
+
*Für das Zufügen eines Icons für das vorgesehene Makro-Werkzeug klicke auf das Symbol &nbsp; {{Button|... }}.
  
[[File:CustomizeToolBar 04.png|640px|center|Select a toolbar]]
+
[[File:CustomizeToolBar 04.png|640px|center|Wähle eine Werkzeugleiste]]
 
{{clear}}
 
{{clear}}
  
Line 38: Line 39:
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<div class="mw-collapsible mw-collapsed toccolours">
  
&nbsp; &nbsp; &nbsp; [... oder füge eines aus einem benutzerdefinierten "Icon-Ordner" ein.]
+
&nbsp; &nbsp; &nbsp; [oder füge Dein eigenes Icon hinzu durch klicken von {{Button|Add icons...}}]. &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;(erweitere für ein Beispiel)
  
 
<div class="mw-collapsible-content">
 
<div class="mw-collapsible-content">
Line 56: Line 57:
 
*Klicke auf  {{KEY|OK}}.
 
*Klicke auf  {{KEY|OK}}.
  
[[File:CustomizeToolBar 07.png|640px|center|Select your icon]]
+
[[File:Customize5de.jpg|640px|center|Select your icon]]
 
{{clear}}
 
{{clear}}
  
 
*Das ausgewählte Icon wird neben dem Symbol &nbsp; {{KEY|...}} angezeigt.
 
*Das ausgewählte Icon wird neben dem Symbol &nbsp; {{KEY|...}} angezeigt.
  
[[File:CustomizeToolBar 08.png|640px|center|Your icon is displayed]]
+
[[File:Customize6de.jpg|640px|center|Your icon is displayed]]
 
{{clear}}
 
{{clear}}
  
Line 73: Line 74:
 
*Auf  {{KEY|Add}} klicken.
 
*Auf  {{KEY|Add}} klicken.
  
[[File:CustomizeToolBar 09.png|640px|center|Click the button]]
+
[[File:CustomizeToolBar 09.png|640px|center|Drücke die Schaltfläche]]
 
{{clear}}
 
{{clear}}
  
 
* Die Programm-Ergänzung (Makro) ist nun als Makro-Werkzeug installiert.
 
* Die Programm-Ergänzung (Makro) ist nun als Makro-Werkzeug installiert.
  
[[File:CustomizeToolBar 10.png|640px|center|Your button is created]]
+
[[File:CustomizeToolBar 10.png|640px|center|Deine Schalrfläche ist erstellt]]
{{clear}}
 
  
<u>'''3.''' Erstellen einer ergänzenden Werkzeugleiste außerhalb des Arbeitsbereichs "Makro", die das kreiierte "Makro-Werkzeug" enthält</u>
+
<u>'''3.''' Erstellen einer ergänzenden Werkzeugleiste außerhalb des Arbeitsbereichs "Makro", die das kreierte "Makro-Werkzeug" enthält</u>
  
 
*Auf den Reiter '''Symbolleisten''' klicken und den Arbeitsbereich wählen, der um eine Werkzeugleiste ergänzt werden soll (z.B. '''Körper''' (Part)).
 
*Auf den Reiter '''Symbolleisten''' klicken und den Arbeitsbereich wählen, der um eine Werkzeugleiste ergänzt werden soll (z.B. '''Körper''' (Part)).
  
&nbsp; &nbsp; &nbsp; &nbsp; [Seit Version 0.15 kann anstattt eines Arbeitsbereiches &nbsp;{{KEY|[[File:Freecad.svg|16px]] Global}}&nbsp;  gewählt werden.  
+
&nbsp; &nbsp; &nbsp; &nbsp; [Seit Version 0.15 kann anstatt eines Arbeitsbereiches &nbsp;{{KEY|[[File:Freecad.svg|16px]] Global}}&nbsp;  gewählt werden.  
  
 
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; In diesem Fall lässt sich die zu erstellende Zusatz-Werkzeugleiste in jedem Arbeitsbereich aktivieren.]
 
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; In diesem Fall lässt sich die zu erstellende Zusatz-Werkzeugleiste in jedem Arbeitsbereich aktivieren.]
  
[[File:CustomizeToolBar 11.png|640px|center|Toolbars tab]]
+
[[File:CustomizeToolBar 11.png|640px|center|Toolbars-Reiter]]
 
{{clear}}
 
{{clear}}
  
*Wähle '''Makros''' in linkem Fenster-Teil (Zeile enthält standardmässig '''Datei''').
+
*Wähle '''Makros''' in linkem Fenster-Teil (Zeile enthält standardmäßig '''Datei''').
  
[[File:CustomizeToolBar 12.png|640px|center|Macros]]
+
[[File:CustomizeToolBar 12.png|640px|center|Makros]]
 
{{clear}}
 
{{clear}}
  
*Die Makro-Werkzeuge werden zusammen mit ihren Icons darunter gelistet (auch das oben erstellte).
+
*Die Makro-Werkzeuge werden zusammen mit ihren Icons darunter gelistet (auch das oben erstellte).
  
[[File:CustomizeToolBar 13.png|640px|center|Your icon is listed]]
+
[[File:CustomizeToolBar 13.png|640px|center|Das Symbol wird aufgeführt]]
 
{{clear}}
 
{{clear}}
  
*Klicke auf{{KEY|Neu...}}
+
*Klicke auf {{Button|Neu...}}
  
[[File:CustomizeToolBar 14.png|640px|center|Click on "New"]]
+
[[File:CustomizeToolBar 14.png|640px|center|Klicke auf "Neu"]]
 
{{clear}}
 
{{clear}}
  
*Trage einen  Namen für die vorgesehene zusätzliche Werkzeugleiste ein. Bestätige mit "OK".
+
*Trage einen  Namen für die vorgesehene zusätzliche Werkzeugleiste ein. Bestätige mit {{Button|OK}}.
  
[[File:CustomizeToolBar 15.png|640px|center|Enter the name for your toolbar]]
+
[[File:CustomizeToolBar 15.png|640px|center|Gib den Namen für die Werkzeugleiste an]]
 
{{clear}}
 
{{clear}}
  
Line 116: Line 116:
 
*Klicke  z.B. auf  das kreierte Makro-Werkzeug. Durch Klicken auf den nach rechts zeigenden  {{KEY|blauen Pfeil}} wird es auch  in die rechts kreierte Werkzeugleiste eingetragen.
 
*Klicke  z.B. auf  das kreierte Makro-Werkzeug. Durch Klicken auf den nach rechts zeigenden  {{KEY|blauen Pfeil}} wird es auch  in die rechts kreierte Werkzeugleiste eingetragen.
  
[[File:CustomizeToolBar 16.png|640px|center|Select your macro]]
+
[[File:CustomizeToolBar 16.png|640px|center|Wähle Dein Makro]]
 
{{clear}}
 
{{clear}}
  
Line 123: Line 123:
 
*Klicke auf {{KEY|Schließen}}.
 
*Klicke auf {{KEY|Schließen}}.
  
[[File:CustomizeToolBar 17.png|640px|center|Close]]
+
[[File:CustomizeToolBar 17.png|640px|center|Schließen]]
 
{{clear}}
 
{{clear}}
  
 
* Diese zusätzliche Werkzeugleiste wird beim Rechts-Klick auf die Werkzeugleiste des Arbeitsbereiches Körper (Part) auch sichtbar. Die Icons ihrer Werkzeuge (im Beispiel nur '''Camera''') werden sichtbar, nachdem die Leiste aktiviert worden ist (blauer Haken gesetzt).
 
* Diese zusätzliche Werkzeugleiste wird beim Rechts-Klick auf die Werkzeugleiste des Arbeitsbereiches Körper (Part) auch sichtbar. Die Icons ihrer Werkzeuge (im Beispiel nur '''Camera''') werden sichtbar, nachdem die Leiste aktiviert worden ist (blauer Haken gesetzt).
  
[[File:CustomizeToolBar 18.png|640px|center|New Toolbar]]
+
[[File:CustomizeToolBar 18.png|640px|center|Neue Werkzeugleiste]]
 
{{clear}}
 
{{clear}}
 +
 +
==Notes for Python based functions like those in Draft==
 +
If you want to use a Draft or other Python based function in a toolbar they don't seem to be available in the drop down list at the left side. You first have to load the corresponding workbench, e.g. Draft, and then you will find the functions available when selecting "Python" in the left drop down menu.
  
  
 
{{clear}}
 
{{clear}}
<languages/>
 

Latest revision as of 17:37, 12 October 2019

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский • ‎svenska • ‎中文(台灣)‎

Base ExampleCommandModel.png Tutorial

Thema
{{{Topic}}}
Niveau
Anfänger
Zeit zum Abschluss
5 Minuten
Autor
Mario52
FreeCAD version
Alle
Beispieldatei(en)
None


Status: FreeCAD-Version 0.16

Zusammenfassung

Dieses Tutorial behandelt die Anpassung von Werkzeugleisten. Werkzeuge (inklusive Makro-Werkzeugen) können in verschiedenen Arbeitsbereichen verwendet werden. In einem Beispiel wird durch Erzeugung eines Menütextes, eines Tooltips und eines Icons aus einem Makro ein Makro-Werkzeug. Anschließend wird dieses Makro-Werkzeug Teil einer zusätzlichen Werkzeugleiste in einem Arbeitsbereich.

Vorgehen

1. Aufruf des Anpassungs-Menüs "Benutzerdefiniert"

  • Klicke Haupt-Menü → Werkzeuge → Benutzerdefiniert...,
Benutzerdefiniert...


  • oder mache einen Rechts-Klick (rechte Maustaste) in irgendeine Werkzeugleiste.
Rechter Mausklick


  • Das Menü (Fenster) "Benutzerdefiniert" öffnet sich.
Das Fenster 'Benutzerdefiniert' erscheint


2. Erzeugen eines Makro-Werkzeugs aus einem Makro

  • Klicke auf den Reiter "Makros"
  • Für das Zufügen eines Icons für das vorgesehene Makro-Werkzeug klicke auf das Symbol   ... .
Wähle eine Werkzeugleiste


  • Suche ein passendes Icon in der Icon-Sammlung von FreeCAD.

      [oder füge Dein eigenes Icon hinzu durch klicken von Add icons...].                  (erweitere für ein Beispiel)

Add icon


     [Der Ordner mit benutzerdefinierten Icons wird durch Klicken auf "Icon-Ordner" geöffnet.       Eines anklicken und mit Klick auf "OK" annehmen.]

Get a file


  • Klicke auf OK.
Select your icon


  • Das ausgewählte Icon wird neben dem Symbol   ... angezeigt.
Your icon is displayed


  • Vorgesehenes Makro in der Zeile "Makro:" auswählen.
  • "Menütext:" eintragen (erscheint als Text-Label in Werkzeugleiste).
  • "Tooltipp:" eintragen (erscheint als Text-Zeile beim Überstreichen des Icons mit der Maus).

        [Ausfüllen weiterer Zeilen ist optional.]

  • Auf Add klicken.
Drücke die Schaltfläche


  • Die Programm-Ergänzung (Makro) ist nun als Makro-Werkzeug installiert.
Deine Schalrfläche ist erstellt

3. Erstellen einer ergänzenden Werkzeugleiste außerhalb des Arbeitsbereichs "Makro", die das kreierte "Makro-Werkzeug" enthält

  • Auf den Reiter Symbolleisten klicken und den Arbeitsbereich wählen, der um eine Werkzeugleiste ergänzt werden soll (z.B. Körper (Part)).

        [Seit Version 0.15 kann anstatt eines Arbeitsbereiches  Freecad.svg Global  gewählt werden.

          In diesem Fall lässt sich die zu erstellende Zusatz-Werkzeugleiste in jedem Arbeitsbereich aktivieren.]

Toolbars-Reiter


  • Wähle Makros in linkem Fenster-Teil (Zeile enthält standardmäßig Datei).
Makros


  • Die Makro-Werkzeuge werden zusammen mit ihren Icons darunter gelistet (auch das oben erstellte).
Das Symbol wird aufgeführt


  • Klicke auf Neu...
Klicke auf "Neu"


  • Trage einen Namen für die vorgesehene zusätzliche Werkzeugleiste ein. Bestätige mit OK.
Gib den Namen für die Werkzeugleiste an


  • Diese Werkzeugleiste ist nun kreiert.
  • Klicke z.B. auf das kreierte Makro-Werkzeug. Durch Klicken auf den nach rechts zeigenden blauen Pfeil wird es auch in die rechts kreierte Werkzeugleiste eingetragen.
Wähle Dein Makro


  • Dem Arbeitsbereich Körper (Part) ist nun eine "Camera" genannte Werkzeugleiste mit dem Makro-Werkzeug Camera zugefügt worden.
  • Klicke auf Schließen.
Schließen


  • Diese zusätzliche Werkzeugleiste wird beim Rechts-Klick auf die Werkzeugleiste des Arbeitsbereiches Körper (Part) auch sichtbar. Die Icons ihrer Werkzeuge (im Beispiel nur Camera) werden sichtbar, nachdem die Leiste aktiviert worden ist (blauer Haken gesetzt).
Neue Werkzeugleiste


Notes for Python based functions like those in Draft

If you want to use a Draft or other Python based function in a toolbar they don't seem to be available in the drop down list at the left side. You first have to load the corresponding workbench, e.g. Draft, and then you will find the functions available when selecting "Python" in the left drop down menu.