Difference between revisions of "Compile on Windows"

From FreeCAD Documentation
Jump to: navigation, search
(more Cmake update)
m (correct the link to "Compile_on_Linux/Unix")
(46 intermediate revisions by 3 users not shown)
Line 2: Line 2:
 
<translate>
 
<translate>
 
<!--T:109-->
 
<!--T:109-->
{{docnav|Tracker|CompileOnUnix}}
+
{{docnav
 +
|[[Tracker|Tracker]]
 +
|[[Compile_on_Linux/Unix|Compile on Linux/Unix]]
 +
}}
  
 
<!--T:1-->
 
<!--T:1-->
This article explains step by step '''how to compile FreeCAD on Windows'''.
+
This page explains step by step '''how to compile FreeCAD 0.18 or newer on Windows'''.
 
 
<!--T:74-->
 
See also
 
* [[Compile_on_Windows_with_VS2013|Compile on Windows with Visual Studio 2013]]
 
* [[Compiling_(Speeding_up)|Compiling - Speeding up]]
 
  
 
== Prerequisites == <!--T:2-->
 
== Prerequisites == <!--T:2-->
Line 21: Line 19:
 
<!--T:116-->
 
<!--T:116-->
 
* [http://git-scm.com/ Git] (There are also a GUI frontends available for Git, see the next section.)
 
* [http://git-scm.com/ Git] (There are also a GUI frontends available for Git, see the next section.)
* [http://www.cmake.org/cmake/resources/software.html CMake] version 3.11.x - 3.14.x. '''Note:''' Usually one cannot take the latest CMake version. Therefore only use a CMake version in the range specified on this page!<br>It is recommended to use the option ''Add CMake to the system PATH for all users'' when installing CMake. Then you can later easily access CMake also from the command line/powershell.
+
 
* LibPack (also called FreeCADLibs). This is a set of libraries necessary to compile FreeCAD on Windows. Depending on the FreeCAD version you want to compile, you must download the corresponding LibPack. For example to compile FreeCAD 0.18, download either the 32bit or the 64bit version of the [https://github.com/FreeCAD/FreeCAD-ports-cache/releases/tag/v0.18 LibPack for 0.18], to compile the latest development version 0.19, download the [https://github.com/FreeCAD/FreeCAD/releases/tag/0.19_pre LibPack for 0.19] (there is only a 64bit version).<br>Just download the LibPack, you will unpack and set it up later.<br>'''Note''': It is recommended to use the same compiler ''MS Visual Studio'' (MSVC) version the LibPack is designed for. This assures that the compilation and the execution of the compiled FreeCAD.exe succeeds. So you should for example be able to compile FreeCAD 0.18 using the LibPack for 0.19 and MSVC 15 but you you might get problems compiling FreeCAD 0.18 using the LibPack for 0.18 and MSVC 15 because the LibPack for 0.18 is designed to be built with MSVC&nbsp;12.
+
<!--T:170-->
 +
* [http://www.cmake.org/cmake/resources/software.html CMake] version 3.11.x - 3.14.x. '''Note:''' Usually one cannot take the latest CMake version. Therefore only use a CMake version in the range specified on this page!
 +
 
 +
<!--T:171-->
 +
It is recommended to use the option ''Add CMake to the system PATH for all users'' when installing CMake. Then you can later easily access CMake also from the command line/powershell.
 +
 
 +
<!--T:172-->
 +
* LibPack (also called FreeCADLibs). This is a set of libraries necessary to compile FreeCAD on Windows. Depending on the FreeCAD version you want to compile, you must download the corresponding LibPack. For example to compile FreeCAD 0.18, download either the 32bit or the 64bit version of the [https://github.com/FreeCAD/FreeCAD-ports-cache/releases/tag/v0.18 LibPack for 0.18], to compile the latest development version 0.19, download the [https://github.com/FreeCAD/FreeCAD/releases/tag/0.19_pre LibPack for 0.19] (there is only a 64bit version).
 +
 
 +
<!--T:173-->
 +
Just download the LibPack, you will unpack and set it up later.
 +
 
 +
<!--T:174-->
 +
'''Note''': It is recommended to use the same compiler ''MS Visual Studio'' (MSVC) version the LibPack is designed for. This assures that the compilation and the execution of the compiled FreeCAD.exe succeeds. So you should for example be able to compile FreeCAD 0.18 using the LibPack for 0.19 and MSVC 15 but you you might get problems compiling FreeCAD 0.18 using the LibPack for 0.18 and MSVC 15 because the LibPack for 0.18 is designed to be built with MSVC&nbsp;12.
  
 
===Optional programs=== <!--T:137-->
 
===Optional programs=== <!--T:137-->
 +
 +
<!--T:175-->
 
* [https://www.python.org/downloads/ Python 3.x]. A separate python installation is not mandatory since the LibPack contains Python. However, to be able to test later your FreeCAD build it is useful to have a standalone Python installation. It is recommended to use not the latest version, but the prior version (e.g. not Python 3.7 but 3.6).
 
* [https://www.python.org/downloads/ Python 3.x]. A separate python installation is not mandatory since the LibPack contains Python. However, to be able to test later your FreeCAD build it is useful to have a standalone Python installation. It is recommended to use not the latest version, but the prior version (e.g. not Python 3.7 but 3.6).
*  A GUI frontend for Git. There are several frontends available, see [https://en.wikipedia.org/wiki/Comparison_of_Git_GUIs this list]. The main benefit of a frontend is that you don't have to learn the Git commands to get the source code of FreeCAD or to send patches to the GitHub repository of FreeCAD.<br>In the following we describe source code handling using the frontend [https://tortoisegit.org/ TortoiseGit]. This frontend integrates directly to Windows file explorer and has a large user community to get help in case you have problems.  
+
 
 +
<!--T:176-->
 +
*  A GUI frontend for Git. There are several frontends available, see [https://en.wikipedia.org/wiki/Comparison_of_Git_GUIs this list]. The main benefit of a frontend is that you don't have to learn the Git commands to get the source code of FreeCAD or to send patches to the GitHub repository of FreeCAD.
 +
 
 +
<!--T:177-->
 +
In the following we describe source code handling using the frontend [https://tortoisegit.org/ TortoiseGit]. This frontend integrates directly to Windows file explorer and has a large user community to get help in case you have problems.  
 +
 
 +
<!--T:178-->
 
* [http://sourceforge.net/projects/nsis/ NSIS] This is the program to generate the Windows installer of FreeCAD. (Information: For FreeCAD 0.17 and older the program [http://wixtoolset.org/ WiX] was used to create the installer.)
 
* [http://sourceforge.net/projects/nsis/ NSIS] This is the program to generate the Windows installer of FreeCAD. (Information: For FreeCAD 0.17 and older the program [http://wixtoolset.org/ WiX] was used to create the installer.)
  
===Source Code=== <!--T:98-->
+
===Source code=== <!--T:98-->
  
 +
<!--T:143-->
 
Now you can get the source code of FreeCAD:
 
Now you can get the source code of FreeCAD:
  
====Using the Command Line==== <!--T:117-->
+
====Using a frontend==== <!--T:144-->
 +
 
 +
<!--T:145-->
 +
When using the [https://en.wikipedia.org/wiki/Comparison_of_Git_GUIs Git frontend] TortoiseGit:
 +
# Create a new folder where the source code should be.
 +
# Right-click on this folder in the Windows file explorer and select in the context menu '''Git Clone'''.
 +
# A dialog will appear. Use there as URL for the FreeCAD repository
 +
 
 +
</translate>
 +
''https://github.com/FreeCAD/FreeCAD.git''
 +
<translate>
 +
 
 +
<!--T:179-->
 +
and click '''OK'''.
 +
 
 +
<!--T:180-->
 +
Now the source code is downloaded and its folder becomes a folder tracked by Git.
 +
 
 +
====Using the command line==== <!--T:117-->
  
 
<!--T:102-->
 
<!--T:102-->
Line 40: Line 79:
 
</translate>
 
</translate>
 
{{Code|code=
 
{{Code|code=
git clone https://github.com/FreeCAD/FreeCAD.git FreeCAD-code
+
git clone https://github.com/FreeCAD/FreeCAD.git
 
}}
 
}}
 
<translate>
 
<translate>
 
====Using a Frontend====
 
 
When using the Git frontend TortoiseGit:
 
# Create a new folder where the source code should be.
 
# Right-click on this folder in the Windows file explorer and select in the context menu '''Git Clone'''.
 
# A dialog will appear. Use there as URL for the FreeCAD repository<br>''https://github.com/FreeCAD/FreeCAD.git''<br>and Click OK.
 
Now the source code is downloaded and its folder becomes a folder tracked by Git.
 
  
 
===Compiler=== <!--T:71-->
 
===Compiler=== <!--T:71-->
Line 57: Line 88:
 
The default (recommended) compiler is MS Visual Studio (MSVC). Though it may be possible to use other compilers using Cygwin or MinGW gcc it is not tested or ported so far.
 
The default (recommended) compiler is MS Visual Studio (MSVC). Though it may be possible to use other compilers using Cygwin or MinGW gcc it is not tested or ported so far.
  
You can get a free version of MSVC (for OpenSource usage) by downloading the ''Community'' edition of MS Visual Studio. To do so, use this URL<br><nowiki>https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=xx</nowiki><br>where xx is the version number. So to get MSVC 15 (calso called MSVC 2017), use this URL:<br>https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=15
+
<!--T:146-->
 +
You can get a free version of MSVC (for OpenSource usage) by downloading the ''Community'' edition of MS Visual Studio. To do so, use this URL
 +
 
 +
<!--T:181-->
 +
<nowiki>https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=xx</nowiki>
 +
 
 +
<!--T:182-->
 +
where xx is the version number. So to get MSVC 15 (calso called MSVC 2017), use this URL:
 +
 
 +
<!--T:183-->
 +
https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=15
  
 
<!--T:106-->
 
<!--T:106-->
 
For those who want to avoid installing the huge MSVC for the mere purpose of having a compiler, see [[CompileOnWindows - Reducing Disk Footprint]].
 
For those who want to avoid installing the huge MSVC for the mere purpose of having a compiler, see [[CompileOnWindows - Reducing Disk Footprint]].
  
 +
<!--T:147-->
 
'''Note:''' Despite that the ''Community'' edition of MSVC is free, you must create a Microsoft account from withing the MSVC IDE that you can use the IDE for more than 30 days. If you will only compile using the command line, you don't need the IDE and thus no Microsoft account.
 
'''Note:''' Despite that the ''Community'' edition of MSVC is free, you must create a Microsoft account from withing the MSVC IDE that you can use the IDE for more than 30 days. If you will only compile using the command line, you don't need the IDE and thus no Microsoft account.
  
===System Path Configuration=== <!--T:5-->
+
<!--T:184-->
 +
As free and OpenSource alternative IDE you can use [https://www.kdevelop.org/download KDevelop]. You can use KDevelop to modify and write C++ code but must use the command line to compile.
 +
 
 +
===Optional system path configuration=== <!--T:5-->
  
 
<!--T:121-->
 
<!--T:121-->
Inside your system path be sure to set the correct paths to the following programs:
+
Optionally you can include the paths to some folders to the system PATH variable. This is helpful if you want to access programs in these folders from the command line/powershell or if you want special programs to be found by the compiler or CMake. Besides this, adding folders to the PATH might be necessary if you did not use the corresponding options when installing the program.
* git (not tortoiseGit, but git.exe) This is necessary for Cmake to properly update the "About FreeCAD" information in the version.h file which allows FreeCAD to report the proper version in About FreeCAD from the help menu.
+
 
*Optionally you can include the Libpack in your system path. This is useful if you plan to build multiple configurations/versions of FreeCAD, you will need to copy less files as explained later in the build process.
+
<!--T:148-->
 +
* You can include the folder of your LibPack in your system PATH variable. This is useful if you plan to build multiple configurations/versions of FreeCAD.
 +
* If you did not use the option to add CMake to the PATH while installing it, add its installation folder
 +
 
 +
<!--T:185-->
 +
''C:\Program Files\CMake\bin'' to the PATH.
 +
* If you did not use the option to add TortoiseGit to the PATH while installing it, add its installation folder
 +
 
 +
<!--T:186-->
 +
''C:\Program Files\TortoiseGit\bin'' to the PATH.
  
 
<!--T:104-->
 
<!--T:104-->
To add to your system path:
+
To add folder paths to the PATH variable:
 +
# In the Windows Start menu Right click on ''Computer'' and choose ''Properties''.
 +
# In the appearing dialog click on ''Advanced system settings''.
 +
# Another dialog will open. Click there in the tab ''Advanced'' on '''Environment Variables'''.
 +
# Again another dialog will open. Select then the variable ''Path'' and click on '''Edit'''.
 +
# And again another dialog will open. Click there on '''New''' and add to path to the folder of Git or the LibPack.
 +
# Finally press '''OK''' and close all dialogs by pressing '''OK''' as well.
  
<!--T:105-->
+
== Configuration == <!--T:6-->
* Start menu → Right click on Computer → Properties → Advanced system settings
 
* Advanced tab → Environment Variables...
 
* Add the PATH/TO/GIT to the '''PATH'''
 
* It should be separated from the others with a semicolon `;`
 
  
== Configuration with CMake == <!--T:6-->
+
===LibPack=== <!--T:149-->
 +
 
 +
<!--T:150-->
 +
At first you need to setup a build folder:
 +
# Create a new folder where the compiled FreeCAD should be. It is highly recommended that this folder is not inside the source code folder of FreeCAD.
 +
# Create there a new subfolder for the LibPack. '''Note:''' The name of this subfolder must be the same as the LibPack file name. If e.g. the LibPack has the filename ''FreeCADLibs_12.1.2_x64_VC15.7z'', you must name the subfolder ''FreeCADLibs_12.1.2_x64_VC15''.
 +
# Extract the LibPack to this subfolder.
 +
 
 +
===CMake=== <!--T:151-->
  
 
<!--T:123-->
 
<!--T:123-->
The first step to build FreeCAD is to configure the environment:  
+
Now you need to configure the build environment using CMake:  
 
# Open the CMake GUI
 
# Open the CMake GUI
# Specify there the source folder
+
# Specify there the source folder of FreeCAD
# Specify the build folder
+
# Specify the build folder you just created in the previous step.
 
# Click '''Configure'''
 
# Click '''Configure'''
# In the appearing dialog specify the generator according to the one you want to use. For the standard MS Visual Studio use ''Visual Studio xx 2yyy'' where xx is the compiler version ad yyy the year of its release. It is recommended to use the default option ''Use default native compilers''. '''Note:''' it is important to specify the correct bit variant. if you have the 64bit variant of LibPack you must also use the x64 compiler.
+
# In the appearing dialog specify the generator according to the one you want to use. For the standard MS Visual Studio use ''Visual Studio xx 2yyy'' where xx is the compiler version ad yyy the year of its release. It is recommended to use the default option ''Use default native compilers''.
 +
 
 +
<!--T:187-->
 +
'''Note:''' It is important to specify the correct bit variant. If you have the 64bit variant of LibPack you must also use the x64 compiler.
  
 
<!--T:76-->
 
<!--T:76-->
This will begin the configuration and will fail because of missing settings. Therefore now:
+
This will begin the configuration and will fail because of missing settings.
 +
 
 +
<!--T:152-->
 +
If it fails with the message that Visual Studio could not be found the CMake support in MSVC is not yet installed. To do this:
 +
#  Open the MSVC IDE
 +
#  Use the menu Tools → Get Tools and Features
 +
#  In the ''Workloads'' tab enable ''Desktop development with C++''
 +
# On the right side you should now see that the component ''Visual C++ tools for CMake'' will be installed.
 +
# Install it.
 +
 
 +
<!--T:153-->
 +
If there is no error about Visual Studio, everything is fine, but CMake does not yet know all necessary settings. Therefore now:
 +
# Assure that the search option ''Advanced'' is checked.
 
# Search in CMake for the variable '''FREECAD_LIBPACK_DIR''' and specify there the correct location to the LibPack folder.
 
# Search in CMake for the variable '''FREECAD_LIBPACK_DIR''' and specify there the correct location to the LibPack folder.
 
# Search for the variable '''BUILD_QT5''' and enable this option.
 
# Search for the variable '''BUILD_QT5''' and enable this option.
Line 99: Line 178:
 
There should now be no errors. If so, click on '''Generate'''. After this is done you could close CMake and continue to start the compilation of FreeCAD. However, for the first compilation keep it open for the case that you want or need to change some options for the build process:
 
There should now be no errors. If so, click on '''Generate'''. After this is done you could close CMake and continue to start the compilation of FreeCAD. However, for the first compilation keep it open for the case that you want or need to change some options for the build process:
  
=== Options for the Build Process === <!--T:77-->
+
=== Options for the build process === <!--T:77-->
  
 
<!--T:78-->
 
<!--T:78-->
The CMake build system gives you the flexibility over the build process. That means you can switch on and off some features or modules. (It is in a way like the Linux kernel build.)
+
The CMake build system gives you the flexibility over the build process. That means you can switch on and off some features or modules by CMake variables.
  
 
<!--T:79-->
 
<!--T:79-->
Here is a description for some of these switches:
+
Here is a description for some of these variables:
  
 
<!--T:80-->
 
<!--T:80-->
 
{| class="wikitable" style="text-align:left"
 
{| class="wikitable" style="text-align:left"
|+ Link table
 
 
|-
 
|-
 
! Variable name      !! Description  !! Default
 
! Variable name      !! Description  !! Default
 
|-               
 
|-               
| BUILD_GUI   || Build FreeCAD with all Gui related modules || ON
+
| BUILD_XXX   || Build FreeCAD with the component XXX. If you don't want/need to compile e.g. the workbench ''OpenSCAD'', disable the variable ''BUILD_OPENSCAD''. FreeCAD will then not have this workbench.
 +
 
 +
<!--T:188-->
 +
'''Note:''' Some components are required for other components. If you for example uncheck ''BUILD_ROBOT'' CMake will inform you that then the component ''Path'' cannot be compiled correctly. Therefore check the CMake output after you changed a BUILD_XXX option! || depends
 
|-               
 
|-               
 
| CMAKE_INSTALL_PREFIX  || The output folder when building the target ''INSTALL'', see also section [[#Running and installing FreeCAD|Running and installing FreeCAD]] || Windows' default program installation folder
 
| CMAKE_INSTALL_PREFIX  || The output folder when building the target ''INSTALL'', see also section [[#Running and installing FreeCAD|Running and installing FreeCAD]] || Windows' default program installation folder
 
|-               
 
|-               
| FREECAD_COPY_LIBPACK_BIN_TO_BUILD || Copies the LibPack libraries needed to execute the FreeCAD.exe to the build folder. See also section [[#Running and installing FreeCAD|Running and installing FreeCAD]] || OFF
+
| FREECAD_COPY_DEPEND_DIRS_TO_BUILD || Copies the LibPack libraries needed to execute the FreeCAD.exe to the build folder. See also section [[#Running and installing FreeCAD|Running and installing FreeCAD]]. || OFF
 +
|-             
 +
| FREECAD_COPY_LIBPACK_BIN_TO_BUILD || Copies the LibPack binaries needed to execute the FreeCAD.exe to the build folder. See also section [[#Running and installing FreeCAD|Running and installing FreeCAD]]. || OFF
 
|-               
 
|-               
| FREECAD_LIBPACK_USE || Switch the usage of the FreeCAD LibPack on or off  || ON      
+
| FREECAD_LIBPACK_USE || Switch the usage of the FreeCAD LibPack on or off  || ON
 
|-               
 
|-               
 
| FREECAD_LIBPACK_DIR || Directory where the LibPack is || FreeCAD's source code folder
 
| FREECAD_LIBPACK_DIR || Directory where the LibPack is || FreeCAD's source code folder
 +
|-             
 +
| FREECAD_RELEASE_PDB || Create debug libraries also for release builds || ON
 
|}
 
|}
 
<!--T:12-->
 
If you are building with Qt Creator, jump to
 
[[#Building with Qt Creator|Building with Qt Creator]],
 
otherwise proceed to
 
[[#Building with Visual Studio 9 2008|Building with Visual Studio 9 2008]].
 
  
 
== Building FreeCAD == <!--T:81-->
 
== Building FreeCAD == <!--T:81-->
  
 
<!--T:125-->
 
<!--T:125-->
Depending on your current setup, the process for building FreeCAD will be slightly different. This is due to the differences in available software and software versions for each operating system.
+
Depending on your compiler, the process for building FreeCAD will be slightly different. In the following sections you known workflows are described.
 +
If you are building with Qt Creator, jump to [[#Building with Qt Creator|Building with Qt Creator]], otherwise proceed directly:
  
 +
</translate>
 +
<div class="mw-collapsible mw-collapsed toccolours">
 +
<translate>
  
<!--T:82-->
+
=== Building with Visual Studio 15 2017 === <!--T:154-->
The following procedure will work for compiling on Windows Vista/7/8, for XP an alternate VS tool set is required for VS 2012 and 2013, which has not been tested successfully with the current Libpacks. To target XP(both x32 and x64) it is recommended to use VS2008 and Libpack FreeCADLibs_11.0_x86_VC9.7z
 
  
 
</translate>
 
</translate>
 +
<div class="mw-collapsible-content">
 +
<translate>
 +
 +
<!--T:155-->
 +
# Start the Visual Studio IDE. This can either be done by pressing the button ''Open Project'' in the CMake GUI or by double-clicking on the file ''FreeCAD.sln'' that you find in your build folder.
 +
# In the toolbar of the MSVC IDE assure that you use for the first compilation ''Release''.
 +
# There is a window called ''Solution'' explorer. it lists all possible compilation targets.
 +
 +
<!--T:189-->
 +
To start a full compilation, right-click on the target ''ALL_BUILD'' and then choose '''Build'''.
 +
This will now take quite a long time.
 +
 +
<!--T:156-->
 +
To compile a ready-to use FreeCAD, compile the target ''INSTALL'', see section [[#Running and installing FreeCAD|Running and installing FreeCAD]].
 +
 +
<!--T:157-->
 +
If you don't get any errors you are done. '''Congratulations!''' You can exit MSVC or keep it open.
 +
</translate>
 +
</div>
 +
</div>
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<translate>
 
<translate>
Line 177: Line 279:
 
</div>
 
</div>
 
</div>
 
</div>
<div class="mw-collapsible mw-collapsed toccolours">
 
<translate>
 
 
=== Building with Visual Studio 9 2008 === <!--T:84-->
 
 
</translate>
 
<div class="mw-collapsible-content">
 
<translate>
 
 
<!--T:113-->
 
{{Note|Warning|Since early 0.17 cycle Freecad uses c++11 features that are not supported by 2008 version}}
 
 
</translate>
 
</div>
 
</div>
 
 
 
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<translate>
 
<translate>
Line 222: Line 307:
 
*** Uncheck: Always deploy project before running it
 
*** Uncheck: Always deploy project before running it
  
==== Import project and Build ==== <!--T:62-->
+
====Import project and building==== <!--T:62-->
  
 
<!--T:127-->
 
<!--T:127-->
Line 244: Line 329:
 
</div>
 
</div>
 
</div>
 
</div>
 
 
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<translate>
 
<translate>
  
=== Command line build === <!--T:66-->
+
===Command line build=== <!--T:66-->
  
 
</translate>
 
</translate>
Line 255: Line 338:
 
<translate>
 
<translate>
  
<!--T:114-->
+
<!--T:158-->
Here an example how to build FreeCAD from the Command line:
+
The steps how to compile from the command line depends on the compiler. For MSVC 2017 the steps are:
 +
# In Windows' start menu go to {{MenuCommand|Visual Studio 2017 → Visual Studio Tools}} and choose '''Developer Command Prompt for VS 2017'''
 +
# Change to your build folder.
 +
# Execute the command
  
 
</translate>
 
</translate>
{{Code|code=
+
{{Code|code=msbuild ALL_BUILD.vcxproj /p:Configuration=Release}}
rem @echo off
 
rem  Build script, uses vcbuild to completetly build FreeCAD
 
 
rem update trunc
 
d:
 
cd "D:\_Projekte\FreeCAD\FreeCAD_0.9"
 
"C:\Program Files (x86)\Subversion\bin\svn.exe" update
 
 
rem  set the aprobiated Variables here or outside in the system
 
 
set PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
 
set INCLUDE=
 
set LIB=
 
 
rem Register VS Build programms
 
call "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcvarsall.bat"
 
 
rem Set Standard include paths
 
set INCLUDE=%INCLUDE%;%FrameworkSDKDir%\include
 
set INCLUDE=%INCLUDE%;C:\Program Files\Microsoft SDKs\Windows\v6.0A\Include
 
 
rem Set lib Pathes
 
set LIB=%LIB%;C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib
 
set LIB=%LIB%;%PROGRAMFILES%\Microsoft Visual Studio\VC98\Lib
 
 
rem Start the Visuall Studio build process
 
"C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcpackages\vcbuild.exe" "D:\_Projekte\FreeCAD FreeCAD_0.9_build\FreeCAD_trunk.sln" /useenv
 
}}
 
</div>
 
</div>
 
 
 
 
<translate>
 
<translate>
  
== Running and installing FreeCAD == <!--T:139-->
+
<!--T:190-->
 +
or
  
<!--T:140-->
+
</translate>
There are 2 methods to run the compiled FreeCAD:
+
{{Code|code=msbuild INSTALL.vcxproj /p:Configuration=Release}}
# You execute the FreeCAD.exe that you find in your build folder in the subfolder ''bin''
+
<translate>
# You build the target ''INSTALL''
 
  
<!--T:141-->
+
<!--T:114-->
Method 2 is the simpler one because it automatically assures that all libraries needed to run the FreeCAD.exe are in the correct folder. The FreeCAD.exe and the libraries will be output in the folder you specified in the CMake variable ''CMAKE_INSTALL_PREFIX''.<br>
+
These steps can also be automaized. Here is for example a solution for MSVC 2017:
For FreeCAD 0.19 there is currently only one issue that requires your action:
+
# Download the script [https://forum.freecadweb.org/download/file.php?id=92135 compile-FC.txt].
# Download the file [https://forum.freecadweb.org/download/file.php?id=90273 qwindowsvistastyle.zip] from the FreeCAD forum.
+
# Rename it to ''compile-FC.bat''
# Create a new subfolder named ''styles'' in the ''bin'' folder.
+
# In Winddows' file explorer Shift+Right-click on your build folder and use from the context menu ''Command prompt here''.
# Extract the ZIP-file to this folder.
+
# Execute the command
This adds the necessary style to make FreeCAD look like a normal Win 10 program, otherwise it looks like in Windows 98.
 
  
<!--T:142-->
+
</translate>
For Method 1 you need to put the libraries into the ''bin'' folder of your build folder (where the FreeCAD.exe is). This can easily be done, by using the CMake variable option ''FREECAD_COPY_LIBPACK_BIN_TO_BUILD''.
+
{{Code|code=compile-FC install}}
 +
<translate>
  
== Building FreeCAD older than version 0.9 == <!--T:67-->
+
<!--T:191-->
 +
Instead of calling '''compile-FC''' with the option ''install'' you can also use ''debug'' or ''release'':
  
=== Using LibPack === <!--T:68-->
+
<!--T:192-->
 +
''debug'' &nbsp; - compile FreeCAD in debug configuration
  
<!--T:128-->
+
<!--T:193-->
To make it easier to get FreeCAD compiled, we provide a collection of all
+
''release'' - compile FreeCAD in release configuration
needed libraries. It's called the [[Third Party Libraries|LibPack]]. You can find it on the  [http://sourceforge.net/project/showfiles.php?group_id=49159 download page] on
 
sourceforge.
 
  
<!--T:26-->
+
<!--T:194-->
You need to set the following environment variables:
+
''install'' &nbsp;&nbsp; - compile FreeCAD in release configuration and create an install setup
  
<!--T:27-->
+
</translate>
:'''FREECADLIB''' = "D:\Wherever\LIBPACK"
+
</div>
 +
</div>
 +
<translate>
  
<!--T:28-->
+
==Running and installing FreeCAD== <!--T:139-->
:'''QTDIR''' = "%FREECADLIB%"
 
  
<!--T:29-->
+
<!--T:140-->
Add "%FREECADLIB%\bin" and "%FREECADLIB%\dll" to the system ''PATH'' variable. Keep in mind that you have to replace "%FREECADLIB%" with the path name, since Windows does not recursively replace environment variables.
+
There are 2 methods to run the compiled FreeCAD:
  
==== Directory setup in Visual Studio ==== <!--T:30-->
+
<!--T:195-->
 +
''Method 1'': You execute the FreeCAD.exe that you find in your build folder in the subfolder ''bin''
  
<!--T:129-->
+
<!--T:196-->
Some search path of Visual Studio need to be set.
+
''Method 2'': You build the target ''INSTALL''
To change them, use the menu ''Tools→Options→Directory
 
  
===== Includes ===== <!--T:31-->
+
<!--T:141-->
 +
Method 2 is the simpler one because it automatically assures that all libraries needed to run the FreeCAD.exe are in the correct folder. The FreeCAD.exe and the libraries will be output in the folder you specified in the CMake variable ''CMAKE_INSTALL_PREFIX''.
  
<!--T:130-->
+
<!--T:142-->
Add the following search path to the include path search list:
+
For Method 1 you need to put the libraries into the ''bin'' folder of your build folder (where the FreeCAD.exe is). This can easily be done:
* %FREECADLIB%\include
+
# Open the CMake GUI.
* %FREECADLIB%\include\Python
+
# Search there for the variable option ''FREECAD_COPY_DEPEND_DIRS_TO_BUILD'' and check it.
* %FREECADLIB%\include\boost
+
# Search there for the variable option ''FREECAD_COPY_LIBPACK_BIN_TO_BUILD'' and check it.
* %FREECADLIB%\include\xercesc
+
# Click on '''Configure'''. At the end of the configuration CMake will automatically copy the necessary libraries from the LibPack folder.
* %FREECADLIB%\include\OpenCascade
 
* %FREECADLIB%\include\OpenCV
 
* %FREECADLIB%\include\Coin
 
* %FREECADLIB%\include\SoQt
 
* %FREECADLIB%\include\QT
 
* %FREECADLIB%\include\QT\Qt3Support
 
* %FREECADLIB%\include\QT\QtCore
 
* %FREECADLIB%\include\QT\QtGui
 
* %FREECADLIB%\include\QT\QtNetwork
 
* %FREECADLIB%\include\QT\QtOpenGL
 
* %FREECADLIB%\include\QT\QtSvg
 
* %FREECADLIB%\include\QT\QtUiTools
 
* %FREECADLIB%\include\QT\QtXml
 
* %FREECADLIB%\include\Gts
 
* %FREECADLIB%\include\zlib
 
  
===== Libs ===== <!--T:32-->
+
<!--T:159-->
 +
For FreeCAD 0.19 there is currently only one issue that requires manual action:
 +
# Download the file [https://forum.freecadweb.org/download/file.php?id=90273 qwindowsvistastyle.zip] from the FreeCAD forum.
 +
# Create a new subfolder named ''styles'' in the ''bin'' folder (where the FreeCAD.exe is).
 +
# Extract the ZIP-file to this folder.
  
<!--T:131-->
+
<!--T:197-->
Add the following search path to the lib path search list:
+
This adds the necessary style to make FreeCAD look like a normal Win 10 program. Otherwise it looks like in Windows 98.
* %FREECADLIB%\lib
 
  
===== Executables ===== <!--T:33-->
+
==Updating the build== <!--T:160-->
  
<!--T:132-->
+
<!--T:161-->
Add the following search path to the executable path search list:
+
FreeCAD is very actively developed. Therefore its source code changes almost daily. New features are added and bugs are fixed. To benefit from these source code changes, you must rebuild your FreeCAD. This is done in two steps:
* %FREECADLIB%\bin
+
# Updating the source code
* TortoiseSVN binary installation directory, usually "C:\Programm Files\TortoiseSVN\bin", this is needed for a distribution build when ''SubWVRev.exe'' is used to extract the version number from Subversion.
+
# Recompilation
  
==== Python needed ==== <!--T:34-->
+
===Updating the source code=== <!--T:162-->
  
<!--T:133-->
+
====Using a frontend==== <!--T:163-->
During the compilation some Python scripts get executed. So the Python
 
interpreter has to function on the OS. Use a command box to check it. If
 
the Python library is not properly installed you will get an error message
 
like ''Cannot find python.exe''. If you use the LibPack you can also use the
 
python.exe in the bin directory.
 
  
==== Special for VC8 ==== <!--T:35-->
+
<!--T:164-->
 +
When using the [https://en.wikipedia.org/wiki/Comparison_of_Git_GUIs Git frontend] TortoiseGit:
 +
# Right-click on your FreeCAD source code folder in the Windows file explorer and select in the context menu '''Pull'''.
 +
# A dialog will appear. Select there what development branch you want to get. '''master''' is the main branch. Therefore use this unless you want to compile a special new feature from a branch that has not yet been merged to ''master''. (For more about Git branches, see [[Source_code_management#Git_development_process|Git development process]].)
  
<!--T:134-->
+
<!--T:198-->
When building the project with VC8, you have to change the link information for the WildMagic library, since you need a different version for VC6 and VC8. Both versions are supplied in ''LIBPACK/dll''. In the project properties for ''AppMesh'' change the library name for the ''wm.dll'' to the VC8 version. Take care to change it in Debug ''and'' Release configuration.
+
Finally click '''OK'''.
  
=== Compile === <!--T:36-->  
+
====Using the command line==== <!--T:165-->
  
<!--T:37-->
+
<!--T:166-->
After you conform to all prerequisites the compilation is - hopefully - only a mouse click in VC
+
Open a terminal (command prompt) and switch there to your source directory. Then type:
 
 
=== After Compiling === <!--T:38-->
 
 
 
<!--T:135-->
 
To get FreeCAD up and running from the compiler environment you need to copy a few files from the [[Third Party Libraries|LibPack]] to the ''bin'' folder where FreeCAD.exe is installed after a successful build:
 
 
 
<!--T:39-->
 
* ''python.exe'' and ''python_d.exe'' from ''LIBPACK/bin''
 
* ''python25.dll'' and ''python25_d.dll'' from ''LIBPACK/bin''
 
* ''python25.zip'' from ''LIBPACK/bin''
 
* make a copy of ''Python25.zip'' and rename it to ''Python25_d.zip''
 
* ''QtCore4.dll'' from ''LIBPACK/bin''
 
* ''QtGui4.dll'' from ''LIBPACK/bin''
 
* ''boost_signals-vc80-mt-1_34_1.dll'' from ''LIBPACK/bin''
 
* ''boost_program_options-vc80-mt-1_34_1.dll'' from ''LIBPACK/bin''
 
* ''xerces-c_2_8.dll'' from ''LIBPACK/bin''
 
* ''zlib1.dll'' from ''LIBPACK/bin''
 
* ''coin2.dll'' from ''LIBPACK/bin''
 
* ''soqt1.dll'' from ''LIBPACK/bin''
 
* ''QtOpenGL4.dll'' from ''LIBPACK/bin''
 
* ''QtNetwork4.dll'' from ''LIBPACK/bin''
 
* ''QtSvg4.dll'' from ''LIBPACK/bin''
 
* ''QtXml4.dll'' from ''LIBPACK/bin''
 
 
 
<!--T:40-->
 
When using a [[Third Party Libraries|LibPack]] with a Python version older than 2.5 you have to copy two further files:
 
* ''zlib.pyd'' and ''zlib_d.pyd'' from ''LIBPACK/bin/lib''. This is needed by python to open the zipped python library.
 
* ''_sre.pyd'' and ''_sre_d.pyd'' from ''LIBPACK/bin/lib''. This is needed by python for the built in help system.
 
 
 
<!--T:41-->
 
If you don't get it running due to a Python error it is very likely that one of the ''zlib*.pyd'' files is missing.
 
 
 
<!--T:107-->
 
Alternatively, you can copy the whole bin folder of libpack into bin folder of the build. This is easier, but takes time and disk space. This can be substited by making links instead of copying files, see [[CompileOnWindows - Reducing Disk Footprint#avoiding copying any libpack files to launch FreeCAD|CompileOnWindows - Reducing Disk Footprint]].
 
 
 
=== Additional stuff === <!--T:42-->
 
 
 
<!--T:43-->
 
If you whant to build the source code documentation you need [http://www.stack.nl/~dimitri/doxygen/ DoxyGen].
 
 
 
<!--T:44-->
 
To create an intstaller package you need [http://wix.sourceforge.net/ WIX].
 
 
 
<!--T:45-->
 
During the compilation some Python scripts get executed. So the Python interpreter has to work properly.
 
 
 
<!--T:46-->
 
For more details have also a look to ''README.Linux'' in your sources.
 
 
 
<!--T:47-->
 
First of all you should build the Qt plugin that provides all custom widgets of FreeCAD we need for the Qt Designer. The sources are located under
 
 
 
</translate>
 
{{Code|code=
 
//src/Tools/plugins/widget//.
 
}}
 
<translate>
 
 
 
<!--T:48-->
 
So far we don't provide a makefile -- but calling
 
</translate>
 
{{Code|code=
 
qmake plugin.pro
 
}}
 
 
 
<translate>
 
<!--T:49-->
 
creates it. Once that's done, calling ''make'' will create the library
 
  
 
</translate>
 
</translate>
 
{{Code|code=
 
{{Code|code=
//libFreeCAD_widgets.so//.
+
git pull https://github.com/FreeCAD/FreeCAD.git master
 
}}
 
}}
 
<translate>
 
<translate>
  
<!--T:50-->
+
<!--T:167-->
To make this library known to your ''Qt Designer'' you have to copy the file to
+
where ''master'' the the name of the main development branch. If you want to get code from another branch, use its name instead of ''master''.
  
</translate>
+
===Recompilation=== <!--T:168-->
{{Code|code=
 
//$QTDIR/plugin/designer//.
 
}}
 
  
<translate>
+
<!--T:169-->
 +
# Open the MSVC IDE by double-clicking either on the file ''FreeCAD.sln'' or on the file ''ALL_BUILD.vcxproj'' in your build folder.
 +
# Continue with step 2 from section [[#Building_with_Visual_Studio_15_2017|Building with Visual Studio 15 2017]].
  
 
== References == <!--T:115-->
 
== References == <!--T:115-->
  
 +
<!--T:74-->
 +
See also
 +
* [[Compile_on_Windows_with_VS2013|Compile on Windows with Visual Studio 2013]]
 +
* [[Compiling_(Speeding_up)|Compiling - Speeding up]]
  
 
<!--T:69-->
 
<!--T:69-->
{{docnav|Tracker|CompileOnUnix}}
+
{{docnav
 +
|[[Tracker|Tracker]]
 +
|[[Compile_on_Linux/Unix|Compile on Linux/Unix]]
 +
}}
  
 
<!--T:110-->
 
<!--T:110-->

Revision as of 14:57, 19 November 2019

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe

This page explains step by step how to compile FreeCAD 0.18 or newer on Windows.

Prerequisites

At first you must install the following required programs ad libraries:

Required

  • Git (There are also a GUI frontends available for Git, see the next section.)
  • CMake version 3.11.x - 3.14.x. Note: Usually one cannot take the latest CMake version. Therefore only use a CMake version in the range specified on this page!

It is recommended to use the option Add CMake to the system PATH for all users when installing CMake. Then you can later easily access CMake also from the command line/powershell.

  • LibPack (also called FreeCADLibs). This is a set of libraries necessary to compile FreeCAD on Windows. Depending on the FreeCAD version you want to compile, you must download the corresponding LibPack. For example to compile FreeCAD 0.18, download either the 32bit or the 64bit version of the LibPack for 0.18, to compile the latest development version 0.19, download the LibPack for 0.19 (there is only a 64bit version).

Just download the LibPack, you will unpack and set it up later.

Note: It is recommended to use the same compiler MS Visual Studio (MSVC) version the LibPack is designed for. This assures that the compilation and the execution of the compiled FreeCAD.exe succeeds. So you should for example be able to compile FreeCAD 0.18 using the LibPack for 0.19 and MSVC 15 but you you might get problems compiling FreeCAD 0.18 using the LibPack for 0.18 and MSVC 15 because the LibPack for 0.18 is designed to be built with MSVC 12.

Optional programs

  • Python 3.x. A separate python installation is not mandatory since the LibPack contains Python. However, to be able to test later your FreeCAD build it is useful to have a standalone Python installation. It is recommended to use not the latest version, but the prior version (e.g. not Python 3.7 but 3.6).
  • A GUI frontend for Git. There are several frontends available, see this list. The main benefit of a frontend is that you don't have to learn the Git commands to get the source code of FreeCAD or to send patches to the GitHub repository of FreeCAD.

In the following we describe source code handling using the frontend TortoiseGit. This frontend integrates directly to Windows file explorer and has a large user community to get help in case you have problems.

  • NSIS This is the program to generate the Windows installer of FreeCAD. (Information: For FreeCAD 0.17 and older the program WiX was used to create the installer.)

Source code

Now you can get the source code of FreeCAD:

Using a frontend

When using the Git frontend TortoiseGit:

  1. Create a new folder where the source code should be.
  2. Right-click on this folder in the Windows file explorer and select in the context menu Git Clone.
  3. A dialog will appear. Use there as URL for the FreeCAD repository

https://github.com/FreeCAD/FreeCAD.git

and click OK.

Now the source code is downloaded and its folder becomes a folder tracked by Git.

Using the command line

To create a local tracking branch and download the source code, open a terminal (command prompt) and switch there to the directory you want the source, then type:

git clone https://github.com/FreeCAD/FreeCAD.git

Compiler

The default (recommended) compiler is MS Visual Studio (MSVC). Though it may be possible to use other compilers using Cygwin or MinGW gcc it is not tested or ported so far.

You can get a free version of MSVC (for OpenSource usage) by downloading the Community edition of MS Visual Studio. To do so, use this URL

https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=xx

where xx is the version number. So to get MSVC 15 (calso called MSVC 2017), use this URL:

https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=15

For those who want to avoid installing the huge MSVC for the mere purpose of having a compiler, see CompileOnWindows - Reducing Disk Footprint.

Note: Despite that the Community edition of MSVC is free, you must create a Microsoft account from withing the MSVC IDE that you can use the IDE for more than 30 days. If you will only compile using the command line, you don't need the IDE and thus no Microsoft account.

As free and OpenSource alternative IDE you can use KDevelop. You can use KDevelop to modify and write C++ code but must use the command line to compile.

Optional system path configuration

Optionally you can include the paths to some folders to the system PATH variable. This is helpful if you want to access programs in these folders from the command line/powershell or if you want special programs to be found by the compiler or CMake. Besides this, adding folders to the PATH might be necessary if you did not use the corresponding options when installing the program.

  • You can include the folder of your LibPack in your system PATH variable. This is useful if you plan to build multiple configurations/versions of FreeCAD.
  • If you did not use the option to add CMake to the PATH while installing it, add its installation folder

C:\Program Files\CMake\bin to the PATH.

  • If you did not use the option to add TortoiseGit to the PATH while installing it, add its installation folder

C:\Program Files\TortoiseGit\bin to the PATH.

To add folder paths to the PATH variable:

  1. In the Windows Start menu Right click on Computer and choose Properties.
  2. In the appearing dialog click on Advanced system settings.
  3. Another dialog will open. Click there in the tab Advanced on Environment Variables.
  4. Again another dialog will open. Select then the variable Path and click on Edit.
  5. And again another dialog will open. Click there on New and add to path to the folder of Git or the LibPack.
  6. Finally press OK and close all dialogs by pressing OK as well.

Configuration

LibPack

At first you need to setup a build folder:

  1. Create a new folder where the compiled FreeCAD should be. It is highly recommended that this folder is not inside the source code folder of FreeCAD.
  2. Create there a new subfolder for the LibPack. Note: The name of this subfolder must be the same as the LibPack file name. If e.g. the LibPack has the filename FreeCADLibs_12.1.2_x64_VC15.7z, you must name the subfolder FreeCADLibs_12.1.2_x64_VC15.
  3. Extract the LibPack to this subfolder.

CMake

Now you need to configure the build environment using CMake:

  1. Open the CMake GUI
  2. Specify there the source folder of FreeCAD
  3. Specify the build folder you just created in the previous step.
  4. Click Configure
  5. In the appearing dialog specify the generator according to the one you want to use. For the standard MS Visual Studio use Visual Studio xx 2yyy where xx is the compiler version ad yyy the year of its release. It is recommended to use the default option Use default native compilers.

Note: It is important to specify the correct bit variant. If you have the 64bit variant of LibPack you must also use the x64 compiler.

This will begin the configuration and will fail because of missing settings.

If it fails with the message that Visual Studio could not be found the CMake support in MSVC is not yet installed. To do this:

  1. Open the MSVC IDE
  2. Use the menu Tools → Get Tools and Features
  3. In the Workloads tab enable Desktop development with C++
  4. On the right side you should now see that the component Visual C++ tools for CMake will be installed.
  5. Install it.

If there is no error about Visual Studio, everything is fine, but CMake does not yet know all necessary settings. Therefore now:

  1. Assure that the search option Advanced is checked.
  2. Search in CMake for the variable FREECAD_LIBPACK_DIR and specify there the correct location to the LibPack folder.
  3. Search for the variable BUILD_QT5 and enable this option.
  4. Click Configure again

There should now be no errors. If so, click on Generate. After this is done you could close CMake and continue to start the compilation of FreeCAD. However, for the first compilation keep it open for the case that you want or need to change some options for the build process:

Options for the build process

The CMake build system gives you the flexibility over the build process. That means you can switch on and off some features or modules by CMake variables.

Here is a description for some of these variables:

Variable name Description Default
BUILD_XXX Build FreeCAD with the component XXX. If you don't want/need to compile e.g. the workbench OpenSCAD, disable the variable BUILD_OPENSCAD. FreeCAD will then not have this workbench.

Note: Some components are required for other components. If you for example uncheck BUILD_ROBOT CMake will inform you that then the component Path cannot be compiled correctly. Therefore check the CMake output after you changed a BUILD_XXX option! || depends

CMAKE_INSTALL_PREFIX The output folder when building the target INSTALL, see also section Running and installing FreeCAD Windows' default program installation folder
FREECAD_COPY_DEPEND_DIRS_TO_BUILD Copies the LibPack libraries needed to execute the FreeCAD.exe to the build folder. See also section Running and installing FreeCAD. OFF
FREECAD_COPY_LIBPACK_BIN_TO_BUILD Copies the LibPack binaries needed to execute the FreeCAD.exe to the build folder. See also section Running and installing FreeCAD. OFF
FREECAD_LIBPACK_USE Switch the usage of the FreeCAD LibPack on or off ON
FREECAD_LIBPACK_DIR Directory where the LibPack is FreeCAD's source code folder
FREECAD_RELEASE_PDB Create debug libraries also for release builds ON

Building FreeCAD

Depending on your compiler, the process for building FreeCAD will be slightly different. In the following sections you known workflows are described. If you are building with Qt Creator, jump to Building with Qt Creator, otherwise proceed directly:

Building with Visual Studio 15 2017

  1. Start the Visual Studio IDE. This can either be done by pressing the button Open Project in the CMake GUI or by double-clicking on the file FreeCAD.sln that you find in your build folder.
  2. In the toolbar of the MSVC IDE assure that you use for the first compilation Release.
  3. There is a window called Solution explorer. it lists all possible compilation targets.

To start a full compilation, right-click on the target ALL_BUILD and then choose Build. This will now take quite a long time.

To compile a ready-to use FreeCAD, compile the target INSTALL, see section Running and installing FreeCAD.

If you don't get any errors you are done. Congratulations! You can exit MSVC or keep it open.

Building with Visual Studio 12 2013

Make sure to specify Visual Studio 12 x64(or the alternate C-Compiler you are using) as the generator in CMake before you continue.

  • Start Visual Studio 12 2013 by clicking on the desktop icon created at installation.
  • Open the project by:

File → Open → Project/Solution

  • Open FreeCAD_Trunk.sln from the build folder CMake created
  • Switch the Solutions Configuration drop down at the top to Release X64

This may take a while depending on your sytem

  • Build → Build Solution
  • This will take a long time...

If you don't get any errors you are done. Exit Visual Studio and start FreeCAD by double clicking the FreeCAD icon in the bin folder of the build directory.

Building with Qt Creator

Installation and configuration of Qt Creator

  • Download and install Qt Creator
  • Tools → Options → Text Editor → Behavior tab:
    • File Encodings → Default Encodings:
    • Set to: ISO-8859-1 /...csISOLatin1 (Certain characters create errors/warnings with Qt Creator if left set to UTF-8. This seems to fix it.)
  • Tools → Options → Build & Run:
    • CMake tab
      • Fill Executable box with path to cmake.exe
    • Kits tab
      • Name: MSVC 2008
      • Compiler: Microsoft Visual C++ Compiler 9.0 (x86)
      • Debugger: Auto detected...
      • Qt version: None
    • General tab
      • Uncheck: Always build project before deploying it
      • Uncheck: Always deploy project before running it

Import project and building

  • File → Open File or Project
  • Open CMakeLists.txt which is in the top level of the source
  • This will start CMake
  • Choose build directory and click next
  • Set generator to NMake Generator (MSVC 2008)
  • Click Run CMake. Follow the instructions depicted above to configure CMake to your liking.

Now FreeCAD can be built

  • Build → Build All
  • This will take a long time...

Once complete, it can be run: There are 2 green triangles at the bottom left. One is debug. The other is run. Pick whichever you want.

Command line build

The steps how to compile from the command line depends on the compiler. For MSVC 2017 the steps are:

  1. In Windows' start menu go to Visual Studio 2017 → Visual Studio Tools and choose Developer Command Prompt for VS 2017
  2. Change to your build folder.
  3. Execute the command
msbuild ALL_BUILD.vcxproj /p:Configuration=Release

or

msbuild INSTALL.vcxproj /p:Configuration=Release

These steps can also be automaized. Here is for example a solution for MSVC 2017:

  1. Download the script compile-FC.txt.
  2. Rename it to compile-FC.bat
  3. In Winddows' file explorer Shift+Right-click on your build folder and use from the context menu Command prompt here.
  4. Execute the command
compile-FC install

Instead of calling compile-FC with the option install you can also use debug or release:

debug   - compile FreeCAD in debug configuration

release - compile FreeCAD in release configuration

install    - compile FreeCAD in release configuration and create an install setup

Running and installing FreeCAD

There are 2 methods to run the compiled FreeCAD:

Method 1: You execute the FreeCAD.exe that you find in your build folder in the subfolder bin

Method 2: You build the target INSTALL

Method 2 is the simpler one because it automatically assures that all libraries needed to run the FreeCAD.exe are in the correct folder. The FreeCAD.exe and the libraries will be output in the folder you specified in the CMake variable CMAKE_INSTALL_PREFIX.

For Method 1 you need to put the libraries into the bin folder of your build folder (where the FreeCAD.exe is). This can easily be done:

  1. Open the CMake GUI.
  2. Search there for the variable option FREECAD_COPY_DEPEND_DIRS_TO_BUILD and check it.
  3. Search there for the variable option FREECAD_COPY_LIBPACK_BIN_TO_BUILD and check it.
  4. Click on Configure. At the end of the configuration CMake will automatically copy the necessary libraries from the LibPack folder.

For FreeCAD 0.19 there is currently only one issue that requires manual action:

  1. Download the file qwindowsvistastyle.zip from the FreeCAD forum.
  2. Create a new subfolder named styles in the bin folder (where the FreeCAD.exe is).
  3. Extract the ZIP-file to this folder.

This adds the necessary style to make FreeCAD look like a normal Win 10 program. Otherwise it looks like in Windows 98.

Updating the build

FreeCAD is very actively developed. Therefore its source code changes almost daily. New features are added and bugs are fixed. To benefit from these source code changes, you must rebuild your FreeCAD. This is done in two steps:

  1. Updating the source code
  2. Recompilation

Updating the source code

Using a frontend

When using the Git frontend TortoiseGit:

  1. Right-click on your FreeCAD source code folder in the Windows file explorer and select in the context menu Pull.
  2. A dialog will appear. Select there what development branch you want to get. master is the main branch. Therefore use this unless you want to compile a special new feature from a branch that has not yet been merged to master. (For more about Git branches, see Git development process.)

Finally click OK.

Using the command line

Open a terminal (command prompt) and switch there to your source directory. Then type:

git pull https://github.com/FreeCAD/FreeCAD.git master

where master the the name of the main development branch. If you want to get code from another branch, use its name instead of master.

Recompilation

  1. Open the MSVC IDE by double-clicking either on the file FreeCAD.sln or on the file ALL_BUILD.vcxproj in your build folder.
  2. Continue with step 2 from section Building with Visual Studio 15 2017.

References

See also