Basic modeling tutorial

From FreeCAD Documentation
Revision as of 19:04, 26 March 2014 by Honza32 (talk | contribs)
Jump to: navigation, search

Tento Výukový program základního modelování Vám ukáže jak vymodelovat ocelový úhelník. Měli byste vědět že FreeCAD je modulární při konstruování a jako mnoho jiných CAD programů má vždy více než jednu možnost jak věci dělat. Zde si projdeme dvě metody.

Než začneme

Mějte na mysli, že FreeCAD je stále v ranné fázi vývoje a proto nemůže být zatím tak produktivní jako jiné CAD aplikace a určitě se setkáte s chybami nebo si vyzkoušíte pády aplikace. FreeCAD už má možnost ukládat záložní soubory. Počet těchto záložních souborů může být specifikován v dialogovém okně předvoleb. Neváhejte použít 2 až 3 záložní soubory dokud nebudete umět s FreeCADem dobře pracovat.

Rozdělanou práci ukládejte často a občas ji uložte pod jiným jménem, získáte tak "bezpečnou" kopii, abyste se mohli vrátit k použitelné verzi Vašeho modelu a byli tak připraveni na možnost, že některé příkazy nevrátí očekávané výsledky.

Úvod do modelovacích technik

První (a základní) technika modelování těles je Constructive Solid Geometry (CSG). Pracujete se základními tvary jako jsou kostky, válce, koule a kužely a konstruujete z nich požadované tvary jejich kombinací, odečítáním jednoho tvaru od druhého nebo jejich protínáním. Tyto nástroje jsou součástí Pracovní plochy Díl. Můžete také uplatnit transformace tvarů, jako jsou zaoblení nebo úkosy hran. Tyto nástroje jsou také v Pracovní ploše Díl.

Potom jsou zde také další pokročilé nástroje. Začnete kreslením 2D profilů, které potom vysunete nebo obtočíte.

Takže začněme tak, že si vyzkoušíme udělat nějaké železné nohy ke stolu pomocí těchto dvou metod.

1.metoda - Konstrukční geometrie těles

  • Začněte na pracovní ploše Díl (menu Pohled > Pracovní plocha > Díl)
  • Klikněte na tlačítko Part Box.png Box pro vytvoření boxu (kostky)
  • Změnte jho rozměry tak, že jej vyberete buď ve 3D prostoru nebo kliknutím na něj v záložce Projektu vlevo, potom
  • klikněte na záložku Data dole v okně Projektu a změňte hodnoty výšky, délky a šířky na 750mm, 50 a 50 (viz. Obr. 1.1)
  • Stejným způsobem vytvořte druhý box, ale s hodnotami 750, 40 a 40mm. Ve výchozím postavení bude tento box překrývat ten první. (viz. Obr. 1.2)
  • Teď odečtete druhý box od prvního. Vyberte ten první (nazvaný Box), potom druhý (nazvaný Box001), pozor, pořadí výběru je důležitét! (ujistěte se, že oba tvary jsou vybrány v okně stromu projektu. Pamatujte si jednu věc: v navigačním módu Invertor - Vynálezce, nefunguje kombinace Ctrl + klik pro vícenásobný výběr. Switch to either CAD or Blender selection.)
  • On the Part Workbench toolbar, click on the Part Cut.png Cut tool.
Fig. 1.1 The first box
Fig. 1.2 The second box on top of the first one, ready to be subtracted
Fig. 1.3 After the subtraction

You now have your first iron angle (Fig. 1.3). You'll notice that, in the Project tab on the left, both boxes have been replaced by a "Cut" object. Actually, they're not disappeared, but rather grouped under the Cut object. Click on the + in front of it, and you'll see that both boxes are still there, but greyed out (Fig. 1.4). If you click on either of them and hit the space bar, it will show up. The space bar toggles visibility of selected objects. (Fig. 1.5)

Don't want the angle oriented that way? You just need to change the placement of the Box001 shape. Select it, unhide it, and in the Data tab, click on the + in front of Placement, then expand the Position parameter, and change its X and Y coordinates. Hit Enter, hide the Box001 shape again, and your angle orientation is now different. (Fig. 1.5) You can even change either of your shapes dimensions, and the Cut object will be updated.

Fig. 1.4 The cut operation retains its original objects (the boxes)
Fig. 1.5 You can still make the original boxes visible

By the way, we can add rounds to the angle so it is more realistic, using the Part Fillet.png Fillet tool. (Fig. 1.6)

Fig. 1.6 The filleted edges

2nd Method - By extruding a profile

This method requires that you start by drawing a 2D profile. You need to activate the 2d Drafting workbench (View > Workbench > 2d Draft menu).

Next we need to set the working plane. Depending on your FreeCAD version, you'll have right under the toolbar, on the right, a "None" button. Click it, and on the left will appear right after "active command": Select Plane Offset, then a text field and a series of buttons. Assuming you want to start your profile on the plan view, select XY. The "None" button will now show "Top" as active plane. See note.

Select the Draft Wire.png Wire (multiple-point line) tool, then start drawing a shape, using the text fields for X and Y positions. The "Relative" box should be checked, as well as the "Filled" box.

  • 1st point: 0,0
  • 2nd point: 50,0
  • 3rd point: 0,10
  • 4th point: -40,0
  • 5th point: 0,40
  • 6th point: -10,0
  • No 7th point, rather click on the "Close" button to close the profile. You should now have this profile, titled "Wire" in the Project tab:
Fig. 1.7 The base wire

Hit the zero key on the numpad to set the view to axonometric.

Activate the Part Workbench.

Click on the Part Extrude.png Extrude tool.

On the Tasks tab on the left, select the Wire object. Then enter the desired length, say 750mm. Leave the direction at Z. Click Apply. You should now have an Extrude object in the Project tab (fig. 1.8)

Fig. 1.8 The extruded object

This method has a minor caveat compared to the other one: to edit the shape, you need to edit the Wire, it's not as easy to do as the previous method.

And there are a few other ways to do it too! I hope these two examples get you started. You'll sure hit some snags along the way (I did when I first learned FreeCAD, and I do have 3D CAD experience ;) ), but don't hesitate to ask questions on the FreeCAD forum!

Note on Draft working plane button:

The label on your button may be different, depending on your version and also on what you were doing beforehand. The button label could read: "top", "front", "side", "None" or a Vector representation such as d(0.0,0.0,1.0). It can also be blank. For example:

Select Plane None
Select Plane Top
Select Plane View


The above instructions will work, no matter what label your button has.

Available translations of this page: Flag-es.jpg Flag-fr.jpg Flag-it.jpg