Difference between revisions of "Basic modeling tutorial/cs"

From FreeCAD Documentation
Jump to: navigation, search
Line 26: Line 26:
 
* On the Part Workbench toolbar, click on the [[Image:Part_Cut.png|32px]] [[Part_Cut|Cut]] tool.
 
* On the Part Workbench toolbar, click on the [[Image:Part_Cut.png|32px]] [[Part_Cut|Cut]] tool.
  
[[Image:Tutorial-normand01.jpg|center|frame|Fig. 1.1 The first box]]
+
[[Image:Tutorial-normand01.jpg|center|frame|Obr. 1.1 První box]]
  
[[Image:Tutorial-normand02.jpg|center|frame|Fig. 1.2 The second box on top of the first one, ready to be subtracted]]
+
[[Image:Tutorial-normand02.jpg|center|frame|Obr. 1.2 Druhý box na prvním, připraven k odečtení]]
  
[[Image:Tutorial-normand03.jpg|center|frame|Fig. 1.3 After the subtraction]]
+
[[Image:Tutorial-normand03.jpg|center|frame|Obr. 1.3 Po odečtení]]
  
You now have your first iron angle ''(Fig. 1.3)''. You'll notice that, in the Project tab on the left, both boxes have been replaced by a "Cut" object. Actually, they're not disappeared, but rather grouped under the Cut object. Click on the + in front of it, and you'll see that both boxes are still there, but greyed out ''(Fig. 1.4)''. If you click on either of them and hit the space bar, it will show up. The space bar toggles visibility of selected objects. ''(Fig. 1.5)''
+
Nyní máte Váš první železný úhelník ''(Obr. 1.3)''. všimněte si, že v okně stromu projektu vlevo byly oba boxy přepsány objektem "Cut". Ve skutečnosti nezmizely, ale jsou seskupeny pod objektem Cut. Klikněte na + před nimi a uvidíte, že oba boxy jsou stále zde, ale zbarveny šedě ''(Obr. 1.4)''. Když kliknete na některý z nich a stisknete klávesu mezerník, tak se ukáže. Mezerník přepíná viditelnost vybraných objektů. ''(Obr. 1.5)''
  
Don't want the angle oriented that way? You just need to change the placement of the Box001 shape. Select it, unhide it, and in the Data tab, click on the + in front of Placement, then expand the Position parameter, and change its X and Y coordinates. Hit Enter, hide the Box001 shape again, and your angle orientation is now different. ''(Fig. 1.5)'' You can even change either of your shapes dimensions, and the Cut object will be updated.
+
Nechcete úhelník orientovaný takto? Potřebujete pouze změnit umístění boxu Box001. Vyberte jej, mezerníkem zviditelněte a v záložce Data klikněte na + před Umístěním a potom rozbalte parametr Pozice a změňte jeho souřadnice X a Y. Stiskněte ENTER, opět skryjte Box001 a orientace Vašeho úhelníku je nyní jiná. ''(Obr. 1.5)'' Můžete změnit i rozměry tvaru a objekt Cut bude aktualizován.
  
[[Image:Tutorial-normand04.jpg|center|frame|Fig. 1.4 The cut operation retains its original objects (the boxes)]]
+
[[Image:Tutorial-normand04.jpg|center|frame|Obr. 1.4 Operace odečtení ponechá její původní objekty (boxy)]]
  
[[Image:Tutorial-normand05.jpg|center|frame|Fig. 1.5 You can still make the original boxes visible]]
+
[[Image:Tutorial-normand05.jpg|center|frame|Obr. 1.5 Stále ještě můžete objekty zviditelnit]]
  
By the way, we can add rounds to the angle so it is more realistic, using the [[Image:Part_Fillet.png|32px]] [[Part_Fillet|Fillet]] tool. ''(Fig. 1.6)''
+
Mimochodem, můžeme přidat zaoblení, tak bude úhelník více realistický. Použijeme nástroj [[Image:Part_Fillet.png|32px]] [[Part_Fillet/cs|Zaoblení]]. ''(Obr. 1.6)''
  
[[Image:Tutorial-normand06.jpg|center|frame|Fig. 1.6 The filleted edges]]
+
[[Image:Tutorial-normand06.jpg|center|frame|Obr. 1.6 Zaoblené hrany]]
  
== 2nd Method - By extruding a profile ==
+
== 2.metoda - Vysunutí profilu ==
  
This method requires that you start by drawing a 2D profile. You need to activate the [[Draft Workbench|2d Drafting workbench]] ('''View > Workbench > 2d Draft''' menu).
+
Tato metoda vyžaduje začít kreslení 2D profilu. Musíte aktivovat [[Draft Workbench/cs|pracovní plocha 2D Kreslení]] (menu '''Pohled > Pracovní plocha > 2D Kreslení''').
  
Next we need to set the [[Draft_SelectPlane|working plane]]. Depending on your FreeCAD version, you'll have right under the toolbar, on the right, a "None" button. Click it, and on the left will appear right after "active command": Select Plane Offset, then a text field and a series of buttons. Assuming you want to start your profile on the plan view, select XY. The "None" button will now show "Top" as active plane.
+
Dále potřebujeme nastavit [[Draft_SelectPlane/cs|pracovní rovinu]]. Podle verze FreeCADu máte přímo pod nástrojovým pruhem vpravo tlačítko "None". Klikněte na ně a vlevo se objeví hned za "aktivní příkaz": Vyberte rovinu Odstup, potom textové pole a několik dalších tlačítek. Předpokládejme, že chcete začít profil v půdorysu, stiskněte XY. Tlačítko "None" nyní bude ukazovat "Top" jako aktivní rovinu.
[[#DraftPlaneButton|See note.]]
+
[[#DraftPlaneButton|Podívejte se na poznámku.]]
 
      
 
      
Select the [[Image:Draft_Wire.png]] [[Draft_Wire|Wire (multiple-point line)]] tool, then start drawing a shape, using the text fields for X and Y positions. The "Relative" box should be checked, as well as the "Filled" box.
+
Vyberte nástroj [[Image:Draft_Wire.png]] [[Draft_Wire/cs|Drát (lomená čára)]], potom začněte kreslit tvar použitím textových polí pro pozice X a Y. Mělo by být zakliknuto políčko "Relativně" i políčko "Vyplněno".
  
* 1st point: 0,0
+
* 1. bod: 0,0
* 2nd point: 50,0
+
* 2. bod: 50,0
* 3rd point: 0,10
+
* 3. bod: 0,10
* 4th point: -40,0
+
* 4. bod: -40,0
* 5th point: 0,40
+
* 5. bod: 0,40
* 6th point: -10,0
+
* 6. bod: -10,0
* No 7th point, rather click on the "Close" button to close the profile. You should now have this profile, titled "Wire" in the Project tab:
+
* 7. bod nebudeme zadávat, lepší je kliknout na tlačítko "Uzavřít" pro uzavření profilu. Teď bychom měli mít profil, označený "Drát" v záložce okna stromu projektu:
  
[[Image:Tutorial-normand07.jpg|center|frame|Fig. 1.7 The base wire]]  
+
[[Image:Tutorial-normand07.jpg|center|frame|Obr. 1.7 Základní drát]]  
  
Hit the zero key on the numpad to set the view to axonometric.
+
Na numerické klávesnici stiskněte nulu a nasatvíte axonometrický pohled.
  
Activate the [[Part Workbench]].
+
Aktivujte [[Part Workbench/cs|pracovní plochu Díl]].
  
Click on the [[Image:Part_Extrude.png|32px]] [[Part_Extrude|Extrude]] tool.
+
Klikněte na nástroj [[Image:Part_Extrude.png|32px]] [[Part_Extrude/cs|Vysunout]].
  
 
On the Tasks tab on the left, select the '''Wire''' object. Then enter the desired length, say 750mm. Leave the direction at Z. Click Apply. You should now have an '''Extrude''' object in the Project tab ''(fig. 1.8)''
 
On the Tasks tab on the left, select the '''Wire''' object. Then enter the desired length, say 750mm. Leave the direction at Z. Click Apply. You should now have an '''Extrude''' object in the Project tab ''(fig. 1.8)''
  
[[Image:Tutorial-normand08.jpg|center|frame|Fig. 1.8 The extruded object]]
+
[[Image:Tutorial-normand08.jpg|center|frame|Obr. 1.8 The extruded object]]
  
 
This method has a minor caveat compared to the other one: to edit the shape, you need to edit the Wire, it's not as easy to do as the previous method.
 
This method has a minor caveat compared to the other one: to edit the shape, you need to edit the Wire, it's not as easy to do as the previous method.

Revision as of 21:10, 26 March 2014

Tento Výukový program základního modelování Vám ukáže jak vymodelovat ocelový úhelník. Měli byste vědět že FreeCAD je modulární při konstruování a jako mnoho jiných CAD programů má vždy více než jednu možnost jak věci dělat. Zde si projdeme dvě metody.

Než začneme

Mějte na mysli, že FreeCAD je stále v ranné fázi vývoje a proto nemůže být zatím tak produktivní jako jiné CAD aplikace a určitě se setkáte s chybami nebo si vyzkoušíte pády aplikace. FreeCAD už má možnost ukládat záložní soubory. Počet těchto záložních souborů může být specifikován v dialogovém okně předvoleb. Neváhejte použít 2 až 3 záložní soubory dokud nebudete umět s FreeCADem dobře pracovat.

Rozdělanou práci ukládejte často a občas ji uložte pod jiným jménem, získáte tak "bezpečnou" kopii, abyste se mohli vrátit k použitelné verzi Vašeho modelu a byli tak připraveni na možnost, že některé příkazy nevrátí očekávané výsledky.

Úvod do modelovacích technik

První (a základní) technika modelování těles je Constructive Solid Geometry (CSG). Pracujete se základními tvary jako jsou kostky, válce, koule a kužely a konstruujete z nich požadované tvary jejich kombinací, odečítáním jednoho tvaru od druhého nebo jejich protínáním. Tyto nástroje jsou součástí Pracovní plochy Díl. Můžete také uplatnit transformace tvarů, jako jsou zaoblení nebo úkosy hran. Tyto nástroje jsou také v Pracovní ploše Díl.

Potom jsou zde také další pokročilé nástroje. Začnete kreslením 2D profilů, které potom vysunete nebo obtočíte.

Takže začněme tak, že si vyzkoušíme udělat nějaké železné nohy ke stolu pomocí těchto dvou metod.

1.metoda - Konstrukční geometrie těles

  • Začněte na pracovní ploše Díl (menu Pohled > Pracovní plocha > Díl)
  • Klikněte na tlačítko Part Box.png Box pro vytvoření boxu (kostky)
  • Změnte jho rozměry tak, že jej vyberete buď ve 3D prostoru nebo kliknutím na něj v záložce Projektu vlevo, potom
  • klikněte na záložku Data dole v okně Projektu a změňte hodnoty výšky, délky a šířky na 750mm, 50 a 50 (viz. Obr. 1.1)
  • Stejným způsobem vytvořte druhý box, ale s hodnotami 750, 40 a 40mm. Ve výchozím postavení bude tento box překrývat ten první. (viz. Obr. 1.2)
  • Teď odečtete druhý box od prvního. Vyberte ten první (nazvaný Box), potom druhý (nazvaný Box001), pozor, pořadí výběru je důležitét! (ujistěte se, že oba tvary jsou vybrány v okně stromu projektu. Pamatujte si jednu věc: v navigačním módu Invertor - Vynálezce, nefunguje kombinace Ctrl + klik pro vícenásobný výběr. Switch to either CAD or Blender selection.)
  • On the Part Workbench toolbar, click on the Part Cut.png Cut tool.
Obr. 1.1 První box
Obr. 1.2 Druhý box na prvním, připraven k odečtení
Obr. 1.3 Po odečtení

Nyní máte Váš první železný úhelník (Obr. 1.3). všimněte si, že v okně stromu projektu vlevo byly oba boxy přepsány objektem "Cut". Ve skutečnosti nezmizely, ale jsou seskupeny pod objektem Cut. Klikněte na + před nimi a uvidíte, že oba boxy jsou stále zde, ale zbarveny šedě (Obr. 1.4). Když kliknete na některý z nich a stisknete klávesu mezerník, tak se ukáže. Mezerník přepíná viditelnost vybraných objektů. (Obr. 1.5)

Nechcete úhelník orientovaný takto? Potřebujete pouze změnit umístění boxu Box001. Vyberte jej, mezerníkem zviditelněte a v záložce Data klikněte na + před Umístěním a potom rozbalte parametr Pozice a změňte jeho souřadnice X a Y. Stiskněte ENTER, opět skryjte Box001 a orientace Vašeho úhelníku je nyní jiná. (Obr. 1.5) Můžete změnit i rozměry tvaru a objekt Cut bude aktualizován.

Obr. 1.4 Operace odečtení ponechá její původní objekty (boxy)
Obr. 1.5 Stále ještě můžete objekty zviditelnit

Mimochodem, můžeme přidat zaoblení, tak bude úhelník více realistický. Použijeme nástroj Part Fillet.png Zaoblení. (Obr. 1.6)

Obr. 1.6 Zaoblené hrany

2.metoda - Vysunutí profilu

Tato metoda vyžaduje začít kreslení 2D profilu. Musíte aktivovat pracovní plocha 2D Kreslení (menu Pohled > Pracovní plocha > 2D Kreslení).

Dále potřebujeme nastavit pracovní rovinu. Podle verze FreeCADu máte přímo pod nástrojovým pruhem vpravo tlačítko "None". Klikněte na ně a vlevo se objeví hned za "aktivní příkaz": Vyberte rovinu Odstup, potom textové pole a několik dalších tlačítek. Předpokládejme, že chcete začít profil v půdorysu, stiskněte XY. Tlačítko "None" nyní bude ukazovat "Top" jako aktivní rovinu. Podívejte se na poznámku.

Vyberte nástroj Draft Wire.png Drát (lomená čára), potom začněte kreslit tvar použitím textových polí pro pozice X a Y. Mělo by být zakliknuto políčko "Relativně" i políčko "Vyplněno".

  • 1. bod: 0,0
  • 2. bod: 50,0
  • 3. bod: 0,10
  • 4. bod: -40,0
  • 5. bod: 0,40
  • 6. bod: -10,0
  • 7. bod nebudeme zadávat, lepší je kliknout na tlačítko "Uzavřít" pro uzavření profilu. Teď bychom měli mít profil, označený "Drát" v záložce okna stromu projektu:
Obr. 1.7 Základní drát

Na numerické klávesnici stiskněte nulu a nasatvíte axonometrický pohled.

Aktivujte pracovní plochu Díl.

Klikněte na nástroj Part Extrude.png Vysunout.

On the Tasks tab on the left, select the Wire object. Then enter the desired length, say 750mm. Leave the direction at Z. Click Apply. You should now have an Extrude object in the Project tab (fig. 1.8)

Obr. 1.8 The extruded object

This method has a minor caveat compared to the other one: to edit the shape, you need to edit the Wire, it's not as easy to do as the previous method.

And there are a few other ways to do it too! I hope these two examples get you started. You'll sure hit some snags along the way (I did when I first learned FreeCAD, and I do have 3D CAD experience ;) ), but don't hesitate to ask questions on the FreeCAD forum!

Note on Draft working plane button:

The label on your button may be different, depending on your version and also on what you were doing beforehand. The button label could read: "top", "front", "side", "None" or a Vector representation such as d(0.0,0.0,1.0). It can also be blank. For example:

Select Plane None
Select Plane Top
Select Plane View


The above instructions will work, no matter what label your button has.

Available translations of this page: Flag-es.jpg Flag-fr.jpg Flag-it.jpg