Come creare dei modelli TechDraw personalizzati

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page TechDraw TemplateHowTo and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎italiano

Base ExampleCommandModel.png Tutorial

Argomento
Disegno tecnico
Livello di difficoltà
Intermedio
Tempo di esecuzione
60 minuti
Autore
wandererfan
Versione di FreeCAD
0.17
File di esempio
Nessuno


Introduzione

Questo tutorial mostra come creare un file SVG da usare come modello di squadratura per le pagine di TechDraw.

Questa guida presume che si abbia una discreta familiarità con Inkscape, SVG e l'ambiente TechDraw di FreeCAD.

Faremo un semplice modello in formato Letter americano con orientamento orizzontale.

Una copia del risultato di questo HowTo è disponibile nella directory dei modelli di FreeCAD:

$INSTALL_DIR/Mod/TechDraw/Templates/HowToExample.svg

Dove $INSTALL_DIR è la directory in cui è stato installato FreeCAD, per esempio

/usr/share/freecad/Mod/TechDraw/Templates/HowToExample.svg

Creare un documento di base

1. Aprire un nuovo documento in Inkscape.

2. Nelle Proprietà del documento

  • selezionare il formato (US Letter) e l'orientamento orizzontale
  • Impostare le unità predefinite su "mm" e le dimensioni della pagina su larghezza "279.4" e altezza "215.9".
InkDocProp.png

Inskcape: il documento con dimensioni e orientamento della pagina


3. Usare l'editor XML (menu Modifica -> Editor XML...) per aggiungere una clausola "freecad" namespace a ogni elemento <svg>.

InkXMLNameSpace.png

Inkscape: editor XML che aggiunge la clausola "freecad" namespace all'elemento <svg>


Creare il disegno del modello

4. Disegnare contorni, numeri di zona, linee centrali e altre geometrie.

5. Disegnare le caselle e le linee per il cartiglio.

6. Aggiungere e posizionare il testo statico.

7. Aggiungere e posizionare il testo che sarà modificabile.

8. Ora, il lavoro finito dovrebbe assomigliare a questo:

InkFinishedArt.png

Inkscape: layout del modello provvisorio


Creare i campi modificabili

9. Utilizzare l'editor XML per aggiungere un tag freecad:editable a ogni elemento <text> editable.

  • Assegnare un nome di campo significativo a ogni testo modificabile.
InkXMLeditableTag.png

Inkscape: editor XML che aggiunge la proprietà "freecad:editable" a ogni elemento <text>


Regolare le dimensioni del SVG

10. Utilizzare l'editor XML per regolare l'attributo viewBox in modo che corrisponda alle dimensioni della pagina in millimetri.

  • Sono quattro valori, nel formato "0 0 larghezza altezza"
InkXMLviewBox.png

Inkscape: editor XML che regola la viewbox in modo che corrisponda alle dimensioni della pagina in millimetri


11. Ora il modello appare molto più grande di quanto desiderato.

InkMuchTooBig.png

Inkscape: layout del modello provvisorio che supera la dimensione della pagina


12. Bisogna ridurlo.

  • Modifica → Seleziona tutto in ogni livello, o box di selezione e selezionare tutto.
  • Adattare gli spinbox W: e H: per impostare le dimensioni del disegno in millimetri.
  • Impostare la dimensione della pagina meno eventuali margini applicabili, ad esempio W: 250 e H: 200.

13. Usare Oggetto → Allinea e distrubuisci o gli spinbox X: e Y: per posizionare il disegno entro i limiti della pagina, se necessario.

14. Ora il modello dovrebbe apparire corretto, proprio come nella foto sopra del disegno finito.

Rimuovere le trasformazioni nel file SVG

15. Assicurarsi che tutti i testi modificabili siano "non raggruppati" con Maiusc+Ctrl+g.

16. Selezionare tutti gli elementi della pagina, Modifica → Seleziona tutto, e poi Modifica → Copia.

17. Quindi eliminare il livello, layer corrente, Livello → Elimina livello attuale.

18. Poi incollare, Modifica → Incolla in origine.

19. Ora il modello dovrebbe apparire corretto e non dovrebbe avere trasformazioni indesiderate.

20. Salvare il modello.

21. Provarlo in FreeCAD e TechDraw con Nuovo disegno da modello.

FCTemplateHow.png

FreeCAD: modello finito con un campo di testo modificabile modificato


Note

Non utilizzare i livelli in Inkscape prima di aver imparato a creare il modello senza di essi. Livelli (e gruppi) possono inserire automaticamente trasformazioni indesiderate nel file SVG risultante.

Vedere una discussione su StackOverflow removing transform clauses in SVG files.