TechDraw Esporta pagina in DXF

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page TechDraw SaveDXF and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский
Arrow-left.svg Techdraw-saveSVG.svg Esporta pagina in SVG Pagina precedente:
Pagina successiva: Tipi di tratteggio Techdraw-hatch.png Arrow-right.svg

TechDraw SaveDXF.png Esporta pagina in DXF

Posizione nel menu
TechDraw → Esporta pagina in DXF
Ambiente
TechDraw
Avvio veloce
Introdotto nella versione
0.18
Vedere anche
Esporta pagina in SVG, DXF


Descrizione

Lo strumento Esporta pagina salva la corrente pagina di disegno come file DXF

Utilizzo

  1. Selezionare una pagina nell'albero, se il documento contiene più pagine.
  2. Premere il pulsante TechDraw SaveDXF.png Esporta pagina in DXF
  3. Si apre una finestra di dialogo per salvare il file. Selezionare un percorso e il nome del file.

Limitazioni

  • Le dimensioni radiali e del diametro vengono esportate correttamente solo se sono "all'interno" dell'arco.
  • Il ridimensionamento non è supportato. Il DXF viene disegnato nelle dimensioni effettive della pagina TechDraw.
  • Le unità non sono supportate. Il DXF viene disegnato in millimetri (mm). Il testo della quota viene mostrato esattamente come visualizzato in TechDraw.
  • TechDraw non può esportare una Vista Draft o una Vista Arch in DXF. Queste viste sono elementi SVG generati internamente da Draft, quindi non esiste una forma geometrica da esportare. Per esportare una vista come DXF, essa deve essere stata creata con Nuova vista o Gruppo di proiezioni di TechDraw. Ad esempio, selezionare un Piano di sezione di Arch, quindi utilizzare Vista profilo 2D per creare una forma in proiezione piatta, poi utilizzare Nuova vista di TechDraw su questo oggetto. In alternativa, selezionare gli oggetti dalla vista ad albero o dalla vista 3D ed esportarli in DXF usando File → Esporta.
  • Anche il cartiglio di una pagina è un modello SVG, quindi non viene esportato in DXF.
  • In generale, TechDraw può esportare in DXF solo gli elementi supportati dalla classe Import::ImpExpDxfWrite del Modulo Import.

Note

  • Questa funzione esporta le versioni R12 (AC1009) e R14 (AC1014) di DXF.
    • R12 è una versione più vecchia e più semplice dello standard, ma dovrebbe essere leggibile dalla maggior parte degli altri software.
    • R14 è la versione predefinita. Tra le altre cose include il supporto per spline e ellisse.
  • Ci sono 2 parametri che influenzano l'uscita DXF:
    • Strumenti → Modifica parametri → BaseApp/Preferences/Mod/Import → DxfVersionOut, le voci valide sono 12 o 14. Il valore predefinito è 14.
    • Strumenti → Modifica parametri → BaseApp/Preferences/Mod/Import → DiscretizeEllipses. Se True le spline e le ellissi sono polilinee; se False le spline e le ellissi sono convertite in spline e ellissi; se False, spline ed ellissi sono scritti come oggetti spline ed ellissi. Default è False.

Script

Vedere anche: API TechDraw e Nozioni di base sugli script di FreeCAD.

Lo strumento Esporta pagina in DXF può essere utilizzato nelle macro e dalla console Python tramite la seguente funzione:

TechDraw.writeDXFPage(page,filename)


Arrow-left.svg Techdraw-saveSVG.svg Esporta pagina in SVG Pagina precedente:
Pagina successiva: Tipi di tratteggio Techdraw-hatch.png Arrow-right.svg