TechDraw SaveDXF

From FreeCAD Documentation
Jump to: navigation, search

Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский
Arrow-left.svg Previous: Techdraw-saveSVG.svg Save SVG
Next: Hatching Techdraw-hatch.png Arrow-right.svg

TechDraw SaveDXF.png TechDraw SaveDXF

Menu location
TechDraw → Export page Dxf
Workbenches
TechDraw
Default shortcut
None
Introduced in version
0.18
See also
TechDraw SaveSVG, Draft DXF


Description

The Export page Dxf tool saves a drawing page as a DXF file

How to use

  1. Select a Page in the tree view, if the document contains multiple pages.
  2. Press the TechDraw SaveDXF.png TechDraw SaveDXF button.
  3. Select a location and file name.

Limitations

  • Radial and Diameter dimensions will only export properly if they are "inside" the arc.
  • Scaling is not supported. The DXF will be drawn in the actual size of the TechDraw page.
  • Units are not supported. The DXF will be drawn in millimeters (mm). Dimension text will be shown exactly as displayed in TechDraw.
  • TechDraw can't export a DraftView or an ArchView to DXF. These views are SVG elements generated internally by the Draft Workbench, so there is no geometrical shape to export. To export a view as DXF, it must have been created with TechDraw NewView or TechDraw NewProjGroup. For example, select an Arch SectionPlane, then use Draft Shape2DView to create a flat projection shape, and then use TechDraw NewView on this object. Alternatively, select the objects from the tree view or the 3D viewport, and export to DXF using File → Export.
  • The title block of a page is an SVG template as well, so it will not be exported to DXF either.
  • In general, TechDraw can only export to DXF those elements that are supported by the Import::ImpExpDxfWrite class of the Import Module.

Notes

  • This function exports the R12 (AC1009) and R14 (AC1014) versions of DXF.
    • R12 is an older, simpler version of the standard, but should be readable by most other software.
    • R14 is the default version. It includes support for splines and ellipses among other things.
  • There are 2 parameters that affect DXF output:
    • Tools → Edit parameters → BaseApp/Preferences/Mod/Import → DxfVersionOut, valid entries are 12 or 14. Default is 14.
    • Tools → Edit parameters → BaseApp/Preferences/Mod/Import → DiscretizeEllipses. If True, splines/ellipses are converted to polylines; if False, spline and ellipses are written as spline and ellipse objects. Default is False.

Scripting

See also: TechDrawGui API and FreeCAD Scripting Basics.

The SaveDXF tool can be used in macros and from the Python console by using the following functions:

TechDraw.writeDXFPage(page,filename)


Arrow-left.svg Previous: Techdraw-saveSVG.svg Save SVG
Next: Hatching Techdraw-hatch.png Arrow-right.svg