Std ToggleClipPlane

From FreeCAD Documentation
Jump to: navigation, search

This documentation is not finished. Please help and contribute documentation.

Gui Command explains how tools should be documented. See Draft ShapeString for an example of a well documented tool. Browse Category:UnfinishedDocu to see incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska

Std ToggleClipPlane

Menu location
View → Clipping plane‏‎
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
View menu, Std Base


Description

A clipping plane is a plane that divides the object space in two half spaces. All object parts in one half space are visible, parts in the other half space are invisible. The objects look like sliced and interior details become visible.

Usage

The clipping plane is activated by the View → Clipping plane.

Options

Show non hollow solid

By default solids cut with Clipping Plane are shown as hollow. To show non-hollow solids, a workarounds could be used. Change the lighting of the solids from Two Side to One Side. Then the inner part of the solid will be dark and not look hollow. To do this change property View → Base → Lightning to One side for parts you want to show as non-hollow.

Another possibility would be to leave the Lightning Two Sided and change the color of the inner solid by activating Edit → Preferences → Display → Enable backlight color. But with this the shading effect will be still there. See Forum Thread Clipping Plane Always Shows Model as a Shell?

ToDoFreeCAD 0.13 version and latest

Set a standard plane

ClippingPlane1 it.png

Planes


Option

  • Offset: Offset
  • Flip: reverses the view direction

Set a definite plane

ClippingPlane2 it.png

Personalized plane


Obsolete Version


PianoTaglio1.png

Selection of the object


PianoTaglio2.png

Change the direction of the plane


PianoTaglio3.png

Scale the plane


PianoTaglio4.png

Move the plane


PianoTaglio5.png

Move the plane from the object


PianoTaglio6.png

Position of the object in the property editor