Std: Graficul Dependențelor

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Std ExportGraphviz and the translation is 85% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Std DependencyGraph.png Std DependencyGraph

Menu location
Tools → Dependency graph...
Workbenches
All
Default shortcut
None
Introduced in version
-
See also
None


Descriere

Dependency graph afișează dependețele între obiecte în documentul activ sub formă de graf. Spre deosebire de arborescența Model, obiectele sunt listate în ordine cronologică inversă, cu primul obiect creat în partea de jos.

Poate fi util în analizarea unui document FreeCAD și în localizarea ramurilor într-o arborescență. Schema de dependență a graficului va depinde de ce Atelier de lucru a fost folosit pentru a crea obiectele din document. De exemplu, în FreeCAD 0.16, un model realizat exclusiv în Atelierul PartDesign ar trebui să afișeze un grafic de dependență liniară cu o singură ramificație verticală. Un model realizat cu Atelierul Part va avea multe ramuri, dar pentru o singură parte se vor alătura la început după operațiunile booleene. Dacă nu, înseamnă că acestea sunt obiecte separate.

Graficul de dependență este pur și simplu un instrument de vizualizare, prin urmare nu poate fi editat; se actualizează automat dacă se fac modificări ale modelului.

DependencyGraph1.png


Instalarea

Pentru a se utiliza Dependency graph, un software terț numit Graphviz trebuie să fie instalat prima dată. Dacă nu-l aveți preinstalat sau este instalat într-o locație neconvențională, FreeCAD va afișa următorul dialog:
FreeCAD-0.17-missing-Graphviz-error-dialogue.png

FreeCAD-0.17-missing-Graphviz-error-dialogue.png

Windows

Descărcați programul graphviz-2.xx.msi de instalare de la Graphviz Download page și lansați-l pentru a instala

Mac/OSX

Puteți instala graphviz folosind Homebrew:

brew install graphviz

Aceasta instalează binarele graphviz sub / usr / local / bin. Din păcate, nu putem naviga direct din dialogul de fișiere care apare din FreeCAD → Instrumente → Graficul dependenței. Când obțineți dialogul de selectare a fișierelor, utilizați tastele Cmd + Shift + G pentru a obține un câmp de introducere pentru cale. Introduceți

/usr/local/bin

și confirmați câmpul de introducere și dialogul de selectare a fișierelor.

În cazul în care fișierele binare Graphviz sunt instalate într-o locație nestandard, încercați să găsiți programul împreună cu comanda:

type dot

Se va emite ceva de genul

dot is /usr/local/bin/dot

Și, prin urmare, puteți să îi spuneți lui FreeCAD să se uite în acel director.

Linux

Sub cele mai multe distribuții Linux (Debian / Ubuntu, Fedora, OpenSUSE), trebuie doar să instalați pachetul grafic din colecțiile de depozitare. Cu toate acestea, în mod similar cu MacOSX, în cazurile în care binarele Graphviz sunt instalate într-o locație nestandardă, încercați să găsiți programul cu comanda:

type dot

Poate ieși ceva asemănător

dot is /usr/local/bin/dot

Și, prin urmare, puteți orienta FreeCAD să se uite în acel director.

Configurare

Nu trebuie să aveți nevoie de nici o configurație a preferințelor FreeCAD. Dacă FreeCAD nu poate găsi utilitarul "dot" (din pachetul Graphviz), atunci apare o fereastră de dialog și întreabă utilizatorul despre calea lui: setați calea către dosarul care conține executabilul "dot", nu selectați executabilul în sine. Apoi, FreeCAD încearcă să pornească din nou utilitarul și, în cazul în care reușește, valoarea este scrisă automat la parametrii utilizatorului.

Cum se folosește

  1. Mergeți la meniu Tools → Dependency graph...
  2. Un nou tab întitulat Dependency graph

se deschide în zona principală a ferestrei FreeCAD.

  1. Utilizați rotița de derulare a mouse-ului pentru a mări / micșora imaginea.
  2. Utilizați cursorul orizontal din partea inferioară a ecranului pentru a panorama în lateral.

Save/Export

Puteți salva / exporta graficul de dependență afișat ca fișier imagine. În timp ce tab-ul Dependency graph este în prim plan:

  • Just choose FileSave As to save the graph as a picture (PNG/BMP/GIF/JPG), a vector graphic (SVG) or as a PDF document.
  • FileExport or ToolsSave picture will NOT work.

Principii Generale

  • Graficul afișează obiectele în ordine cronologică inversă, de jos în sus.
  • Direcția săgeților care arată dependențele trebuie să fie întotdeauna în jos, de la obiectul copil la obiectul părinte. O săgeată îndreptată indică o dependență ciclică, o problemă care trebuie rezolvată.
  • O schiță care conține legături către geometry extern va avea un număr cu un sufix "x", în afară de săgeata care o leagă de părinți, indicând numărul de geometrie externă legat în schiță.
  • Obiectele pot avea dependențe față de mai mulți părinți. De exemplu, pentru un model construit în PartDesign, un buzunar poate fi legat de schița sa și de caracteristica Pad (Protrusion) care a venit înainte.
  • Se vor afișa dependențe nepermise (de exemplu, între o operațiune de Draft/Part și un element din cadrul unui PartDesign Body) cu o săgeată roșie. Acest tip de link afișează, de obicei, o eroare "Links go out of allowed scope" în afișarea raportului.
  • Container și DesignDesign își înglobează conținutul într-un cadru cu fundal aleatoriu colorat. Originea acestora include, de asemenea, conținutul lor (planuri și axe standard) într-un cadru.
  • Group este afișat ca un singur element legat de conținutul său.

Limite

  • Graficul de dependență nu poate ajuta la problemele cauzate de topological naming. Dacă o schiță comută fețe ale unei caracteristici după o editare, ea este încă legată de caracteristică; chiar dacă unele funcții sunt rupte, graficul de dependență va rămâne neschimbat.
  • Un bug în v0.17 / v0.18 determină ca un corp să dispară din grafic și conținutul acestuia să disemineze dacă o Piesă sau un obiect Drafr este creat din Corp. Acest lucru nu afectează altfel modelul.