Visualizza: Piano di taglio

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Std ClippingPlane and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska

Std ClippingPlane.png Piano di taglio

Posizione nel menu
Visualizza → Piano di taglio‏‎
Ambiente
All
Avvio veloce
Introdotto nella versione
-
Vedere anche



Un piano di taglio divide lo spazio dell'oggetto in due metà. Tutte le parti dell'oggetto che si trovano in un semispazio sono visibili, mentre le parti nell'altra metà sono invisibili. Gli oggetti sembrano affettati e diventano visibili i dettagli interni. Il piano si attiva nel menu Visualizza → Piano di taglio.


Visualizzare il solido non vuoto

Di default i solidi tagliati con il Piano di taglio sono mostrati come vuoti. Per mostrare solidi non vuoti è possibile utilizzare soluzioni alternative. Cambiare l'illuminazione dei solidi da Two Side a One Side. Quindi la parte interna del solido sarà scura e non sembrerà vuota. Per fare ciò, modificare la proprietà Visualizza → Base → Illuminazione su un lato per le parti che si vuole mostrare come non vuote. Un'altra possibilità è quella di lasciare l'illuminazione su Two Side e cambiare il colore del solido interno attivando dal Menu Modifica → Preferenze → Visualizzazione → Abilita colore di retroilluminazione. Ma con questo l'effetto di ombreggiatura è ancora presente. Vedere nel forum la discussione http://forum.freecadweb.org/viewtopic.php?f=3&t=4371&start=20#p94850


Dalla versione 0.13 di FreeCAD questo oggetto ha un nuovo aspetto. Quando si attiva la funzione, il piano non è più visibile e nella Vista combinata si apre una finestra per impostare la sua posizione.

Impostare un piano standard

piani standard

Opzioni

  • Offset: scostamento
  • Flip: inverte la direzione della vista


Impostare un piano orientato

piano personalizzato


Vecchia versione obsoleta


Questa descrizione vale solo fino alla versione 0.13 di FreeCAD

Manipolare il Piano di taglio

Il piano di taglio può essere modificato tramite i suoi manipolatori.
Dopo l'attivazione il piano appare nell'oggetto e sono mostrati sette manipolatori a forma di piccole scatole: uno su ciascuna estremità dei tre assi e uno al centro dell'asse del piano normale. Ci sono inoltre quattro manipolatori non visibili: il piano stesso e la parte sottile dei tre assi.

Scalare
Per scalare l'oggetto cliccare con il tasto sinistro sui box manipolatori alla fine degli assi e muovere il mouse avanti o indietro. Secondo il tipo di oggetto i manipolatori agiscono in modo autonomo o sincrono.
Spostare fuori del piano
Per spostare l'oggetto lungo il suo vettore normale, trascinare la scatola lunga al centro di un asse con il tasto sinistro del mouse. Per ogni piano di sezione esiste un solo manipolatore lungo il vettore normale.
Spostare il piano
Per spostare il centro del piano, fare clic sull'oggetto piano e trascinarlo nella posizione desiderata.
Ruotare il piano
Cliccare sulla parte sottile degli assi per applicare al manipolatore la modalità rotazione.

Esempio

Nella barra principale selezionare Visualizza → Piano di taglio.
Appare il piano di sezione nella posizione di default.
Una parte dell'oggetto scompare.
Selezione dell'oggetto

Posizionare il cursore su un asse e premere il tasto Ctlr per commutare la posizione del piano di sezione fino a individuare quella desiderata.
Commutare la posizione del piano

Con i manipolatori che si trovano alla fine degli assi è possibile scalare il piano.
Scalare il piano

Per spostare il piano selezionare il manipolatore scatola lunga e muovere il mouse.
Spostare il piano

Per ruotare il piano selezionare un asse nella parte sottile.

Per spostare il piano e separarlo dall'oggetto cliccare su un'area interna al piano, tenere premuto il tasto sinistro e muovere il mouse.
Separare il piano dall'oggetto


Controllare nella scheda dati i valori della posizione ed eventualmente modificarli.
Verificare la posizione dell'oggetto


Per uscire dalla funzione disattivarla tramite il menu Visualizza → Piano di taglio.

Nota: questo comando è differente dai comandi Ruota e Sposta.
Esso muove solo l'oggetto senza modificare la posizione dei piani, osservare che l'icona degli assi rimane sempre nella stessa posizione.
Con il tasto Ctrl premuto, alternando la pressione sul destro e sul sinistro del mouse si possono produrre azioni di trasformazione simili.