Raytracing tutorial

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Raytracing tutorial and the translation is 29% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Thema
Raytracing
Niveau
Anfänger
Zeit zum Abschluss
10 Minuten + Renderzeit
Autor
Drei
FreeCAD version
0.16 oder neuer
Beispieldatei(en)


Einführung

Dieses Tutorial soll den Leser in die grundlegende Vorgehensweise des Arbeitsbereichs Raytracing einführen und die meisten der dort vorhandenen Werkzeuge zum Rendern von Bildern kurz vorstellen.

Raytracing tutorial result.png

Voraussetzungen

  • FreeCAD Version 0.16 oder neuer
  • POV-Ray und/oder LuxRender muss installiert sein
  • Im Falle von POV-Ray reicht es nicht aus, nur das Programm (binary executable) an der richtigen Stelle zu haben, sondern es erfordert die Installation von unterstützenden Dateien (supporting files), und in Ubuntu werden diese durch das Recommends-gekennzeichnete Paket povray-includes zur Verfügung gestellt. Potenzielle Probleme gab es auch bei Linux-Installationen, die manuell im home-Verzeichnis des Benutzer angelegte lokale Konfigurationsdateien erforderten, wie hier diskutiert.
  • Im Falle von POV-Ray wird die zusätzliche Installation von psicofil's macro empfohlen.
  • Der Leser sollte Grundkenntnisse über die Arbeitsbereiche Part und PartDesign besitzen.

Prozedur

Modellierung

In diesem Beispiel verwenden wir einen einfachen Würfel als Beispielobjekt, aber es kann beim Raytracing auch jedes andere Objekt, das mit den Arbeitsbereichen Part oder PartDesign erstellt wurde, verwendet werden.

  1. Erstellen Sie ein neues Dokument.
  2. Wechseln Sie in den Arbeitsbereich Part (Auswahlschaltfläche oder im Menü unter Ansicht > Arbeitsbereich > Part).
  3. Erzeugen Sie einen Würfel Part Box.png. Sie können seine Eigenschaften beliebig wählen.

Wir haben nun ein Modell, mit dem wir im Folgenden arbeiten können.

Vorbereiten des Renderns

  1. Wechseln Sie in den Arbeitsbereich Raytracing.
  2. Ändern Sie die Ansicht in "Perspektivisch" (Menü: Ansicht > Perspektivische Ansicht).
  3. Teilen Sie FreeCAD den Ort des Renderers mit. Das dazugehörige Fenster findet man unter Bearbeiten > Einstellungen und muss dort, je nachdem ob man POV-Ray oder LuxRender installiert hat, die passende ausführbare Datei auswählen.
  4. Wählen Sie im gleichen Fenster die Größe des resultierendes Bildes aus (Werte "+W" und "+H").
POV-Ray
  1. Klicken Sie auf Neues Pov-Ray-Projekt Raytracing New.png. Es erscheint ein DropDown-Menü, in dem RadiosityNormal gewählt werden sollte.
LuxRender
  1. Klicken Sie auf Neues LuxRender-Projekt Raytracing Lux.png. Im nun erscheinenden DropDown-Menü sollte LuxClassic gewählt werden.

Festlegen der Kameraposition

  1. Verschieben Sie die 3D-Ansicht in die von Ihnen gewünschte Position. In diesem Fall wählen wir die "Axonometrische Ansicht".
  2. Wählen Sie im Modellbaum den Projektordner aus.
  3. Klicken Sie auf Kamera zurücksetzen Raytracing ResetCamera.png.

Importieren des Modells

  1. Wählen Sie das zu rendernde Modell.
  2. Klicken Sie auf Teil einfügen Raytracing InsertPart.png.

Starten des Rendervorgangs

  1. Klicken Sie auf Render Raytracing Render.png.
  2. Wählen Sie den Ort aus, wo das Bild gespeichert werden soll.
  3. Warten Sie, bis der Vorgang beendet ist. Dies kann einige Zeit dauern.

Betrachten der Ergebnisse

FreeCAD wird das erzeugte Bild sofort öffnen, sobald der Rendervorgang abgeschlossen ist.

Wir sind nun fertig mit der grundlegenden Vorgehensweise mit dem Arbeitsbereich Raytracing.