Редактор настроек

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Preferences Editor and the translation is 68% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Настройки FreeCAD расположены в меню Правка → Настройки.

FreeCAD функционально разделён на различные модули, каждый модуль отвечает за работу конкретного верстака. FreeCAD использует концепцию, называемую конечной загрузкой, которая означает, что компоненты загружаются только тогда, когда они необходимы. Вы могли заметить, что когда выбираете верстак на панели инструментов FreeCAD, в этот момент загружается верстак и все его компоненты. Это включает в себя и параметры настроек.

Без загруженных модулей у вас будет доступ к двум разделам конфигурации, отвечающие за основные настройки приложения и за настройки дисплея. Когда вы находитесь в определенном верстаке, настройки этого верстака отображаются в виде нового раздела, а форматы файлов, поддерживаемые верстаком, отображаются в виде новой вкладки в разделе Импорт-Экспорт.

Нажатие на кнопку Reset в левом нижнем углу экрана настроек установит «все» настройки FreeCAD в их значения по умолчанию.

Основные настройки

Этот раздел настроек имеет 6 вкладок:

Основная

На вкладке «Основная» вы можете указать следующее:

Имя Описание
Изменить язык Выберите язык пользовательского интерфейса FreeCAD
Размер списка последних файлов Укажите, сколько файлов должно быть указано в списке последних файлов.
Включить фон из повторяющегося узора Если этот флажок установлен, фон главного окна FreeCAD по умолчанию будет состоять из плиток этого изображения: Background.png
Этот параметр действует только в том случае, если в Таблица стилей / Нет таблицы стилей .
Изображение можно изменить, добавив папки Gui/Images в папку
%APPDATA%/FreeCAD (в Windows),
$HOME/.FreeCAD (в Linux) или
$HOME/Library/Preferences/FreeCAD (в MacOS).
Поместите туда файл с именем background.png и снимите флажок / установите этот флажок чтобы увидеть измененный файл.
Стиль интерфейса Выбор таблицы стилей. Таблицы стилей определяют, как выглядит пользовательский интерфейс FreeCAD.
Размер значков на панелях инструментов Выбор размера для значков панели инструментов
При запуске автоматически загружать верстак Выбор того, какой верстак будет использоваться сразу после запуска FeeCAD
Включение экрана-заставки при запуске Если этот флажок установлен, при запуске отображается заставка FreeCAD.
Изображение заставки можно изменить, добавив папки Gui/Images в папку %APPDATA%/FreeCAD (где %APPDATA% - пользовательская папка приложения FreeCAD вашей операционной системы). Поместите туда файл с именем splash_image.png и перезапустите FreeCAD, чтобы увидеть измененный экран-заставку.
Включить перенос слов Слова будут перенесены, когда они превысят доступное горизонтальное пространство в консоли Python. Эта консоль отображается с помощью меню Вид → Панели → Консоль Python.
Preference General Tab 01 ru.png


Документ

На вкладке «Документ» вы можете указать следующее:

Name Описание
Создавать новый документ при запуске Если отмечено, FreeCAD создаст новый документ при запуске
Уровень сжатия сохраняемого документа Спецификация уровня сжатия для файлов FCStd. Файлы FCStd являются сжатыми файлами ZIP. Поэтому вы можете переименовать их суффикс .FCStd в .zip и открыть их с помощью программы ZIP-архива.
Отмены/Повторы Если этот флажок установлен, все изменения в документах сохраняются, чтобы их можно было отменить/повторить.
Максимум шагов отмен/повторов Укажите, сколько шагов Отмена/Повтор нужно записать
Запуск автоматического восстановления при запуске Если файл восстановления доступен, FreeCAD автоматически запустит восстановление файла при запуске. Таким образом, файлы могут быть восстановлены в случае сбоя.
Автосохранение каждые Укажите, как часто записывается файл восстановления.
Сохранить миниатюру в файл проекта при сохранении документа Если этот флажок установлен, при сохранении документа также будет сохранена миниатюра. Например, миниатюра будет отображаться в списке последних файлов в Верстаке Start.
Добавить логотип программы в генерируемую миниатюру Если установлен этот флажок, логотип программы FreeCAD FreeCAD-logo.svg будет добавлен к миниатюре. Этот параметр действует только в том случае, если используется Сохранить миниатюру в файл проекта при сохранении документа.
Максимальное количество файлов резервных копий, при пересохранении документа Если этот флажок установлен, файлы резервных копий будут сохраняться при сохранении документа. Вы можете указать количество сохраняемых файлов резервных копий. Они содержат ранее сохраненную версию документа. Первый файл резервной копии будет иметь суффикс файла .FCStd1, второй .FCStd2 и т.д.
Разрешить идентичные метки объектов в одном документе Если флажок установлен, объекты могут иметь одинаковую метку/имя. Например, разные части или элементы могут иметь одинаковое имя в одном и том же документе.
Имя автора Все документы, которые будут созданы, получат указанное имя автора. Оставьте поле автора пустым для анонимного автора. Если опция Устанавливать при сохранении отмечена, поле Last updated by будет установлено для указанного автора при сохранении файла. Это поле можно просмотреть с помощью меню Файл → Информация о проекте.
Компания Все документы, которые будут созданы, получат указанное название компании
Лицензия по умолчанию Выбор лицензии по умолчанию для новых документов. Для предопределенной лицензии URL-адрес лицензии будет автоматически установлен соответствующим образом. Выберите «Другое» для собственной или специальной лицензии.
URL адрес лицензии Указание URL-адреса, описывающего лицензию, выбранного в Лицензия по умолчанию
Preference General Tab 02 ru.png


Редактор кода

Настройки предпочтений редактора влияют на поведение редактора макросов. Этот редактор можно открыть с помощью меню Макрос → Макросы... → Редактировать/Создать.
Примечание: настройки цвета и шрифта также влияют на Python консоль. Эта консоль отображается с помощью меню Вид→Панели→Консоль Python.

На вкладке «Редактор» вы можете указать следующее:

Name Описание
Подсветка синтаксиса Выбор типа кода. Настройки цвета и шрифта будут применены к выбранному типу. Результат можно увидеть в поле «Предпросмотр».
Шрифт Выбор типа шрифта, который должен использоваться для выбранного типа кода
Размер Выбор размера шрифта, который должен использоваться для выбранного типа кода
Показывать номера строк Если флажок установлен, строки кода будут пронумерованы
Шаг табуляции Определение шага табулятора (количество пробелов). Если, например, установлено значение «6», при нажатии Tab будет выполнен переход к символу 7, 13, 19 и т.д., в зависимости от текущей позиции курсора. Этот параметр используется только в том случае, если выбран Символы табуляции.
Размер отступа Укажите, сколько пробелов будет вставлено при нажатии Tab. Этот параметр используется только в том случае, если выбран Заменять на пробелы.
Символы табуляции Если выбрано, нажатие Tab вставит табулятор с растром, определяемым Шаг табуляции
Заменять на пробелы Если выбрано, нажатие Tab вставит количество пробелов, определяемых Размер отступа
Preference General Tab 03 ru.png


Просмотр отчета

На вкладке «Просмотр отчёта» вы можете указать следующее:

Name Описание
Выводить информационные сообщения (log) Если установлен этот флажок, также будут отображаться информационные сообщения. Они будут выведены на панель Отчет цветом, установленным в Журнал (logs). Эта панель активируется с помощью меню Вид → Панели → Отчет.
Выводить предупреждения (warnings) Если флажок установлен, предупреждения будут отображаться. Они будут выведены на панель Отчет цветом, установленным в Предупреждения (warnings).
Выводить сообщения об ошибках (errors) Если флажок установлен, то будут отображаться сообщения об ошибках. Они будут выведены на панель Отчет цветом, установленным в Ошибки (errors)
Обычные сообщения Задание цвета шрифта для обычных сообщений на панели Отчет.
Журнал (log) Задание цвета шрифта для сообщений журнала на панели Отчет.
Предупреждения (warnings) Задание цвета шрифта для предупреждающих сообщений на панели Отчет.
Ошибки (errors) Задание цвета шрифта для сообщений об ошибках на панели Отчет.
Перенаправить внутренний вывод Python в отчёт Если этот флажок установлен, внутренний вывод Python будет перенаправлен с консоли Python на панель Отчет. Консоль Python отображается с помощью меню Вид → Панели → Консоль Python
Перенаправить внутренние ошибки Python в отчёт Если этот флажок установлен, сообщения об ошибках Python будут перенаправляться из консоли Python на панель Отчет.
Preference General Tab 04 ru.png


Макрос

На вкладке «Макрос» вы можете указать следующее:

Name Описание
Запуск макросов в локальном окружении Если флажок установлен, переменные, определенные макросами, создаются как локальные переменные, в противном случае они создаются как глобальные переменные Python
Куда записывать макросы Указание пути к макросам
Запись команд графического интерфейса Если флажок установлен, записанные макросы также будет содержать команды интерфейса пользователя
Записывать как комментарий Если этот флажок установлен, записанные макросы также будет содержать команды интерфейса пользователя, но в виде комментариев. Это полезно, если вы не хотите выполнять видимые действия при запуске макроса, а видеть, что можно сделать визуально.
Показать команды скрипта в консоли Python Если этот флажок установлен, команды, выполняемые макросами, отображаются в консоли Python. Эта консоль отображается с помощью меню Вид → Панели → Консоль Python.
Preference General Tab 05 ru.png


Единицы измерения

На вкладке «Единицы измерения» вы можете указать следующее:

Name Описание
Пользовательская система Выбор системы единиц, которая должна использоваться для всех частей FreeCAD
Количество десятичных знаков Количество десятичных знаков, которые должны быть указаны для чисел и размеров в FreeCAD
Минимальный часть дюйма Минимальная часть дюйма, которая должна отображаться. Этот параметр доступен только в том случае, если используется система измерения 'Строительные US (Футы-дюймы/кв. футы/куб. футы)' .
Preference General Tab 06 ru.png


Настройки дисплея(Отображение)

Этот раздел настроек имеет до 3 вкладок:

Трехмерный вид

Параметры импорта-экспорта влияют на то, как файлы импортируются и экспортируются во FreeCAD и из него. Обратите внимание, что диалоговое окно настроек «Импорт-экспорт» предлагает параметры типа файла для большинства верстаков, но не все верстаки могут импортировать / экспортировать все типы файлов.

На вкладке «Трехмерный вид» вы можете указать следующее:

Имя Описание
Показать систему координат в углу Если флажок установлен, основная система координат всегда будет отображаться в правом нижнем углу в открытых файлах
Показать счетчик кадров в секунду Если этот флажок установлен, время, необходимое для последней операции, и полученная частота кадров [1] всегда будут отображаться в нижнем левом углу в открытых файлах.
Показать навигационный куб Если установлен этот флажок, навигационный куб всегда будет отображаться в выбранном углу в открытых файлах
Использовать объект вершинного буфера (Vertex Buffer) OpenGL Если флажок установлен, будут использоваться объекты буфера вершин (VBO). VBO - это функция OpenGL, которая предоставляет методы для загрузки данных вершин (положение, вектор нормали, цвет и т.д.) на видеоустройство. VBO обеспечивает существенный выигрыш в производительности, потому что данные находятся в памяти видеоустройства, а не в системной памяти, и поэтому они могут отображаться непосредственно видеоустройством. Для получения дополнительной информации см. эту веб-страницу.
Включить анимацию Если установлен этот флажок, вращения можно анимировать. Например, если используется набор Трехмерная навигация CAD и мышь перемещается, когда колесо прокрутки и правая кнопка мыши нажаты, детали вращаются. Если удерживать мышь во время отпускания, например, правая кнопка мыши, вращение будет продолжено как анимация. Для завершения анимации щелкните левой кнопкой мыши.
Трехмерная навигация Выбор набора настроек навигации. Чтобы увидеть, что определяет каждый набор, выберите набор и нажмите кнопку Мышь....
Вращение Выбор стиля вращения. При просмотре детали в плоскости xy, находящейся в режиме вращения 3D-навигации, разница в следующем: если выбран 'Трекбол' , перемещение мыши по горизонтали будет вращать деталь вокруг оси y, если выбран ' «Поворотный круг» , деталь будет вращаться вокруг оси z.
Сглаживание Выбор используемого типа Multisample сглаживания
Ориентация камеры нового документа Выбор ориентации камеры для новых документов
Зум туда, где мышь Если установлен этот флажок, операции масштабирования будут выполняться в позиции указателя мыши. В противном случае операции масштабирования будут выполняться в центре текущего вида. Zoom step определяет коэффициент масштабирования. Шаг масштабирования «1» означает коэффициент 7,5 для каждого шага масштабирования.
Инвертировать зум Если флажок установлен, направление операций масштабирования будет инвертировано.
Отключить жест наклона сенсорного экрана Если установлен этот флажок, жест наклона будет отключен для масштабирования с увеличением (двумя пальцами). Это влияет только на набор Трехмерная навигация Gesture.
Перенести к курсору Если этот флажок установлен, для поворотов в 3D будет использоваться текущая позиция курсора в качестве центра поворота. В противном случае всегда будет использоваться центр экрана.
Размер метки Выбор размера вершины (точки) в верстаке Sketcher
Расстояние между глаз для стерео режима Спецификация расстояния между глазами, используемого для стереопроекции. Указанное значение является коэффициентом, который будет умножен на размер ограничивающего прямоугольника трехмерного объекта, который отображается в данный момент.
Включить цвет подсветки Если флажок установлен, подсветка включена с заданным цветом
Интенсивность подсветки Спецификация интенсивности подсветки. Этот параметр включается только в том случае, если отмечен Включить цвет подсветки.
Тип камеры Выбор типа проекции камеры.
Если выбран Прорисовка перспективной проекции, объекты будут отображаться в перспективной проекции.
Если выбран Прорисовка ортогональной проекции, объекты будут проецироваться в оротогональной проекции.
Preference Display Tab 01 ru.png


Цвета

FreeCAD поддерживает множество форматов файлов. Для следующих форматов файлов предлагается применить специальные настройки:

На вкладке «Цвета» вы можете указать следующее:

Параметр Описание
Включить подсвечивание при наведении курсора Если этот флажок установлен, предварительный выбор включен и будет выделен указанным цветом. Предварительный выбор означает, что, например, ребра в деталях будут выделены при наведении курсора на них, чтобы указать, что они могут быть выбраны.
Включить подсвечивание выделенного Если флажок установлен, подсветка выделения включена и для нее будет использоваться указанный цвет
Укажите радиус (пикс.) Устанавливает размер области для выбора элементов в трехмерном представлении. Большее значение облегчает выбор материала, но делает невозможным выбор некоторых мелких функций.
Один цвет Если выбрано, фон для деталей будет иметь выбранный цвет
Цветовой градиент Если выбрано, фон для деталей будет иметь выбранный градиент цвета
Средний цвет Доступно только если выбрано Цветовой градиент. Если этот флажок установлен, цветовой градиент получит выбранный цвет как средний цвет.
Объект редактируется Выбор цвета фона для объектов в виде дерева, которые в данный момент редактируются
Активный контейнер Выбор цвета фона для активных контейнеров в виде дерева. Например, если в древовидном представлении есть несколько частей и одна часть переключается как активное тело, она получит выбранный цвет фона в древовидном представлении.
Preference Display Tab 02 ru.png


Цвета деталей

Эта вкладка отображается только в том случае, если вы находитесь на верстаке Part или PartDesign или если вы уже были в верстаках.

На вкладке «Цвета детали» вы можете указать следующее:

Параметр Описание
Цвет формы по умолчанию Выбор цвета по умолчанию для новых фигур. Если установлен параметр Случайный цвет формы, вместо него используется случайный цвет.
Цвет линии по умолчанию Выбор цвета линии по умолчанию для новых фигур
Ширина линии по умолчанию Спецификация толщины линии по умолчанию для новых фигур
Цвет вершины по умолчанию Выбор цвета по умолчанию для новой вершины
Размер вершины по умолчанию Указание размера по умолчанию для новой вершины
Цвет охватывающей рамки Выбор цвета охватывающей рамки в 3D виде
Цвет текста по умолчанию Выбор цвета текста по умолчанию для аннотаций документов. В настоящее время нет диалогового окна для добавления аннотаций к документам. Аннотации могут быть добавлены только с помощью консоли Python с помощью этой команды:
obj = App.ActiveDocument.addObject("App::Annotation", "Label")
Эта консоль отображается через меню Вид → Панели → Консоль Python.
Preference Display Tab 03 ru.png


Mesh view

This tab is only shown if you are in the Mesh workbench or if you have been in this workbench before.

In the Mesh view tab you can specify the following:

Name Description
Default mesh color Selection of the default color for new meshes
Default line color Selection of the default line color for new meshes
Mesh transparency Specification of the default mesh transparency for new meshes
Line transparency Specification of the default line transparency for new meshes
Two-side rendering If checked, the bottom side of the surface will be rendered the same way than the top side. If not checked, it depends on the option Enable backlight color (see section 3D view). Either the backlight color will be used or black.
Show bounding-box for highlighted or selected meshes If checked, a yellow bounding box will be displayed for highlighted or selected meshes.
Define normal per vertex If checked, Phong shading is used, otherwise flat shading. Shading defines the appearance of surfaces.

With flat shading the surface normals are not defined per vertex that leads to a unreal appearance for curved surfaces while using Phong shading leads to a smoother appearance.

Crease angle The crease angle is a threshold angle between two faces. It can only be set if the option Define normal per vertex is used.
If face angle ≥ crease angle, facet shading is used
If face angle < crease angle, smooth shading is used

Mesh View Preferences.png

Настройки импорта-экспорта

The Import-Export settings affect how files are imported and exported to and from FreeCAD. They are described in the page Import Export Preference.


Настройки верстаков

Настройки для более распространенных верстаков приведены ниже. У некоторых верстаков нет предпочтений. Другие дополнительные верстаки могут быть не перечислены.


A2plus Настройки

Настройки Arch

Настройки Draft

Настройки Drawing (нет)

Fem Настройки

Настройки Image (нет)

Настройки Inspection (нет)

Настройки Mesh Design (нет)

OpenSCAD Preferences

Настройки Part (нет)

Настройки Part Design (нет)

Path Preferences

Настройки Plot (нет)

Настройки Points (нет)

Raytracing Préférences

Настройки Reverse Engineering (нет)

Настройки Robot (нет)

Настройки Ship (нет)

Sketcher Preferences

Настройки Spreadsheet (нет)

Настройки Surface (нет)

TechDraw Preferences

Настройки Test Framework (нет)


Насстройки Web (нет)