L'atelier Path

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Path Workbench and the translation is 100% complete.

Introduction

L'atelier Path est utilisé pour produire les instructions machine pour les machines CNC à commande numérique à partir d'un modèle 3D FreeCAD. Celui-ci produit des objets 3D réels sur des machines CNC telles que des fraiseuses, des tours, des cutters laser ou similaires. Généralement, les instructions sont en langage G-Code.


Pathwb.png


Le flux de travail de l'atelier Path FreeCAD crée ces instructions machine comme suit:

  • Un modèle 3D est l'objet de base, généralement créé à l'aide d'un ou plusieurs des ateliers Part Design, Part ou Draft.
  • Un Travail (Tâche) est créé dans l'atelier Path. Celui-ci contient toutes les informations nécessaires pour générer le G-Code nécessaire pour traiter l'usinage sur une fraiseuse CNC: il y a le brut de matière, le magasin d'outils de la fraiseuse et il suit certaines commandes contrôlant la vitesse et les mouvements (généralement en G-Code).
  • Les outils sont sélectionnés comme requis par les opérations d'usinage.
  • Les parcours de l'outil de fraisage sont créés en utilisant par ex. des opérations de Contournage et Poche. Ces objets Parcours d'usinage utilisent le langage G-Code interne à FreeCAD, indépendant de la machine CNC.
  • Exporte le travail en G-Code, correspondant à votre machine.


Liens pour les impatients

En fonction de votre intérêt pour l'atelier Path, vous pouvez lire d'autres sujets:

  • Si vous êtes un nouvel utilisateur essayant de vous familiariser avec Path, vous pourriez être intéressé par un tutoriel rapide walk-through.
  • Si vous avez une machine spéciale qui ne peut pas utiliser l'un des post-processeurs disponibles, vous voudrez peut-être en savoir plus sur personnalisation du post-processeur
  • En tant qu'utilisateur expérimenté, vous voudrez peut-être écrire une macro ou automatiser un processus qui pourrait nécessiter d'en savoir plus sur script
  • Les utilisateurs expérimentés qui souhaitent rationaliser leur flux de travail peuvent en apprendre davantage sur personnalisation.
  • Les nouveaux développeurs qui souhaitent contribuer à Path peuvent vouloir comprendre concepts de base.

Concepts Généraux

L'atelier Path génère le G-Code définissant les parcours d'outils requis pour fabriquer le projet représenté par le modèle 3D sur la fraiseuse cible dans [l'ensemble des opérations de travail Path FreeCAD en langage G-Code], qui est ensuite traduit dans le langage approprié pour le contrôleur CNC cible en sélectionnant le Post processeur approprié.

Le G-Code est généré à partir des directives et des opérations contenues dans un Travail (Tâche) Path. Le Flux de travail des tâches les répertorie dans l'ordre dans lequel elles seront exécutées. La liste est remplie en ajoutant des opérations Path, des optimisations Path, des commandes partielles Path, et des modifications Path - à partir du menu Path, ou des boutons d'interface graphique.

L'atelier Path fournit des outils de gestion (bibliothèque, table d'outils), d'inspection de G-Code et de simulation. Il relie le Post processeur et permet d'importer et d'exporter des modèles de Tâches.

L'atelier Path possède des dépendances externes, notamment:

  1. Les unités du modèle 3D FreeCAD sont définies dans les paramètres Unités → Préférences ... → Général → Unités. La configuration du Post processeur définit les unités G-Code finales.
  2. Le chemin du fichier Macro et les tolérances géométriques sont définis dans l'onglet Edition → Préférences... → Path → Préférences des Tâches.
  3. Les couleurs sont définies dans l'onglet Édition → Préférences... → Path → Couleurs.
  4. Les paramètres des éléments de maintien sont définis dans l'onglet Edit → Préférences... → Path → Habiller.
  5. La qualité du modèle 3D de base prend en charge les exigences de l'atelier Path - exécute la vérification de la géométrie.

Unités

La gestion des unités dans Path peut prêter à confusion. Il y a plusieurs points à comprendre:

  1. Les unités de base FreeCAD pour la longueur et le temps sont respectivement 'mm' et 's'. La vélocité est donc 'mm/s'. C'est ce que FreeCAD stocke en interne indépendamment de toute autre chose
  2. Le schéma d'unité par défaut utilise les unités par défaut. Si vous utilisez le schéma par défaut et que vous entrez un taux d'avance sans chaîne d'unité, il sera saisi en tant que 'mm/s'
  3. La plupart des machines à commande numérique attendent un débit d'alimentation sous forme de 'mm/min' ou 'in/min'. La plupart des post-processeurs convertissent automatiquement l'unité lors de la génération de gcode.

Schémas:

  1. Changer le schéma dans les préférences change la chaîne d'unité par défaut pour les champs d'entrée. Si vous êtes un utilisateur Path et que vous préférez concevoir en métrique, il est fortement recommandé d'utiliser le schéma "Metric Small Parts & CNC". Si vous concevez en unités américaines, Imperial Decimal et Building US fonctionneront
  2. Changer le schéma de votre unité préférée n'aura aucun effet sur la sortie, mais aidera à éviter les erreurs de saisie

Sortie:

  1. La génération de l'unité correcte en sortie relève de la responsabilité du post-processeur et n'est effectuée qu'à ce moment-là
  2. L'unité de sortie de la machine n'a aucun lien avec le schéma de votre unité sélectionnée
  3. Les post-processeurs produisent une sortie métrique (G21), une sortie impériale (G20) ou sont configurables.
  4. Post-processeurs configurables par défaut à la mesure (G21)
  5. Si vous voulez que votre post-processeur configurable produise un gcode impérial (G20), placez l'argument correct dans votre config de sortie de travail (ie --inches pour linuxcnc). Cela peut être stocké dans un modèle de travail et défini comme modèle par défaut pour le rendre automatique pour tous les travaux futurs

Path Inspection:

  1. Si vous utilisez l'outil Path Inspect pour regarder le g-code, vous le verrez en 'mm/s' car il n'est pas post-traité

Commandes Path

Ces commandes sont utilisées pour configurer un projet CNC et gérer vos modèles.

  • Path Contour.png Contour: Crée un parcours d'usinage du contour de l'objet de base
  • Path Pocket.png Poche: Crée une opération de poche à partir d'une ou de plusieurs poches sélectionnées
  • Path Drilling.png Perçage: Effectue un cycle de perçage
  • Path-Engrave.png Gravure: Crée un parcours de gravure
  • Path-Helix.png Hélice: Crée un parcours hélicoïdal
  • Path-3DPocket.png Poche 3D: Crée un parcours d'usinage pour une poche 3D

Habillage Path

  • Path Dressup.png Usinage des coins: Ajoute une modification pour l'usinage des coins à un parcours sélectionné
  • Path Dressup.png Rampe d'entrée: Ajoute une rampe d'entrée d'usinage à un parcours sélectionné

Commandes Particulières

  • Path Comment.png Commentaire: Insère un commentaire dans le G-code d'un parcours d'outil
  • Path Stop.png Stop: Insère un arrêt complet de la machine

Modification de parcours d'usinage

  • Path Copy.png Copier: Crée une copie paramétrique d'un objet parcours sélectionné
  • Path Array.png Copie en réseau: Crée une copie en réseau en dupliquant un parcours sélectionné
  • Path SimpleCopy.png Copie Simple: Crée une copie non paramétrique d'un objet parcours sélectionné

Autres

  • Path-3DSurface.png Surface 3D: Crée un parcours d'usinage pour une surface 3D
  • Path-Area.png Zone d'usinage: Crée une zone d'usinage à partir d'objets sélectionnés

Préférences


Script

L'atelier Path offre une large API script python. Avec cet API, vous pouvez créer et modifier des scripts Python de parcours d'usinage, ou étendre les fonctionnalités disponibles dans l'atelier.

FAQ

FAQ

L'atelier Path partage de nombreux concepts avec d'autres progiciels de FAO, mais possède ses propres particularités. Si quelque chose ne va pas, c'est peut-être un bon point de départ.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎português • ‎română • ‎русский • ‎中文(中国大陆)‎