鼠标控制模式

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Mouse Model and the translation is 24% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎
Freecad的鼠标控制模式由用于三维空间可视化导航和与显示对象交互的命令组成.Freecad支持多个鼠标控制导航样模式。默认的导航样式被称为“CAD导航”,非常简单和实用,但FreeCad还提供了多种可选的导航样式,您可以根据自己的喜好进行选择。

导航

对象处理对于所有工作台都是通用的。下面的鼠标手势可根据选择的导航样式用于控制对象的位置和视图。

改变导航样式可以通过两种方式进行。

  • 首选项编辑器中的“显示”窗口,“3D视图”选项卡;
  • 在三维视图区域的空白处单击鼠标右键,然后在弹出菜单中选择“导航样式”。

CAD导航(默认)

这是默认的导航样式,允许用户对视图进行简单的控制,并且不需要使用键盘键,除非进行多个选择。

选择 平移 缩放 旋转视图
第一种方法
旋转视图
替代方法
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
在要选择的对象上按鼠标左键。按住Ctrl可以选择多个对象。 按住鼠标中键,然后移动鼠标。 使用鼠标滚轮放大和缩小。单击鼠标中键可将视图重新置于光标位置的中心。 introduced in version 0.17 按住鼠标中键,然后按住鼠标左键,然后移动指针。按下鼠标中键时的光标位置决定旋转中心。

旋转就像旋转一个围绕中心旋转的球。如果在停止鼠标移动之前释放按钮,则视图将继续旋转,如果启用了此选项。用鼠标中键双击可设置新的旋转中心。

按住鼠标中键,然后按住鼠标右键,然后移动鼠标。

使用此方法,按住鼠标右键后,可以释放鼠标中键。用右手使用鼠标的用户可能会发现这种方法比第一种方法容易。

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
平移模式:按住Ctrl键,按下鼠标右键一次,然后移动鼠标。 缩放模式:按住CtrlShift键,按下鼠标右键一次,然后移动鼠标。 introduced in version 0.17 旋转模式:按住Shift键,按下鼠标右键一次,然后移动鼠标。 introduced in version 0.17
Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Press the left mouse button over an object you want to select.

Holding down Ctrl allows the selection of multiple objects.

Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Clicking the middle mouse button re-centers the view on the location of the cursor.

Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues spinning, if this is enabled.

A double click with the middle mouse button sets a new center of rotation.

Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.

With this method the middle mouse button may be released after the right mouse button is held pressed.

Users who use the mouse with their right hand may find this method easier than the first method.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: hold the Ctrl key, press the right mouse button once, then move the pointer. introduced in version 0.17 Zoom mode: hold the Ctrl and Shift keys, press the right mouse button once, then move the pointer. introduced in version 0.17 Rotate mode: hold the Shift key, press the right mouse button once, then move the pointer. introduced in version 0.17


openinventor导航

在Openinventor(之前的Inventor)导航中,参照Open Inventor(不要与Autodesk的inventor混淆)的操作,不能仅靠鼠标进行选取操作。要选择对象,必须按住ctrl键。

选择 平移 缩放 旋转视图
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
按住ctrl,然后在要选择的对象上按鼠标左键。 按住鼠标中键,然后移动鼠标。 使用鼠标滚轮放大和缩小。

或者,按住鼠标中键,然后按住鼠标左键,然后移动鼠标。

按住鼠标左键,然后移动鼠标。

This mode is not based on Autodesk Inventor.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Hold Ctrl, then press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

Hold the left mouse button, then move the pointer.


Blender导航

Blender导航参照Blender的操作。以前需要SHIFT配合鼠标才能完成视图平移. 在2016年Blender增加了一个功能改变了这一情况。要平移视图,现在可以同时按下鼠标左键和鼠标右键并在视图中拖动。

选取 平移 缩放 旋转视图
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
在要选择的对象上按鼠标左键。 按住Shift 并按住鼠标中键,然后移动鼠标。

或者,按住鼠标左键和右键,然后移动鼠标。

使用鼠标滚轮放大和缩小。 按住鼠标中键,然后移动鼠标。

Alternatively, hold both left and right mouse buttons, and then move the pointer. |Zoom_text=Use the mouse wheel to zoom in and out. |Rotate_view_text=Hold the middle mouse button, then move the pointer. }}

触控板导航

触控板导航中,平移、缩放或视图旋转操作都需要键盘和鼠标一起配合。

选取 平移 缩放 旋转视图
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
在要选择的对象上按鼠标左键。 按住 Shift,然后移动鼠标. 使用 PageUpPageDown进行缩放操作. 按住Alt,然后移动鼠标.
Shift+Ctrl+Touchpad.svg Shift+Touchpad LB hold.svg
或者按住ShiftCtrl, 然后移动鼠标. 或者,按住Shift和左键,然后移动鼠标。

手势导航(v0.16)

这种导航风格是为触摸屏和笔的可用性而量身定做的,但也非常适用于鼠标。

选择 平移 缩放 旋转视图 倾斜视图
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
在要选择的对象上按鼠标左键。 按住鼠标右键,然后移动鼠标。 使用鼠标滚轮缩放。 按住鼠标左键,然后移动鼠标。

草图工作台和其他编辑模式下,此行为被禁用。按下鼠标按钮进入旋转模式的同时时按住键alt。 要设置相机的焦点进行旋转,请用鼠标中键单击一个点。或者,将光标对准一个点,然后按键盘上的H

按住鼠标左键和右键,然后将鼠标移到一边。
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
点击选择。 用两个手指拖拽。

或者,轻按并按住,然后拖动。这将使用鼠标右键模拟平移。

将两个手指(捏)拉近或拉远。 用一个手指拖动以旋转

草图工作台中按住Alt

旋转由两个触摸点组成的假想线。

在v0.18上,默认情况下禁用此方法。要启用,请转到编辑→首选项→显示,然后取消选中“禁用触摸屏倾斜手势”复选框。


}}

Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button. |Zoom_text=Use the mouse wheel to zoom in and out. |Zoom_gesture_text=Drag two fingers (pinch) closer or farther apart. |Rotate_view_text=Hold the left mouse button, then move the pointer. In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard. |Rotate_view_gesture_text=Drag with one finger to rotate.

Hold Alt when in the Sketcher. |Tilt_view_text=Hold both left and right mouse buttons, then move the pointer sideways. |Tilt_view_gesture_text=Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox. }}

Maya手势导航

在maya手势导航中,所有视图移动都是ALT 和鼠标按钮激活的,因此需要有一个3按钮鼠标才能正确使用此导航模式。另外,也可以使用手势,因为该模式是在常规手势导航模式基础上下开发的。

选取 平移 缩放 旋转视图
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
在要选择的对象上按鼠标左键。 按住 Alt并按住鼠标中键,然后移动鼠标。 按住Alt 并单击鼠标右键,然后移动鼠标。

或者,使用鼠标滚轮放大和缩小。

按住Alt和鼠标左键,然后移动鼠标。

Alternatively, use the mouse wheel to zoom in and out. |Rotate_view_text=Hold Alt and the left mouse button, then move the pointer. }}


Revit Navigation

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, then move the pointer.

Use the mouse wheel to zoom in and out. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.


OpenCascade

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold Ctrl and the left mouse button, then move the pointer.

Hold Ctrl and the right mouse button, then move the pointer.


选择对象

简单选择

可以通过用鼠标左键单击三维视图中的对象或在树视图中选择对象来选择对象

预选

还有一种“预选”机制,只需将鼠标悬停在对象上,即可突出显示对象并在选择前显示信息。如果您不喜欢这种模式,或者您的机器速度较慢,可以在首选项中关闭预选。

操控对象

FreeCAD提供manipulators可以用来修改的对象的外观,形状,或其他参数。

裁剪面是一个带有manipulators对象的例子. 一个裁剪面可以通过视图→裁剪面菜单激活。

硬件支持

FreeCAD 也支持一些3D输入设备.

Mac OS X Issues

最近我们在论坛中收到了来自Mac用户的报告称这些鼠标按钮和按键组合不能正常工作。不幸的是,没有一个开发人员拥有Mac,其他的常规志愿者也没有。我们需要您的帮助来确定哪些鼠标按钮和组合键有效,以便我们可以更新此wiki。

Arrow-left.svg Previous: Getting starte/zh