Fare ile 3D gezinme

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Mouse Model and the translation is 26% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

FreeCAD fare ile modelleme , 3D alanda görsel olarak gezinmek ve görüntülenen nesnelerle etkileşimde bulunmak için kullanılan komutlardan oluşur. FreeCAD, çoklu fare modeli gezinme stillerini destekler. Varsayılan gezinme stiline "CAD Gezinme" denir ve çok basit ve pratiktir, ancak FreeCAD ayrıca tercihlerinize göre seçebileceğiniz alternatif gezinme stilleri de sunar.

Gezinme

Nesne işleme, tüm tezgahlarda ortaktır. Aşağıdaki fare hareketleri, nesnenin konumunu kontrol etmek ve seçilen Gezinme stiline göre görüntülemek için kullanılabilir.

Gezinme stilini değiştirmenin iki yolu vardır:

  • Seçenekler penceresi içinde 3D Görünüm → 3D Navigasyon → Ekran → Düzen → Tercihler .
  • 3D görünümünde boş alana sağ tıklayarak, ardından bağlam menüsünde "Gezinme stili" seçeneğini seçerek.

CAD Gezinme (varsayılan)

Bu, varsayılan gezinme stilidir. Kullanıcıya görünümün basit bir kontrolünü sağlar ve çoklu seçim yapmak dışında klavye tuşlarının kullanılmasını gerektirmez.

Seçme Taşıma Zumlama Görünümü döndürme
Birinci yöntem
Görünümü döndürme
Alternatif yöntem
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Seçmek için Taşımak için Zumlamak için + veya - Döndürmek için Döndürmek için alternatif
Seçmek istediğiniz nesne üzerinde sol fare tuşuna basın.Ctrl tuşunu basılı tutmak birden fazla nesnenin seçimini sağlar. Fare orta tuşunu basılı tutun ve fareyi hareket ettirin. Nesneyi büyütmek/küçültmek için fare tekerleğini kullanın.Fare orta tuşuna tıklamak, nesneyi imlecin bulunduğu konuma getirir. Fare orta tuşunu basılı tutun, fare sol tuşuna basın ve tutun, fareyi hareket ettirin.

Orta fare düğmesine basıldığında imleç konumu, dönme merkezini belirler. Dönme, merkezinin etrafında dönen bir topun dönmesi gibi çalışır. Tuşlar, fare hareketini durdurmadan önce serbest bırakılırsa, görünüm dönmeye devam eder. Farenin orta düğmesiyle çift tıklandığında yeni bir dönüş merkezi belirlenir.

Fare orta tuşunu basılı tutun, sonra fare sağ tuşunu basılı tutun, fareyi hareket ettirin.

Bu yöntemle farenin sağ tuşu basılı tutulduktan sonra, orta fare tuşu serbest bırakılabilir.

Fareyi sağ elleriyle kullanan kullanıcılar, bu yöntemi ilk yöntemden daha kolay bulabilirler.

Taşıma için Zumlama için Döndürme için
Ctrl tuşunu basılı tutun, fare sağ tuşunu tıklayın, fareyi hareket ettirin. 0.17 sürümünde kullanılabilir Ctrl ve Shift tuşlarını basılı tutun, fare sağ tuşuna tıklayın, fareyi hareket ettirin. 0.17 sürümünde kullanılabilir Döndürme Yöntemi:Shift tuşunu basılı tutun, fare sağ tuşunu tıklayın, fareyi hareket ettirin. 0.17 sürümünde kullanılabilir

Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Press the left mouse button over an object you want to select.

Holding down Ctrl allows the selection of multiple objects.

Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Clicking the middle mouse button re-centers the view on the location of the cursor.

Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues spinning, if this is enabled.

A double click with the middle mouse button sets a new center of rotation.

Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.

With this method the middle mouse button may be released after the right mouse button is held pressed.

Users who use the mouse with their right hand may find this method easier than the first method.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: hold the Ctrl key, press the right mouse button once, then move the pointer. introduced in version 0.17 Zoom mode: hold the Ctrl and Shift keys, press the right mouse button once, then move the pointer. introduced in version 0.17 Rotate mode: hold the Shift key, press the right mouse button once, then move the pointer. introduced in version 0.17


OpenInventor Gezinme

OpenInventor'de (önceden Inventor) gezinme, Open Inventor den sonra eklendi. (Bu mod Autodesk Inventor'a dayalı değildir.) Fare tek başına yeterli değildir. Nesneleri seçmek için,CTRL tuşunu basılı tutmanız gerekir .

Seçme Taşıma Zumlama Döndürme
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
ctrl +Seçme Taşıma Yakınlaştırma/Uzaklaştırma veya Yakınlaştırma/Uzaklaştırma Döndürme
Ctrl tuşunu basılı tutun ve seçmek istediğiniz nesnenin üzerinde fare sol tuşuna basın. Fare sol düğmesine tıklayın ve nesneyi hareket ettirin. Yakınlaştırmak ve uzaklaştırmak için fare tekerleğini kullanın veya orta fare düğmesini basılı tutun ve fare sol düğmesini tıklayın. Sol fare düğmesini tıklayın ve döndürmek için sürükleyin.

This mode is not based on Autodesk Inventor.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Hold Ctrl, then press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

Hold the left mouse button, then move the pointer.


Blender Gezinme

Blender Gezinme Blender'dan sonra eklendi. Daha önce tek başına fareyle taşıma yapılamıyordu,taşıma içinSHIFT tuşu kullanılıyordu. 2016'da bu özellik yenilendi. Hem fare sağ tuşu hem de fare sol tuşu birlikte basılı tutularak taşıma yapılabilir.

Seçme Taşıma Zumlama Döndürme
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Seçme shift+Taşıma veya Mouse LMB+RMB.svg Yakınlaştırma/Uzaklaştırma Döndürme
Seçmek istediğiniz nesnenin üzerinde farenin sol tuşuna basın. shift tuşu ile fare orta tuşunu birlikte basılı tutun ve nesneyi taşıyın.

Alternatif olarak, hem sol hem de sağ fare düğmelerini basılı tutun ve ardından imleci hareket ettirin.

Yakınlaştır/Uzaklaştır için fare tekerleğini kullanın. Fare orta tuşunu basılı tutun ve nesneyi döndürün.

Alternatively, hold both left and right mouse buttons, and then move the pointer. |Zoom_text=Use the mouse wheel to zoom in and out. |Rotate_view_text=Hold the middle mouse button, then move the pointer. }}

Dokunmatik fare gezinme

Dokunmatik fare gezinti de, Taşıma , zumlama ve döndürme işlemleri, yalnız fare kullanılarak (veya yalnız dokunmatik fare) yapılamaz.

Seçme Taşıma Zumlama Döndürme
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Seçme shift+Taşıma PgUp / PgDn alt+Döndürme
Seçmek istediğiniz nesnenin üzerinde farenin sol tuşuna basın. shift tuşunu basılı tutun imleci hareket ettirin. Yakınlaştırma/Uzaklaştırma için PgUp ve PgDn tuşlarını kullanın. alt tuşunu basılı tutun ve imleci hareket ettirin.
veya alternatif olarak veya alternatif olarak
shift+ctrl+Zumlama shift+ctrl+Döndürme
shift+ctrl + dokunmatik fare sol tuşuna basılı tutun ve imleci hareket ettirin. shift+ctrl birlikte basılı tutun ve imleci hareket ettirin.

Gesture Gezinme (v0.16)

Bu gezinme stili dokunmatik ekran ve kalemle kullanım için uyarlandı, ancak dokunmatik fare için de kullanılabilir.

Seçme Taşıma Zumlama Döndürme Eğme
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Seçme Taşıma Zumlama Döndürme Eğme
Seçmek istediğiniz nesnenin üzerinde farenin sol tuşuna basın.Ctrl tuşunu basılı tutmak birden fazla nesnenin seçimini sağlar. Görünümü taşımak için farenin sağ düğmesine basın ve sürükleyin. Yakınlaştırma/Uzaklaştırma için Fare tekerleğini kullanın. Sol fare düğmesine basın ve görünümü döndürmek için sürükleyin.

Eskiz ve diğer düzenleme modlarında bu davranış devre dışı bırakılır. Fare tuşu basılıyken Alt tuşuna basılı tutarsanız nesneyi döndürebilirsiniz.

Dönme, kameranın odak noktasının etrafındadır. Kameranın odak noktasını ayarlamak için, farenin orta tuşuyla yeni noktaya tıklayın; manzara bu noktada ortalanacak. Ayrıca fare işaretçisini istenen noktaya getirebilir ve klavyedeki H tuşuna basabilirsiniz .

Hem sol hem de sağ fare düğmelerine basın, sonra görünümü yatırmak için sola veya sağa kaydırın (ufku ayarlayın).
Touch Tap.svg Touch Tap-Hold-Drag.svg

veya

Touch Two-Finger-Drag.svg

Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Seçmek için dokunun. Görünümü taşımak için iki parmağınızla sürükleyin veya dokunup basılı tutun, sonra kaydırın (sağ fare tuşuyla kaydırmayı simüle eder). Yakınlaştırma/Uzaklaştırma için parmakları sıkıştırın (yani iki parmağınızı birbirine doğru kaydırın veya birbirinden uzağa kaydırın). Döndürmek için parmağınızı kaydırın. Ek olarak, Eskiz'in taslak düzenleme modunda ve diğer düzenleme modlarında Alt tuşuna basın. Görünümü yatırmak için döndürün (yani, yüzeye iki parmağınızı bastırın ve iki temas noktasından oluşan hayali çizgiyi döndürün).

V0.18'de bu yöntem varsayılan olarak devre dışıdır. Etkinleştirmek için, Düzenle → Tercihler → Ekran seçeneğine gidin ve "Dokunmatik ekran eğme hareketini devre dışı bırak" onay kutusunun işaretini kaldırın.


Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button. |Zoom_text=Use the mouse wheel to zoom in and out. |Zoom_gesture_text=Drag two fingers (pinch) closer or farther apart. |Rotate_view_text=Hold the left mouse button, then move the pointer. In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard. |Rotate_view_gesture_text=Drag with one finger to rotate.

Hold Alt when in the Sketcher. |Tilt_view_text=Hold both left and right mouse buttons, then move the pointer sideways. |Tilt_view_gesture_text=Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox. }}

Maya-Gesture Gezinme

Maya-Gesture Gezinme,ALT tuşu ve bir fare düğmesine basarak tüm görünüm hareketleri etkinleştirilir , böylece bu gezinme modunu doğru kullanmak için 3 düğmeli bir fareye ihtiyaç duyulur. Alternatif olarak, bu mod, normal Gesture Gezinme modu üzerinde geliştirildiği için tüm Gestures hareketlerini kullanmak mümkündür.

Seçme Taşıma Zumlama Döndürme
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Seçme Alt+Taşıma Alt+Zumalam veya Zumlama Alt+Döndürme
Seçmek istediğiniz nesne üzerindeki fare sol düğmesine basın. Alt tuşu ve fare orta tuşunu birlikte basılı tutun, imleci hareket ettirin. Alt tuşu ve fare sağ tuşunu birlikte basılı tutun, imleci hareket ettirin.

Alternatif olarak, Yakınlaştırma/Uzaklaştırma için fare tekerleğini kullanın.

Alt tuşu ve fare sol tuşunu birlikte basılı tutun, imleci hareket ettirin.

Alternatively, use the mouse wheel to zoom in and out. |Rotate_view_text=Hold Alt and the left mouse button, then move the pointer. }}


Revit Navigation

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, then move the pointer.

Use the mouse wheel to zoom in and out. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.


OpenCascade

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold Ctrl and the left mouse button, then move the pointer.

Hold Ctrl and the right mouse button, then move the pointer.


Nesneleri seçmek

Basit seçim

Nesneler, 3D görünümdeki nesneyi tıklatarak veya ağaç görünümünde seçerek farenin sol tuşu ile tıklanarak seçilebilir.

Ön Seçim

Nesneleri vurgulayan ve seçimden önce fareyi nesnelerin üzerine getirerek bilgileri görüntüleyen bir 'Ön Seçim' mekanizması da vardır. Bu davranışı sevmiyorsanız veya yavaş bir makineniz varsa, tercihlerde ön seçimi devre dışı bırakabilirsiniz.

Nesne özelliklerini değiştirme

FreeCAD, bir nesnenin görüntüsü, şekil veya diğer parametrelerini değiştirmek için kullanılabilecek manipulators sağlar.

Kırpma düzlemi, manipulators nesnesi için bir örnektir.Kırpma düzlemi,"Görünüm→ Kırpma düzlemi" menüsünden etkinleştirilebilir.

Donanım desteği

FreeCAD, ayrıca bazı 3D giriş cihazlarını destekler.

Mac OS X Sorunları

Son zamanlarda Mac kullanıcılarından forum'da bu fare tuş ve klavye tuş kombinasyonunun beklendiği gibi çalışmadığı bildirildi.Maalesef, geliştiricilerin hiçbiri Mac'e sahip değil, diğer düzenli katkı yapanlar da yok. Hangi wiki düğmelerinin ve tuş kombinasyonunun işe yaradığını belirlemek için sizin yardımınıza ihtiyacımız var, böylece bu wiki'yi güncelleyebiliriz.

Arrow-left.svg Başlangıç önceki sayfa:
sonraki sayfa: Belge yapısı Arrow-right.svg