Модель мыши

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Mouse Model and the translation is 96% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Модель мыши FreeCAD состоит из команд для визуальной навигации в трёхмерном пространстве и взаимодействия с показываемыми объектами. FreeCAD поддерживает несколько моделей навигации с помощью мыши. Стиль навигации по умолчанию обозначается как "CAD Navigation," он очень простой и практичный, но FreeCAD так же предлагает альтернативные стили навигации, которые Вы можете выбрать по своим предпочтениям.

Навигация

Используемые для манипуляции объектами жесты мышью отличаются в зависимости от выбранного стиля навигации, выбранный стиль общий для всех верстаков.

Существует два способа изменить стиль навигации:

  • В Настройках, Правка → Параметры → Отображение → 3D Вид → 3D-навигация.
  • Правым кликом на пустом месте области пространственного вида и выбором Стили навигации контекстного меню.

Навигация CAD

Это стиль навигации по умолчанию и позволяет пользователю простейшее управление видом, не требуя использования клавиатуры, кроме как для множественного выделения.

Выбор Сдвиг Масштаб Вращать
Исходный метод
Вращать
Альтернативный метод
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Нажмите левую кнопку мыши над объектом, который вы хотите выбрать.

Нажатием Ctrl можно выбрать несколько объектов.

Удерживая среднюю кнопку мыши, двигаем указатель. Используем колёсико мыши для приближения и отдаления.

Кликом средней кнопкой вид центрируется по положению курсора.

Удерживая среднюю кнопку мыши, нажмите и удерживайте левую кнопку мыши, затем двигайте указатель.

Положение курсора во время нажатия средней кнопки мыши определяет центр вращения. Вращение работает как кручение шара вокруг своего центра. Если кнопки отпущены до остановки кнопки мыши, если так настроено, вид продолжает крутиться.

Двойной клик средней кнопкой мыши устанавливает новый центр вращения.

Удерживая среднюю кнопку мыши, нажмите и удерживайте правую кнопку мыши, затем двигайте указатель.

При этом методе средняя кнопка мыши может быть отпущена после того как правая кнопка осталась нажатой.

Пользователи, использующие мышь правой рукой могут счесть этот метод проще исходного.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Режим сдвига: удерживая кнопку Ctrl, один раз нажимаем правую кнопку мыши, затем двигаем указатель. introduced in version 0.17 Режим приближения: удерживая кнопки Ctrl и Shift, нажмите правую кнопку, и двигайте указатель. introduced in version 0.17 Режим вращения: удерживая кнопку Shift, нажмите правую кнопку, затем двигайте указатель. introduced in version 0.17


Навигация OpenInventor

При навигации в стиле OpenInventor. Для выделения объектов надо нажать кнопку CTRL.

Этот метод базируется на на Autodesk Inventor.

Выбор Сдвиг Масштаб Вращать
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Удерживая Ctrl, нажимаем левую кнопку мыши над объектом, который хотим выделить. Удерживая среднюю кнопку мыши, двигаем указатель. Используем колёсико мыши для приближения и отдаления.

Иначе, удерживая среднюю кнопку мыши, нажимаем и удерживаем её левую кнопку, затем двигаем указатель.

Удерживая левую кнопку мыши, двигаем указатель.


Навигация Blender

Стиль навигации Blender ориентируется на Blender. Ранее не было возможности сдвига только мышью, и требовалось нажимать кнопку SHIFT для сдвига вида. Это было изменено в 2016 году при добавке возможностей, теперь для сдвига можно нажать левую и правую кнопку мыши.

Выбор Сдвиг Масштаб Вращать
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Нажмите левую кнопку мыши над выделяемым объектом. Удерживайте Shift и среднюю кнопку мыши и двигайте объект.

Либо удерживайте левую и правую кнопки и перемещайтесь.

Используйте колёсико мыши для приближения и отдаления. Нажмите и тяните средней кнопкой мыши.


Навигация Touchpad

При включении навигации тачпадом, сдвиг, масштабирование и вращение вида требует вместе с тачпадом использования модифицирующих клавиш.

Выбор Сдвиг Масштаб Вращение
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
Нажмите левую кнопку над объектом, который хотите выбрать. Удерживайте Shift и двигайте объект. Используйте PageUp и PageDown для приближения или отдаления. Удерживайте Alt и двигайте указатель.
Shift+Ctrl+Touchpad.svg Shift+Touchpad LB hold.svg
Иначе, удерживайте вместе Shift и Ctrl, нажмите левую кнопку мыши, и двигайте указатель. Иначе, удерживайте клавиши Shift стрелку влево, затем двигайте указатель.


Навигация Gesture

Этот стиль навигации был предложен в версии 0.16, и скроен для использования с точскрином и пером, однако пригоден и для использования с мышью.

Выбор Сдвиг Масштаб Вращение Tilt view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Нажмите левую кнопку мыши над объектом, который хотите выделить. Удерживайте правую кнопку мыши и тяните курсор для сдвига вида. Используйте колёсико мыши для масштабирования. Удерживайте левую кнопку мыши и тяните указатель.

В режиме Sketcher и некоторых других это действие заблокировано. Удерживайте Alt при нажатии кнопки мыши для перехода в режим вращения.

Чтобы установить точку фокуса камеры для вращения, кликните новую точку средней кнопкой мыши. Взамен, нацельте курсор в новую точку и нажмите кнопку H на клавиатуре.

Удерживайте левую и правую кнопку мыши и тяните указатель в сторону.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Щелкните для выбора. Тяните двумя пальцами.

Иначе, удерживайте щёлкните и удержите, потом тяните. Это симулирует сдвиг правой кнопкой мыши.

Сдвиньте пальцы для масштабирования (т.е. потяните два пальца к/от друг друга). Потяните одним пальцем для вращения.

Удерживайте вдобавок Alt в режиме Sketcher.

Вращайте воображаемую линию между двумя точками касания.

В версии v0.18 этот метод по умолчанию отключён. Для разрешения Правка → Параметры → Отображение, и снимите метку "Disable touchscreen tilt gesture".


Навигация MayaGesture

При навигации типа MayaGesture, перемещения видов требуют нажатия ALT с кнопкой мыши, поэтому для него требуется трехкнопочная мышь. Взамен можно использовать жесты из режима Gesture.

Выбор Сдвиг Масштаб Вращать
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Нажмите левую кнопку мыши над выделяемым объектом. Удерживая Alt и среднюю кнопку мыши, двигайте указатель. Удерживая Alt и правую кнопку мыши, двигайте указатель.

Иначе, используйте для приближения и отдаления колёсико мыши.

Удерживая Alt и левую кнопку мыши, двигайте указатель.


Навигация Revit

Этот стиль был предложен в версии 0.18.

Выбор Сдвиг Масштаб Вращать
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Нажать левую кнопку мыши над выделяемым объектом. Удерживайте среднюю кнопку мыши и двигайте указатель.

Иначе, удерживая левую и правую кнопку мыши, двигайте указатель.

Используйте для приближения и отдаления колёсико мыши. Удерживая Shift и среднюю кнопку мыши, двигайте указатель.

Иначе, удерживая среднюю кнопку мыши, нажмите и удерживайте правую кнопку, затем двигайте указатель.


OpenCascade

Этот стиль был предложен в версии 0.18.

Выбор Сдвиг Масштаб Вращать
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Нажать левую кнопку мыши над выделяемым объектом. Удерживайте среднюю кнопку мыши и двигайте указатель. Используйте колёсико мыши для приближения и отдаления.

Иначе, удерживая Ctrl и левую кнопку мыши, двигайте указатель.

Удерживая Ctrl и правую кнопку мыши, двигайте указатель.


Выбор объектов

Простой Выбор

Объекты могут быть выбраны щелчком левой клавиши мыши, нажав на объект в окне 3D просмотра или выбрав его в дереве.

Предварительный выбор

Также существует механизм Предвыбор, который подсвечивает объект и отображает информацию о них до выбора, уже при наведении указателя мыши на них. Если вам не нравится это поведение или у вас медленная машина, вы можете отключить предварительный выбор (preselection) в настройках.

Управление Объектами

FreeCAD предлагает манипуляторы которые могут быть использованы для изменения объектов или их внешнего вида.

Простой пример секущая плоскость которая может быть активирована в меню View → Clipping Plane.

Поддержка оборудования

FreeCAD так же поддерживает несколько 3d мышей.

Проблемы Mac OS X

В настоящее время имеется сообщение на форуме от пользователей Mac, что кнопка мыши и сочетание клавиш работают не так, как ожидается. К сожалению, ни один из наших разработчиков не использует Mac. Нам требуется помощь, чтобы определить, какие сочетания кнопок мыши и комбинации клавиш работают, чтобы мы смогли обновить текст на wiki.