Mausbedienung

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Mouse Model and the translation is 26% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Das FreeCAD Maus-Modell besteht aus den Befehlen, die verwendet werden, um den 3. Raum visuell zu befahren und mit den angezeigten Objekten zu interagieren. Es gibt zurzeit 3 verschiedene Maus-Navigationsschemas in FreeCAD. Der Standard-Navigations-Stil wird als "CAD-Navigation" bezeichnet und ist sehr einfach und praktisch, aber FreeCAD hat auch alternative Navigations-Stile, welche Sie Ihren Bedürfnissen entsprechend auswählen können.

Navigation

Das Objekt Handling ist für alle Arbeitsbereiche gleich. Die folgenden Maus-Gesten können verwendet werden, um die Objekt Position und Ansicht zu kontrollieren, je nach dem ausgewählten Navigationsstil.

Es gibt zwei Möglichkeiten, um den Navigationsstil zu ändern:

  • Im Einstellungen-Menu, Abschnitt Anzeige, Registerkarte "3D-Ansicht";
  • Mit der rechten Maustaste im leeren Raum in der 3D Ansicht klicken, dann "Navigationsstil" im Kontextmenü auswählen.

CAD Navigation (Standard)

Dies ist der Standard-Navigationsstil. Er erlaubt dem Benutzer eine einfache Kontrolle der Ansicht und erfordert keine Verwendung von Tasten der Tastatur, außer zur Multi-Auswahl von Objekten.

Auswählen Bewegen Zoom Ansicht drehen
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
to Select to Pan to Zoom in or out to Rotate view
Drücken Sie den linken Maus-Knopf über einem Objekt, das Sie auswählen wollen. Gleichzeit gedrückte Strg-Taste erlaubt die Auswahl von mehreren Objekten. Klicken und halten Sie die mittlere Maustaste gedrückt und verschieben Sie das Objekt. Mit dem Mausrad können Sie vergrößern oder verkleinern. Klicken und halten Sie zunächst die mittlere Maustaste, klicken Sie während dessen mit der linken Maustaste auf einen sichtbaren Teil eines Objekts und ziehen Sie ihn in die gewünschte Richtung. Das arbeitet wie das Drehen eines Balls, der um sein Zentrum rotiert. Wenn Sie die Tasten loslassen, bevor Sie Ihre Bewegung zu stoppen, wird das Objekt weiter drehen, wenn dies in den Einstellungen aktiviert ist. Ein Doppelklick mit der mittleren Maustaste auf einen beliebigen Teil eines Objekts setzt den neuen Drehpunkt und zoomt auf diesen Punkt.
Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Press the left mouse button over an object you want to select.

Holding down Ctrl allows the selection of multiple objects.

Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Clicking the middle mouse button re-centers the view on the location of the cursor.

Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues spinning, if this is enabled.

A double click with the middle mouse button sets a new center of rotation.

Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.

With this method the middle mouse button may be released after the right mouse button is held pressed.

Users who use the mouse with their right hand may find this method easier than the first method.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: hold the Ctrl key, press the right mouse button once, then move the pointer. introduced in version 0.17 Zoom mode: hold the Ctrl and Shift keys, press the right mouse button once, then move the pointer. introduced in version 0.17 Rotate mode: hold the Shift key, press the right mouse button once, then move the pointer. introduced in version 0.17
Select Pan Zoom Rotate view
First method
Rotate view
Alternate method
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse MMB+RMB hold.svg
Press the left mouse button over an object you want to select.

Holding down Ctrl allows the selection of multiple objects.

Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Clicking the middle mouse button re-centers the view on the location of the cursor.

Hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

The cursor location when the middle mouse button is pressed determines the center of rotation. Rotation works like spinning a ball which rotates around its center. If the buttons are released before you stop the mouse motion, the view continues spinning, if this is enabled.

A double click with the middle mouse button sets a new center of rotation.

Hold the middle mouse button, then press and hold the right mouse button, then move the pointer.

With this method the middle mouse button may be released after the right mouse button is held pressed.

Users who use the mouse with their right hand may find this method easier than the first method.

Ctrl+Mouse RMB.svg Ctrl+Shift+Mouse RMB.svg Shift+Mouse RMB.svg
Pan mode: hold the Ctrl key, press the right mouse button once, then move the pointer. introduced in version 0.17 Zoom mode: hold the Ctrl and Shift keys, press the right mouse button once, then move the pointer. introduced in version 0.17 Rotate mode: hold the Shift key, press the right mouse button once, then move the pointer. introduced in version 0.17


OpenInventor Navigation

In der OpenInventor Navigation (der Navigation von Open Inventor nachempfunden), gibt es keine reine Mausselektion. Um Objekte auszuwählen, müssen Sie zusätzlich die CTRL-Taste gedrückt halten.

Auswählen Bewegen Zoom Ansicht drehen
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Strg +to Select to Pan to Zoom in or out oder to Zoom in or out to Rotate
Halten Sie die Strg-Taste gedrückt und drücken Sie die linke Maustaste über einem Objekt, das Sie auswählen möchten. Klicken Sie den linken Maus-Knopf und bewegen Sie das Objekt herum. Mit dem Mausrad vergrößern oder verkleinern, oder klicken und halten Sie die mittlere Maustaste gedrückt und klicken mit der linken Maustaste. Klicken und ziehen Sie Objekte mit der linken Maustaste zum rotieren.


Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Hold Ctrl, then press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

Hold the left mouse button, then move the pointer.

This mode is not based on Autodesk Inventor.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Ctrl+Mouse LMB.svg Mouse MMB hold.svg Mouse MMB rotate.svg Mouse MMB+LMB hold.svg Mouse LMB hold.svg
Hold Ctrl, then press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold the middle mouse button, then press and hold the left mouse button, then move the pointer.

Hold the left mouse button, then move the pointer.


Blender Navigation

Die Blender Navigation wurde gemäß Blender modelliert. Früher gab es dabei kein Maus-only-Bewegen und um die Ansicht zu bewegen musste die SHIFT-Taste gedrückt werden. Dies hat sich 2016 durch eine zusätzliche Funktion geändert. Um die Ansicht zu schwenken, können Sie nun sowohl die linke als auch die rechte Maustaste drücken und in der Ansicht ziehen.

Auswählen Bewegen Zoom Ansicht drehen
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
to Select Shift+to Pan or Mouse LMB+RMB.svg to Zoom in or out to Rotate
Drücken Sie die linke Maustaste über einem Objekt, das Sie auswählen möchten. Halten Sie die Umschalttaste(Shift) gedrückt und klicken Sie die mittlere Maustaste und bewegen Sie das Objekt herum, oder halten Sie die Tasten Links und Rechts gedrückt und bewegen Sie. Mit dem Mausrad vergrößern oder verkleinern. Klicken und ziehen Sie mit der mittleren Maustaste.
Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Press the left mouse button over an object you want to select. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, and then move the pointer.

Use the mouse wheel to zoom in and out. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, and then move the pointer. |Zoom_text=Use the mouse wheel to zoom in and out. |Rotate_view_text=Hold the middle mouse button, then move the pointer. }}

Touchpad Navigation

Innerhalb der Touchpad Navigation funktioniert weder das Schwenken, Zoomen oder Rotieren der Ansicht nur mit dem Touchpad.

Select Pan Zoom Rotate View
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
to Select shift+to Pan PgUp / PgDn alt+to Rotate
Press the left mouse button over an object you want to select. Hold shift and move the object around. Use PgUp and PgDn to zoom in and out. Hold alt and move the pointer.
or or
shift+ctrl+to Zoom shift+ctrl+to ROtate
Hold down both the shift and the ctrl keys, press the left mouse button, and move the pointer. Hold down both the shift and the ctrl keys and move the pointer.
Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Touchpad LB.svg Shift+Touchpad.svg PageUp, PageDown Alt+Touchpad.svg
Press the left mouse button over an object you want to select. Hold Shift, then move the pointer. Use PageUp and PageDown to zoom in and out. Hold Alt, then move the pointer.
Shift+Ctrl+Touchpad.svg Shift+Touchpad LB hold.svg
Alternatively, hold Shift and Ctrl, then move the pointer. Alternatively, hold Shift and the left button, then move the pointer.

Gestennavigation (v0.16)

Dieser Navigationsstil wurde speziell auf die Benutzung mit einem Touchscreen oder Stifteingabe zugeschnitten. Sie ist allerdings auch bei Verwendung mit der Maus nützlich.

Select Pan Zoom Rotate view Tilt view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png Rotate cursor.png
Mouse LMB.svg Mouse RMB hold.svg Mouse MMB rotate.svg Mouse LMB hold.svg Mouse LMB+RMB hold.svg
Press the left mouse button over an object you want to select. Hold the right mouse button, then move the pointer. Use the mouse wheel to zoom in and out. Hold the left mouse button, then move the pointer.

In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard.

Hold both left and right mouse buttons, and then move the pointer sideways.
Touch Tap.svg Touch Two-Finger-Drag.svg Touch Tap-Hold-Drag.svg Touch Pinch.svg Touch One-Finger-Drag.svg Touch Rotate.svg
Tap to select. Drag with two fingers.

Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button.

Drag two fingers (pinch) closer or farther apart. Drag with one finger to rotate.

Hold Alt when in the Sketcher.

Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox.

Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button. |Zoom_text=Use the mouse wheel to zoom in and out. |Zoom_gesture_text=Drag two fingers (pinch) closer or farther apart. |Rotate_view_text=Hold the left mouse button, then move the pointer. In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard. |Rotate_view_gesture_text=Drag with one finger to rotate.

Hold Alt when in the Sketcher. |Tilt_view_text=Hold both left and right mouse buttons, then move the pointer sideways. |Tilt_view_gesture_text=Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox. }}

Maya-Gesture Navigation

In der Maya-Gesture-Navigation werden alle Ansichtsbewegungen durch Drücken von ALT und einer Maustaste aktiviert, so dass eine 3-Tasten-Maus benötigt wird, um diesen Navigationsmodus korrekt zu verwenden. Alternativ ist es möglich, Gesten zu verwenden, da dieser Modus über den normalen Gestennavigationsmodus entwickelt wurde.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Alt+Mouse MMB hold.svg Alt+Mouse RMB hold.svg Mouse MMB rotate.svg Alt+Mouse LMB hold.svg
Press the left mouse button over an object you want to select. Hold Alt and the middle mouse button, then move the pointer. Hold Alt and the right mouse button, then move the pointer.

Alternatively, use the mouse wheel to zoom in and out.

Hold Alt and the left mouse button, then move the pointer.

Alternatively, use the mouse wheel to zoom in and out. |Rotate_view_text=Hold Alt and the left mouse button, then move the pointer. }}


Revit Navigation

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, then move the pointer.

Use the mouse wheel to zoom in and out. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.


OpenCascade

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold Ctrl and the left mouse button, then move the pointer.

Hold Ctrl and the right mouse button, then move the pointer.


Objekte anwählen

Objekte können mittels eines Klicks mit der linken Maus-Taste, entweder direkt auf das Objekt in der 3D-Ansicht, oder durch einen Klick auf den Objektnamen, links in der Baum-Ansicht angewählt werden.

Es gibt auch einen sogenannten Preselection-mechanismus, dieser belegt Objekte mit einem Lichtschimmer und zeigt Informationen dazu an, bevor sie Angewählt werden, nur durch plazieren der Maus direkt über dem Objekt. Falls Sie dieses Verhalten nicht mögen oder einen langsamen Rechner besitzen, können Sie dieses in den Einstellungen abschalten.

Objekte Manipulieren

FreeCAD bietet manipulators, die benutzt werden können, um ein Objekt, oder aber seine Optische Erscheinung zu verändern. Ein einfaches Beispiel ist die Schnittebene- ;engl.

clipping plane; die einfach aktiviert werden kann über das Menü Ansicht→Schnittebene . Nach der Aktivierung erscheint dann das Schnittebene-Objekt und zeigt sieben offensichtliche

Hardware support

Die SVN-Version von FreeCAD unterstützt auch ein paar 3D Eingabegeräte.

Problem mit Mac OS X

Es gibt Rückmeldungen von Mac-Nutzern im Forum, deren Tasten- und Mauskombinationen wider Erwarten nicht funktionieren. Leider wird derzeit nicht auf Macs entwickelt. Wir würden uns über Meldungen von Mac-Nutzern freuen, die das Problem näher beschreiben können, sodass das Wiki aktualisiert werden kann.