Manuale: L'interfaccia di FreeCAD

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Manual:The FreeCAD Interface and the translation is 50% complete.

Outdated translations are marked like this.
Other languages:
English • ‎français • ‎italiano • ‎română • ‎русский

FreeCAD utilizza il framework Qt per disegnare e gestire la sua interfaccia. Questa struttura viene utilizzata in una vasta gamma di applicazioni, perciò l'interfaccia di FreeCAD è molto classica e non presenta particolari difficoltà di comprensione. La maggior parte dei pulsanti sono standard e si trovano dove ci si aspetta che siano (File -> Apri, Modifica -> Incolla, ecc). Ecco l'aspetto di FreeCAD quando lo si apre per la prima volta, subito dopo l'installazione, e mostra il centro di partenza:

Freecad-interface-01.jpg

Lo start center è una comoda "schermata di benvenuto", che mostra le informazioni utili ai nuovi utenti, come gli ultimi file su cui si è lavorato, cosa c'è di nuovo nel mondo FreeCAD, o sintetiche informazioni sugli ambienti di lavoro più comuni. Comunica inoltre se è disponibile una nuova versione stabile di FreeCAD.

Ma dopo un po' di tempo, o dopo aver fatto alcuni cambiamenti nelle preferenze, molto probabilmente si vuole andare direttamente in uno degli altri ambienti di lavoro, con un nuovo documento aperto. O semplicemente, chiudere la pagina iniziale e creare un nuovo documento:

Freecad-interface-02.jpg

Gli ambienti di lavoro

Notare che tra le due schermate precedenti alcune delle icone sono cambiate. Questo è il momento in cui entra in gioco il concetto più importante utilizzato nell'interfaccia di FreeCAD: gli ambienti di lavoro.

Gli ambienti di lavoro sono costituiti da un gruppo di strumenti (i pulsanti della barra degli strumenti, i menu e altri controlli dell'interfaccia) che sono raggruppati secondo la loro specializzazione. Pensate ad un laboratorio dove ci sono diverse persone che lavorano insieme: una che lavora con il metallo, un'altra con il legno. Ognuno di loro ha, nel laboratorio, un tavolo separato con gli strumenti specifici per il proprio lavoro. Tuttavia, tutti possono lavorare sugli stessi oggetti. Lo stesso accade in FreeCAD.

Il più importante controllo dell'interfaccia di FreeCAD è il selettore Workbench, che si usa per passare da un ambiente all'altro:

Freecad-interface-03.jpg

Gli ambienti di lavoro spesso confondono i nuovi utenti, dato che non è sempre facile sapere in quale ambiente cercare uno specifico strumento. Ma in breve tempo, quasi senza rendersene conto, si trova un modo conveniente per organizzare la moltitudine di strumenti che FreeCAD offre, e che sono anche completamente personalizzabili (vedi sotto). Lo stesso strumento può apparire in più di un ambiente. L'icona del pulsante per uno specifico strumento è sempre la stessa, indipendentemente dall'ambiente in cui appare.

Più avanti in questo manuale, troverete anche una tabella che mostra i contenuti di tutti gli ambienti di lavoro.

L'interfaccia

Diamo uno sguardo alle diverse parti dell'interfaccia:

Freecad-interface-04.jpg
  • La vista 3D è il componente principale dell'interfaccia. Essa può essere sganciata dalla finestra principale, è possibile avere diverse viste dello stesso documento (o stessi oggetti), o più documenti aperti contemporaneamente. È possibile selezionare gli oggetti o parti di oggetti facendo clic su di loro, e si può spostare, zoomare e ruotare la vista con i pulsanti del mouse. Questo verrà spiegato ulteriormente nel prossimo capitolo.
  • La vista combinata ha due schede:
    • La scheda Modello vi propone i contenuti e la struttura del documento nella parte superiore e le proprietà (o parametri) dell'oggetto selezionato (i) nella parte inferiore. Queste proprietà sono divise in due categorie:
      • Dati (proprietà che riguardano la geometria stessa)
      • Vista (proprietà che determinano il modo in cui la geometria appare sullo schermo).
    • La scheda Azioni è il posto dove FreeCAD chiede di specificare i valori per lo strumento che si sta utilizzando, per esempio, di inserire un valore per la 'lunghezza' quando si utilizza lo strumento Linea. Essa si chiude automaticamente quando si preme il tasto OK (o Annulla). Inoltre, facendo doppio clic sull'oggetto correlato nella vista combinata, la maggior parte degli strumenti permette di ritornare sul pannello delle Azioni, per modificare le impostazioni.
  • Il pannello report normalmente è nascosto, ma è una buona idea lasciarlo aperto perché elenca qualsiasi informazione, avviso o errore e può essere di aiuto nel decifrare (o debug) gli errori eventualmente commessi.
  • La console Python per impostazione predefinita è anche essa nascosta. Questo è il posto dove è possibile interagire con il contenuto del documento utilizzando il linguaggio Python. Dato che ogni azione fatta sull'interfaccia di FreeCAD in realtà esegue un pezzo di codice Python, con questo pannello aperto è possibile vedere il codice svolgersi in tempo reale, e consente strada facendo di imparare un po' di Python in un modo meraviglioso e facile, quasi senza accorgersene .

In addition to the 3D view panel, the following information panels are available. They may be made visible or hidden by selecting them from View → Panels . The name of the panel appears in the upper left corner of the panel when it is displayed:

  • The combo view has two tabs:
    • The Model tab shows you the contents and structure of your document above and the properties (or parameters) of the selected object(s) below. These properties are separated into two categories:
      • Data (properties which concern the geometry itself)
      • View (properties that affect how the geometry looks on screen).
    • The Tasks tab is where FreeCAD will prompt you for values specific to the workbench and tool you are currently using. For example, entering a 'length' value when the Draft Workbench Line Tool is being used. It will clear and switch back to the Model tab after the OK (or Cancel) button is pressed. Double-clicking the related object in the Model tab will usually reopen the corresponding Task tab in order to modify the settings.
      The Tasks tab sometimes has puzzling and frustrating side-effects. If the Task tab is not empty, some FreeCAD operations will not work as expected. For example, if you have a single object in your model such as a cube, double-clicking on it will open the Tasks tab to allow you to modify the parameters characterizing the cube. If you have the Selection view open, you will see the cube's internal name listed there. The entire cube will turn green in the 3D panel, indicating the entire cube is selected. Clicking on the background will deselect the entire cube and clear the Selection view. So far, this is normal behavior. However, if you now click on a face of the cube, instead of that face being selected, nothing will be selected — because the Tasks tab has not been completed. Even if you have made no modifications to the parameters there, FreeCAD is waiting for the OK (or other) button in the Tasks tab to be clicked.
  • The report view is normally hidden, but it is a good idea to open it as it will list any information, warnings or errors to help you decipher (or debug) what you may have done wrong.
  • The Python console is also hidden by default. This is where you can interact with the contents of the document using the Python language. Since every action you do on the FreeCAD interface actually executes a piece of Python code, having this open allows you to watch the code unfold in real time — allowing you a wonderful and easy way to learn a little Python on the way, almost without noticing it.
  • The tree view displays only the object tree shown under the Model tab in the combo view. It is normally hidden.
  • The property view displays only the object property information shown at the bottom of the combo view. It is normally hidden.
  • The selection view
    shows the names of any objects which are currently selected. These are the objects to which a workbench operation will be applied. It can be used to refine the selection by deselecting some of those objects before a workbench operation is applied. The selection view can also be used to search for objects by name and then select them. The selection view is normally hidden; you can usually determine the currently selected object by looking at the object tree in the Model tab of the combo view.
Freecad-interface-07.jpg

Personalizzare l'interfaccia

L'interfaccia di FreeCAD è altamente personalizzabile. Tutti i pannelli e le barre degli strumenti possono essere spostati in luoghi diversi o impilati uno sull'altro. Quando è necessario possono anche essere chiusi e riaperti dal menu Visualizza o facendo clic destro su un'area vuota dell'interfaccia. Inoltre sono disponibili molte altre opzioni, come la creazione di barre degli strumenti personalizzate contenenti gli strumenti di uno qualsiasi degli ambienti, o l'assegnazione e la modifica dei tasti di scelta rapida.

Le opzioni di personalizzazione avanzate sono disponibili dal menu Strumenti -> Personalizza:

Freecad-interface-06.jpg

Approfondimenti