Manual:BIM-Modellierung

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Manual:BIM modeling and the translation is 64% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎română • ‎русский

BIM steht für Bauwerksdatenmodellierung. Die exakte Definition, was damit gemeint ist, variiert, aber vereinfacht gesagt handelt es sich darum, wie Gebäude und andere große Strukturen wie Brücken, Tunnel, etc. heutzutage modelliert werden. BIM-Modelle basieren normalerweise auf 3D-Modellen und enthalten auch eine Reihe von zusätzlichen Informationsschichten, wie Materialinformationen, Beziehungen zu anderen Objekten oder Modellen oder speziellen Anweisungen für Gebäude oder Wartung. Diese zusätzlichen Informationen erlauben alle Arten von erweiterten Analysen des Modells, wie struktureller Widerstand (structural resistance), Kosten und geschätzte Bauzeit oder Berechnungen des Energieverbrauchs.

Der FreeCAD Arch-Arbeitsbereich enthält eine Reihe von Werkzeugen und Möglichkeiten für die BIM-Modellierung. Obwohl es einem anderen Zweck dient, arbeitet es in enger Integration mit dem Rest von FreeCAD: Alles, was mit einem anderen Arbeitsbereich erstellt wurde, kann zu einem Arch-Objekt oder Grundlage für ein Arch-Objekt werden.

Wie im PartDesign-Arbeitsbereich sind mit dem Arch-Arbeitsbereich erstellte Objekte für die reale Welt gedacht. Daher müssen sie solide (solid) sein. Die Arch-Werkzeuge achten normalerweise automatisch darauf und bieten auch Hilfswerkzeuge zur Prüfung der Gültigkeit von Objekten.

Der Arch-Arbeitsbereich enthält auch alle Werkzeuge des Draft-Arbeitsbereichs und verwendet das Raster und das Einrastsystem. Bevor wir anfangen, sollten wir vorher die Einstellungen von Arch und Draft ansehen und die Standardvorgaben an unsere Wünsche anpassen.

In diesem Kapitel werden wir sehen, wie dieses kleine Gebäude modelliert wird:

Exercise arch 01.jpg

und einen Plan und eine Schnittansicht davon erstellen:

Exercise arch 02.jpg

  • Erstelle ein neues Dokument und wechsle zum Arch-Arbeitsbereich.
  • Öffne das Menü Bearbeiten -> Einstellungen -> Draft -> Raster und einrasten und setze den Rasterabstand auf 1000mm, so dass wir ein Raster von 1 m haben, das passend zur Größe unseres Gebäudes ist.
  • In der Entwurfs-Einrastung-Symbolleiste muss der Snap Grid.png Gitternetz umschalten-Button aktiviert sein, so dass wir das Raster so oft wie möglich nutzen können
  • Setze mit Ebene markieren die Arbeitsebene auf "XY"
  • Zeichne vier Linien mit dem Draft Line.png Linie-Werkzeug. Du kannst die Koordinaten manuell eingeben oder einfach mit der Maus die Punkte auf dem Gitter wählen:
    • Von Punkt (0,0) zu Punkt (0,3)
    • Von Punkt (0,3) zu Punkt (4,3)
    • Von Punkt (4,3) zu Punkt (4,0)
    • Von Punkt (4,0) zu Punkt (0,0)

Exercise arch 03.jpg

Beachte, dass wir immer in der gleichen Richtung gezeichnet haben (im Uhrzeigersinn). Dies ist nicht notwendig, stellt aber sicher, dass die Wände anschließend alle die gleichen rechts/links-Eigenschaften haben. Du könntest auch denken, dass wir einfach ein Rechteck hätten zeichnen können (was stimmt). Die vier Linien illustrieren aber besser, wie ein Objekt zu einem anderen hinzugefügt werden kann.

  • Wähle die erste Linie, drücke dann den Arch Wall.png Wand-Button.
  • Wiederhole dies für die anderen drei Linien, bis Du vier Wände hast.
  • Wähle die vier Wände und setze die Height-Eigenschaft auf 3,00 m und die Alignment-Eigenschaft auf left. Falls Du die Linien nicht in der gleichen Reihenfolge wie oben gezeichnet hast, sind bei einigen Wänden möglicherweise die rechts/links-Richtungen vertauscht, so dass hier right eingestellt werden muss. Du hast nun vier sich kreuzende Wände innerhalb der Grundlinien:

Exercise arch 04.jpg

Jetzt müssen wir diese Wände miteinander verbinden, so dass sie sich sauber schneiden. Das ist nicht notwendig, wenn Deine Wände so gezeichnet sind, dass sie bereits sauber verbunden sind, aber hier müssen wir es tun, da sie sich überschneiden. Im Arch-Arbeitsbereich passiert das, indem eine Wand zum "Host" wird und die anderen als "Additions" hinzugefügt werden. Jedes Arch-Objekt kann eine beliebige Anzahl von "Additions" haben (Objekte, deren Geometrie zur Host-Geometrie hinzugefügt wird), und "Subtractions" (Objekte, deren Geometrie subtrahiert wird). Die "Additions" und "Subtractions" eines Objekts können jederzeit durch Doppelklick auf das Objekt in der Baumansicht verändert werden.

  • Wähle die vier Wände mit gedrückter Strg-Taste, die letzte wird dann zum Host
  • Drücke den Arch Add.png Komponente hinzufügen-Button. Die vier Wände sind nun zu einer geworden:

Exercise arch 05.jpg

Die einzelnen Wände sind nach wie vor zugänglich, wenn die Wand in der Baumansicht expandiert wird.

  • Nun werden wir eine Tür einfügen. In FreeCAD sind Türen eine besondere Form von Fenster, deshalb verwenden wir das Fenster-Werkzeug.
  • Starte mit der Wahl der Wand. Dies ist nicht notwendig, sollte aber eine gute Angewohnheit werden. Wenn bei Aufruf des Fenster-Werkzeugs ein Objekt ausgewählt ist, dann wird das Fenster in dieses Objekt eingefügt, selbst wenn Du an ein anderes Objekt einrastest.
  • Setze mit Ebene markieren die Arbeitsebene auf auto, so dass wir nicht auf den Fußboden beschränkt sind.
  • Drücke den Arch Window.png Fenster-Button.
  • Wähle im Fenster-Erstellungsdialog die "Simple door"-Vorgabe und setze Width auf 0,9 m und Height auf 2,1 m.
  • Die Snap Near.png Nächste-Einrastung muss aktiviert sein, damit wir auf Flächen einrasten können
  • Platziere Dein Fenster ungefähr in der Mitte der Vorderansicht der Wand:

Exercise arch 06.jpg

  • Nach dem Klicken ist unser Fenster auf der richtigen Fläche platziert, aber nicht exakt da, wo wir es wollen:

Exercise arch 07.jpg

  • Durch Aufklappen des Wand- und des Fensterobjekts in der Baumansicht können wir nun die genaue Position festlegen. Dazu ist die Placement-Eigenschaft der Grundlinie unserer Tür zu ändern. Setze die Position auf x = 2m, y = 0, z = 0. Unsere Tür ist nun genau an der richtigen Stelle:

Exercise arch 08.jpg

  • Wiederhole die Operation, um ein Fenster zu platzieren: Wähle die Wand, drücke das Fenster-Werkzeug, wähle die Open 2-pane-Vorgabe und platziere ein 1m x 1m-Fenster auf der gleichen Fläche wie die Tür. Setze die Placement-Eigenschaft der Grundlinie des Fensters auf x = 0.6m, y = 0, z = 1.1m, so dass die Oberkante des Fensters mit der der Tür übereinstimmt.

Exercise arch 09.jpg

Fenster basieren immer auf Skizzen. Es ist einfach, maßgeschneiderte Fenster zu erstellen, indem zuerst eine Skizze auf einer Fläche erzeugt wird, die dann zu einem Fenster wird, wenn man den Fenster-Button drückt. Dann können nach Doppelklick auf das Fenster in der Baumansicht die Fenster-Erstellungsparameter, also welche Polygonzüge der Skizze und wie sehr diese zu extrudieren sind, verändert werden. Nun werden wir eine Decke erstellen:

  • Setze mit Ebene markieren die Arbeitsebene auf XY
  • Erstelle ein Draft Rectangle.png Rechteck mit einer length von 5 m, einer height von 4 m und einer Position von x = -0.5m, y:-0.5m, z:0.
  • Wähle das Rechteck
  • Klicke das Arch Structure.png Struktur-Werkzeug, um aus dem Rechteck eine Decke zu erzeugen
  • Setze die height-Eigenschaft der Decke auf 0,2 m und die normal-Richtung auf (0,0,-1), weil wir sie nach unten extrudieren wollen. Wir hätten sie auch vorher 20 cm nach unten verschieben können, aber es immer gute Praxis, das extrudierte Objekt am gleichen Platz wie das Basisprofil zu belassen.
  • Setze die Role-Eigenschaft der Decke auf slab. Das ist für FreeCAD nicht nötig, aber für den IFC-Export ist das wichtig, weil es dafür sorgt, dass das Objekt mit dem richtigen IFC-Typ exportiert wird.

Exercise arch 10.jpg

  • Jetzt benutzen wir eine der strukturellen Vorgaben, um einen metallischen Balken zu erstellen. Klicken den Arch Structure.png Struktur-Button, wähle die HEB 180-Vorgabe und setze height auf 4 m. Platziere ihn irgendwo:

Exercise arch 11.jpg

  • Passe das Placement an, indem Angle auf 90° in der (1,0,0)-Achse und Position auf x:90mm, y:3.5m, z:3.09m geändert werden. Dies wird den Balken exakt auf einer der Seitenwände positionieren:

Exercise arch 12.jpg

  • Wir müssen diesen Balken nun ein paar Mal duplizieren. Wir können das einen nach dem anderen mit dem Draft Clone.png Klonen-Werkzeug machen, aber es gibt einen besseren Weg, alle Kopien mit Hilfe einer Anordung auf einmal zu machen:
  • Wähle den Balken
  • Drücke den Draft Array.png Anordnung-Button
  • Setze die Number X-Eigenschaft der Anordung auf 6 und belasse die Werte für Y und Z auf 1
  • Erweitere die interval X-Eigenschaft und drücke das Bound-expression-unset.png Expression-Icon rechts neben dem X-Feld. Das öffnet den Ausdrucks-Editor?:

Exercise arch 13.jpg

  • Schreibe (4m-180mm)/5 in das Ausdrucksfeld und drücke OK. Dies wird den x-Wert auf 0,764 setzen (4 m ist die Gesamtlänge unserer vorderen Wand, 180 mm ist die Breite des Balken, der deshalb HEB180 heißt, und wir wollen ein Fünftel des Platzes als Zwischenraum zwischen den Balken haben):

Exercise arch 14.jpg

  • Wir können nun problemlos eine einfache Decke auf diesen Balken erstellen, indem wir ein Rechteck direkt auf der oberen Fläche der Balken zeichnen. Wähle die obere Fläche eines der Balken
  • Drücke den Draft SelectPlane.png Ebene markieren-Button. Die Arbeitsebene wird nun auf diese Fläche gesetzt.
  • Erstelle ein Draft Rectangle.png Rechteck durch Einrasten von zwei gegenüberliegenden Punkten der äußeren Balken:

Exercise arch 15.jpg

  • Wähle das Rechteck
  • Klicke den Arch Structure.png Struktur-Button und erstelle eine Decke mit einer Höhe von 0,2 m.

Das war's, unser Modell ist jetzt fertig. Wir sollten es nun gliedern, um es richtig nach IFC exportieren zu können. Das IFC-Format erfordert, dass sich alle Objekte eines Gebäudes in einem Gebäude-Objekt befinden, optional in einem Geschoss. Es erfordert auch, dass alle Gebäude auf einem Grundstück platziert werden, aber der IFC-Export-Prozess von FreeCAD wird automatisch ein Standardgrundstück erstellen, falls erforderlich, so dass wir uns hier darum nicht kümmern müssen.

  • Wähle die beiden Decken, die Wand und die Anordung der Balken
  • Drücke den Arch Floor.png Geschoss-Button
  • Wähle das gerade angelegte Geschoss
  • Drücke den Arch Building.png Gebäude-Button

Unser Modell ist nun bereit für den Export:

Exercise arch 16.jpg

Das IFC-Format ist einer der wertvollsten Aktivposten in einer freien BIM-Welt, denn es erlaubt den Datenaustausch zwischen jeder Anwendung und jedem Akteur in der Welt des Baugewerbes in einer offenen Weise (das Format ist offen, frei und wird von einem unabhängigen Konsortium gepflegt). Der Export Deines Modells im IFC-Format gewährleistet, dass jeder es ansehen und untersuchen kann, unabhängig von der verwendeten Anwendung.

In FreeCAD erfolgt der IFC-Im- und Export durch Anbindung an ein anderes Stück Software namens IfcOpenShell. Für den Export nach IFC muss außerdem das IfcOpenShell-python-Package auf Deinem System installiert sein. Stelle sicher, dass das Paket die gleiche Python-Version wie FreeCAD verwendet. Die von FreeCAD benutzte Python-Version kann über Ansicht -> Paneele -> Python-Konsole ermittelt werden. Wenn das getan ist, können wir nun unser Modell exportieren:

  • Wähle das oberste zu exportierende Objekt, das Gebäude-Objekt.
  • Wähle aus dem Menü Datei -> Export -> IFC und speichere Deine Datei.
  • Die resultierende IFC-Datei kann nun mit einer Vielzahl von Anwendungen und Betrachtern (das folgende Bild zeigt die geöffnete Datei im IfcPlusPlus-Betrachter). Die Überprüfung der exportierten Datei in solch einer Betrachtungsanwendung ist wichtig, um sicherzustellen, dass die enthaltenen Daten korrekt sind, bevor die Datei an andere Personen weitergegeben wird. FreeCAD kann ebenfalls verwendet werden, um die IFC-Datei zu öffnen.

Exercise arch 17.jpg

Wir werden nun ein paar Bemaßungen platzieren. Wir werden anders als im vorigen Kapitel die Bemaßungen nicht direkt auf das Zeichenblatt zeichnen, sondern hier eine andere Methode nutzen und Bemaßungen direkt im 3D-Modell platzieren. Diese Bemaßungen werden dann automatisch auf dem Zeichenblatt platziert. Wir werden zuerst zwei Gruppen für unsere Bemaßungen erstellen, eine für die Bemaßungen, die im Lageplan erscheinen, und eine weitere für die in der Draufsicht.

  • Rechtsklicke das house-Dokument in der Baumansicht und erstelle zwei neue Gruppen: Plan dimensions und Elevation dimensions.
  • Setze mit Ebene markieren die Arbeitsebene auf XY
  • Stelle sicher, dass die Option Snap WorkingPlane.png restrict-Einrasten aktiviert ist, so dass sämtliche Zeichnugen auf der Arbeitsebene bleiben.
  • Zeichne eine Reihe von Draft Dimension.png Bemaßungen, beispielsweise wie auf dem folgenden Bild. Das Drücken von Shift und Strg während des Objektfangs der Bemaßungspunkte zeigt weitere Optionen.

Exercise arch 18.jpg

  • Wähle all Deine Bemaßungen und ziehe sie in die Plan dimensions-Gruppe in der Baumansicht.
  • Setze mit Ebene markieren die Arbeitsebene auf XY, also die Draufsicht.
  • Wiederhole die Operation, zeichne eine Reihe von Bemaßungen und verschiebe sie in die Elevation dimensions-Gruppe.

Exercise arch 19.jpg

Wir werden nun einen Satz von Ansichten unseres Modells vorbereiten, die auf einem Zeichenblatt platziert werden. Wir können das mit den Werkzeugen des Drawing-Arbeitsbereichs tun, wie wir das im vorigen Kapitel gesehen haben, aber der Arch-Arbeitsbereich bietet auch ein fortgeschrittenes All-in-one-Werkzeug, um Lagepläne, Schnitt- und Draufsichten zu erstellen, genannt Schnittebenen. Wir werden nun zwei dieser Schnittebenen hinzufügen, um einen Lageplan und eine Draufsicht zu erzeugen.

  • Wähle das Gebäude-Objekt in der Baumansicht
  • Drücke den Arch SectionPlane.png Schnittebene-Button.
  • Setze die Height-Eigenschaft auf 5 m, die Display Length auf 6 m, so dass wir unser Haus erfassen (das ist nicht nötig, aber es sieht besser aus, weil es auf natürliche Weise zeigt, wofür es benutzt wird) und die Placement-Position auf x:2m, y:1.5m, z:1.5m.
  • Prüfe die von der Schnittebene vorgeschlagene Objekt-Liste durch Doppelklick in der Baumansicht. Schnittebenen rendern nur angegebene Objekte des Modells, nicht alle. Die ausgewählten Objekte können hier geändert werden.

Exercise arch 20.jpg

  • Wiederhole die Operation, um eine weitere Schnittebene zu erzeugen, mit den gleichen Werten für Height und Display length, aber unterschiedlicher Placement-Position: x:2m, y:-2m, z:1.5m, angle: 90°, axis: x:1, y:0, z:0. Sorge dafür, dass diese Schnittebene ebenfalls das Gebäude-Objekt berücksichtigt.

Exercise arch 21.jpg

  • Jetzt haben wir alles Nötige und können unsere Zeichnungsseite erstellen. Wechsle zum Drawing-Arbeitsbereich und erzeuge eine neue Standard Drawing Landscape A3.png A3-Seite (oder wähle eine andere Vorlage, falls gewünscht).
  • Wähle die erste Schnittebene, die für den Lageplan benutzt wird
  • Drücken den Drawing DraftView.png Draft Ansicht?-Button. Dieses Werkzeug bietet eine Reihe von zusätzlichen Möglichkeiten gegenüber dem Standard-Entwurfsansicht-Werkzeug und unterstützt die Schnittebenen des Arch-Arbeitsbereichs.
  • Gib der neuen Ansicht folgende Eigenschaften:
    • X: 50
    • Y: 140
    • Scale: 0.03
    • Line width: 0.15
    • Show Cut True
    • Show Fill: True
  • Wähle die andere Schnittebene und erstelle eine neue Draft-Ansicht mit den folgenden Eigenschaften:
    • X: 250
    • Y: 150
    • Scale: 0.03
    • Rendering: Solid

Exercise arch 22.jpg

Wir werden nun zwei weitere Draft-Ansichten erzeugen, für jede Gruppe von Bemaßungen eine.

  • Wähle die Plan dimensions-Gruppe
  • Drücke den Drawing DraftView.png Entwurfsansicht-Button.
  • Gib der neuen Ansicht folgende Eigenschaften:
    • X: 50
    • Y: 140
    • Scale: 0.03
    • Line width: 0.15
    • Font size: 10mm
  • Wiederhole die Operation für die andere Gruppe mit den folgenden Eigenschaften:
    • X: 250
    • Y: 150
    • Scale: 0.03
    • Line width: 0.15
    • Font size: 10mm
    • Direction: 0,-1,0
    • Rotation: 90°

Unsere Seite ist nun fertig und wir können sie im SVG- oder DXF-Format ausgeben oder sie drucken. Das SVG-Format erlaubt Dir, die Datei in Illustrationsanwendungen wie Inkscape zu öffnen, mit denen Du technische Zeichnungen schnell aufwerten und sie in schönere Präsentationszeichnungen verwandeln kannst. Es bietet viel mehr Möglichkeiten als das DXF-Format.

Downloads

Lies mehr