Personalizarea interfeţei

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface Customization and the translation is 69% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Deoarece interfaţa FreeCAD se bazează pe setul de unelte moderne din bibliotecile Qt, ea beneficiază de o structurare avansată. Ferestrele, meniurile, barele de unelte şi alte instrumente pot fi modificate, mutate, distribuite intre panouri, scurtaturile pot fi personalizate si macroinstructiunile pot fi inregistrate si redate. Fereastra de personalizare se acceseaza din meniul Tools -> Customize

Screenshot-customize.jpg

Tab-uri de personalizare

Tab-ul Comenzi permite afişarea tuturor comenzilor FreeCAD, organizate pe categorii.

În Tastatură puteţi vedea combinaţiile de taste asociate cu fiecare comandă FreeCAD şi, dacă doriţi, le puteţi modifica sau să asociaţi noi taste rapide pentru oricare dintre comenzi. Aici trebuie să intraţi dacă utilizaţi adesea un anumit panou şi doriţi să creşteţi viteza de lucru prin folosirea scurtăturilor.

Tab-urile Bare de unelte şi Barele cutii cu unelte vă permit modificarea barelor de unelte existente ori crearea unora proprii.

Tab-ul Macro-uri permite gestionarea acestora.

Creaţi-vă propriile Bare de unelte pentru gestionarea macrocomenzilor nou-create.

De la Versiunea 0.16 se oferă o nouă unealtă care vă permite să gestionaţi propriile ateliere.

CustomizeWorkbenches.png

Example

Drept exemplu pentru un flux de operaţii, să presupunem că dorim ca unealta pentru măsurători liniare Ruletă să apară într-o bară personalizată de unelte din atelierul Draft Workbench.

  • În FreeCAD, alegeţi "Instrumente -> Personalizare" din meniul de sus
  • selectaţi tab-ul "Bare de instrumente"
  • în partea stângă, derulaţi meniul de sus în jos şi alegeţi "Componentă" (Part)
  • în fereastra de jos din stânga, derulaţi până la opţiunea "Ruletă̝" şi selectaţi-o.
  • în jumătatea dreaptă, alegeţi "Ciornă (Draft) din meniul cu desfăşurare în jos
  • daţi clic pe butonul New... ca să creaţi o bară nouă de unelte şi daţi-i un nume
  • în fereastra din dreapta jos, selectaţi ca destinaţie propria bară de unelte (aceasta doar dacă aveţi mai multe bare)
  • daţi clic pe butonul "Săgeată albastră către dreapta" (aflat deasupra celor din spaţiul central) şi veţi adăuga opţiunea dorită în bara selecţionată

De remarcat

Când selectaţi "Global" în meniul cu derulare în jos din dreapta, veţi crea o bară de unelte vizibilă în toate panourile

Ca să adăugaţi o macrocomandă existentă într-o bară de unelte, trebuie:

  • să selectaţi "Macro-uri" în meniul cu derulare în jos din stânga
  • să alegeţi textul din meniu, o iconiţă (Pixmap) şi folosiţi în continuare meniul "Instrumente -> Personalizare -> Macro-uri"