Anpassung der Benutzeroberfläche

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface Customization and the translation is 100% complete.

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Seit die FreeCAD Oberfläche auf dem modernen Qt Werkzeugkasten basiert, verfügt sie über eine zeitgemäße Struktur. Widgets, Menüs, Symbolleisten und andere Werkzeuge können geändert, verschoben, zwischen den Arbeitsbereichen geteilt, Tastenkombinationen festgelegt, geändert und Makros aufgezeichnet und abgespielt werden. Das Anpassungsfenster wird über das Menü Werkzeuge → Anpassen aufgerufen:

BenutzerdefBefehle.jpg

Anpassung Reiter

Auf der Registerkarte "Befehle" kannst Du alle verfügbaren FreeCAD Befehle durchsuchen, geordnet nach ihrer Kategorie.

Unter Tastatur siehst Du die Tastaturkurzbefehle die mit jedem FreeCAD Befehl verbunden sind, wenn Du willst, kann ein neuer Kurzbefehl geändert oder jedem Befehl zugewiesen werden. Wenn du einen bestimmten Arbeitsbereich häufig benutzt und seine Nutzung mit der Tastatur beschleunigen möchtest, ist dies genau das Richtige für dich.

Mit den Registerkarten " Werkzeugleisten " und " Werkzeugkastenleisten " kannst Du bestehende Werkzeugleisten ändern oder Deine eigenen benutzerdefinierten Werkzeugleisten erstellen.

Unter der Registerkarte Arbeitsbereiche (Workbenches) sind die in FreeCAD existierenden Arbeitsbereiche aufgeführt, links die z.Zt. passiven, rechts die z.Zt. aktiven Bereiche. Der Status-Wechsel erfolgt mit den horizontalen Pfeilen.

BenutzerdefSymbLeisten.jpg

Unter der Registerkarte Symbolleisten (Toolbars) stehen links die gleichen Befehls-Kategorien wie unter der Karte Befehle. Nach Anklicken einer Kategorie erscheinen die dazugehörenden Befehle, die auf die rechte Seite hinüber kopiert werden können. Vorher wählt man dort einen aktiven Arbeitsbereich, dem man eine individuelle Symbolleiste zufügen möchte. Für diese Leiste ist zuerst mit Neu (New...) ein Name zu wählen, bevor man in sie Befehle herüber kopiert. Beim späteren Aufruf dieses Arbeitsbereichs ist diese Leiste zu aktivieren: Ansicht -> Werkzeugleisten.

Anmerkung: Wenn rechts "Global" (anstatt eines Arbeitsbereiches) gewählt wird, kann die zugefügte Symbolleiste in jedem Arbeitsbereich aktiviert werden.


Auf der Registerkarte "Makros" kannst Du Deine gespeicherten Makros verwalten.

Erstelle Deine Werkzeugleisten für Dein Makro Anpassung der Werkzeugleisten

Seit FreeCAD v0.16 ist ein neues Werkzeug verfügbar, mit dem die Arbeitsbereiche verwaltet werden können.

CustomizeWorkbenches.png

Beispiel

Angenommen, wir wollen das Werkzeug "Linear messen" auch in einer benutzerdefinierten Symbolleiste in der Draft Arbeitsbereich anzeigen lassen.

  • in FreeCAD wähle Werkzeuge → Anpassung aus dem oberen Menü.
  • Wähle die Registerkarte "Symbolleisten".
  • auf der linken Seite wähle "Part" im Auswahlmenü.
  • auf der linken Seite im unteren Fenster scrolle nach unten zum Eintrag " Lineare Messung" und wähle ihn aus.
  • auf der rechten Seite wähle "Draft" im Auswahlmenü.
  • Klicke auf New...., um eine neue Symbolleiste zu erstellen und einen Namen dafür zu wählen.
  • Wähle nun Deine Ziel Symbolleiste im rechten unteren Fenster (nur erforderlich, wenn Du mehr als eine Symbolleiste hast).
  • durch Anklicken des blauen "Pfeils rechts" (oberes Symbol in der mittleren Zeile) füge Deinen ausgewählten Eintrag der ausgewählten Symbolleiste hinzu

Anmerkungen

Wenn Du im Auswahlmenü auf der rechten Seite "Global" auswählst, erstellst Du eine Symbolleiste, die auf allen Arbeitsbereichen sichtbar ist.

Um ein installiertes Makro zu einer Symbolleiste hinzuzufügen, musst Du folgendes tun

  • Wähle "Makros" im Pulldown-Menü auf der linken Seite.
  • haben Menütext, Symbol (Pixmap) und so weiter mit dem Werkzeuge → Anpassen → Makros Menü zugewiesen.

Template:Std Base navi/de