Uživatelské nastavení

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface Customization and the translation is 31% complete.

Outdated translations are marked like this.
Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎日本語 • ‎한국어 • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎українська • ‎中文 • ‎中文(中国大陆)‎

Protože grafické rozhraní FreeCADu je založeno na moderním toolkitu Qt, má nejvyšší úroveň organizace. Widgety, menu, nástrojové pruhy a další nástroje mohou být modifikovány, přesunovány, sdíleny mezi pracovními plochami, mohou být nastavovány a modifikovány klávesové zkratky a mohou být zaznamenávána a přehrávána makra. Okno pro nastavení je přístupné z menu Nástroje -> Nastavení

Screenshot-customize.jpg

Záložka Commands (Příkazy) vám umožní prohlédnout všechny dostupné příkazy FreeCADu, organizované podle kategorií.

V záložce Keyboard (Klávesnice) najdete klávesové zkratku spojené s příkazy FreeCADu a budte-li chtít můžete si modifikovat nebo přiřazovat novou klávesovou zkratku k libovolnému příkazu. Toto je místo kam jít pokud budete chtít často používat některou pracovní plochu a budete chtít pro přechod na ni používat nějakou klávesovou zkratku.

Záložky Toolbars (Nástrojové pruhy) a Toolbox bars (Nástrojové boxy) Vám umožní modifikovat existující nástrojové pruhy nebo vytvářet Vaše vlastní uživatelské nástrojové pruhy.

Záložka Macros (Makra) slouží ke správě uložených maker.

Create your Toolbars for your macro Customize Toolbars

Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.

CustomizeWorkbenches.png

Example

For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in the Draft Workbench.

  • in FreeCAD choose Tools → Customize from the top menu
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on New... to create a new toolbar and choose a name for it
  • now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
  • by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar

Remarks

When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu