Interfaccia

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface and the translation is 91% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Introduzione

L'interfaccia di FreeCAD si basa su Qt, un noto toolkit di interfaccia utente grafica, particolarmente utilizzato in Linux, ma disponibile anche in Windows e MacOS.

FreeCAD interface base divisions.png

Interfaccia standard di FreeCAD 0.19.

La finestra principale dell'applicazione può essere suddivisa approssimativamente in 10 sezioni:

  1. Vista 3D
  2. Parte superiore della Vista combinata, che include la Vista a albero e il pannello Azioni
  3. Parte inferiore della Vista combinata, che include l'editor delle proprietà
  4. Vista selezione
  5. Vista report
  6. Console Python
  7. Barra di stato
  8. Barra degli strumenti, vedere le seguenti informazioni sulla barra degli strumenti
  9. Selettore degli ambienti, che è essa stessa uno strumento
  10. Menu standard

Componenti dell'interfaccia

Come molti software, FreeCAD include una barra dei menu standard, quindi una serie di barre degli strumenti e pannelli in cui si trovano gli strumenti per l'utente.

Menu

I menu standard sono: File, Modifica, Visualizza, Strumenti, Macro, Finestre, Aiuto.

Barre degli strumenti

Le barre degli strumenti standard che appaiono nell'interfaccia sono:

  • Barra degli strumenti File: strumenti per lavorare con i file, aprire documenti, copiare, incollare, annullare e ripetere azioni.
  • Selettore degli ambienti: contiene un singolo widget per selezionare l'ambiente attivo.
  • Barra degli strumenti Macro: strumenti per registrare, modificare ed eseguire le macro.
  • Barra degli strumenti Visualizza: strumenti per controllare la modalità di visualizzazione degli oggetti nella vista 3D.
  • Barra degli strumenti Struttura: strumenti per organizzare gli oggetti nel documento e creare collegamenti a documenti aggiuntivi.

Questi possono essere attivati e disattivati facendo clic con il pulsante destro del mouse su uno spazio vuoto su una delle barre degli strumenti e scegliendo l'elemento desiderato, oppure dal menu Visualizza → Barre degli strumenti.

Pannelli

I pannelli principali che consentono di lavorare con gli oggetti sono:

Ad eccezione della vista 3D, tutto può essere attivato e disattivato facendo clic con il pulsante destro del mouse su uno spazio vuoto su una delle barre degli strumenti in alto e scegliendo l'elemento desiderato, oppure dal menu Visualizza → Pannelli.

Per attivare e disattivare la barra di stato utilizzare il menu Visualizza → Barra di stato.

Altro

Altre interfacce e finestre utili includono:

  • Ispettore di scena: un pannello che mostra i nodi Coin3D che compongono la scena grafica. Per utenti esperti e sviluppatori, può essere utile per risolvere le operazioni che manipolano direttamente la scena e gli oggetti creati nella Vista 3D.
  • Grafico delle dipendenze: una finestra che mostra il grafico delle dipendenze di tutti gli oggetti nel documento, creato con il programma ausiliario Graphviz. È utile per riconoscere i problemi nella creazione di oggetti, come le dipendenze circolari, che potrebbero non essere del tutto evidenti dalla vista ad albero o dalla vista DAG.

Personalizzazione

Le barre degli strumenti possono avere più o meno pulsanti e le barre degli strumenti personalizzate possono essere create con un mix di strumenti diversi e per ospitare le macro sviluppate.

Queste opzioni sono nel menu Strumenti → Personalizza. Vedere Personalizzare l'interfaccia.