Interface

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Introduction

L’interface FreeCAD est basée sur Qt, un toolkit d’interface utilisateur graphique bien connu, particulièrement utilisé sous Linux, mais également disponible sous Windows et MacOS.

FreeCAD interface base divisions.png

Interface standard FreeCAD dans v0.19.


La fenêtre principale de l'application peut être grossièrement divisée en 10 sections:

  1. Vue 3D
  2. Partie supérieure de la Vue combinée, qui inclut la Vue d'arborescence et Panneau des tâches
  3. Partie inférieure de la Vue combinée, qui inclut l'Éditeur de propriétés
  4. Fenêtre de sélection
  5. Fenêtre de rapport
  6. Console Python
  7. Barre d'état
  8. Zone de la barre d’outils, voir les informations suivantes sur les barres d’outils
  9. Sélecteur d'atelier, qui est lui-même une barre d'outils
  10. Menu Standard

Composants de l'interface

Comme de nombreux logiciels, FreeCAD comprend une barre de menus standard, puis une série de barres d’outils et de panneaux contenant les outils utilisateur.

Menus

Les menus standard sont:

Les menus standard sont: Fichier, Edition, Affichage, Outils, Macro, Fenêtre, Aide.

Barres d'outils

Les barres d'outils standard qui apparaissent dans l'interface sont:

  • Barre d’outils Fichier: outils pour travailler avec des fichiers, ouvrir des documents, copier, coller, annuler et rétablir des actions.
  • Barre atelier: contient un seul widget pour sélectionner l'atelier actif.
  • Barre d’outils Macro: outils pour enregistrer, éditer et exécuter macros.
  • Barre d’outils Vue: outils permettant de contrôler l’apparence des objets dans la Vue 3D.
  • Barre d'outils Structure: outils pour organiser les objets dans le document et créer des liens vers des documents supplémentaires.

Celles-ci peuvent être activées ou désactivées en cliquant avec le bouton droit de la souris sur un espace vide de l'une des barres d'outils et en choisissant l'élément souhaité, ou dans le menu. Affichage → Barres d'outils.

Panneaux

Les panneaux principaux permettant de travailler avec des objets sont:

À l'exception de la vue 3D, tout peut être activé ou désactivé en cliquant avec le bouton droit de la souris sur un espace vide de l'une des barres d'outils supérieures et en choisissant l'élément souhaité, ou dans le menu, Affichage → Panneaux.

Pour activer et désactiver la barre d'état utiliser le menu, Affichage → Barre d'état.

Autre

Les autres interfaces et fenêtres utiles incluent:

  • Inspecteur de scène‏‎: panneau affichant les nœuds Coin3D constituant la Scène graphique. Pour les utilisateurs expérimentés et les développeurs, il peut être utile de résoudre les opérations manipulant directement la scène et les objets créés dans la Vue 3D.
  • Graphique de dépendance: une fenêtre affichant le graphe de dépendance de tous les objets du document, créée à l'aide du programme auxiliaire Graphique de dépendance. Il est utile de reconnaître les problèmes de création d'objets, tels que les dépendances circulaires, qui peuvent ne pas être entièrement évidents à partir de la Vue d'arborescence ou de la Vue DAG.

Personnalisation

Les barres d’outils peuvent avoir plus ou moins de boutons, et des barres d’outils personnalisées peuvent être créées avec un mélange de différents outils et pour stocker des macros développées.

Ces options sont dans le menu, Outils → Personnaliser.... Voir Personnalisation de l'interface.