Schnittstelle

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Interface and the translation is 87% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Einleitung

Die FreeCAD Schnittstelle basiert auf Qt, einem sehr bekannten grafischen Anwenderschnittstellen Werkzeugsatz, insbesondere unter Linux verwendet, der aber auch unter Windows und MacOS verfügbar ist.

FreeCAD interface base divisions.png

Standard FreeCAD Schnittstelle in 0.19.

Das Hauptfenster der Anwendung kann grob in 10 Abschnitte unterteilt werden:

  1. 3D-Ansicht
  2. Oberer Teil der Combo-Ansicht, der die Baumansicht und Aufgabenleiste beinhaltet.
  3. Unterer Teil der Combo-Ansicht, der den Eigenschaftseditor beinhaltet.
  4. Auswahlansicht
  5. Berichtansicht
  6. Python-Konsole
  7. Statusleiste
  8. Werkzeugleistenbereich, siehe folgende Informationen zu den Werkzeugleisten
  9. Workbench Selektor, der selbst eine Werkzeugleiste ist.
  10. Standardmenü

Schnittstellenkomponenten

Wie viele andere Programmstücke enthält FreeCAD eine Standardmenüleiste und dann eine Reihe von Werkzeugleisten und Eingabefeldern, in denen sich die Anwenderwerkzeuge befinden.

Menüs

Das standard menus sind: File, Edit, View, Tools, Macro, Windows, Help.

Werkzeugleisten

Die Werkzeugleisten, die in der Schnittstelle erscheinen, sind:

  • Datei Werkzeugleiste: Werkzeuge zum Arbeiten mit Dateien, Öffnen von Dokumenten, Kopieren, Einfügen, Rückgängigmachen und Wiederherstellen von Aktionen.
  • Arbeitsbereich Werkzeugleiste: Es enthält ein einziges Widget zur Auswahl der aktiven Workbench.
  • Makro Werkzeugleiste: Werkzeuge zum Aufnehmen, Bearbeiten und Ausführen von Makros.
  • Werkzeugleiste Ansicht: Werkzeuge zur Steuerung der Darstellung von Objekten in der 3D-Ansicht.
  • Struktur Werkzeugleiste: Werkzeuge, um Objekte im Dokument zu organisieren und Links zu zusätzlichen Dokumenten zu erstellen.

Diese können ein- und ausgeschaltet werden, indem mit der rechten Maustaste auf eine leere Stelle in einer der Werkzeugleiste geklickt und das gewünschte Element ausgewählt wird, oder aus dem Menü View → Toolbars.

Konsolen

The main panels that allow working with objects are:

  • 3D view: the area where 2D and 3D geometry is drawn.
  • Combo view: the panel that contains the tree view, the task panel, and the property editor.
  • Tree view: the element that shows all objects in the document and their parametric history.
  • Task panel: the panel that shows different actions and options depending on the drawing tool selected.
  • Property editor: the place where object properties are modified.
  • Selection view: the panel that shows elements that are currently selected.
  • Report view: the text box that shows different messages from the application and its tools.
  • Python console: the editor that allows running Python code interactively to see results in the 3D view.
  • Status bar: the bar that shows certain messages from the application, and that has the mouse navigation selector.
  • DAG view: an alternative to the tree view, which shows the relationships between different objects through a graph.

Mit Ausnahme der 3D Ansicht können alle Funktionen ein- und ausgeschaltet werden, indem man mit der rechten Maustaste auf einen leeren Bereich in einer der oberen Werkzeugleisten klicken und das gewünschte Element oder aus dem Menü Ansicht → Paneele auswählen.

Um die Statusleiste zu aktivieren und zu deaktivieren, verwenden Sie das Menü Ansicht → Statusleiste.

Andere

Weitere nützliche Schnittstellen und Fenster umfassen:

  • Scene Inspector: eine Konsole, die die Coin3D-Knoten anzeigt, aus denen sich der scenegraph zusammensetzt. Für Erfahrene Anwender und Entwickler kann es sinnvoll sein, Vorgänge, die die Szene direkt manipulieren, und die in der 3D-Ansicht erstellten Objekte zu beheben.
  • Dependency graph: ein Fenster, das den Abhängigkeitsgraphen aller Objekte im Dokument anzeigt, die mit dem Hilfsprogramm Graphviz erstellt wurden. Es ist hilfreich, Probleme bei der Erstellung von Objekten zu erkennen, wie z.B. zirkuläre Abhängigkeiten, die aus der Baumansicht oder der DAG-Ansicht nicht ganz ersichtlich sind.

Anpassung

Werkzeugleisten können mehr oder weniger Schaltflächen haben, und benutzerdefinierte Werkzeugleisten können mit einer Mischung aus verschiedenen Werkzeugen erstellt werden, um entwickelte Makros zu speichern.

Diese Optionen befinden sich im Menü, Werkzeuge → Benutzerdefiniert. Siehe Schnittstellenanpassung.