Installing Helpfile

From FreeCAD Documentation
Jump to: navigation, search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano


FreeCAD Helpfiles

The FreeCAD offline documentation is built from the FreeCAD wiki by using scripts. It has grown to a file size over 100 MB. These big files are not part of installers and executables of FreeCAD, but can be installed separately as documented here.

Translations from the community are encouraged, so the offline documentation is now also available in French and Italian. Other languages may be in different stages of completeness.

Download Helpfiles

A working offline documentation consist of at least two files: freecad.qhc the Qt-helpfile-configuration and freecad.qch the compressed Qt-helpfile. They are put together in a ZIP-archive.

The helpfiles can be downloaded here: https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre

As a future option they can be installed from within FreeCAD with the Addon Manager.

The help files do always have the same names: freecad.qhc and freecad.qch. In order to have different version of the helpfiles, these need to be installed in different directories. In case of a manual download, just store the zip-file locally and extract the archive into the wanted directory.

Register the Documentation

The actual organization of the offline help does allow only one helpfile to be active. It is therefore not possible to have helpfiles in different languages accessible from FreeCAD at the same time.

In order to make another FreeCAD documentation active the following steps have to be applied:

  • Click inside FreeCAD in the menu Help → Help . The program Qt-assistant should open.
  • In Qt-assistant click in the menu Edit → preferences.
  • In the preferences dialog click on the tab Documentation.
  • In the list registered documentation select org.freecad.usermanual and click on the button Remove.
  • Close the dialog with OK, but do not close the Qt-assistant. This is important as otherwise another helpfile will not be registered.
  • Open again the preferences dialog via the menu Edit → preferences.
  • Select the tab documentation and click the button Add...
  • In the filedialog navigate to your new helpfile and select freecad.qch
  • close the filedialog by confirming your selection. The Documentation tab in the preferences should now have again a line with org.freecad.usermanual.
  • Close the Preferences with OK.
  • You should now have the new documentation available in the Qt-assistant, which is accessible from within FreeCAD.

Additional Notes

In case your operating system doesn't have Qt Assistant, you should install it first.