Installieren

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Installing and the translation is 100% complete.

Other languages:
български • ‎čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎Bahasa Indonesia • ‎italiano • ‎português • ‎português do Brasil • ‎română • ‎русский • ‎svenska • ‎中文(中国大陆)‎


Betriebssystem auswählen

FreeCAD ist eine echte Multi-Platform-Anwendung, die mit dem weltberühmten Qt-Framework entwickelt wurde. Das bedeutet, Aussehen und Verhalten von FreeCAD sind unter Windows, Linux und Mac OS gleich. Der Ablauf der Installation unterscheidet sich jedoch geringfügig zwischen den einzelnen Betriebssystemen. Wählen Sie Ihr Betriebssystem (s.u.), um mehr Details über die Installation von FreeCAD zu erhalten.

'Windows' 'Linux' 'Mac'
Installation für Windows Installation für Linux/Unix Installation für Mac

Installieren zusätzlicher Inhalte

Die lokal verfügbare Dokumentation ist nicht in allen Installationsoptionen enthalten und als separates Paket erhältlich. Zu Details siehe hier: Installieren von Hilfedateien.

Abgesehen von den Standard-Arbeitsbereichen (Workbenches), die mit FreeCAD gebündelt sind, gibt es eine wachsende Sammlung nützlicher zusätzlicher Workbenches und Module, die von Community-Mitgliedern im Internet zur Verfügung gestellt werden. Es sind Bemühungen im Gange, diese zu sammeln und Ihnen auf bequeme Weise zur Verfügung zu stellen. Welche Möglichkeiten Sie haben, ist unten aufgeführt.

Da diese Workbenches nicht Teil des offiziellen FreeCAD-Pakets sind und nicht vom FreeCAD-Team direkt unterstützt werden, sollten Sie die auf den einzelnen Addons-Seiten bereitgestellten Informationen lesen, bevor Sie sie installieren, um sicherzustellen, dass Sie wissen, was Sie installieren. Außerdem sollten Fehlerberichte und Feature-Anfragen direkt auf jeder Addon-Seite gemacht werden.

Das FreeCAD-Addon Repository

Dies ist eine Sammlung von nützlichen Workbenches und Makros, die das GIT Submodul-System benutzen, welches es erlaubt, ständig aktualisierte Inhalte zu erhalten. Das FreeCAD-Addons-Repository finden Sie unter https://github.com/FreeCAD/FreeCAD-addons. Dieses Repository verfügt über ein Installer-Makro, das von FreeCAD aus gestartet werden kann und jedes der Add-Ons automatisch auflistet, herunterlädt und installiert. Seit FreeCAD 0.17 können die Addons direkt über das Tools-Menü verwaltet werden. Es ist nicht mehr nötig, das Makro zu installieren.

Bei älteren Versionen verwendet man das Installer Makro:

Das Addon Repository ist mittlerweile Bestandteil von FreeCAD

Werkzeuge->Addon Manager

Die Erweiterung für das Laden von Zusatzmodulen

Die Erweiterung für das Laden von Zusatzmodulen (pluginloader) ist eine viel besser ausgearbeitete Möglichkeit zusätzliche Inhalte für FreeCAD zu installieren und zu verwalten. Installieren Sie diese Erweiterung mit der obigen Methode oder folgen Sie den Anweisungen auf der pluginloader-Seite.

Manualles installieren von Workbenches

Externe Workbenches können, wenn sie in Python vollständig programmiert sind (was zum Zeitpunkt des Schreibens für alle zutraf) immer einfach manuell installiert werden, indem man sie einfach herunterlädt (normalerweise auf die Schaltfläche ** Download ZIP ** oben klicken) auf jeder Addon-Seite, (wenn sie auf github gehostet wird), und platzieren Sie sie im FreeCAD / Mod-Ordner Ihres Benutzers (oder im Macros-Ordner, wenn es sich um Makros handelt). Befolgen Sie die Anweisungen auf jeder Addon-Seite für vollständige Anweisungen.c

Anmerkungen für Nutzer mit 32-bit System und FreeCAD 0.16.6706

Nach Installationsversuchen sind die zusätzlichen Workbenches möglicherweise nicht verfügbar. In diesem Fall

Externe, von FreeCAD unterstützte Anwendungen

FreeCAD unterstützt von Haus aus eine Menge externer Anwendungen. Das heißt, dass die Software nur installiert werden muss und beim nächsten Start automatisch verfügbar ist. Eine Neu-Kompilierung ist nicht notwendig. Dieser Abschnitt möchte eine Liste derartiger Anwendungen bereitstellen, zusammen mit Informationen darüber, wie sie in FreeCAD verwendet werden, und wo man sie beziehen kann.

CAD Exchanger

Eine proprietäre, closed-source Anwendung zum Austausch diverser im CAD Umfeld verwendeter Dateiformate. Sie kann verwendet werden, um proprietäre, nicht-öffentliche Dateiformate in solche zu konvertieren, die von FreeCAD verwendet werden können. Die Homepage ist unter https://cadexchanger.com/ erreichbar, wo auch eine Evaluierungsversion heruntergeladen, oder eine Lizenz erworben werden kann.

CalculiX

CalculiX ist eine Suite aus zwei Finite-Elemente Paketen. Die Eine, CalculiX GraphiX, oder calculix-cgx, ist eine GUI zur Darstellung der Ergebnisse des anderen Paketes, CalculiX CrunchiX, oder calculix-ccx, einem FEM Solver. Nur die letztere wird von FreeCAD unterstützt. Es kann in der FEM Workbench über Solve->Solver CalculiX verwendet werden. Es werden ein Standard und ein experimenteller Solver von FreeCAD unterstützt. CalculiX kann von http://calculix.de heruntergeladen werden.

DXF Importer

FreeCAD verfügt über eine eingebaute Im- und Exportfunktion für DXF Dateien, die in C++ programmiert ist. Derzeit hat diese jedoch noch nicht alle Merkmale des DXF Formates implementiert. Falls diese Merkmale benötigt werden, kann ein älterer, in Python programmierter Importer/Exporter über Bearbeiten->Einstellungen->Import-Export durch Aktivieren der Option Verwende einen älteren Python-Importeur verwendet werden. Hier kann man auch angeben, ob FreeCAD diesen automatisch herunterlädt oder ob man die Dateien selbst von https://github.com/yorikvanhavre/Draft-dxf-importer beziehen möchte. Der gewählte Importer/Exporter wird über die Menus Datei->Importieren oder Datei->Exportieren verwendet, indem man das AutoDesk DXF 2D Dateiformat wählt.

Elmer

Elmer ist eine Simulationssoftware für multiphysikalische Fragestellungen, deren Quellcode in 2005 veröffentlicht wurde. In FreeCAD werden ihre Grid und Solver Module von der FEM Workbench über das Menü Solve->Solver Elmer verwendet. Die Homepage des Projektes ist unter https://www.elmerfem.org und es kann über GitHub von https://github.com/ElmerCSC/elmerfem/releases/ heruntergeladen werden.

FEniCS

FEniCS ist eine Platform zur numerischen Berechnung der Lösungen von partiellen Differentialgleichungen (PDEs), welche bei der Lösung von FEM Problemen weit verbreitet sind. Als solche kann sie von der FEM Workbench verwendet werden. FreeCAD kann FEniCS Netze (meshes) über das Menü Datei->Importieren und Datei->Exportieren durch Wahl des FEM mesh fenics Dateiformats importieren und exportieren. Die Homepage von FEniCS ist über https://fenicsproject.org erreichbar.

GitPython

Eine Python Bibliothek die zur Interaktion mit Git Repositories verwendet wird. Diese Funktionalität befindet sich bei FreeCAD derzeit im Entwicklungsstadium. Der Addon manager kann diese Bibliothek verwenden um Addons aus einem Git Repository zu installieren. Das Projekt wird auf GitHub unter https://github.com/gitpython-developers/GitPython entwickelt.

Gmsh

Ein Netzgenerator zum automatisierten Erzeugen von 3D Finite Element Netzen. Er kann von FreeCAD durch die FEM Workbench über das Menü Mesh->FEM mesh from shape by gmsh verwendet werden. Die Homepage von gmsh ist http://www.geuz.org/gmsh.

GraphViz

GraphViz ist eine Open Source Software zur Visualisierung von Graphen. In FreeCAD wird sie verwendet um Abhängigkeitsgraphen über das Menü Werkzeuge->Abhängigkeitsgraph... zu erstellen. Die Homepage ist auf https://www.graphviz.org.

ifcOpenShell

IfcOpenShell ist eine Bibliothek zur Verwendung des Industry Foundation Classes (IFC) Dateiformates, welches in der Architektur Verwendung findet. Sie kann über die Arch Workbench und das Menü Arch->Utilities->Ifc Explorer erreicht werden. Die Homepage ist http://ifcopenshell.org.

LuxCoreRender

LuxCoreRender, auch bekannt als LuxRender, ist einer von aktuell zwei unterstützten Render Engines in FreeCAD. Er wird durch den Workflow in der Raytracing Workbench verwendet. Derzeit wird nur die ältere Version LuxRender-1.x von FreeCAD unterstützt, welche aber nicht mehr weiterentwickelt wird. Falls Sie Interesse daran haben, den Code auf den neuen LuxCoreRender-2 zu aktualisieren, können Sie über das Raytracing Projekt Team mit den Entwicklern in Verbindung treten. Downloads für LuxRender-1.6 können noch über die LuxCoreRender GitHub Release Seite unter https://github.com/LuxCoreRender/LuxCore/releases heruntergeladen werden. Die Homepage des aktuellen LuxCoreRender Projektes ist https://www.luxcorerender.org.

ODA File Converter

Der ODA Dateikonverter ist eine proprietäre, Closed-Source und binäre, aber frei verfügbare Anwendung zum Import und Export der DWG und DXF Dateiformate. In FreeCAD kann er über die Menüs Datei->Importieren sowie Datei->Exportieren verwendet werden, indem man das AutoDesk DWG 2D Dateiformat auswählt. Er kann von https://www.opendesign.com/guestfiles/oda_file_converter heruntergeladen werden.

OpenCAMLib

Eine Open-Source Bibliothek die Algorithmen für Computer Aided Manufacturing (CAM) bereitstellt. Sie wird in FreeCAD in der Path Workbench verwendet. Die Homepage ist auf http://www.anderswallin.net/CAM/.

OpenFOAM

Eine Bibliothek zur Bearbeitung und Manipulation von Feldern (Field Operation and Manipulation - FOAM), welche in der numerischen Strömungssimulation (Computational Fluid Dynamics - CFD) verwendet wird. Daher wird OpenFOAM von der FEM Workbench von FreeCAD benötigt. Sie kann über das Menü Model->Fluid constraints erreicht werden. Das Projekt ist über https://openfoam.org/ erreichbar.

OpenSCAD

Der Programmers Solid 3D CAD Modellierer ist eine weitere CAD Software, die auf der Constructive Solid Geometry (CSG) Methode basiert. Das bedeutet, dass er keine Netze bearbeiten kann, sondern ausschließlich mit Festkörpergeometrie arbeitet. FreeCAD kann Dateien, die von OpenSCAD erzeugt wurden importieren und dessen Format exportieren, indem über das Menü Datei->Importieren und Datei->Exportieren eines der Dateiformate OpenSCAD CSG format oder OpenSCAD format ausgewählt wird. Man kann OpenSCAD über https://www.openscad.org/ beziehen.

POVRay

POVRay ist ein bekannter Raytracer zum Rendern von fotorealistischen Bildern. Er ist einer von zwei Raytracern, die derzeit von FreeCAD über die Raytracing Workbench unterstützt werden. Seine Verwendung wird auf der Raytracing Modul Seite beschrieben. Man kann POVRay von https://www.povray.org/ herunterladen.

pycollada

Pycollada, auch bekannt unter python-collada ist eine Python Bibliothek zum Lesen und Schreiben von COLLADA Dokumenten, einem Standard zum Austausch von 3D Szenen und Elementen. Falls sie installiert ist, kann man Szenen aus COLLADA Dateien über das Menü Datei->Importieren und Datei->Exportieren importieren und exportieren, indem man das COLLADA Dateiformat auswählt. Das Projekt wird auf GitHub unter https://pycollada.github.io/ gehostet. Man kann die Releases von https://github.com/pycollada/pycollada/releases/ herunterladen.

Z88

Z88 ist ein weiteres FEM Programm, das einen Mesher (Netzgenerator), einen Solver, sowie einen Konverter beinhaltet, welches von FreeCAD's FEM Workbench verwendet werden kann. Es kann über das Menü Solve->Solver Z88 erreicht werden. Für Z88 sind mehrere Pakete erhältlich, die frei verfügbar, aber Closed-Source sind. Das Z88OS, welches von FreeCAD benötigt wird, ist jedoch unter einer Open-Source Lizenz erhältlich. Die Homepage ist unter https://z88.de/ erreichbar. Z88OS wird auch auf GitHub unter https://github.com/LSCAD/Z88OS bereitgestellt, falls man es selbst kompilieren möchte.

< vorherige: About FreeCAD/de
nächste: Über FreeCAD >