Come installare le macro

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page How to install macros and the translation is 100% complete.

Base ExampleCommandModel.png Tutorial

Argomento
Programmazione e Configurazione
Livello di difficoltà
Medio
Tempo di esecuzione
15 minuti
Autore
Mario52
Versione di FreeCAD
Tutte
File di esempio
Nessuno


Descrizione

Questo tutorial è una breve guida su come installare le macro disponibili e utlizzarle in FreeCAD.

Questo tutorial è stato redatto su Windows, per gli altri sistemi può essere necessario apportare alcune piccole modifiche. È stato aggiornato per coprire la piattaforma Macintosh.

Python

Python è un linguaggio di programmazione, molto semplice da usare e molto veloce da imparare.

L'estensione dei file Python è .py, mentre le macro di FreeCAD, che sono anche dei file Python, hanno l'estensione .FCMacro, ma possono essere eseguite anche con l'estensione .py. L'autore di Python è Guido Van Rossun

Il menu Macro e i suoi strumenti

record Avvia registrazione stop Ferma registrazione open editor Apri menu macro execute Esegui start Debug macro stop Stop

Posizione e destinazione delle macro

Per localizzare la posizione finale delle macro è possibile usare la seguente procedura:

1 : cliccare sul menu Macro → Std DlgMacroExecuteDirect.svg Macro..., oppure, dalla barra degli strumenti, usare il pulsante Std DlgMacroExecuteDirect.svg "Apri una finestra di dialogo che consente di eseguire una macro registrata"

Dxf Importer Install 01.png

2 : questa azione apre una finestra di dialogo che contiene il campo Percorso macro,

3 : la schermata sottostante mostra un esempio di finestra con il "Percorso Macro" che di solito

  • per Windows è drive:\Users\your_user_name\AppData\Roaming\FreeCAD\
  • per Ubuntu è /home/your_user_name/.FreeCAD
  • per Macintosh è "/Users/your_user_name/Library/Preferences/FreeCAD"

4 : selezionare e poi copiare l'indirizzo di "Percorso Macro" (in questo caso è C:\Users\your_user_name\AppData\Roaming\FreeCAD\)

Dxf Importer Install 02.png

5 : Per esplorare la cartella delle macro

  • con Windows: incollare l'indirizzo nel proprio esploratore e confermare
  • con Macintosh: individuare la cartella nel Finder o incollare l'indirizzo nel esploratore (ricordarsi del prefisso "file:///" nel esploratore per un file nel disco)
Dxf Importer Install 03.png

6 : Per accedere al file

  • con Windows: lasciare aperto l'esploratore
  • con Macintosh: in alternativa, lasciare una finestra del Finder aperta, o creare un segnalibro della posizione nel esploratore, o creare un alias che punti ad esso, o trascinare la cartella nella barra laterale del Finder da cui utilizzarla con altri programmi quali editor di testo, ecc (Note: version 0.14 of FreeCAD does not support Aliases but does support the SideBar)
Dxf Importer Install 04.png


Leggere questa sezione se non si ha familiarità con la programmazione Python. Gli errori frequenti fatti con copia/incolla.

Gli errori di indentazione: esempi di codice sbagliato

Nella programmazione python la rientranza è molto importante ed è parte integrante del codice, uno spazio o uno spostamento non appropriato causano un errore di indentazione di questo tipo:

<unknown exception traceback><type 'exceptions.IndentationError'>: ('expected an indented block', ('C:/Users/d/AppData/Roaming/FreeCAD/Macro_Apothem_Based_Prism_GUI.FCMacro', 21, 3, 'def priSm(self):\n'))

in cui restituisce l'errore 'expected an indented block' block indentation expected to line 21, 3, normale dopo una class p (): in quanto la riga successiva deve avere una rientranza di almeno uno spazio.

1 : In questo esempio, il codice viene incollato senza indentazione e naturalmente non funziona! Questo è probabilmente un errore fatto dal programmatore quando ha incollato il suo codice nella pagina.

il codice incollato senza indentazione

2 : ecco come deve essere il codice corretto, con le giuste indentazioni.

il codice corretto, con le giuste indentazioni

3 : quando, selezionando il codice, si vede che la selezione avviene sul bordo del codice la macro deve funzionare

the macro must works so good

4 : Qui viene selezionato uno spazio di troppo, allora si deve copiare il codice in un elaboratore di testi e rimuovere uno spazio all'inizio di ogni riga

remove one space all lines

5 : In questo caso il codice è stato copiato da una finestra del forum con il pulsante Select all e la selezione sembra buona,

Here the code has been copied in a forum

6 : ma quando la selezione viene incollata nell'editor di FreeCAD si ha una sorpresa: il sistema aggiunge un rientro di quattro spazi! Il codice non è valido,

But the selection pasted into the FreeCAD editor gives a surprise

7 : è necessario eliminare tutto lo spazio in più che è di quattro spazi per ogni riga. In Windows l'elaboratore notepad-plus-plus consente la selezione verticale usando la combinazione di tasti Alt + Trascinamento del Mouse oppure con Menu> Modifica> Indentazione> Diminuisci indentazione.

You must delete all the extra space

8 : Qui la selezione cattura anche la colonna dei numeri di riga, e anche questo darà errore.

Here the selection also take the column numbers

9 : Il codice perfetto.

Perfect code


Metodo 1:

Metodo per copiare il codice da una finestra e incollarlo nell'editor di FreeCAD

In questo esempio viene copiata la macro Part Prism Apothem.svg Macro Apothem Based Prism GUI

Se ci sono delle icone per scaricarle posizionare il mouse sopra l'icona, fare clic sul pulsante destro del mouse e cliccare su "Salva immagine con nome ...". Le icone vengono inserite nella directory delle macro e una di esse serve come icona scorciatoia da usare nella barra degli strumenti.

Download icon

Dopo averlo copiato il codice verrà incollato nell'editor FreeCAD.

1 : Avviare FreeCAD e aprire l'editor

Dxf Importer Install 01.png

2 : Si apre la finestra dei file delle macro, fare clic sul pulsante Crea

The window macros file opens

3 : Si apre una nuova finestra, immettere il nome della macro (in questo caso: "Macro_Apothem_Based_Prism_GUI") poi cliccare su Ok

enter the macro name

4 : Ora la finestra di modifica macro di FreeCAD è disponibile e ha il nome della nostra futura macro.

The editing window FreeCAD macros

5 : Incollare il codice nella finestra dell'editor delle macro e fare clic sulla piccola croce per chiudere la finestra.

close the window

6 : Viene visualizzata una finestra di avviso che chiede di confermare, fare clic su Yes

Notare Affinché la modifica sia presa in carico e possa essere eseguita la macro deve essere registrata e poi riaperta.

A warning window appears asking for confirmation of save code

7 : Ripetere il numero 1 : , cliccare sulla nuova macro e poi su Esegui

Click on your new macro and button Execute

8 : La macro si avvia, Compila i campi dei valori e fare clic sul pulsante OK

The macro runs, complete the fields

9 : La macro restituisce un errore! Non ha trovato nessun documento aperto, aprire un documento Document-new.svg e ripetere le operazioni 7 e 8. Solo alcune macro aprono un nuovo documento quando non ne trovano uno già aperto.

The macro returns an error!

10 : Ecco il prisma!

your prism

11 : È anche possibile aprire la macro nell'editor per eseguirla o modificarla, facendo clic sul pulsante Modifica

You can also open your macro in the editor

12 : Ora che la macro è nell'editor di FreeCAD è possibile eseguirla tramite il menù "Macro Esegui macro" o cliccando sul triangolo verde Macro-execute.svg nella barra degli strumenti delle macro

The macro is now in the FreeCAD editor

Metodo 2:

Metodo per le macro compresse in un file .ZIP

Come esempio, scaricare il file Macro_screw_maker 1.7 descritto nella pagina Macro_screw_maker

Per decomprime i file in Windows si può usare una delle seguenti applicazioni free: 7-zip o L-Zarc o quickzip

In Linux basta aprire un terminale e digitare:

unzip your_file.zip -d your_directory 

si deve decomprimere lo zip e copiare i file (o tutti i file e le cartelle) nella propria directory delle macro.

Procedimento

1 : Scaricare il file in una cartella locale, in questo esempio la cartella usata è Temp

Download your file in your local folder here the folder Temp

2 : Decomprimere il file all'interno della cartella.

Unzip your file in the folder.

3 : Il decompressore ha finito il suo lavoro e ha creato una nuova cartella contenente il file scompattato

The decompressor finished his work and created a new folder with the unpacked file

4 : Entrare nella directory, selezionare il file .py poi fare clic con il pulsante destro del mouse e fare cliccare su Taglia.

Enter in the newly created directory

5 : Ritornare a l'esploratore che è rimasto aperto alla cartella delle macro (in questo esempio C:\Users\your_user_name\AppData\Roaming\FreeCAD\) , Incollare il file e poi chiudere l'esploratore.

Ritorna a l'esploratore lasciato aperto

6 : Aprire FreeCAD poi cliccare su Menu > Macro > Macros oppure cliccare sul pulsante Std DlgMacroExecuteDirect.svg "Apri una finestra di dialogo che consente di eseguire una macro registrata"

Open FreeCAD

7 : Si apre la finestra delle macro , selezionare la macro e cliccare sul pulsante Esegui

The macros window open

8 : La macro viene eseguita, inserire i dati e fare clic su Crea

Your macro is executed

9 : Whaouu

Whaouu

Se il testo non viene visualizzato:

Quando non viene visualizzata nessuna informazione.

In genere le informazioni sono visualizzate nella vista Report, ma alcune macro visualizzano le informazioni sullo schermo.

FreeCAD usa due metodi per visualizzare le informazioni nella finestra della vista report.

1 : Comandi

App = FreeCAD
App.Console.PrintMessage ("Hello World ! \n")
App.Console.PrintError ("Hello World ! \n")
App.Console.PrintWarning ("Hello World ! \n") 

oppure

FreeCAD.Console.PrintMessage ("Hello World ! \n")
FreeCAD.Console.PrintError ("Hello World ! \n")
FreeCAD.Console.PrintWarning ("Hello World ! \n") 

oppure

print "Hello World !" 

Per vedere le informazioni visualizzate nella console è necessario:

1 : Aprire FreeCAD

Open FreeCAD

2 : Cliccare sul menu Visualizza e poi su Viste

Click the View menu and Views

3 : Attivare Report e Console Python

Check Report View and Python Console

4 : ora le finestre sono abilitate e i comandi disponibili, come "App.Console.PrintMessage", sono configurati per la vista "Report"

Hello World!


2 : il comando "print" che è un comando Python.

È possibile che questo comando non visualizzi la stringa attesa.

Per visualizzare le informazioni nella finestra procedere in questo modo:

1 : Cliccare sul menu Modifica e poi su Preferenze

Edit menu

2 : Nella nuova finestra cliccare su Generali, e selezionare la scheda Finestra di Output

General

3 : attivare entrambe le caselle:

Case a cocher O.png Reindirizzare l'output interno di Python nella vista report

Case a cocher O.png Reindirizzare gli errori interni di Python alla finestra di report

e poi cliccare sul pulsante OK

Redirect internal

4 : la configurazione è finita, si dovrebbe vedere tutto.

the setup is complete

Fine dell'esercitazione. Buon lavoro.

Link

Macro addons_installer.FCMacro per una installazione facile delle macro.

Altra macro per installare facilmente delle macro freecad-pluginloader

La pagina degli Esempi di macro

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎русский • ‎svenska