Come installare ambienti di lavoro aggiuntivi

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page How to install additional workbenches and the translation is 86% complete.

Outdated translations are marked like this.
Other languages:
English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский

Base ExampleCommandModel.png Tutorial

Argomento
Programmazione
Livello di difficoltà
Medio
Tempo di esecuzione
15 minuti
Autore
r-frank
Versione di FreeCAD
Tutte
File di esempio
Nessuno


Descrizione

Gli utenti esperti hanno esteso FreeCAD con vari ambienti di lavoro esterni personalizzati, che non sono integrati nel codice sorgente di FreeCAD (non ancora!), ma che sono facili da implementare in una installazione FreeCAD esistente. Qui sono descritti i metodi di installazione per i diversi sistemi operativi.

Nota A partire dalla versione 0.17, FreeCAD include un gestore dei componenti aggiuntivi nel menu Strumenti, che consente di installare facilmente una serie di ambienti esterni. Le istruzioni riportate di seguito sono necessarie solo se si sta eseguendo una versione precedente o se si desidera installare un ambiente che non è presente nell'elenco proposto dal manager dei componenti aggiuntivi.

Installazione in Windows

Metodo di installazione consigliato

Note: using the "addons-installer" is not recommended any more. Using the Addon Manager in all systems is the recommended way.

Usare addons-installer da Github.
Durante il Google Summer of Code 2016 lo studente Mandeep Singh ha iniziato a lavorare su una versione migliore
(disponibile qui) ma tale versione necessita di ulteriori lavori prima di poter essere completamente integrata in FreeCAD.

During Google Summer of Code 2016 student Mandeep Singh started work on an improved version (available here) but that version needs further work before it can be fully integrated in FreeCAD.

Metodo di installazione alternativo "Installazione manuale"

  • scaricare il workbench da github cliccando sul pulsante “clone or download” sulla pagina GitHub (in alto a destra) e scegliendo "Download ZIP"
  • decomprimere l'archivio scaricato sul disco rigido locale
  • all'interno di FreeCAD, individuare il percorso delle macro scegliendo “Modifica > Preferenze > Generale > Macro” e vedere quale è il ”Percorso Macro”
  • supponendo che il vostro login di Windows sia “User-Name” il percorso predefinito delle macro è “C:\User-Name\Appdata\Roaming\FreeCAD”
  • all'interno della directory delle macro creare (se non è ancora presente) una cartella chiamata “Mod”
  • all'interno della cartella Mod creare una cartella con il nome dell'ambiente, ad esempio “Assembly2”
  • ora spostare i file decompressi e le sottocartelle del Workbench nella cartella dell'ambiente appena creato
  • ora, dopo il riavvio di FreeCAD si dovrebbe avere una nuova voce nel menu a discesa degli ambienti

Raccomandazioni aggiuntive per l'aggiornamento degli ambienti

In Windows, durante l'aggiornamento di un ambiente già installato, Windows mantiene il vecchio file .py come .pyc.
Dato che questo può causare dei problemi, si consiglia di disinstallare l'ambiente, riavviare FreeCAD e installare la nuova versione.

Installazione su Linux (Ubuntu/Mint)

Metodo di installazione consigliato

Aggiungere il community-ppa al ppa-manager.
Installare gli ambienti tramite il gestore dei pacchetti synaptic.

Metodo di installazione alternativo "Installazione via Git"

$ sudo apt-get install git python-numpy python-pyside
$ mkdir ~/.FreeCAD/Mod
$ cd ~/.FreeCAD/Mod
$ git clone https://github.com/hamish2014/FreeCAD_assembly2.git

Ora negli ambienti di FreeCAD ci dovrebbe essere una nuova voce denominata "Assembly 2". Una volta installato, utilizzare git per l'aggiornamento alla versione più recente tramite BASH in questo modo:

$ cd ~/.FreeCAD/Mod/FreeCAD_assembly2
$ git pull
$ rm *.pyc

Metodo di installazione alternativo "Installazione manuale"

  • scaricare il workbench da github cliccando sul pulsante “clone or download” sulla pagina GitHub (in alto a destra) e scegliendo "Download ZIP"
  • decomprimere l'archivio scaricato sul disco rigido locale
  • all'interno di FreeCAD, individuare il percorso delle macro scegliendo “Modifica > Preferenze > Generale > Macro” e vedere quale è il ”Percorso Macro”
  • Per impostazione predefinita, la directory delle macro è la directory (nascosta) "/.FreeCAD" nella propria home-directory
  • all'interno della directory delle macro creare (se non è ancora presente) una cartella chiamata “Mod”
  • all'interno della cartella Mod creare una cartella con il nome dell'ambiente, ad esempio “Assembly2”
  • ora spostare i file decompressi e le sottocartelle del Workbench nella cartella dell'ambiente appena creato
  • ora, dopo il riavvio di FreeCAD si dovrebbe avere una nuova voce nel menu a discesa degli ambienti

Installazione su Mac

Metodo di installazione consigliato


Metodo di installazione alternativo “installazione manuale” - qui una descrizione per l'ambiente "assembly2"

  • scaricare il repository git come ZIP
  • assumendo che FreeCAD sia installato in "/Applications/FreeCAD/v0.15", andare in "/Applications/FreeCAD/v0.15" con il Browser, e selezionare FreeCAD.app
  • cliccare con il tasto destro del mouse e selezionare "Show Package Contents", appare una nuova scheda denominata "Contents"
  • fare un singolo clic sulla cartella "Contents" e selezionare la cartella "Mod"
  • nella cartella "Mod" creare una nuova cartella con il nome "assembly2"
  • decomprimere il repository scaricato nella cartella "Contents/Mod/assembly2"


Copiare o decomprimere la cartella drawing dimensioning nella directory FreeCAD.app/Contents/Mod dove FreeCAD.app è la cartella in cui è installato FreeCAD.

Risoluzione dei problemi generali

  • In Windows non utilizzare i caratteri speciali (ad esempio dieresi tedesca) per il nome utente, altrimenti FreeCAD non riconosce i file e le cartelle nel percorso delle macro
  • Se è già stato impostato un nome utente con caratteri speciali, creare un nuovo nome utente o puntare il percorso macro a una directory che non utilizzi caratteri speciali
  • L'ambiente non viene ancora mostrato? In FreeCAD, scegliere “Strumenti > Personalizza > Ambienti” e assicurarsi che non sia impostato su invisibile
  • Nota per gli utenti dei sistemi 32-bit e FreeCAD 0.16.6706. Dopo un tentativo di installazione, gli ambienti aggiuntivi potrebbero non essere disponibili. In questo caso