FreeCAD ve DXF içe aktarma

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page FreeCAD and DXF Import and the translation is 50% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎hrvatski • ‎italiano • ‎Türkçe

Yasal Uyarı

DXF Dosyalarını içe aktarabilmek için birkaç dosyayı manuel olarak yüklemeniz gerekir. Neden derseniz? Bu kütüphaneler, FreeCAD'den başka bir lisansla yayınlanmaktadır, dolayısıyla FreeCAD geliştiricileri, FreeCAD-Uygulaması ile birlikte sunmayacaktır.

Nasıl kurulur

Draft-dxf-importer uygulamasını kurmak için:

  1. Yorik'in Github hesabına gidin ve bu dosyaları indirin (sağ tarafta "ZIP olarak indir" seçeneğini seçebilirsiniz).
  2. Dosyaları makro klasörünüze yerleştirin.
  • Ubuntu'da bu normal

  /home/your_user_name/.FreeCAD Dizin gizlidir. Görünür hale getirmek için gizliliğini kaldırmanız gerekebilir.

  • Windows'ta, (standart) makro dizininiz

  C:\Users\kullanıcı_adınız\AppData\Roaming\FreeCAD

Automatically

If not already installed, go to the menu Edit → Preferences → Import/Export → DXF and enable the option Allow FreeCAD to automatically download the DXF libraries to make FreeCAD automatically and installing these libraries.

For FreeCAD 0.14 or older you have to install it manually:

Manually

  1. Go to Yorik's Github account and download these files (on the right side you can choose "download as ZIP").
  2. Put the files in your macro folder.
  • In Ubuntu, this is normally
/home/your_user_name/.FreeCAD 

The directory is hidden. You may need to unhide it to make it visible.

  • In Windows, your (standard) macro directory is
C:\Users\your_user_name\AppData\Roaming\FreeCAD

Makro dizininizin nerede olduğundan emin değilseniz,

  1. FreeCAD'i açın ve "Düzenle → Seçenekler" e gidin,
  2. Sol sütunda "Genel" i seçin ve Seçenekler penceresinin sağ üst köşesinde "Makro" kategorisini seçin. "Makro Yolu" adlı bir alan olmalı.

Kılavuz: Dxf Importer kurulumu

== Ayar Seçenekleri DWG / DXF için çeşitli içe aktarma seçenekleri ayarlayabilirsiniz. Sürümünüze bağlı olarak farklı bir yöntem kullanmanız gerekir.

  • FreeCAD 0.14 ve daha eski sürümler
  1. FreeCAD'i açın.
  2. Taslak Tezgahına geçin. (Aksi takdirde seçenekleri göremezsiniz)
  3. "Düzenle → Seçenekler" e gidin ve sol sütunda "Taslak" ı seçin.
  4. Tercihler penceresinin sağ üst köşesindeki "DXF / DWG-Options" seçeneğini seçin.
  • FreeCAD 0.15 ve üzeri sürümler
  1. FreeCAD'i açın.
  2. Taslak Tezgahına geçin. (Aksi takdirde seçenekleri göremezsiniz)
  3. "Düzenle → Seçenekler" e gidin.
  4. Şimdi sol sütunda "İçe Aktar" etiketli bir simge görmelisiniz. Bunu seçin.

İpuçları ve Püf Noktaları

Bazen DXF Dosyaları 2D-DXF-CAD Programlarında sorunsuz bir şekilde açılsa bile içe aktarılamıyor olabilir.
Şunları deneyebilirsiniz:

  1. Düzenle → Seçenekler → İçe / Dışa Aktar → DXF / DWG seçeneğine gidin ve "geometri birleştir" seçeneğinin işaretini kaldırın ve tekrar deneyin.
  2. Unutmayın belki şimdi rastlantısal çizgi sonu noktalarına sahip olmayacaksınız. Onları kendin tayin etmek zorunda kalacaksın.
  3. Bunu, eskiz çalışma tezgahında "Şekli Kapat" komutuyla yapabilir (sürüm 0.15'e ihtiyaç duyar) veya kısıtlamaları manuel olarak uygulayabilirsiniz.

Ayrıca şunu da deneyebilirsiniz:

  1. Düzenle → Seçenekler → Taslak → Genel'e gidin ve "Tolerans" değerini ayarlayın (varsayılan: 0,05)
  2. Tekrar deneyin

İçe aktarma da sorun yaşamamanız dileğiyle.