File Format FCStd

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page File Format FCStd and the translation is 100% complete.

Other languages:
čeština • ‎English • ‎español • ‎français • ‎Bahasa Indonesia • ‎italiano • ‎polski • ‎português • ‎română • ‎русский

Le format de fichier .FCStd est le format de fichier principal de FreeCAD. Il s’agit d’un format conteneur prenant en charge la compression et l’incorporation de différents types de données.

Contenu d'un fichier .FCStd

FCStd est un fichier zip standard contenant un ou plusieurs fichiers dans une structure spécifique. En tant que tel, il est possible de décompresser un fichier .FCStd à l'aide d'un outil de décompression zip, mais des précautions doivent être prises lors de la reconstruction du fichier .FCStd. FreeCAD possède un "Utilitaire de Projet" pour reconstruire les fichiers .FCStd, dont l'utilisation est décrite dans Modifier le code source du fichier .FCStd ci-dessous.

Composants

Document.xml

C'est le fichier .xml principal, décrivant tous les objets à l'intérieur d'un document FreeCAD, c'est-à-dire la définition géométrique et les paramètres des objets, mais pas leur représentation visuelle. Si FreeCAD est exécuté en mode console (sans l'interface graphique), c'est ce Document.xml qui sera utilisé.

Exemple de Document.xml
 <?xml version='1.0' encoding='utf-8'?>
 <!--
 FreeCAD Document, see http://free-cad.sourceforge.net for more informations...
 -->
 <Document SchemaVersion="4">
    <Properties Count="9">
       <Property name="Comment" type="App::PropertyString">
          <String value=""/>
       </Property>
       <Property name="Company" type="App::PropertyString">
          <String value=""/>
       </Property>
       <Property name="CreatedBy" type="App::PropertyString">
          <String value=""/>
       </Property>
       <Property name="CreationDate" type="App::PropertyString">
          <String value="Fri Jan 29 15:14:38 2010 "/>
       </Property>
       <Property name="FileName" type="App::PropertyString">
          <String value="/tmp/test.FCStd"/>
       </Property>
       <Property name="Id" type="App::PropertyString">
          <String value="201b746f-a1ed-4297-bf3d-65d5ec11abe0"/>
       </Property>
       <Property name="Label" type="App::PropertyString">
          <String value="names"/>
       </Property>
       <Property name="LastModifiedBy" type="App::PropertyString">
          <String value=""/>
       </Property>
       <Property name="LastModifiedDate" type="App::PropertyString">
          <String value="Fri Jan 29 15:15:21 2010 "/>
       </Property>
    </Properties>
    <Objects Count="2">
       <Object type="Mesh::Cube" name="Cube" />
       <Object type="Part::Box" name="Box" />
    </Objects>
    <ObjectData Count="2">
       <Object name="Cube">
          <Properties Count="7">
             <Property name="Height" type="App::PropertyFloatConstraint">
                <Float value="10"/>
             </Property>
             <Property name="Label" type="App::PropertyString">
                <String value="Cube"/>
             </Property>
             <Property name="Length" type="App::PropertyFloatConstraint">
                <Float value="10"/>
             </Property>
             <Property name="Mesh" type="Mesh::PropertyMeshKernel">
                <Mesh file="MeshKernel.bms"/>
             </Property>
             <Property name="Placement" type="App::PropertyPlacement">
                <PropertyPlacement Px="0" Py="0" Pz="0" Q0="0" Q1="0" Q2="0" Q3="1"/>
             </Property>
             <Property name="Pos" type="App::PropertyPlacementLink">
                <Link value=""/>
             </Property>
             <Property name="Width" type="App::PropertyFloatConstraint">
                <Float value="10"/>
             </Property>
          </Properties>
       </Object>
       <Object name="Box">
          <Properties Count="7">
             <Property name="Height" type="App::PropertyLength">
                <Float value="10"/>
             </Property>
             <Property name="Label" type="App::PropertyString">
                <String value="Box2"/>
             </Property>
             <Property name="Length" type="App::PropertyLength">
                <Float value="10"/>
             </Property>
             <Property name="Placement" type="App::PropertyPlacement">
                <PropertyPlacement Px="0" Py="0" Pz="0" Q0="0" Q1="0" Q2="0" Q3="1"/>
             </Property>
             <Property name="Pos" type="App::PropertyPlacementLink">
                <Link value=""/>
             </Property>
             <Property name="Shape" type="Part::PropertyPartShape">
                <Part file="PartShape.brp2"/>
             </Property>
             <Property name="Width" type="App::PropertyLength">
                <Float value="10"/>
             </Property>
          </Properties>
       </Object>
    </ObjectData>
 </Document>

GuiDocument.xml

Il s'agit de l'équivalent GUI (Graphique User Interface) du fichier Document.xml. Pour chaque objet décrit dans le Document.xml, il y a un objet correspondant dans GuiDocument.xml, qui décrit la représentation visuelle de l'objet (couleur, largeur, etc.).

Thumbnails/thumbnail.png

Il s'agit d'une image miniature (thumbnail) du document de 128 x 128 pixels, qui représente une capture d'écran de la vue 3D pour gagner du temps. Les vignettes sont uniquement générées, si l'option correspondante est activée dans les préférences de FreeCAD, Édition → Préférences... → Général → Document → (case à cocher) Enregistrer la vignette dans le fichier projet lors de la sauvegarde du document.

Templates/*.svg

Les fichiers .svg résultants, sont stockés dans le dossiers "modèles", et, sont utilisés dans le Module Drawing.

*.brep

Ce sont les formes B-Rep de tous les objets, qui ont une forme dans le Document.xml. Même s'il est paramétrique, chaque objet a sa forme stockée comme un fichier individuel .brep, on y accède donc par des composants sans devoir recalculer la forme.

Structure

Structure typique d'un fichier .FCStd :

 --File.fcstd
  |
  --Document.xml
  --GuiDocument.xml
   |
   --Thumbnails
    |
    --thumbnail.png
   |
   --Templates
    |
    --MyPage.svg
  --Shape1.brep
  --Shape2.brep
  --etc...

Modifier le code source du fichier .FCStd

ATTENTION TRAVAILLEZ TOUJOURS SUR UNE COPIE DE VOTRE PROJET !


Il est possible de modifier le source d'un fichier .FCStd mais la procédure n'est pas sans risques c'est pour cela qu'il faut toujours travailler sur une copie.

Après avoir fait une copie de votre projet, procédez comme suit :

Créez un nouveau répertoire et placez votre copie dans ce répertoire (il peut y avoir beaucoup de fichiers dans votre FCStd).

  • Allez dans le menu Outils → Utilitaire de projet... Extraire le projet

Project utility fr.png

  • Source : Donnez le chemin de votre copie à décompresser.
  • Destination : Donnez le chemin pour les fichiers décompressés.
  • Cliquez sur Extraire
  • Allez dans votre répertoire et ouvrez les deux fichiers GuiDocument.xml et Document.xml à l'aide de Notepad++ (Windows) (Notepad permet de modifier un mot dans tous les documents ouverts).
  • GuiDocument.xml : contient tous les renseignements de votre projet relatifs à l'interface, affichage dans la Vue combinée, la configuration de FreeCAD . . .
    • Exemple avec Text004
		<ViewProvider name="Text004">
			<Properties Count="9">
				<Property name="DisplayMode" type="App::PropertyEnumeration">
					<Integer value="1"/>
				</Property>
				<Property name="FontName" type="App::PropertyString">
					<String value="Arial"/>
				</Property>
				<Property name="FontSize" type="App::PropertyFloat">
					<Float value="5.199999809265"/>
				</Property>
				<Property name="Justification" type="App::PropertyEnumeration">
					<Integer value="0"/>
				</Property>
				<Property name="LineSpacing" type="App::PropertyFloat">
					<Float value="0.600000023842"/>
				</Property>
				<Property name="Rotation" type="App::PropertyAngle">
					<Float value="0.000000000000"/>
				</Property>
				<Property name="RotationAxis" type="App::PropertyEnumeration">
					<Integer value="2"/>
				</Property>
				<Property name="TextColor" type="App::PropertyColor">
					<PropertyColor value="4294901760"/>
				</Property>
				<Property name="Visibility" type="App::PropertyBool">
					<Bool value="true"/>
				</Property>
			</Properties>
		</ViewProvider>
  • Document.xml : contient tous les renseignements relatifs aux objets constituants votre projet.
    • Exemple avec Text004
		<Object type="App::Annotation" name="Text004" />
		<Object name="Text004">
			<Properties Count="3">
				<Property name="Label" type="App::PropertyString">
					<String value="Text004"/>
				</Property>
				<Property name="LabelText" type="App::PropertyStringList">
					<StringList count="1">
						<String value="135"/>
					</StringList>
				</Property>
				<Property name="Position" type="App::PropertyVector">
					<PropertyVector valueX="-30.000000000000" valueY="26.000000000000" valueZ="0.000000000000"/>
				</Property>
			</Properties>
		</Object>
  • Les renseignements comme :
<VectorList file="Points1"/> 
<ColorList file="DiffuseColor"/> 
<Mesh file="MeshKernel.bms"/> 
<Part file="PartShape.brp2"/>
. . . .
  • ainsi que d'autres définitions contenants file= sont reliées a un de ces fichiers et si vous modifiez par exemple "DiffuseColor" dans <ColorList file="DiffuseColor"/> vous devez aussi modifier le nom du fichier pour la correspondance.
  • Une fois que le mot à modifier est repéré, faites "Recherche" (votre mot) et "Remplacer par" (votre nouveau mot) et cliquez sur Remplacez dans tous les documents ouverts et votre changement se fera de la même manière dans les deux fichiers GuiDocument.xml et Document.xml.
  • Quand les modification sont terminées, retournez dans le Menu Outils → Utilitaire de projet... Créer un projet
  • Source : Donnez le chemin du fichier que vous venez de modifier et qui est à reconstituer.
  • Destination : Donnez le chemin du fichier FCStd à reconstituer.
  • Cliquez sur ... dans la nouvelle fenêtre cliquez sur Créez un nouveau dossier (pour éviter les erreurs de réécriture du fichier) et validez. Cliquez sur Créer vous pouvez cocher la case "Charger le fichier de projet après la création".
  • Si vous avez coché la case "Charger le fichier de projet après la création" votre projet se chargera dans FreeCAD.
  • PS : Il faut absolument qu'il y ait concordance entre les documents GuiDocument.xml, Document.xml et les fichiers sans quoi il y aura des erreurs dans votre fichier .FCStd. C'est pour cela qu'il faut toujours travailler sur une copie de votre projet.

Autres

Voici un utilitaire convertisseur de fichiers ImageConv.