Draft tutorial obsoleto

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft tutorial Outdated and the translation is 100% complete.

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎Türkçe

Base ExampleCommandModel.png Tutorial

Argomento
Draf
Livello di difficoltà
Base
Tempo di esecuzione
Autore
Versione di FreeCAD
File di esempio


Il modulo Draft è cambiato molto da quando questo tutorial è stato scritto. Molti concetti sono ormai diversi e potrebbero non funzionare nel modo in cui sono descritti di seguito.


Questo tutorial vi spiega come utilizzare il modulo di disegno 2D di FreeCAD (chiamato modulo Draft) per creare il disegno di una semplice architettura. A questo scopo, disegneremo una semplice cabina in muratura. Supponiamo di aver ricevuto in un disegno CAD la mappa che mostra la posizione della cabina, quindi la useremo per disegnarvi sopra il nostro progetto. Disegneremo un piano, una sezione e due prospetti.

Prima di iniziare

Ricordate che FreeCAD è ancora in una fase iniziale di sviluppo, quindi potrebbe non essere così produttivo come altre applicazioni CAD, e incontrerete certamente dei bug o dei crash. Ora FreeCAD ha la possibilità di salvare i file di backup. Il numero di questi file di backup può essere specificato nella finestra di dialogo delle preferenze. Non esitate a consentire 2 o 3 file di backup finché non sapete bene come comportarvi con FreeCAD.

Salvare sovente il proprio lavoro, e di tanto in tanto salvarlo con un nome diverso, in modo da poter sempre recuperare una copia di "sicurezza"; inoltre, essere preparati alla possibilità che alcuni comandi possano dare risultati diversi da quelli attesi.

Impostare l'area lavoro di FreeCAD

FreeCAD è un modellatore 3D, ma in questo tutorial lo useremo solo per lavorare in 2D. Disegneremo sul piano terra, e tutto ciò che faremo avrà la coordinata Z=0. Per prima cosa, disponetevi in vista dall'alto premendo il tasto 2 e accertatevi di essere in proiezione ortogonale premendo il tasto O, per evitare di essere ingannati dagli effetti prospettici.

Un'altra cosa molto importante da fare, è quello di personalizzare i tasti scorciatoia dei vostri comandi di Draft. Così potrete eseguire tutti i comandi da tastiera e incrementare drasticamente la velocità. Fondamentalmente si può fare tutto dalla tastiera, il mouse serve solo per disegnare i punti e per selezionare gli oggetti. Andate nel menu Personalizza -> Tastiera -> Category Python e selezionate le scorciatoie come preferite, una buona idea è quella di renderli facili da ricordare. Ad esempio, io uso L per la linea, W per Polilinea (chiamata anche Wire in FreeCAD), A per Arco, C per Cerchio, M per il movimento, R per ruotare, F per Offset (O è già usato per ortografico), D per Dimensione, T per il testo, ecc ..

Finita la configurazione, possiamo cominciare a disegnare.

Importare i disegni CAD

Se avete intenzione di importare un disegno CAD 2D, ci sono molte probabilità che esso sia in un formato proprietario come .dwg (da AutoCAD) o .mcd (da VectorWorks). Le specifiche di tali formati di file vengono tenuti segreti dai loro creatori, per cui è estremamente difficile o del tutto impossibile supportarli in FreeCAD. Tuttavia, un formato di file che è abbastanza ben documentato è il formato DXF, e il modulo Draft lo supporta parzialmente.

Quasi tutte le applicazioni CAD possono esportare in formato DXF, inoltre sono disponibili diversi convertitori free come l'utility Open Design Alliance's ODA File Converter che permette di convertire i file nel formato DXF. Per esempio, Doublecad è un programma CAD free con tutte le funzioni per esportare i file DXF:

Doublecad.jpg

Aprite il file DXF semplicemente con il dialogo File -> Apri. Nella schermata Preferenze di Draft possono essere configurate diverse impostazioni di importazione. Ad esempio, è possibile stabilire se si desidera che il file DXF sia importato con i colori e gli spessori di linea originali, o convertito nella gamma dei colori correnti di Draft, visibili sul lato destro della barra dei comandi Draft. In FreeCAD non è necessario attribuire dei colori brutti agli oggetti per determinare lo spessore delle loro linee. Tutti gli oggetti hanno gli attributi di colore e di spessore linea indipendenti. Potete tranquillamente ignorare i colori del DXF, o convertire tutto con colori a scelta.

Dopo averlo importato in FreeCAD, il disegno sarà simile a questo:

Situation.jpg

Continuiamo facendo qualche pulizia.

Tutorial-treeview.jpg
In FreeCAD, non ci sono i layer (livelli o strati) come in AutoCAD. Noi lavoriamo invece con i gruppi. I gruppi sono un modo più flessibile per organizzare il disegno. È possibile creare dei nuovi gruppi con il tasto destro del mouse sulla vista ad albero, riorganizzarli, spostarli in altri gruppi, o spostare oggetti da o per gruppi semplicemente trascinando e rilasciando le cose nella vista ad albero. Inoltre, è possibile assegnare simultaneamente la larghezza di linea e i colori correnti a tutti gli oggetti in un gruppo, oppure attivarli o disattivarli premendo la barra SPAZIO.

Per accelerare il lavoro, mettere tutti gli oggetti in un nuovo gruppo e disattivare tutto quello che non sarà usato, come la vegetazione e le dimensioni.

Disegnare la vista in pianta

Utilizzando gli strumenti di disegno

L'unica cosa che ci serve in questo momento è l'area che viene assegnata alla nostra cabina. Si trova in un gruppo separato denominato "proiezione". Quindi possiamo nascondere tutto il resto con il tasto SPAZIO e iniziare a disegnare su di essa. Disegneremo una piccola cabina con una stanza di guardia e un WC, in semplice muratura portante, quindi non ci sarà bisogno di lavori speciali nello stesso piano. Metteremo uno strato di intonaco all'interno, e uno strato di piastrelle di ceramica all'esterno.

Allora, cominciamo creando la forma generale dei muri:

Draft-tutorial-01.jpg

Il nostro disegno DXF è stato redatto in metri, quindi a meno che non abbiamo qualche motivo per cambiare, continueremo con le stesse unità. FreeCAD al momento non ha ancora un sistema amichevole per lavorare con le unità reali, quindi supponiamo che "uno" significhi "un metro".

Un'altra buona cosa che è bene ricordare è quella di costruire la geometria temporanea quando serve. Volete avere un punto che si trovi a 2 metri di distanza orizzontale? Disegnate una linea verticale, spostatela alla distanza di 2m, e incrociatela con una linea orizzontale ed ecco costruito il punto.

  • Creare un rettangolo: Con CTRL agganciare i suoi vertici ai vertici dell'area assegnata
  • Creare un rettangolo Offset: Con il rettangolo selezionato, premere Offset, premere C per attivare la modalità di copia, spostare il mouse all'interno del primo rettangolo così offset sa in quale direzione andare, e digitare 0.20, poi Enter
  • Trasformarli in facce: Upgrade il primo rettangolo, Upgrade il secondo rettangolo, quindi selezionare il rettangolo esterno, CTRL e selezionare il rettangolo interno e premere Downgrade
  • Creare l'apertura della porta: Creare un rettangolo di 1.00 x 0.50, spostarlo nell'angolo superiore della parete principale (premere C per disattivare la modalità di copia).
  • Spostare l'apertura della porta nella posizione giusta: Spostarla di 0.10 a sinistra. Non mettiamo l'apertura nell'angolo, perché renderebbe difficile aprire la porta.
  • Sottrarre l'apertura della porta: Selezionare il muro, CTRL e selezionare l'apertura della porta, e premere downgrade.

Una nota su upgrade & downgrade

Il kernel OpenCascade su cui è costruito FreeCAD è un kernel 3D, fatto principalmente per le operazioni 3D. Quando deve tagliare o unire delle facce piane, come stiamo facendo ora con le operazioni di upgrade / downgrade, a volte fa strane cose, e le operazioni successive (come altri upgrade/downgrade) non danno sempre i risultati sperati. Naturalmente con il tempo questi comportamenti finiranno per essere corretti dagli sviluppatori di FreeCAD, ma è bene conoscere dei modi alternativi per risolvere i problemi attuali.

Il modo migliore per risolvere una faccia in cui le operazioni di upgrade/downgrade/offset non funzionano correttamente, è quello di scomporla ripetutamente, fino a quando tutto è scomposto in singoli bordi, quindi ricomporre di nuovo i bordi in una nuova faccia. Nel caso che questo non funzioni, ridisegnare un nuovo contorno (polilinea) sulla parte superiore della faccia problematica, agganciandosi alle sue estremità, quindi eliminare la vecchia faccia e applicare upgrade al nuovo contorno. Di solito è meglio avere una faccia disegnata piuttosto che una faccia ottenuta con upgrade o downgrade.

Un'altra cosa da tenere a mente è che quando si sottrae una forma da un'altra, ci si può trovare con un oggetto che contiene diverse facce. Questo potrebbe rendere difficile il lavoro successivo (offset non realizzati correttamente, ecc), quindi una buona cosa in questo caso è quello di separarle sempre con lo strumento downgrade.

Un'altra nota su aggancio

Nel modulo Draft ci sono due forme di aggancio: quello passivo, che avviene quando si passa semplicemente il cursore del mouse su un oggetto (appare il simbolo del cerchio aperto), e l'aggancio attivo, che avviene quando si preme CTRL. L'aggancio attivo permette di ancorare dei punti specifici di un oggetto, come i suoi punti finali, i punti medi, i centri o le intersezioni con altri oggetti. Se si preme SHIFT, che è il tasto per vincolare orizzontale e verticale, si ottengono ulteriori punti di aggancio. Ma questo ha un costo, perché FreeCAD deve fare molti calcoli in tempo reale. Quando ci sono molti oggetti, si inizia a notare la differenza. Quindi un buon trucco per velocizzare il lavoro è quello abituarsi a lavorare il più possibile con SHIFT e solo l'aggancio passivo. Si vedrà rapidamente che si ottengono risultati accurati lavorando molto più velocemente.

Ora torniamo al lavoro:

  • Creare un muro largo 10 cm tra la sala principale e il WC. Promuoverlo, quindi promuoverlo con il muro principale per unirli
  • Creare degli altri rettangoli per le altre aperture. Io ho messo una finestra di 60 cm in quello che diventerà il WC, una porta di 80 cm tra la camera principale e il bagno, e per la grande finestra della stanza principale ho semplicemente lasciato 40 centimetri di muro a sinistra e a destra.
  • Creare un offset di 1 cm con tutte le pareti, per l'intonaco, quindi declassare le copie offsett per trasformarle in semplici contorni
  • Creare uno strato di piastrellatura in ceramica sul lato esterno, applicando un offset di due centimetri alla linea dell'intonaco, quindi disegnare una forma di 2 cm di spessore tra le due linee
  • Eliminare l'offset di 2 cm. che non serve più, così come tutta la geometria di costruzione. Se si pensa che possa servire in un secondo momento, è sufficiente metterla in un gruppo separato e nascondere tutto il gruppo con il tasto SPAZIO.

Questo è il punto a cui siamo ora (ho mantenuto la geometria di costruzione, in blu, per farla vedere):

Draft-tutorial-walls.jpg

Importare e costruire oggetti composti

In FreeCAD, gli oggetti composti sono degli oggetti realizzati con la geometria di alcuni altri oggetti. In altri software, si parla di blocchi, simboli o componenti. È un modo molto pratico per raggruppare le geometrie sotto un unico oggetto. Tutti gli oggetti creati con il modulo Draft possono essere raggruppati in un composto. Il comando per creare un composto è Upgrade. Il suo utilizzo è semplice, selezionate tutto quello che volete trasformare in un composto e poi premete Upgrade. Se non è possibile creare nessuna altra forma più intelligente, gli oggetti saranno trasformati in un composto.

Utilizzare la geometria composta è particolarmente utile per costruire una libreria di simboli, in modo da poterli riutilizzare in seguito. Un uso astuto di questo, unito alla funzione di importazione DXF, è che si può facilmente utilizzare le librerie dei simboli in formato DXF (se i simboli sono in formato dwg, l'applicazione free "Teigha file Converter" può convertire tutta la libreria in una volta sola).

Quando esiste una libreria di simboli DXF, basta trascinarne uno e rilasciarlo nella finestra aperta di FreeCAD e questi sarà importato nel documento corrente. Non sarà importato come un composto, ma tutta la geometria simbolo verrà inserita in un gruppo separato, quindi è facile selezionare tutto e premere "Upgrade". Attenzione che gli utenti di AutoCAD hanno la cattiva abitudine di disegnare le cose molto lontano dal punto di origine (0,0,0), il simbolo inserito può quindi trovarsi molto lontano dalla zona di disegno.

Quindi, tornando al nostro disegno:

  • Importate un blocco sanitario se ne avete uno, oppure sceglietene uno in nel sito Cad Exchange e convertirlo in DXF con "Teigha file Converter"
  • Create la geometria per una porta, applicate upgrade per produrre un composto, copiate il composto nella posizione dell'altra porta, applicate downgrade, adeguate gli elementi alla nuova dimensione, e poi applicate di nuovo upgrade
  • Fate la stessa cosa per le finestre

Draft-tutorial-blocks.jpg

Quote e annotazioni

Ora che il nostro piano è più o meno pronto, possiamo aggiungere le dimensioni e i testi. Di solito, questo è abbastanza semplice, quindi probabilmente non c'è bisogno di spiegare molto. Basta provare a quotare tutto, e come da convenzione, far partire sempre le linee di quota dalla linea della parete principale, non dallo strato di finitura. Una cosa è bene sapere, a volte si disegna un testo o una quota in una zona riempita e il riempimento dell'area copre la dimensione. C'è un modo semplice per risolvere questo, applicate un downgrade e poi di nuovo un upgrade all'area riempita. In questo modo il riempimento risulta visualizzato sotto agli altri elementi che diventano così visibili.

La dimensione del testo di quotatura di default hanno la stessa altezza del testo, che può essere modificato nella scheda Preferenze. È quindi possibile modificare singolarmente ogni altezza del testo.

Purtroppo alcuni oggetti che non sono geometria, come i testi e le dimensioni, non sono ancora selezionabili nella vista 3D di FreeCAD, quindi è necessario selezionarli nella struttura, e non è possibile agganciarsi a questi oggetti, ma questo sarà probabilmente risolto in un prossimo futuro. Inoltre al momento non è possibile scegliere un font di stile. Per allineare le dimensioni, per ora, è necessario tracciare prima una linea e poi agganciare le dimensioni alla linea.

Draft-tutorial-dims.jpg

Organizzare

Draft-tutorial-typical-tree.jpg

Infine, possiamo aggiungere un paio di cose per finire il piano, come mettere la vegetazione intorno alla cabina. Basta copiare alcuni alberi dal disegno DXF importato e scalarli con lo strumento scala, per esempio a (0.5,0.5). Possiamo anche modificare lo spessore di un paio di oggetti, per esempio, fare i muri più spessi e cambiare il colore di alcune cose. Possiamo organizzare tutti i nostri elementi in gruppi.

La capacità di organizzare il lavoro in gruppi nidificati è sicuramente uno dei grandi vantaggi dei gruppi rispetto al lavoro più tradizionale basato sui livelli. In questo tutorial, ho raggruppato i miei oggetti per tipo, all'interno del gruppo Piano. Ad esempio, invece di avere un grande livello con tutte le dimensioni del disegno, ogni parte del disegno contiene il proprio gruppo dimensioni, rendendo estremamente facile organizzare il disegno.

In un primo momento, se si proviene da un programma di disegno tradizionale come AutoCAD, potrebbe sembrare una perdita, ma vedrete immediatamente la potenza che questo metodo porta.

Ad esempio, tutta la nostra geometria di costruzione può andare in un gruppo separato, che disattiviamo. Forse più avanti avremo bisogno di apportare alcune modifiche, e sarà comodo avere quella geometria a disposizione.

Così, ora siamo pronti a disegnare altre parti ...


Disegnare i prospetti

Draft-tutorial-elevation.jpg

Dato che in questo esercizio abbiamo intenzione di rimanere in puro 2D, disegneremo direttamente i prospetti e le sezioni. Negli ambienti di architettura più avanzati (quali FreeCAD, si spera, diventerà in futuro), non sarebbe necessario disegnare le altimetrie. Si modellerebbe l'edificio in 3D e poi i vari prospetti sarebbero generati automaticamente. Ma ai fini di questo esercizio (e anche perché in FreeCAD non sono ancora implementati tutti gli strumenti necessari), li faremo a mano, come ai vecchi tempi.

Iniziamo con il prospetto della parete posteriore perché, dato il modo in cui il nostro piano è orientato, può essere disegnato direttamente sotto di esso, senza la necessità di ruotare la vista. Disegniamo le linee di costruzione del piano, le linee orizzontali posizionate alle altezze desiderate. Io ho impostato il livello 0,00, il livello della soletta del pavimento a +0,15, le altezze delle finestre e il solaio di copertura a +2.50. Dopo, basandoci su queste linee, possiamo disegnare molto rapidamente la geometria.

Possiamo poi inserire un paio di annotazioni, le dimensioni e aggiornare alcuni degli oggetti in modo che appaiano colorati. Infine, possiamo fare un po' di pulizia, creando il gruppo "Prospetto Sud", poi i sottogruppi per la geometria di costruzione e le annotazioni e inserirvi tutti i nuovi oggetti.


Ruotare la vista, creare le macro

Ora, dobbiamo disegnare le altre elevazioni del nostro piccolo edificio. Il modo più semplice sarebbe quello di disegnare direttamente sotto la vista in pianta, come abbiamo fatto con il prospetto sud. Per questo, sarebbe utile poter ruotare la vista di 90°, in modo da poter continuare a disegnare le nostre quote "ai piedi". Purtroppo, FreeCAD al momento non ha nessuno strumento "Rotate View". Per fortuna, ha strumenti che ci consentono di creare facilmente dei nostri strumenti, chiamati Macro. Per noi questa è una buona opportunità per provare qualcosa di facile.

Le Macro, così come tutti gli script in FreeCAD, sono fatte nel linguaggio di programmazione python che è molto semplice. In python è possibile scrivere per FreeCAD programmi molto complessi, ma è anche possibile utilizzarlo per eseguire delle operazioni molto semplici per cui nella barra degli strumenti di FreeCAD non c'è ancora una icona corretta, come nel caso dello strumento per ruotare la vista. Quindi, per prima cosa, aprite la vista Report, se è chiusa, e selezionate la scheda python. Lì, digitate (o fate copia / incolla) il seguente codice:

import math
 from pivy import coin
 cam = Gui.ActiveDocument.ActiveView.getCameraNode()
 rot = coin.SbRotation()
 rot.setValue(coin.SbVec3f(0,0,1),math.pi/2)
 cam.orientation = rot

Questo piccolo script è sufficiente per ruotare la vista di 90° (a sinistra). Per ruotare di -90° (a destra), basta cambiare math.pi/2 in -math.pi/2. Se volete saperne di più sugli script python in FreeCAD, su questo wiki c'è una vasta sezione dedicata agli Script.

Ora, dobbiamo fare un altro passo, che consiste salvare il nostro pezzo di codice in una macro, in modo da poterlo riutilizzare in seguito. Invece di incollare il codice nell'interprete python, aprite il gestore delle macro (Strumenti -> Macro), create una nuova macro, premete il pulsante "Modifica" e incollate il codice. Chiudete la scheda dell'editor di macro e la macro verrà salvato.

Le macro possono comportarsi come qualsiasi altro strumento di FreeCAD. Con il menu Strumenti -> Personalizza, possiamo aggiungere un'icona alla nostra macro, una scorciatoia da tastiera, e aggiungerla a una barra degli strumenti.

Disegnare le viste ruotate

Draft-tutorial05.jpg

Ora che siamo in grado di ruotare la vista a piacere, possiamo disegnare gli altri prospetti. Il modo più semplice è quello di disegnare l'elevazione al posto giusto sotto la vista in pianta, e utilizzare uno "specchio" (una linea orientata a 45°) per riflettere e prolungare le linee delle altezze derivandole da un'altra elevazione. In questo modo, il disegno procede abbastanza veloce.

Infine, disegniamo le altri due elevazioni, e poiché la quarta è uguale alla seconda (ma riflessa), la saltiamo. Possiamo quindi tracciare una sezione trasversale, e il nostro disegno è completo:

Fctutorial-complete.jpg

Da continuare ...