Draft tutorial Outdated/fr

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft tutorial Outdated and the translation is 48% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎Türkçe
Base ExampleCommandModel.png Tutoriel
Thème
Drafting
Niveau
Beginner
Temps d'exécution estimé
Auteur
Version de FreeCAD
Fichier(s) exemple(s)



Le module Projet (Draft) a beaucoup changé depuis l'écriture de ce tutoriel. Plusieurs concepts sont maintenant totalement différents et pourraient ne pas fonctionner de la façon dont ils sont décrits ci-dessous.

Ce tutorial va vous apprendre à utiliser le module de dessin 2D de FreeCAD (aussi appelé Draft module Projet) pour créer un dessin architectural simple.
Pour ce faire, nous allons élaborer une simple cabine en maçonnerie. Supposons que nous avons reçu un dessin CAO montrant l'emplacement de la cabine, nous allons l'utiliser pour dessiner notre projet en calquant celui-ci. Nous allons dessiner un plan, une section et deux élévations.

Before you begin

Keep in mind that FreeCAD is still in an early stage of development, so you might not be as productive as with another CAD application, and you will certainly encounter bugs, or experience crashes. FreeCAD now has the ability to save backup files. The number of those backup files can be specified in the preferences dialog. Don't hesitate to allow 2 or 3 backup files until you know well how to deal with FreeCAD.

Enregistrez souvent votre travail, et de temps en temps, enregistrer votre travail sous un nom différent, comme par exemple "motoculteur_00.FCStd", "motoculteur_01.FCStd", "motoculteur_02.FCStd" vous aurez une copie de "sécurité" et en même temps un "historique" simple de votre projet, et . . . être prêt à un éventuel dysfonctionnement de FreeCAD ou erreur de votre part.
Un autre truc d'archivage de sécurité, est de changer l'attribut de l'ancien fichier en lecture seule (se poser sur le fichier, clic sur le bouton droit de la souris → Propriétés → Général → Attributs → cocher Lecture seule) et le placer dans un répertoire "Archive" par exemple.

Configurer votre espace de travail FreeCAD

FreeCAD est un modeleur 3D, mais dans ce tutoriel, nous allons l'utiliser uniquement pour un travail en 2D. Donc, nous allons nous en tenir au plan de base, et tout ce que nous aurons, c'est notre coordonnée Z à zéro.
Alors d'abord, nous allons nous mettre en vue de dessus en appuyant sur ​​le 2 du pavé numérique et être sûr que nous ne sommes pas dans la projection orthographique (touche 0 ) autrement, nous pourrions nous laisser tromper par certains effets de perspective.

Another very important thing to do, is to give custom hotkeys to your Draft commands. So you can do all the commands from the keyboard, which will drastically improve your speed. Basically you can do about everything from the keyboard, and will need the mouse only to draw points and select objects. Go to menu Customize -> Keyboard -> Category Python and select shortcuts as you like, a good idea is to make them easy to remember. For example, I use L for Line, W for Polyline (also called Wire in FreeCAD), A for Arc, C for Circle, M for Move, R for Rotate, F for Offset (O is already taken by Orthographic), D for Dimension, T for Text, etc...

Now we are set up, we can begin to draw.

Importer des dessins CAD

Si vous importez un dessin de CAO en 2D, les chances sont élevées pour qu'ils soient dans un format propriétaire comme .Dwg (à partir d'AutoCAD) ou .Mcd (à partir de VectorWorks).
Les spécifications de ces formats de fichiers sont gardés secrets par leurs fournisseurs, il est donc pour FreeCAD extrêmement difficile, voire totalement impossible de les soutenir. Toutefois, un format de fichier universel existe, c'est le format DXF et qui de plus est très bien documenté, notre module de Projet le prend en charge partiellement.

Almost all CAD applications can export to the DXF format, and you also have several free converters such as Open Design Alliance's ODA File Converter utility, that will allow you to convert your file to the DXF format. For example, Doublecad is a free, fully functional CAD program that allows you to export DXF files:

Doublecad.jpg

Open your DXF file simply with the File -> Open dialog. Several import settings can be configured in the Draft Preferences screen. For example, you can configure if you want the DXF file to be imported with original colors and linewidths, or converted to current Draft color, that you see at the right side of the Draft command bar. But in FreeCAD you won't need to attribute ugly colors to your objects to determine their linewidth. Objects all have independent color and linewidth attributes. So, you can very well forget about DXF colors, or convert everything to the colors of your choice.

Après avoir importé votre dessin dans FreeCAD, il ressemblera à ceci:

Situation.jpg

Let's begin with doing some cleaning.

Dans FreeCAD, il n'ya pas de couches (layers), comme dans Autocad, nous travaillons avec des groupes. Les groupes sont un autre moyen plus souple pour organiser votre projet.
Vous pouvez créer de nouveaux groupes avec un clic droit sur ​​l'arborescence, les réorganiser, les déplacer dans d'autres groupes, ou déplacer des objets vers/à partir de groupes simplement par glisser-déposer dans l'arborescence.
Vous pouvez également attribuer la largeur de la ligne courante et les couleurs à tous les objets dans un groupe, ou les visualiser/aveugler en appuyant sur ESPACE.

Mettons tous nos objets dans un seul nouveau groupe, et rendons "invisible" avec avec la touche ESPACE tout ce que nous n'utiliserons pas, comme la végétation et les cotations, afin d'accélérer notre travail.

Drawing the plan view

Using the drawing tools

The only thing we'll need at the moment is the area that is assigned to our cabin. It lies in a separate group named "projection". So we can basically turn off everything else with the SPACE key, and start drawing on top of it. We will draw a small cabin with a guard room and a WC, in very simple structural masonry, so there won't be any need for special concretework in the plan itself. But we'll put a layer of plaster inside, and a layer of ceramics outside.

Donc, nous allons commencer par faire la forme générale de nos murs :

Draft-tutorial-01.jpg

Our DXF drawing was drawn in meters, so unless we have any reason to change that, we'll continue with the same units. FreeCAD currently does not have a friendly system to work with real-world units, so we simply assume that "one" means "one meter".

Another good thing to remember is to construct temporary geometry whenever you need. You want a point that lies 2 meters away horizontally? Draw a vertical line, move it 2m away, pass a horizontal line through it, there is your point.

  • Créer un rectangle Draft Rectangle.png : Enclenchez avec CTRL les coins de la zone affectée.
  • Décalage du rectangle : Avec le rectangle sélectionné, appuyez sur décalageDraft Offset.png, pressez C pour activer le mode copie, déplacez votre souris à l'intérieur du premier rectangle de sorte qu'il sait dans quelle direction aller, et entrez 0,20.
  • Transformez les en face : Upgrade Draft Upgrade.png le premier rectangle, mettez à niveau le second rectangle, puis sélectionnez le rectangle extérieur avec CTRL, sélectionnez le rectangle intérieur et appuyez sur Downgrade Draft Downgrade.png.
  • Créez l'ouverture de la porte : faites un rectangle de 1,00 x 0,50, déplacez le vers le coin supérieur de notre mur principal (pressez C pour activer le mode copie sur off).
  • Déplacez Draft Move.png l'ouverture de la porte à la bonne position : déplacez de 0,10 vers la gauche. Nous ne mettrons pas notre ouverture directement sur ​​le coin, car la porte serait difficile à ouvrir.
  • Soustraire l'ouverture de porte : Sélectionnez le mur, avec CTRL, sélectionnez l'ouverture de la porte, puis appuyez sur downgrade Draft Downgrade.png.

Une note à propos de upgrade Draft Upgrade.png et downgrade Draft Downgrade.png

(Monter et descendre d'un niveau)
Maintenant, vous devez être conscient du fait que le noyau Opencascade que FreeCAD est construit pour la 3D. Il est fait principalement pour des opérations 3D.
Quand il doit couper ou réunir des faces planes, comme nous le faisons maintenant avec les opérations Upgrade/Downgrade, il fait parfois des choses étranges, et les opérations ultérieures (comme d'autres améliorations ou déclassements) parfois ne donnent pas les résultats escomptés.
Bien sûr, avec le temps, ces comportements finiront par être corrigés par les développeurs de FreeCAD, mais il est intéressant de connaître d'autres façons de résoudre les problèmes immédiats.

La meilleure façon de résoudre correctement une face qui n'est pas mise à Upgrade / Downgrade / compensée, c'est tout simplement de le Downgrader Draft Downgrade.png jusqu'à ce qu'il soit complètement explosé, puis mettre à niveau les bords du nouvel ensemble pour en faire une nouvelle face.
Dans le cas où cela ne fonctionnerais pas non plus, redessinez tout simplement un nouveau fil (polyline Draft Wire.png) sur le dessus de la face problématique, l'accrocher à ses extrémités, puis supprimer le vielle face et améliorer le nouveau fil.
Habituellement, la face que vous obtenez est en bien meilleure forme que la face que vous avez obtenu par Upgrade/Downgrade.

Another thing to keep in mind is that when you subtract a shape from another, you can find yourself with one object containing several faces. This might difficult your further work (they don't offset correctly, etc), so a good thing in that case is always to separate them with the downgrade tool.

Une autre note, snapping

Il existe deux formes de snap dans le module Projet : snap passive, qui se produit lorsque vous passez simplement le curseur de la souris sur un objet (un symbole cercle ouvert apparaît), et composant logiciel accrochage qui est actif quand vous appuyez sur CTRL.
L'accrochage actif vous permet de prendre des points spécifiques sur un objet, comme, les extrémités, les milieux, les centres ou les intersections avec d'autres objets.
Si vous appuyez sur SHIFT, qui est la clé pour contraindre l'action horizontalement et verticalement, vous gagnerez des points d'accrochage encore plus décisivement. Mais cela a un coût, car FreeCAD doit réaliser de nombreux calculs en temps réel. Si vous avez de nombreux objets, vous allez commencer à voir la différence.
Ainsi, un bon truc pour accélérer votre travail, est de prendre l'habitude de travailler autant que possible seulement avec les SHIFT snap passive. Vous verrez vite que vous obtiendrez des résultats précis et que vous travaillerez beaucoup plus vite.

So let's go back to work:

  • Créer un mur de 10 cm à l'échelle entre la salle principale et le WC. Le mettre à niveau, puis le mettre à niveau avec la paroi principale de les unir.
  • Créer d'autres rectangles pour vos autres ouvertures. Je mets une fenêtre de 60 cm à l'échelle de ce qui deviendra le WC, une porte 80cm entre la salle principale et les toilettes, et pour la grande fenêtre dans la pièce principale, j'ai simplement laissé 40cm de mur sur le côté gauche et droit.
  • Déplacez tous les murs de 1cm, faire une couche de ciment/plâtre, puis baissez les copies déplacées pour les transformer en simples fils.
  • Créez une couche de céramique sur le côté extérieur, par voie de compensation de nos 2cm de plâtre, puis dessinez une forme de 2cm d'épaisseur entre les deux lignes.
  • Supprimez les 2cm de décalage que nous n'avons plus besoin, ainsi que toute la géométrie de construction. Si vous sentez que vous pourriez en avoir besoin plus tard, il suffit de les mettre dans un groupe distinct et de transformer ce groupe off avec (ESPACE Visibility=True).

C'est là que nous sommes maintenant (j'ai gardé la géométrie de construction là-bas, en bleu, à vous de voir):

Draft-tutorial-walls.jpg

Importation et construction d'objets composés

Dans FreeCAD, les objets composés sont des objets fabriqués avec les formes géométriques de plusieurs autres objets. Dans d'autres logiciels, ils sont appelés blocs, symboles ou composants.
C'est une façon très pratique de grouper les formes géométriques dans un seul objet. Tout les objets créés avec le projet de module peuvent être regroupés en un composant.

La commande pour créer un composant est la commande Upgrade Draft Upgrade.png. L'utilisation est simple, sélectionnez tout ce que vous voulez transformer en un composant, et appuyez sur Draft Upgrade.png. Si aucune autre forme plus intelligente peut être créé, ils seront transformés en un composant.

L'utilisation des formes géométriques composées est spécialement utile pour construire une bibliothèque de symboles sur votre disque, afin que vous puissiez les réutiliser plus tard.
Une utilisation cool, couplée à la fonction d'importation dxf, c'est que vous pouvez très facilement utiliser des bibliothèques de symboles au format DXF (si vos symboles sont au format dwg, l'application "Teigha file Converter" peut convertir en un lot toute votre bibliothèque à la fois).

Once you have a library of DXF symbols, just drag one of them and drop it on top of your open FreeCAD window and it will be imported in the current document. It won't be imported as a compound, but all of the symbol geometry will be placed in a separate group, so it is easy to select it all and simply press "Upgrade". Beware that AutoCAD users have the bad habit of drawing things very far from the origin point (0,0,0), your inserted symbol can then lie very far from your drawing zone.

Donc, revenons à notre dessin:

  • Importer un bloc sanitaire, si vous en avez un, ou en choisir un sur Cad Exchange, et le convertir en dxf avec le convertisseur "Teigha file Converter".
  • Créer la géométrie d'une porte, upgrade Draft Upgrade.png l'un des composants, copier à l'emplacement des portes d'autre part, downgrade Draft Downgrade.png, ajuster les éléments à la nouvelle taille, et upgrade Draft Upgrade.png à nouveau. Faites de même pour les fenêtres
  • Une fois que vous avez une bibliothèque de symboles DXF, il suffit de glisser l'un d'eux et de le déposez sur la fenêtre ouverte de FreeCAD, il sera importé dans le document courant.
  • Il ne sera pas importée en tant que composant, mais comme symbole géométrique, et, sera placé dans un groupe distinct, de sorte qu'il est facile de tout sélectionner et d'appuyez simplement sur Upgrade Draft Upgrade.png.
  • Faire de même pour les fenêtres.

Draft-tutorial-blocks.jpg

Dimensions and annotations

Now that our plan is more or less ready, we can add dimensions and texts. This is usually pretty straightforward, so there is probably no need to explain much. Just try to dimension everything, and as a convention, always start the dimension lines from the main wall line, not the finishing layer. One thing is good to know, sometimes you draw a text or a dimension over a filled area, and the filled area will cover your dimension. There is a simple way to fix that, it is by downgrading and upgrading again the filled area. It will then be displayed under the other elements.

The dimension and text will by default have the same text height, which can be changed in the Draft Preferences page. You can then edit individually each text height.

Malheureusement certains objets non-géométriques tels que textes et cotations ne sont pas toujours sélectionnable dans la vue 3D de FreeCAD, vous devez donc les sélectionner dans l'arbre du projet, et vous ne serez peut être pas en mesure de vous aligner sur eux, ce sera résolu tout en allant.
Il n'est également pas possible pour le moment de choisir un style de police. Pour aligner les cotations, actuellement, vous devez tracer une ligne, puis coter cette ligne.

Draft-tutorial-dims.jpg

Organisation

Draft-tutorial-typical-tree.jpg

Enfin, nous pouvons ajouter quelques petites choses pour terminer notre plan, comme mettre de la végétation autour de la cabine. Nous pouvons tout simplement copier quelques arbres de notre fichier dxf importé, et, de les réduire avec l'outil échelle Draft Scale.png, par exemple (0.5,0.5).
Nous pouvons également changer l'épaisseur du trait d'un couple d'objets, par exemple pour faire des murs plus épais, et changer la couleur de certaines choses. Et nous pouvons organiser l'ensemble de nos éléments dans les groupes.

La capacité d'organiser votre travail en groupes imbriqués est sûrement plus avantageux que de travailler avec les traditionnelles couches (pages ou layers ou calques).

Dans ce tutoriel, j'ai regroupé mes objets par type, dans l'intérieur du groupe Plan. Par exemple, au lieu d'avoir un grosse couche avec toutes les cotations de votre projet, chaque parties du dessin contient son propre groupe de cotations, ce qui rend une organisation extrêmement facile de votre dessin.

Dans un premier temps, vous pourriez vous sentir perdu, si vous migrez d'un programme de CAO traditionnel comme AutoCAD, mais vous verrez rapidement la puissance et la souplesse que cette méthode apporte.

For example, all our construction geometry can go in a separate group, that we'll turn off. Maybe later we'll need to make some changes, and it will be handy to have that geometry available.

So, now we are ready to draw other parts...


Drawing the elevations

Draft-tutorial-elevation.jpg



Etant donné que dans cet exercice nous allons rester dans le plus pur 2D, nous tirerons directement nos élévations et sections.
Dans des environnements d'architecture plus avancés (nous espérons qu'a l'avenir FreeCAD le deviendra), nous n'aurions pas besoin de tirer les élévations.
Nous modélisons le bâtiment en 3D, puis générons les différents points de vue automatiquement. Mais pour l'amour de dieu (et aussi parce que tous les outils nécessaires ne sont pas encore mis en oeuvre dans FreeCAD), nous allons faire cet exercice à la main, comme au bon vieux temps.

Nous allons commencer par l'élévation de la paroi arrière, parce que la façon dont notre plan est orienté, il peut être prélevé directement ci-dessous, sans la nécessité de faire pivoter la vue.
Nous allons tout simplement dessiner les lignes de construction du plan, fait de lignes horizontales et de hauteurs désirées (je défini le niveau 0,00, le niveau 0.15 de la dalle, puis la hauteur des fenêtres, et la dalle du toit à 2,50).
Nous pouvons alors tirer notre forme géométrique très rapidement au-dessus de celle-ci.

Nous pouvons maintenant placer nos textes, nos cotations, et améliorer quelques-uns des objets de sorte qu'ils apparaissent colorés et attractifs. Enfin, nous pouvons faire un peu de nettoyage en créant une "élévation au Sud" du groupe, puis sous-grouper notre construction et les textes, ainsi que d’assembler nos nouveaux objets.


Rotating the view, and creating macros

Now, we need to draw other elevations of our little building. The simplest way would be to draw them directly under the plan view, as we did with the south elevation. For this, it would be handy to be able to rotate the view by 90°, so we can continue drawing our elevations "on foot". Unfortunately, FreeCAD has at the moment no "Rotate View" tool. But, fortunately, it has tools for us to easily create our own tools, called Macros. So, this is a good opportunity for us to try something easy.

Macros, as well as all scripting in FreeCAD, is done in a very simple programming language called python. You can write very complex programs in FreeCAD in python, but you can also use it to perform very simple operations where there still isn't a proper FreeCAD toolbar icon, such as our Rotate The View tool. So, first thing to do, open the Report view, if you closed it, and select the python tab. In there, type (or copy/paste) the following code:

import math
 from pivy import coin
 cam = Gui.ActiveDocument.ActiveView.getCameraNode()
 rot = coin.SbRotation()
 rot.setValue(coin.SbVec3f(0,0,1),math.pi/2)
 cam.orientation = rot

Ce petit script va simplement faire pivoter la vue de 90° vers la gauche. Pour faire tourner vers la droite faire -90°, vous pouvez tout simplement changer la formule math.pi/2 par -math.pi/2.
Si vous souhaitez en savoir plus sur scripts Python dans FreeCAD, il existe une vaste section Scripts sur ce wiki.

Now, we need to do one more step, which is save our piece of code in a macro, so we can reuse it later. So, instead of pasting our code in the python interpreter, let's open the macro manager (Tools -> Macros), create a new macro, press the "Edit" button and paste our code in it. Close the macro editor tab, and the macro will be saved.

The macros can behave like any other FreeCAD tool. With the Tools -> Customize menu, we can add an icon to our macro, a keyboard shortcut, and add it to a toolbar.

Drawing the rotated views

Draft-tutorial05.jpg

Now that we can rotate the view at will, we can draw our other elevations. The easiest way is to draw your elevation at the right place under the plan view, and use a "mirror" (a 45°-oriented line) to push the height lines from another elevation. This way, drawing goes pretty fast.

Finally, we draw 2 others elevations, and since the fourth one is the same as the second one (but mirrored), we will skip it. We can then draw a cross section, and our drawing is complete:

Fctutorial-complete.jpg

To be continued...