Draft tutorial Outdated/es

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft tutorial Outdated and the translation is 55% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎Türkçe

Base ExampleCommandModel.png Tutorial

Tema
Drafting
Nivel
Beginner
Tiempo para completar
Autor
Versión de FreeCAD
Archivo(s) de ejemplo(s)


El módulo de Bocetao ha cambiado mucho desde que se creó este tutorial. Diversos conceptos ahora son diferentes y podrían no funcionar del modo que se describe más abajo.

..

This tutorial will teach you how to use FreeCAD's 2D drafting module (also called Draft module) to create a simple architecture drawing. For this purpose, we will be drawing a simple masonry cabin. Let's assume that we received a CAD drawing showing the location of the cabin, and we'll use it to draw our project on top of it. We'll draw a plan, a section and two elevations.

Antes de empezar

Recuerda que FreeCAD aún está en una etapa inicial de desarrollo, de modo que podrías no ser tan productivo como con otras aplicaciones de CAD, y seguramente encuentres errores, o esperimentes algún cuelgue de la aplicación. FreeCAD ahora dispone de la posibilidad de realizar copias de seguridad. El número de dichas copias de seguridad se puede especificar en el letrero de diálogo de preferencias. No dudes en permitir 2 o 3 archivos de respaldo hasta que conozcas bien como funciona FreeCAD.

Guarda tu trabajo con frecuencia, de vez en cuando guarda tu trabajo con un nombre diferente, así tendrás una copia "a salvo" a la que puedas volver, y prepárate para la posibilidad de que algunos comandos puedan no ofrecer los resultados que esperabas.

Setting up your FreeCAD workspace

FreeCAD is a 3D modeler, but in this tutorial we will use it only for working in 2D. So, we will be drawing on the ground plane, and everything we do will have a Z coordinate of zero. So first, let's put ourselves in top view by pressing the 2 and be sure we are in orthographic projection (key O) otherwise we might get fooled by some perspective effects.

Otra cosa muy importante que hacer, es establecer Atajos de teclado personalizados para nuestros comandos de Croquis. Así podremos ejecutar todos nuestros comandos desde el teclado, lo que aumentará drásticamente nuestra velocidad. Basicamente puedes hacer casi todo desde el teclado, y necesitaremos el ratón sólo para dibujar puntos y seleccionar objetos. Ve al menú Personalizar -> Teclado -> Categoría Python y selecciona los atajos de teclado que desees, una buena idea es hacerlos sencillos de recordar. Por ejemplo, utilizar L para Línea, W para polilínea (también llamada wire en FreeCAD) A para arco, C para circunferencia, M para mover, R para girar, F para equidistancia (O es utilizado para Ortográfica), D para Cota, T para texto, etc.

Ahora estamos preparados, podemos comenzar a dibujar.

Importando dibujos de CAD

Si vas a importar dibujos 2D de CAD, hay muchas posibilidades de que estén en un formato propietario como .dwg (de AutoCAD) o .mcd (de VectorWorks). La especificación de estos formatos de archivo es mantenida en secreto por sus comercializadores, de modo que es extremadamente difícil o totalmente imposible para FreeCAD soportarlos. Sin embargo, un formato de archivo ampliamente documentado es el DXF, y el módulo de Croquis lo soporta parcialmente.

La mayoría de aplicaciones de CAD pueden exportar en formato DXF, y también existen varios conversores como la utilidad de openDWG "Teigha file Converter", que te permitirá convertir tu archivo a formato DXF. Por ejemplo, Doublecad es un programa de CAD libre completamente funcional que te permite exportar archivos DXF:

Doublecad.jpg

Open your DXF file simply with the File -> Open dialog. Several import settings can be configured in the Draft Preferences screen. For example, you can configure if you want the DXF file to be imported with original colors and linewidths, or converted to current Draft color, that you see at the right side of the Draft command bar. But in FreeCAD you won't need to attribute ugly colors to your objects to determine their linewidth. Objects all have independent color and linewidth attributes. So, you can very well forget about DXF colors, or convert everything to the colors of your choice.

Después de importar el dibujo en FreeCAD, se parecerá a esto:

Situation.jpg

Let's begin with doing some cleaning.

Tutorial-treeview.jpg
En FreeCAD, no existen capas como en AutoCAD. En su lugar trabajamos con grupos. Los grupos son otro modo mucho más flexible de organizar tus dibujos. Puedes crear nuevos grupos pulsando con el botón derecho en la vista en árbol, reorganizarlos, moverlos dentro de otros grupos, o mover objetos de/hacia los grupos simplemente arrastrando y soltando cosas en la vista en árbol. También puedes asignar el espesor de línea y color actuales a todos los objetos de un grupo, o activarlos o desactivarlos pulsando ESPACIO.

Let's put all our objects into one new group, and turn off everything we won't use, like vegetation and dimensions, to speed up our work.

Dibujando la vista en planta

Utilizando las herramientas de dibujo

Lo único que necesitamos de momento es el área asignada a nuestra cabaña. Está en un grupo denominado "projection". Así que desactivamos todo con la tecla SPACE, y comenzamos dibujando sobre ello. Dibujaremos una pequeña cabaña con un cuarto y un WC, en una mampostería estructural muy simple, así que no necesitaremos ningún trabajo especial en la planta. Pero pondremos una capa de yeso en su interior y una capa cerámica en el exterior.

Así que, comencemos haciendo la forma general de nuestros muros:

Draft-tutorial-01.jpg

Nuestro dibujo DXF está en metros, así que a menos que tengamos alguna razón para cambiarlo, continuaremos con la misma unidad. FreeCAD actualmente no dispone de un sistema amigable para trabajar con unidades del mundo real, así que simplemente asumiremos que "uno" significa "un metro".

Otra buena cosa a recordar es construir una geometría temporal si es necesario. Quieres un punto a 2 metros en dirección horizontal? Dibuja una línea vertical, muevela 2m, pasa una línea horizontal por ella, ahí está tu punto.

  • Create a rectangle: Snap its cornerpoints with CTRL to the corners of the assigned area
  • Offset the rectangle: With the rectangle selected, press Offset, press C to turn on copy mode, move your mouse inside the first rectangle so offset knows in which direction to go, and type 0.20, Enter
  • Turn them into a face: Upgrade the first rectangle, upgrade the second rectangle, then select the outer rectangle, CTRL-select the inner rectangle and press Downgrade
  • Create the door opening: Make a 1.00 x 0.50 rectangle, move it to the upper corner of our main wall (press C to turn copy mode off).
  • Move the door opening to the right position: Move it 0.10 to the left. We won't put our opening directly on the corner, because it would make the door difficult to open.
  • Subtract the door opening: Select the wall, CTRL-select the door opening, and press downgrade.

Una nota sobre Promocionar y Degradar

Ahora, debes ser consciente de que el kernel de openCasCade sobre el que está construido FreeCAD, es un kernel 3D. Está construido principalmente para operaciones en 3D. Cuando tiene que cortar o unir caras planas, como estamos haciendo con las operaciones promocionar / degradar, a veces hace cosas extrañas, y las siguientes operaciones (como otras operaciones de promocionar / degradar) a veces no dan el resultado esperado. Por supuesto con el tiempo este comportamiento se corregirá por el equipo de desarrollo de FreeCAD, pero es prudente conocer modos alternativos para resolver los problemas de inmediato.

El mejor modo de resolver una cara que no se promociona / degrada / equidista de forma correcta, es simplemente degradarla hasta que sean aristas simples, luego promocionar esas aristas juntas en una nueva cara. En caso de que tampoco funcione, simplemente redibuja una nueva polilínea (wire) (polyline) por encima de la cara que da problemas, ajustanta a sus vértices, luego borrar la cara antigua y promocionar el nuevo contorno. Normalmente una cara que dibujas tu mismo es una forma mucho mejor que una cara que has obtenido promocionando y degradando.

Another thing to keep in mind is that when you subtract a shape from another, you can find yourself with one object containing several faces. This might difficult your further work (they don't offset correctly, etc), so a good thing in that case is always to separate them with the downgrade tool.

Otra nota sobre el ajuste

Hay dos formas de ajuste en el módulo de croquizado: Ajuste pasivo, que ocurre cuando simplemente pasas con el cursor sobre un objeto (aparece un símbolo con una circunferencia abierta), y ajuste activo, que es cuando pulsas CTRL. El ajuste activo permite ajustar a puntos específicos de un objeto, como sus puntos finales, medios, centros, o intersecciones con otros objetos. Si pulsas SHIFT, que es la tecla que activa las restricciones horizontal y vertical, obtienes incluso más puntos de ajuste. Pero esto tiene un coste, porque FreeCAD debe hacer más cálculos en tiempo real. Si tienes muchos objetos, notaras la diferencia. Así que un buen consejo para ser más rápidos es coger el hábito de trabajar tanto como sea posible sólo con SHIFT y el ajuste pasivo. Verás rápidamente que obtendras resultados precisos y trabajarás mucho más rápido.

So let's go back to work:

  • Crea un contorno de 10cm de ancho entre la habitación y el WC. Promocionalo, después promocionalo con el muro principal para unirlos
  • Crea otro rectángulo para otras aperturas. Pon una ventana de 60cm de ancho en lo que sera el WC, una puerta de 80cm entre la habitación principal y el WC, y para la ventana grande en la habitación principal deja 40cm de muro a izquierda y derecha.
  • Equidista todos los muros 1cm, para crear una capa de cemento / yeso, luego degrada las copias equidistantes para que vuelvan a ser contornos
  • Crea una capa cerámica en el lado exterior, creando una equidistancia de 2cm, luego dibuja una forma de 2cm de espesor entre las dos líneas
  • Borra la equidistancia de 2cm. Esa ya no la necesitaremos más, así como a toda la geometría de Construcción. Si crees que la podrías necesitar después, simplemente ponla en un grupo aparte y desactiva ese grupo con ESPACIO.

This is where we are now (I kept construction geometry there, in blue, for you to see):

Draft-tutorial-walls.jpg

Importing and building compound objects

In FreeCAD, compound objects are objects made with the geometry of several other objects. In other softwares, it is called blocks, symbols or components. It is a very handy way to group geometry under one single object. Any of the objects created with the draft module can be grouped into a compound. The command to create a compound is the Upgrade command. The use is simple, select everything you want to turn into a compound, and press Upgrade. If no other more intelligent shape can be created, they will be turned into a compound.

Utilizar geometría compuesta es especialmente útil para crear una librería de símbolos en tu disco, así podrás reutilizarlos después. Un interesante uso de esto, en conjunto con la función de importar DXF, es que puedes utilizar librerías de símbolos en formato DXF (Si tus símbolos están en formato DWG, la aplicación gratuita "Teigha file Converter" puede convertir por lotes toda tu librería en un único paso).

Once you have a library of DXF symbols, just drag one of them and drop it on top of your open FreeCAD window and it will be imported in the current document. It won't be imported as a compound, but all of the symbol geometry will be placed in a separate group, so it is easy to select it all and simply press "Upgrade". Beware that AutoCAD users have the bad habit of drawing things very far from the origin point (0,0,0), your inserted symbol can then lie very far from your drawing zone.

Así que, volvamos a nuestro dibujo:

  • Importa un bloque de un sanitario si tienes uno, o coge uno de la web Cad Exchange, y conviértelo en DXF con "Teigha file Converter"
  • Crea la geometría de una puerta, Promociona la puerta en un objeto compuesto, Copiala a las ubicaciones de las puertas, Degradalas, ajusta los elementos a su nuevo tamaño, y promocionalos de nuevo
  • Do the same for the windows

Draft-tutorial-blocks.jpg

Cotas y anotaciones

Ahora que nuestra planta está más o menos lista, podemos añadir Cotas y textos. Esto es normalmente bastante sencillo, así que probablemente no necesite explicarse mucho. Simplemente trata de acotar todo, y como try to dimension everything, and as a convención, empieza siempre las líneas de cota desde el muro principal, no la capa de acabado. Algo que es bueno saber, a veces dibujas un texto o una cota sobre un área rellena, y el relleno cubre tu cota. Existe un modo simple de arreglarlo, degradando y promocionando de nuevo el área de relleno. Se mostrará entonces bajo los otros elementos.

The dimension and text will by default have the same text height, which can be changed in the Draft Preferences page. You can then edit individually each text height.

Por desgracia, ciertos objetos no geométricos como los textos y las cotas aún no son seleccionables en la vista 3D de FreeCAD, debes por tanto seleccionarlos en el árbol, y no podrás utilizar el ajuste sobre ellos,pero esto seguramente esté solucionado en el futuro próximo. Tampoco es posible is also not posible de momento seleccionar un estilo de fuente. Para alinear las cotas, de momento, necesitas dibujar una línea antes, y luego ajustar tus cotas a dicha línea.

Draft-tutorial-dims.jpg

Organización

Draft-tutorial-typical-tree.jpg

Finalmente, podemos añadir unas cuantas cosas para terminar nuestra planta, como poniendo vegetación alrededor de la cabaña. Podemos simplemente copiar algunos árboles desde nuestro dibujo DXF importado y escalarlos con la herramienta Escala, a por ejemplo (0.5,0.5). Podemos cambiar el espesor de línea de varios objetos, por ejemplo hacer los muros más gruesos, y cambiar el color de algunas cosas. Y podemos organizar todos nuestros elementos en grupos.

La habilidad de organizar tu trabajo en grupos anidados es seguramente una de las grandes ventajas de los grupos con respecto al sistema tradicional de trabajar con capas. En este tutorial, he agrupado mis objetos por tipo, dentro del grupo Planta. Por ejemplo, en lugar de tener una gran capa con todas las cotas del dibujo, cada parte del dibujo contendrá su propio grupo de cotas, haciendo que sea extremadamente sencillo de organizar tus dibujos.


Podrías verlo como una pérdida al principio si vienes de programas de dibujo tradicionales como AutoCAD, pero rápidamente verás el potencial que ofrece este método.

Por ejemplo, toda nuestra geometría constructiva puede ir a grupos independientes, que desactivaremos. Puede que después necesitemos hacer algunos cambios, y será práctico tener esa geometría disponible.

Así que, ahora estamos listos para dibujar las otras partes...


Drawing the elevations

Draft-tutorial-elevation.jpg

Ya que en este ejercicio estamos trabajando en 2D, tendremos que dibujar los perfiles y secciones directamente. En entornos de arquitectura más avanzados (lo que esperamos que llegue a ser FreeCAD en el futuro), no necesitaríamos dibujar los perfiles. Podríamos modelar el edificio en 3D y generar las diferentes vistas automáticamente. Pero por el propio bien de este ejercicio (y también porque todas las herramientas necesarias aún no están implementadas en FreeCAD), lo haremos a mano, como en los viejos tiempos.

We'll begin with the rear wall elevation, because the way our plan is oriented, it can be drawn directly below it, without the need to rotate the view. We will simply draw construction lines from the plan, set horizontal lines to the desired heights, I set the 0.00 level, the +0.15 level of the slab, then heights for the windows, and the roof slab at +2.50. We can then draw our geometry very quickly on top of it.

We can then place a couple of annotations, dimensions, and upgrade some of the objects so they appear filled with a color. Finally, we can make a bit of cleaning by creating a "South Elevation" group, then subgroups for our construction geometry and annotations, and place all of our new objects in them.


Rotating the view, and creating macros

Now, we need to draw other elevations of our little building. The simplest way would be to draw them directly under the plan view, as we did with the south elevation. For this, it would be handy to be able to rotate the view by 90°, so we can continue drawing our elevations "on foot". Unfortunately, FreeCAD has at the moment no "Rotate View" tool. But, fortunately, it has tools for us to easily create our own tools, called Macros. So, this is a good opportunity for us to try something easy.

Las macros, así como los archivos de guión en FreeCAD, están creados en un lenguaje de programación muy simple llamado Python. Puedes escribir programas muy complejos en Python para FreeCAD, pero también puedes utilizarlo para optimizar operaciones muy simples para las que no hay un icono apropiado en las barras de herramientas de FreeCAD, como nuestra herramienta de Girar la Vista. Así que, lo primero que hay que hacer es abrir la vista de informes, si está cerrada, y seleccionar la pestaña de Python. Allí, escribe (o copia y pega) el siguiente código:

import math
 from pivy import coin
 cam = Gui.ActiveDocument.ActiveView.getCameraNode()
 rot = coin.SbRotation()
 rot.setValue(coin.SbVec3f(0,0,1),math.pi/2)
 cam.orientation = rot

Este pequeño archivo de guión simplemente rotara la vista 90º (hacia la izquierda). Para girarla -90° (hacia la derecha), podrías simplemente cambiar math.pi/2 por -math.pi/2. Si quieres aprender más sobre los archivos de guión de Python en FreeCAD, existe una extensa sección Archivos de guión en esta wiki.

Ahora, necesitamos hacer un paso más, el cual es guardar pedazos de código en una macro, así podremos reutilizarlo luego. De este modo, en lugar de pegar nuestro código en el interprete de Python, vamos a abrir el gestor de macros (Herramientas -> Macros), crea una nueva macro, presiona el botón "Editar" y pega el código allí. Cierra la pestaña del editor de macros, y la macro se salvará.

The macros can behave like any other FreeCAD tool. With the Tools -> Customize menu, we can add an icon to our macro, a keyboard shortcut, and add it to a toolbar.

Dibujando las vistas giradas

Draft-tutorial05.jpg

Now that we can rotate the view at will, we can draw our other elevations. The easiest way is to draw your elevation at the right place under the plan view, and use a "mirror" (a 45°-oriented line) to push the height lines from another elevation. This way, drawing goes pretty fast.

Finalmente, dibujamos otras 2 elevaciones, y ya que la cuarta es la misma que la segunda (pero simétrica), lo evitaremos. Podemos dibujar una sección, y nuestro dibujo está completo:

Fctutorial-complete.jpg

To be continued...