Draft tutorial

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft tutorial and the translation is 100% complete.

Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(繁體)‎

Base ExampleCommandModel.png Tutorial

Thema
Skizzieren
Niveau
Anfänger
Zeit zum Abschluss
20 Minuten
Autor
Drei
FreeCAD version
0.16 oder neuer
Beispieldatei(en)
None


Einleitung

Dieses Tutorial soll den Leser in die grundlegenden Arbeitsschritte des Moduls Draft einführen Dies umfasst das Erstellen von Profilen, die Verwendung von Arbeitsebenen und das Einfügen von Maßen, Text und Anmerkungen. Dieses Tutorial nutzt die mathematische Notation (X, Y, Z), um die Koordinaten von Punkten innerhalb eines Objektes anzugeben.

Draft tutorial result.png

Voraussetzungen

  • FreeCAD Version 0.16 oder neuer
  • Der Leser sollte bereits wissen, wie mit den Registerkarten "Daten" und "Ansicht" die Eigenschaften eines Objektes geändert werden können

Vorgehensweise

Für dieses Tutorial ist es zwingend notwendig, die Werkzeugleiste "Draft Snap" verfügbar zu machen. Dies funktioniert folgendermaßen:

  1. Starten Sie FreeCAD
  2. Wenn Sie noch kein neues FreeCAD-Dokument geöffnet haben (die meisten der FreeCAD-Fenster sehen ausgegraut aus), dann klicken Sie aus dem Datei-Menü "Neu" oder klicken Sie das Document-new.svg Erstelle ein neues leeres Dokument Icon.
  3. Wechseln Sie in den Arbeitsbereich Draft
  4. Klicken Sie oben im Menü auf Bearbeiten->Einstellungen
  5. Klicken Sie im neuen Fenster links unten auf Draft und danach auf die Registerkarte Rast-Optionen
  6. Stellen Sie dort sicher, dass die Option Entwurfs-Fang-Werkzeugleiste einblenden aktiviert ist

Beachten Sie, dass Sie bei Bedarf im gleichen Menü die Sichtbarkeit des Gitters ändern können.

Verwenden von Arbeitsebenen

Arbeitsebenen werden verwendet, um das Verhalten der Entwurfswerkzeuge auf eine bestimmte Ebene einzuschränken, sodass Probleme beim Einfügen von Punkten und Kurven in komplexen Bauteilen vermieden werden. Arbeitsebenen können sich auf Achsen des Koordinatensystems (XY, usw.) beziehen oder Oberflächen von bereits im Dokument vorhandenen Objekten als Referenz nehmen.

  1. Klicken Sie auf die Schaltfläche Ebene markieren Draft SelectPlane.png. Sie finden sie entweder in der Werkzeugleiste oder im Menü unter Entwurf->Dienstprogramme.
  2. Wählen Sie die XY-Ebene.

Profile erstellen

Das Erstellen von Profilen kann auf verschiedene Weise erfolgen. Es ist zwar möglich die meiste Arbeit mit einfachen Bögen und Linien zu erledigen, jedoch bietet FreeCAD mehrere Werkzeuge, die diese Arbeit beschleunigen.

Linien und Bögen

  1. Wählen Sie die Schaltfläche Arc Draft Arc.png.
  2. Setzen Sie den Mittelpunkt auf (0,0,0).
  3. Geben Sie beim Radius "30 mm" ein.
  4. Der Startwinkel soll 60.0° betragen.
  5. Der Öffnungswinkel soll ebenfalls 60.0° sein.

Wiederholen Sie das Ganze für einen zweiten Bogen mit Radius 25 mm und ansonsten gleichen Eigenschaften wie der erste Bogen.

Wir werden das Profil nun mit ein paar Linien schließen.

  1. Wählen Sie die Schaltfläche Linie Draft Line.png.
  2. Bewegen Sie den Mauszeiger nahe an die Endpunkte der Bögen. Es sollte ein weißer Punkt zusammen mit dem Symbol Snap Endpoint.png erscheinen. Klicken Sie dann mit der linken Maustaste.
  3. Wählen Sie den Endpunkt des jeweils anderen Bogens und klicken Sie genauso darauf.
  4. Wiederholen Sie diese Prozedur für die andere Seite der Bögen.

Wir haben nun mehrere Kurven bzw. Linien, die ein und dasselbe Profil beschreiben, aber dennoch nicht als ein einzelner Eintrag im Modellbaum angezeigt werden. Prinzipiell kann trotzdem mit dem Profil gearbeitet werden, dennoch wollen wir in diesem Fall die Elemente in ein Element vereinen.

Die folgenden Schritte werden das Verhalten der Objekte verändern und eine Änderung ihrer Eigenschaften schwierig machen. Deshalb sollten notwendige Modifikationen vorher durchgeführt werden.

  1. Wählen Sie nacheinander einen Bogen und eine Linie per Mausklick aus und halten Sie dabei die Strg-Taste gedrückt.
  2. Klicken Sie auf Hochstufen Draft Upgrade.png.

Dadurch werden beide Objekte in ein neues Objekt namens "Wire" (deutsch: Draht) vereint. Wiederholen Sie die letzten beiden Schritte, bis nur noch ein Element übrig ist.


Ebenen, Rechtecke und Kreise

  1. Klicken Sie auf Rechteck Draft Rectangle.png.
  2. Setzen Sie den ersten Punkt auf (-100, -60, 0). (Wenn "Relativ" nach dem Setzen des ersten Punkts aktiviert ist, deaktivieren Sie diese Einstellung vor dem Setzen des zweiten Punkts).
  3. Setzen Sie den zweiten Punkt auf (140, 90, 0).

Das Ergebnis ist eine Ebene. Ihre Eigenschaften können verändert werden, um z.B. die Füllung zu entfernen (Attribut Displaymode in Wireframe ändern).

  1. Wählen Sie Kreis Draft Circle.png.
  2. Setzen Sie den Mittelpunkt auf (0, 0, 0).
  3. Geben Sie beim Radius 15 mm ein.

Polygone

  1. Wählen Sie Polygon Draft Polygon.png
  2. Der Mittelpunkt soll wieder bei (0, 0, 0) liegen
  3. Die Anzahl der Seiten beträgt 6
  4. Der Radius soll auf 50 mm gesetzt werden

Anordnungen

Anordnungen (engl. Array) werden verwendet, um ein Objekt zu vervielfältigen. Dies kann entweder in einer geraden Richtung, um eine Achse oder entlang eines Pfades geschehen.

  1. Wählen Sie das zuvor erzeugte Objekt "Wire".
  2. Klicken Sie auf Anordnung Draft Array.png.
  3. In der Registerkarte "Daten" des Objekts muss der Array Type von ortho nach polar geändert werden.
  4. Ändern Sie im selben Menü Number Polar von 1 auf 4.


Abmessungen hinzufügen

Abmessungen benötigen eine durchgehende Verwendung von Fangbeschränkungen um die zu bemaßenden Eckpunkte/Linien ordentlich zu erkennen und auszuwählen. Die Werkzeugleiste Snapping wird dazu verwendet, die vom Programm fangbaren Punkte auszuwählen.

  1. Wählen Sie Draft Dimension.png Abmessung.
  2. Wählen Sie den ersten Punkt aus. Dies kann entweder ein existierendes Element in der Skizze sein oder festgelegt durch eingegebene Koordinaten. In diesem Tutorial wird dies immer der Punkt (0, 0, 0) sein.
  3. Wählen Sie den zweiten Punkt aus. Nähern Sie den Mauszeiger an den Mittelpunkt der oberen Polygonlinie an, bis ein weißer Punkt zusammen mit dem Symbol Snap Midpoint.png erscheint.
  4. Bewegen Sie den Mauszeiger an einen selbst gewählten Ort der Bemaßung und klicken Sie darauf.
  5. Ändern Sie die Font Size (dt. "Schriftgröße") in der Registerkarte "Ansicht" auf 6 mm.

Wiederholen Sie dies für die Bögen und Kreise.

Anmerkungen und Text

Es gibt einen kleinen Unterschied zwischen Anmerkungen und Text: Text kann als Profil für dreidimensionale Operationen in FreeCAD verwendet werden.

Anmerkungen

  1. Klicken Sie auf Text Draft Text.png.
  2. Wählen Sie einen Bezugspunkt in der 3D-Ansicht. In diesem Fall den Mittelpunkt des obersten Bogens.
  3. Geben Sie ihren Text ein und drücken Sie "Eingabetaste".
  4. Wiederholen Sie dies für beliebige viele Zeilen.
  5. Drücken Sie "Eingabetaste".

Text

  1. Klicken Sie auf Form von Text Draft ShapeString.png.
  2. Wählen Sie einen Bezugspunkt in der 3D-Ansicht. Dies kann ein vorhandener Punkt oder die Position des Mauszeigers sein.
  3. Geben Sie einen Text ein und drücken Sie "Eingabetaste".
  4. Legen Sie die gewünschte Schriftgröße ("Höhe") fest und drücken Sie "Eingabetaste".
  5. Lassen Sie "Verfolgung" bei 0 mm und drücken Sie "Eingabetaste".
  6. Wählen Sie beim Pfad die gewünschte Schriftdatei aus (z.B. unter Windows 7 C:\Windows\Fonts\Arial.ttf).

Erstellen von Blaupausen

Um Blaupausen zu erstellen, ist es notwendig, zunächst eine Zeichnung mit allen benötigten Elementen zu zeichnen. Schauen Sie sich dazu das Tutorial Drawing tutorial/de an.

Wir sind nun mit den grundlegenden Arbeitsschritten des Moduls Draft fertig.

Weiterführende Literatur

  • Eine detaillierte Beschreibung des Arbeitsbereichs findet sich unter Draft Module.
  • Mehr über die Fangoptionen des Arbeitsbereichs findet sich unter Draft Snap.