Draft Coordinates

From FreeCAD Documentation
Jump to: navigation, search
This page is a translated version of the page Draft Coordinates and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
čeština • ‎Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎svenska • ‎Türkçe • ‎中文(中国大陆)‎

I alla skissverktyg, när du ombes efter 3d punktspositioner, avstånd, radier, vinklar eller någon annan numerisk data, så kan du alltid välja att mata in dessa värden grafiskt, genom att markera på skärmen med din mus, eller direkt genom att mata in siffror med tangentbordet. Den första metoden är vanligtvis mer intuitiv, men när du arbetar med absolut precision, så behöver du ofta mata in ett exakt nummer för att få rätt koordinat. Av den anledningen så kan Skissmodulens kommandolåda alltid acceptera numerisk inmatning:

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates.jpg

Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


Skiss kommandolådan är en "intelligent" verktygslåda, vilket innebär att dess innehåll förändras beroende på vilket verktyg som används och vilken information som krävs från användaren. När du till exempel ritar en cirkel, så kommer kommandolådan att succesivt fråga dig efter cirkelns centrum, och sedan radien. Dessa två värden kan indikeras både genom att markera en punkt på skärmen eller genom att skriva in siffror.

Varje gång som du ser ett sifferinmatningsfält i kommandolådan, så kan du skriva in siffror. Du kommer att se att dessa nummer också motsvarar rörelserna på din musmarkör.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Ibland kan det vara svårt att rikta upp objekt när du arbetar i 3D rymden. Du kan låsa Z koordinaten, så du är säker på att allt du ritar kommer att bli i samma horisontalplan. När du startar FreeCAD, så är Z koordinaten som standard låst vid 0.00, men du kan lätt andra det: lås upp, ändra Z värdet, och lås igen. Om Z koordinaten är låst, så kan du inte rita i icke-horisontella plan.

De flesta Skisskommandona fungerar nu i 3D, lås bara upp Z koordinaten och växla till passande vinkel, och det du sedan ritar kommer att vara uppriktat mot den vyn.

Set the number of decimals

By default, FreeCAD shows two decimal places in quantities. To change the number of decimal places shown change the preferences:

  • Go to Edit → Preferences → General → Units, and set "Number of decimals" to the desired value.
  • Then press Apply and OK.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.

PreferencesDecimals 01 en.png

Parameter editor to change the decimal places shown by a numerical value